Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| mck-ivpip | 2698 | udp | MCK-IVPIP | Robert Vincent | Robert Vincent | ||||||
| csoft-plusclnt | 2699 | tcp | Csoft Plus Client | Nedelcho Stanev | Nedelcho Stanev | ||||||
| csoft-plusclnt | 2699 | udp | Csoft Plus Client | Nedelcho Stanev | Nedelcho Stanev | ||||||
| supermon | 2709 | tcp | Supermon | Ron Minnich | Ron Minnich | ||||||
| supermon | 2709 | udp | Supermon | Ron Minnich | Ron Minnich | ||||||
| scan-change | 2719 | tcp | Scan & Change | Alexander Raji | Alexander Raji | ||||||
| scan-change | 2719 | udp | Scan & Change | Alexander Raji | Alexander Raji | ||||||
| tcim-control | 2729 | tcp | TCIM Control | Dean Skelton | Dean Skelton | ||||||
| tcim-control | 2729 | udp | TCIM Control | Dean Skelton | Dean Skelton | ||||||
| tn-timing | 2739 | tcp | TN Timing | Paul Roberts | Paul Roberts | ||||||
| tn-timing | 2739 | udp | TN Timing | Paul Roberts | Paul Roberts | ||||||
| fjippol-cnsl | 2749 | tcp | |||||||||
| fjippol-cnsl | 2749 | udp | |||||||||
| apollo-gms | 2759 | tcp | APOLLO GMS | Simon Hovell | Simon Hovell | ||||||
| apollo-gms | 2759 | udp | APOLLO GMS | Simon Hovell | Simon Hovell | ||||||
| exce | 2769 | tcp | eXcE | Norm Freedman | Norm Freedman | ||||||
| exce | 2769 | udp | eXcE | Norm Freedman | Norm Freedman | ||||||
| lbc-sync | 2779 | tcp | LBC Sync | ||||||||
| lbc-sync | 2779 | udp | LBC Sync | ||||||||
| media-agent | 2789 | tcp | Media Agent | Nitzan Daube | Nitzan Daube | ||||||
| media-agent | 2789 | udp | Media Agent | Nitzan Daube | Nitzan Daube | ||||||
| plgproxy | 2790 | tcp | PLG Proxy | Charlie Hava | Charlie Hava | ||||||
| plgproxy | 2790 | udp | PLG Proxy | Charlie Hava | Charlie Hava | ||||||
| mtport-regist | 2791 | tcp | MT Port Registrator | Maxim Tseitlin | Maxim Tseitlin | ||||||
| mtport-regist | 2791 | udp | MT Port Registrator | Maxim Tseitlin | Maxim Tseitlin | ||||||
| f5-globalsite | 2792 | tcp | f5-globalsite | Christian Saether | Christian Saether | ||||||
| f5-globalsite | 2792 | udp | f5-globalsite | Christian Saether | Christian Saether | ||||||
| initlsmsad | 2793 | tcp | initlsmsad | Kelly Green | Kelly Green | ||||||
| initlsmsad | 2793 | udp | initlsmsad | Kelly Green | Kelly Green | ||||||
| urp | 2794 | tcp | Uniform Resource Platform | Liu Hongyan | Han Yingying | 2024-11-26 | |||||
| urp | 2794 | udp | Uniform Resource Platform | Liu Hongyan | Han Yingying | 2024-11-26 | |||||
| livestats | 2795 | tcp | LiveStats | Chris Greene | Chris Greene | ||||||
| livestats | 2795 | udp | LiveStats | Chris Greene | Chris Greene | ||||||
| ac-tech | 2796 | tcp | ac-tech | Chiming Huang | Chiming Huang | ||||||
| ac-tech | 2796 | udp | ac-tech | Chiming Huang | Chiming Huang | ||||||
| esp-encap | 2797 | tcp | esp-encap | Jorn Sierwald | Jorn Sierwald | ||||||
| esp-encap | 2797 | udp | esp-encap | Jorn Sierwald | Jorn Sierwald | ||||||
| tmesis-upshot | 2798 | tcp | TMESIS-UPShot | Brian Schenkenberger | Brian Schenkenberger | ||||||
| tmesis-upshot | 2798 | udp | TMESIS-UPShot | Brian Schenkenberger | Brian Schenkenberger | ||||||
| icon-discover | 2799 | tcp | ICON Discover | Alexander Falk | Alexander Falk | ||||||
| icon-discover | 2799 | udp | ICON Discover | Alexander Falk | Alexander Falk | ||||||
| corbaloc | 2809 | tcp | CORBA LOC | Ted McFadden | Ted McFadden | ||||||
| corbaloc | 2809 | udp | CORBA LOC | Ted McFadden | Ted McFadden | ||||||
| fc-faultnotify | 2819 | tcp | FC Fault Notification | Dave Watkins | Dave Watkins | ||||||
| fc-faultnotify | 2819 | udp | FC Fault Notification | Dave Watkins | Dave Watkins | ||||||
| silkp1 | 2829 | tcp | silkp1 | ||||||||
| silkp1 | 2829 | udp | silkp1 | ||||||||
| nmsigport | 2839 | tcp | NMSigPort | Peter Egli | Peter Egli | ||||||
| nmsigport | 2839 | udp | NMSigPort | Peter Egli | Peter Egli | ||||||
| fxp | 2849 | tcp | FXP | Martin Lichtin | Martin Lichtin | ||||||
| fxp | 2849 | udp | FXP | Martin Lichtin | Martin Lichtin | ||||||
| msrp | 2855 | tcp | MSRP over TCP | 2014-04-09 | RFC 4976 | ||||||
| activememory | 2859 | tcp | Active Memory | Joe Graham | Joe Graham | ||||||
| activememory | 2859 | udp | Active Memory | Joe Graham | Joe Graham | ||||||
| icslap | 2869 | tcp | ICSLAP | Richard Lamb | Richard Lamb | ||||||
| icslap | 2869 | udp | ICSLAP | Richard Lamb | Richard Lamb | ||||||
| ucentric-ds | 2879 | tcp | ucentric-ds | Alex Vasilevsky | Alex Vasilevsky | ||||||
| ucentric-ds | 2879 | udp | ucentric-ds | Alex Vasilevsky | Alex Vasilevsky | ||||||
| rsom | 2889 | tcp | RSOM | Justine Higgins | Justine Higgins | ||||||
| rsom | 2889 | udp | RSOM | Justine Higgins | Justine Higgins | ||||||
| cspclmulti | 2890 | tcp | CSPCLMULTI | Yoneda Terumasa | Yoneda Terumasa | ||||||
| cspclmulti | 2890 | udp | CSPCLMULTI | Yoneda Terumasa | Yoneda Terumasa | ||||||
| cinegrfx-elmd | 2891 | tcp | CINEGRFX-ELMD License Manager | Greg Ercolano | Greg Ercolano | ||||||
| cinegrfx-elmd | 2891 | udp | CINEGRFX-ELMD License Manager | Greg Ercolano | Greg Ercolano | ||||||
| snifferdata | 2892 | tcp | SNIFFERDATA | Jeff Mangasarian | Jeff Mangasarian | ||||||
| snifferdata | 2892 | udp | SNIFFERDATA | Jeff Mangasarian | Jeff Mangasarian | ||||||
| vseconnector | 2893 | tcp | VSECONNECTOR | Ingo Franzki | Ingo Franzki | ||||||
| vseconnector | 2893 | udp | VSECONNECTOR | Ingo Franzki | Ingo Franzki | ||||||
| abacus-remote | 2894 | tcp | ABACUS-REMOTE | Mike Bello | Mike Bello | ||||||
| abacus-remote | 2894 | udp | ABACUS-REMOTE | Mike Bello | Mike Bello | ||||||
| natuslink | 2895 | tcp | NATUS LINK | Jonathan Mergy | Jonathan Mergy | ||||||
| natuslink | 2895 | udp | NATUS LINK | Jonathan Mergy | Jonathan Mergy | ||||||
| ecovisiong6-1 | 2896 | tcp | ECOVISIONG6-1 | Henrik Holst | Henrik Holst | ||||||
| ecovisiong6-1 | 2896 | udp | ECOVISIONG6-1 | Henrik Holst | Henrik Holst | ||||||
| citrix-rtmp | 2897 | tcp | Citrix RTMP | Myk Willis | Myk Willis | ||||||
| citrix-rtmp | 2897 | udp | Citrix RTMP | Myk Willis | Myk Willis | ||||||
| appliance-cfg | 2898 | tcp | APPLIANCE-CFG | Gary A. James | Gary A. James | ||||||
| appliance-cfg | 2898 | udp | APPLIANCE-CFG | Gary A. James | Gary A. James | ||||||
| powergemplus | 2899 | tcp | POWERGEMPLUS | Koich Nakamura | Koich Nakamura | ||||||
| powergemplus | 2899 | udp | POWERGEMPLUS | Koich Nakamura | Koich Nakamura | ||||||
| quicksuite | 2900 | tcp | QUICKSUITE | William Egge | William Egge | ||||||
| quicksuite | 2900 | udp | QUICKSUITE | William Egge | William Egge | ||||||
| allstorcns | 2901 | tcp | ALLSTORCNS | Steve Dobson | Steve Dobson | ||||||
| allstorcns | 2901 | udp | ALLSTORCNS | Steve Dobson | Steve Dobson | ||||||
| netaspi | 2902 | tcp | NET ASPI | Johnson Luo | Johnson Luo | ||||||
| netaspi | 2902 | udp | NET ASPI | Johnson Luo | Johnson Luo | ||||||
| suitcase | 2903 | tcp | SUITCASE | Milton E. Sagen | Milton E. Sagen | ||||||
| suitcase | 2903 | udp | SUITCASE | Milton E. Sagen | Milton E. Sagen | ||||||
| m2ua | 2904 | tcp | M2UA | Lyndon Ong | Lyndon Ong | ||||||
| m2ua | 2904 | udp | M2UA | Lyndon Ong | Lyndon Ong | ||||||
| m2ua | 2904 | sctp | M2UA | Lyndon Ong | Lyndon Ong | ||||||
| m3ua | 2905 | tcp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| 2905 | udp | De-registered | 2001-06-07 | ||||||||
| m3ua | 2905 | sctp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| caller9 | 2906 | tcp | CALLER9 | Shams Naqi | Shams Naqi | ||||||
| caller9 | 2906 | udp | CALLER9 | Shams Naqi | Shams Naqi | ||||||
| webmethods-b2b | 2907 | tcp | WEBMETHODS B2B | Joseph Hines | Joseph Hines | ||||||
| webmethods-b2b | 2907 | udp | WEBMETHODS B2B | Joseph Hines | Joseph Hines | ||||||
| mao | 2908 | tcp | mao | Marc Baudoin | Marc Baudoin | ||||||
| mao | 2908 | udp | mao | Marc Baudoin | Marc Baudoin | ||||||
| funk-dialout | 2909 | tcp | Funk Dialout | Cimarron Boozer | Cimarron Boozer |