Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| lbc-sync | 2779 | udp | LBC Sync | ||||||||
| lbc-control | 2780 | tcp | LBC Control | Keiji Michine | Keiji Michine | ||||||
| lbc-control | 2780 | udp | LBC Control | Keiji Michine | Keiji Michine | ||||||
| whosells | 2781 | tcp | whosells | William Randolph Royere III | William Randolph Royere III | ||||||
| whosells | 2781 | udp | whosells | William Randolph Royere III | William Randolph Royere III | ||||||
| everydayrc | 2782 | tcp | everydayrc | Ahti Heinla | Ahti Heinla | ||||||
| everydayrc | 2782 | udp | everydayrc | Ahti Heinla | Ahti Heinla | ||||||
| aises | 2783 | tcp | AISES | Daniel Grazioli | Daniel Grazioli | ||||||
| aises | 2783 | udp | AISES | Daniel Grazioli | Daniel Grazioli | ||||||
| www-dev | 2784 | tcp | world wide web - development | ||||||||
| www-dev | 2784 | udp | world wide web - development | ||||||||
| aic-np | 2785 | tcp | aic-np | Brad Parker | Brad Parker | ||||||
| aic-np | 2785 | udp | aic-np | Brad Parker | Brad Parker | ||||||
| aic-oncrpc | 2786 | tcp | aic-oncrpc - Destiny MCD database | Brad Parker | Brad Parker | ||||||
| aic-oncrpc | 2786 | udp | aic-oncrpc - Destiny MCD database | Brad Parker | Brad Parker | ||||||
| piccolo | 2787 | tcp | piccolo - Cornerstone Software | Dave Bellivea | Dave Bellivea | ||||||
| piccolo | 2787 | udp | piccolo - Cornerstone Software | Dave Bellivea | Dave Bellivea | ||||||
| fryeserv | 2788 | tcp | NetWare Loadable Module - Seagate Software | Joseph LoPilato | Joseph LoPilato | ||||||
| fryeserv | 2788 | udp | NetWare Loadable Module - Seagate Software | Joseph LoPilato | Joseph LoPilato | ||||||
| media-agent | 2789 | tcp | Media Agent | Nitzan Daube | Nitzan Daube | ||||||
| media-agent | 2789 | udp | Media Agent | Nitzan Daube | Nitzan Daube | ||||||
| plgproxy | 2790 | tcp | PLG Proxy | Charlie Hava | Charlie Hava | ||||||
| plgproxy | 2790 | udp | PLG Proxy | Charlie Hava | Charlie Hava | ||||||
| mtport-regist | 2791 | tcp | MT Port Registrator | Maxim Tseitlin | Maxim Tseitlin | ||||||
| mtport-regist | 2791 | udp | MT Port Registrator | Maxim Tseitlin | Maxim Tseitlin | ||||||
| f5-globalsite | 2792 | tcp | f5-globalsite | Christian Saether | Christian Saether | ||||||
| f5-globalsite | 2792 | udp | f5-globalsite | Christian Saether | Christian Saether | ||||||
| initlsmsad | 2793 | tcp | initlsmsad | Kelly Green | Kelly Green | ||||||
| initlsmsad | 2793 | udp | initlsmsad | Kelly Green | Kelly Green | ||||||
| urp | 2794 | tcp | Uniform Resource Platform | Liu Hongyan | Han Yingying | 2024-11-26 | |||||
| urp | 2794 | udp | Uniform Resource Platform | Liu Hongyan | Han Yingying | 2024-11-26 | |||||
| livestats | 2795 | tcp | LiveStats | Chris Greene | Chris Greene | ||||||
| livestats | 2795 | udp | LiveStats | Chris Greene | Chris Greene | ||||||
| ac-tech | 2796 | tcp | ac-tech | Chiming Huang | Chiming Huang | ||||||
| ac-tech | 2796 | udp | ac-tech | Chiming Huang | Chiming Huang | ||||||
| esp-encap | 2797 | tcp | esp-encap | Jorn Sierwald | Jorn Sierwald | ||||||
| esp-encap | 2797 | udp | esp-encap | Jorn Sierwald | Jorn Sierwald | ||||||
| tmesis-upshot | 2798 | tcp | TMESIS-UPShot | Brian Schenkenberger | Brian Schenkenberger | ||||||
| tmesis-upshot | 2798 | udp | TMESIS-UPShot | Brian Schenkenberger | Brian Schenkenberger | ||||||
| icon-discover | 2799 | tcp | ICON Discover | Alexander Falk | Alexander Falk | ||||||
| icon-discover | 2799 | udp | ICON Discover | Alexander Falk | Alexander Falk | ||||||
| cspmulti | 2807 | tcp | cspmulti | Terumasa Yoneda | Terumasa Yoneda | ||||||
| cspmulti | 2807 | udp | cspmulti | Terumasa Yoneda | Terumasa Yoneda | ||||||
| nmsigport | 2817 | tcp | NMSig Port | Peter Egli | Peter Egli | ||||||
| nmsigport | 2817 | udp | NMSig Port | Peter Egli | Peter Egli | ||||||
| slc-ctrlrloops | 2827 | tcp | slc ctrlrloops | Erwin Hogeweg | Erwin Hogeweg | ||||||
| slc-ctrlrloops | 2827 | udp | slc ctrlrloops | Erwin Hogeweg | Erwin Hogeweg | ||||||
| repliweb | 2837 | tcp | Repliweb | William Orme | William Orme | ||||||
| repliweb | 2837 | udp | Repliweb | William Orme | William Orme | ||||||
| aimpp-port-req | 2847 | tcp | AIMPP Port Req | Brian Martinicky | Brian Martinicky | ||||||
| aimpp-port-req | 2847 | udp | AIMPP Port Req | Brian Martinicky | Brian Martinicky | ||||||
| msrp | 2855 | tcp | MSRP over TCP | 2014-04-09 | RFC 4976 | ||||||
| simctlp | 2857 | tcp | SimCtIP | Christian Zietz | Christian Zietz | ||||||
| simctlp | 2857 | udp | SimCtIP | Christian Zietz | Christian Zietz | ||||||
| esps-portal | 2867 | tcp | esps-portal | Nicholas Stowfis | Nicholas Stowfis | ||||||
| esps-portal | 2867 | udp | esps-portal | Nicholas Stowfis | Nicholas Stowfis | ||||||
| daishi | 2870 | tcp | daishi | Patrick Chipman | Patrick Chipman | ||||||
| daishi | 2870 | udp | daishi | Patrick Chipman | Patrick Chipman | ||||||
| msi-selectplay | 2871 | tcp | MSI Select Play | Paul Fonte | Paul Fonte | ||||||
| msi-selectplay | 2871 | udp | MSI Select Play | Paul Fonte | Paul Fonte | ||||||
| radix | 2872 | tcp | RADIX | Stein Roger Skaflotten | Stein Roger Skaflotten | 2011-07-06 | |||||
| radix | 2872 | udp | RADIX | Stein Roger Skaflotten | Stein Roger Skaflotten | 2011-07-06 | |||||
| psrt | 2873 | tcp | PubSub Realtime Telemetry Protocol | Altertech | Serhij Symonenko | 2021-11-12 | |||||
| psrt | 2873 | udp | PubSub Realtime Telemetry Protocol | Altertech | Serhij Symonenko | 2021-11-12 | |||||
| dxmessagebase1 | 2874 | tcp | DX Message Base Transport Protocol | ||||||||
| dxmessagebase1 | 2874 | udp | DX Message Base Transport Protocol | ||||||||
| dxmessagebase2 | 2875 | tcp | DX Message Base Transport Protocol | G.E. Ozz Nixon Jr. | G.E. Ozz Nixon Jr. | 2009-01-13 | |||||
| dxmessagebase2 | 2875 | udp | DX Message Base Transport Protocol | G.E. Ozz Nixon Jr. | G.E. Ozz Nixon Jr. | 2009-01-13 | |||||
| sps-tunnel | 2876 | tcp | SPS Tunnel | Bill McIntosh | Bill McIntosh | ||||||
| sps-tunnel | 2876 | udp | SPS Tunnel | Bill McIntosh | Bill McIntosh | ||||||
| bluelance | 2877 | tcp | BLUELANCE | Michael Padrezas | Michael Padrezas | ||||||
| bluelance | 2877 | udp | BLUELANCE | Michael Padrezas | Michael Padrezas | ||||||
| aap | 2878 | tcp | AAP | Stephen Hanna | Stephen Hanna | ||||||
| aap | 2878 | udp | AAP | Stephen Hanna | Stephen Hanna | ||||||
| ucentric-ds | 2879 | tcp | ucentric-ds | Alex Vasilevsky | Alex Vasilevsky | ||||||
| ucentric-ds | 2879 | udp | ucentric-ds | Alex Vasilevsky | Alex Vasilevsky | ||||||
| aironetddp | 2887 | tcp | aironet | Victor Griswold | Victor Griswold | ||||||
| aironetddp | 2887 | udp | aironet | Victor Griswold | Victor Griswold | ||||||
| citrix-rtmp | 2897 | tcp | Citrix RTMP | Myk Willis | Myk Willis | ||||||
| citrix-rtmp | 2897 | udp | Citrix RTMP | Myk Willis | Myk Willis | ||||||
| webmethods-b2b | 2907 | tcp | WEBMETHODS B2B | Joseph Hines | Joseph Hines | ||||||
| webmethods-b2b | 2907 | udp | WEBMETHODS B2B | Joseph Hines | Joseph Hines | ||||||
| elvin-client | 2917 | tcp | Elvin Client IANA assigned this well-formed service name as a replacement for "elvin_client". |
David Arnold | David Arnold | ||||||
| elvin_client | 2917 | tcp | Elvin Client | David Arnold | David Arnold | This entry is an alias to "elvin-client". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| elvin-client | 2917 | udp | Elvin Client IANA assigned this well-formed service name as a replacement for "elvin_client". |
David Arnold | David Arnold | ||||||
| elvin_client | 2917 | udp | Elvin Client | David Arnold | David Arnold | This entry is an alias to "elvin-client". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 2925 | Unassigned (FRP-Released 12/7/00) | ||||||||||
| unimobilectrl | 2927 | tcp | UNIMOBILECTRL | Vikas | Vikas | ||||||
| unimobilectrl | 2927 | udp | UNIMOBILECTRL | Vikas | Vikas | ||||||
| pnaconsult-lm | 2937 | tcp | PNACONSULT-LM | Theo Nijssen | Theo Nijssen | ||||||
| pnaconsult-lm | 2937 | udp | PNACONSULT-LM | Theo Nijssen | Theo Nijssen | ||||||
| gpsd | 2947 | tcp | GPS Daemon request/response protocol | Eric S. Raymond | Eric S. Raymond | 2010-04-19 | |||||
| gpsd | 2947 | udp | GPS Daemon request/response protocol | Eric S. Raymond | Eric S. Raymond | 2010-04-19 | |||||
| jmact5 | 2957 | tcp | JAMCT5 | ||||||||
| jmact5 | 2957 | udp | JAMCT5 | ||||||||
| ssc-agent | 2967 | tcp | SSC-AGENT | George Dzieciol | George Dzieciol | ||||||
| ssc-agent | 2967 | udp | SSC-AGENT | George Dzieciol | George Dzieciol | ||||||
| index-net | 2970 | tcp | INDEX-NET | Chris J. Wren | Chris J. Wren | ||||||
| index-net | 2970 | udp | INDEX-NET | Chris J. Wren | Chris J. Wren | ||||||
| netclip | 2971 | tcp | NetClip clipboard daemon | Rudi Chiarito | Rudi Chiarito | ||||||
| netclip | 2971 | udp | NetClip clipboard daemon | Rudi Chiarito | Rudi Chiarito |