Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| firepower | 2615 | udp | firepower | Jason Volk | Jason Volk | ||||||
| blwnkl-port | 2625 | tcp | Blwnkl Port | Weng Chin (Winson) Yung | Weng Chin (Winson) Yung | ||||||
| blwnkl-port | 2625 | udp | Blwnkl Port | Weng Chin (Winson) Yung | Weng Chin (Winson) Yung | ||||||
| backburner | 2635 | tcp | Back Burner | Kevin Teiskoetter | Kevin Teiskoetter | ||||||
| backburner | 2635 | udp | Back Burner | Kevin Teiskoetter | Kevin Teiskoetter | ||||||
| novell-ipx-cmd | 2645 | tcp | Novell IPX CMD | Juan Carlos Luciani | Juan Carlos Luciani | ||||||
| novell-ipx-cmd | 2645 | udp | Novell IPX CMD | Juan Carlos Luciani | Juan Carlos Luciani | ||||||
| eristwoguns | 2650 | tcp | eristwoguns | Jason Lockett; Melanie Kacerek | Jason Lockett; Melanie Kacerek | 2008-12-16 | |||||
| eristwoguns | 2650 | udp | eristwoguns | Jason Lockett; Melanie Kacerek | Jason Lockett; Melanie Kacerek | 2008-12-16 | |||||
| ebinsite | 2651 | tcp | EBInSite | Lefteris Kalamaras | Lefteris Kalamaras | ||||||
| ebinsite | 2651 | udp | EBInSite | Lefteris Kalamaras | Lefteris Kalamaras | ||||||
| interpathpanel | 2652 | tcp | InterPathPanel | Stephen Misel | Stephen Misel | ||||||
| interpathpanel | 2652 | udp | InterPathPanel | Stephen Misel | Stephen Misel | ||||||
| sonus | 2653 | tcp | Sonus | Mark Garti | Mark Garti | ||||||
| sonus | 2653 | udp | Sonus | Mark Garti | Mark Garti | ||||||
| corel-vncadmin | 2654 | tcp | Corel VNC Admin IANA assigned this well-formed service name as a replacement for "corel_vncadmin". |
Oleg Noskov | Oleg Noskov | ||||||
| corel_vncadmin | 2654 | tcp | Corel VNC Admin | Oleg Noskov | Oleg Noskov | This entry is an alias to "corel-vncadmin". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| corel-vncadmin | 2654 | udp | Corel VNC Admin IANA assigned this well-formed service name as a replacement for "corel_vncadmin". |
Oleg Noskov | Oleg Noskov | ||||||
| corel_vncadmin | 2654 | udp | Corel VNC Admin | Oleg Noskov | Oleg Noskov | This entry is an alias to "corel-vncadmin". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| unglue | 2655 | tcp | UNIX Nt Glue | Peter Santoro | Peter Santoro | ||||||
| unglue | 2655 | udp | UNIX Nt Glue | Peter Santoro | Peter Santoro | ||||||
| kana | 2656 | tcp | Kana | Colin Goldstein | Colin Goldstein | ||||||
| kana | 2656 | udp | Kana | Colin Goldstein | Colin Goldstein | ||||||
| sns-dispatcher | 2657 | tcp | SNS Dispatcher | ||||||||
| sns-dispatcher | 2657 | udp | SNS Dispatcher | ||||||||
| sns-admin | 2658 | tcp | SNS Admin | ||||||||
| sns-admin | 2658 | udp | SNS Admin | ||||||||
| sns-query | 2659 | tcp | SNS Query | Mary Holstege | Mary Holstege | ||||||
| sns-query | 2659 | udp | SNS Query | Mary Holstege | Mary Holstege | ||||||
| patrol-mq-nm | 2665 | tcp | Patrol for MQ NM | Portnoy Boxman | Portnoy Boxman | ||||||
| patrol-mq-nm | 2665 | udp | Patrol for MQ NM | Portnoy Boxman | Portnoy Boxman | ||||||
| ttc-etap | 2675 | tcp | TTC ETAP | Daniel Becker | Daniel Becker | ||||||
| ttc-etap | 2675 | udp | TTC ETAP | Daniel Becker | Daniel Becker | ||||||
| mpnjsocl | 2685 | tcp | mpnjsocl | ||||||||
| mpnjsocl | 2685 | udp | mpnjsocl | ||||||||
| vspread | 2695 | tcp | VSPREAD | Sumitake kobayashi | Sumitake kobayashi | ||||||
| vspread | 2695 | udp | VSPREAD | Sumitake kobayashi | Sumitake kobayashi | ||||||
| sds-admin | 2705 | tcp | SDS Admin | Don Traub | Don Traub | ||||||
| sds-admin | 2705 | udp | SDS Admin | Don Traub | Don Traub | ||||||
| hpstgmgr2 | 2715 | tcp | HPSTGMGR2 | Kevin Collins | Kevin Collins | ||||||
| hpstgmgr2 | 2715 | udp | HPSTGMGR2 | Kevin Collins | Kevin Collins | ||||||
| msolap-ptp2 | 2725 | tcp | MSOLAP PTP2 | Cristian Petculescu | Cristian Petculescu | ||||||
| msolap-ptp2 | 2725 | udp | MSOLAP PTP2 | Cristian Petculescu | Cristian Petculescu | ||||||
| g5m | 2732 | tcp | G5M | Graham Klyne | Graham Klyne | ||||||
| g5m | 2732 | udp | G5M | Graham Klyne | Graham Klyne | ||||||
| netiq-mc | 2735 | tcp | NetIQ Monitor Console | Scott Southard | Scott Southard | 2010-08-25 | |||||
| netiq-mc | 2735 | udp | NetIQ Monitor Console | Scott Southard | Scott Southard | 2010-08-25 | |||||
| urbisnet | 2745 | tcp | URBISNET | Urbis.Net Ltd | Urbis.Net Ltd | ||||||
| urbisnet | 2745 | udp | URBISNET | Urbis.Net Ltd | Urbis.Net Ltd | ||||||
| fjippol-port1 | 2750 | tcp | |||||||||
| fjippol-port1 | 2750 | udp | |||||||||
| fjippol-port2 | 2751 | tcp | Shoichi Tachibana | Shoichi Tachibana | |||||||
| fjippol-port2 | 2751 | udp | Shoichi Tachibana | Shoichi Tachibana | |||||||
| rsisysaccess | 2752 | tcp | RSISYS ACCESS | Christophe Besant | Christophe Besant | ||||||
| rsisysaccess | 2752 | udp | RSISYS ACCESS | Christophe Besant | Christophe Besant | ||||||
| de-spot | 2753 | tcp | de-spot | Sanjay Parekh | Sanjay Parekh | ||||||
| de-spot | 2753 | udp | de-spot | Sanjay Parekh | Sanjay Parekh | ||||||
| apollo-cc | 2754 | tcp | APOLLO CC | Brand Communications | Brand Communications | ||||||
| apollo-cc | 2754 | udp | APOLLO CC | Brand Communications | Brand Communications | ||||||
| expresspay | 2755 | tcp | Express Pay | Ben Higgins | Ben Higgins | ||||||
| expresspay | 2755 | udp | Express Pay | Ben Higgins | Ben Higgins | ||||||
| simplement-tie | 2756 | tcp | simplement-tie | Tzvika Chumash | Tzvika Chumash | ||||||
| simplement-tie | 2756 | udp | simplement-tie | Tzvika Chumash | Tzvika Chumash | ||||||
| cnrp | 2757 | tcp | CNRP | Jacob Ulmert | Jacob Ulmert | ||||||
| cnrp | 2757 | udp | CNRP | Jacob Ulmert | Jacob Ulmert | ||||||
| apollo-status | 2758 | tcp | APOLLO Status | ||||||||
| apollo-status | 2758 | udp | APOLLO Status | ||||||||
| apollo-gms | 2759 | tcp | APOLLO GMS | Simon Hovell | Simon Hovell | ||||||
| apollo-gms | 2759 | udp | APOLLO GMS | Simon Hovell | Simon Hovell | ||||||
| qip-audup | 2765 | tcp | qip-audup | Mike Morgan | Mike Morgan | ||||||
| qip-audup | 2765 | udp | qip-audup | Mike Morgan | Mike Morgan | ||||||
| smpp | 2775 | tcp | SMPP | Owen Sullivan | Owen Sullivan | ||||||
| smpp | 2775 | udp | SMPP | Owen Sullivan | Owen Sullivan | ||||||
| aic-np | 2785 | tcp | aic-np | Brad Parker | Brad Parker | ||||||
| aic-np | 2785 | udp | aic-np | Brad Parker | Brad Parker | ||||||
| f5-globalsite | 2792 | tcp | f5-globalsite | Christian Saether | Christian Saether | ||||||
| f5-globalsite | 2792 | udp | f5-globalsite | Christian Saether | Christian Saether | ||||||
| livestats | 2795 | tcp | LiveStats | Chris Greene | Chris Greene | ||||||
| livestats | 2795 | udp | LiveStats | Chris Greene | Chris Greene | ||||||
| wta-wsp-s | 2805 | tcp | WTA WSP-S | Sebastien Bury | Sebastien Bury | ||||||
| wta-wsp-s | 2805 | udp | WTA WSP-S | Sebastien Bury | Sebastien Bury | ||||||
| lbc-measure | 2815 | tcp | LBC Measurement | ||||||||
| lbc-measure | 2815 | udp | LBC Measurement | ||||||||
| 2825 | (unassigned) Possibly assigned | ||||||||||
| evtp-data | 2835 | tcp | EVTP-DATA | Eric Bruno | Eric Bruno | ||||||
| evtp-data | 2835 | udp | EVTP-DATA | Eric Bruno | Eric Bruno | ||||||
| bpcp-trap | 2845 | tcp | BPCP TRAP | Steve Van Duser | Steve Van Duser | ||||||
| bpcp-trap | 2845 | udp | BPCP TRAP | Steve Van Duser | Steve Van Duser | ||||||
| metaconsole | 2850 | tcp | MetaConsole | Rakesh Mahajan | Rakesh Mahajan | ||||||
| metaconsole | 2850 | udp | MetaConsole | Rakesh Mahajan | Rakesh Mahajan | ||||||
| webemshttp | 2851 | tcp | webemshttp | Stephen Tsun | Stephen Tsun | ||||||
| webemshttp | 2851 | udp | webemshttp | Stephen Tsun | Stephen Tsun | ||||||
| bears-01 | 2852 | tcp | bears-01 | Bruce McKinnon | Bruce McKinnon | ||||||
| bears-01 | 2852 | udp | bears-01 | Bruce McKinnon | Bruce McKinnon | ||||||
| ispipes | 2853 | tcp | ISPipes | Rajesh Nandyalam | Rajesh Nandyalam | ||||||
| ispipes | 2853 | udp | ISPipes | Rajesh Nandyalam | Rajesh Nandyalam | ||||||
| infomover | 2854 | tcp | InfoMover | Carla Caputo | Carla Caputo | ||||||
| infomover | 2854 | udp | InfoMover | Carla Caputo | Carla Caputo | ||||||
| msrp | 2855 | tcp | MSRP over TCP | 2014-04-09 | RFC 4976 | ||||||
| 2855 | udp | Reserved | 2014-04-09 | ||||||||
| cesdinv | 2856 | tcp | cesdinv | Yoshiaki Tokumoto | Yoshiaki Tokumoto |