Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cesdinv 2856 tcp cesdinv Yoshiaki Tokumoto Yoshiaki Tokumoto
cesdinv 2856 udp cesdinv Yoshiaki Tokumoto Yoshiaki Tokumoto
simctlp 2857 tcp SimCtIP Christian Zietz Christian Zietz
simctlp 2857 udp SimCtIP Christian Zietz Christian Zietz
ecnp 2858 tcp ECNP Robert Reimiller Robert Reimiller
ecnp 2858 udp ECNP Robert Reimiller Robert Reimiller
activememory 2859 tcp Active Memory Joe Graham Joe Graham
activememory 2859 udp Active Memory Joe Graham Joe Graham
astronova-main 2864 tcp main 5001 cmd AstroNova, Inc. Chris Tate 2020-03-03
astronova-main 2864 udp main 5001 cmd AstroNova, Inc. Chris Tate 2020-03-03
pit-vpn 2865 tcp pit-vpn Norbert Sendetzky Norbert Sendetzky
pit-vpn 2865 udp pit-vpn Norbert Sendetzky Norbert Sendetzky
dxmessagebase2 2875 tcp DX Message Base Transport Protocol G.E. Ozz Nixon Jr. G.E. Ozz Nixon Jr. 2009-01-13
dxmessagebase2 2875 udp DX Message Base Transport Protocol G.E. Ozz Nixon Jr. G.E. Ozz Nixon Jr. 2009-01-13
topflow 2885 tcp TopFlow Ted Ross Ted Ross
topflow 2885 udp TopFlow Ted Ross Ted Ross
natuslink 2895 tcp NATUS LINK Jonathan Mergy Jonathan Mergy
natuslink 2895 udp NATUS LINK Jonathan Mergy Jonathan Mergy
m3ua 2905 tcp M3UA Lyndon Ong Lyndon Ong RFC 4666
2905 udp De-registered 2001-06-07
m3ua 2905 sctp M3UA Lyndon Ong Lyndon Ong RFC 4666
tksocket 2915 tcp TK Socket Dino Ciano Dino Ciano 2011-03-02
tksocket 2915 udp TK Socket Dino Ciano Dino Ciano 2011-03-02
2925 Unassigned (FRP-Released 12/7/00)
qtp 2935 tcp QTP Cameron Young Cameron Young
qtp 2935 udp QTP Cameron Young Cameron Young
sm-pas-5 2942 tcp SM-PAS-5 Tom Haapanen Tom Haapanen
sm-pas-5 2942 udp SM-PAS-5 Tom Haapanen Tom Haapanen
h248-binary 2945 tcp H248 Binary Tom Taylor Tom Taylor
h248-binary 2945 udp H248 Binary Tom Taylor Tom Taylor
h248-binary 2945 sctp Megaco/H.248 binary Tom Taylor Tom Taylor 2006-09
esip 2950 tcp ESIP David Stephenson David Stephenson
esip 2950 udp ESIP David Stephenson David Stephenson
ottp 2951 tcp OTTP Brent Foster Brent Foster
ottp 2951 udp OTTP Brent Foster Brent Foster
mpfwsas 2952 tcp MPFWSAS Toru Murai Toru Murai
mpfwsas 2952 udp MPFWSAS Toru Murai Toru Murai
ovalarmsrv 2953 tcp OVALARMSRV
ovalarmsrv 2953 udp OVALARMSRV
ovalarmsrv-cmd 2954 tcp OVALARMSRV-CMD Eric Pulsipher Eric Pulsipher
ovalarmsrv-cmd 2954 udp OVALARMSRV-CMD Eric Pulsipher Eric Pulsipher
csnotify 2955 tcp CSNOTIFY Israel Beniaminy Israel Beniaminy
csnotify 2955 udp CSNOTIFY Israel Beniaminy Israel Beniaminy
ovrimosdbman 2956 tcp OVRIMOSDBMAN Dimitrios Souflis Dimitrios Souflis
ovrimosdbman 2956 udp OVRIMOSDBMAN Dimitrios Souflis Dimitrios Souflis
jmact5 2957 tcp JAMCT5
jmact5 2957 udp JAMCT5
jmact6 2958 tcp JAMCT6
jmact6 2958 udp JAMCT6
rmopagt 2959 tcp RMOPAGT Shuji Okubo Shuji Okubo
rmopagt 2959 udp RMOPAGT Shuji Okubo Shuji Okubo
bullant-rap 2965 tcp BULLANT RAP Michael Cahill Michael Cahill
bullant-rap 2965 udp BULLANT RAP Michael Cahill Michael Cahill
fjmpcm 2975 tcp Fujitsu Configuration Management Service Hiroki Kawano Hiroki Kawano
fjmpcm 2975 udp Fujitsu Configuration Management Service Hiroki Kawano Hiroki Kawano
hpidsagent 2985 tcp HPIDSAGENT John Trudeau John Trudeau
hpidsagent 2985 udp HPIDSAGENT John Trudeau John Trudeau
idrs 2995 tcp IDRS Jeff Eaton Jeff Eaton
idrs 2995 udp IDRS Jeff Eaton Jeff Eaton
origo-native 3001 tcp OrigoDB Server Native Interface Devrex Labs Robert Friberg 2013-03-29 port 3001 previously "Removed on 2006-05-25"
3001 udp Reserved 2013-03-29 port 3001 previously "Removed on 2006-05-25"
geniuslm 3005 tcp Genius License Manager Jakob Spies Jakob Spies
geniuslm 3005 udp Genius License Manager Jakob Spies Jakob Spies
nati-dstp 3015 tcp NATI DSTP Paul Austin Paul Austin
nati-dstp 3015 udp NATI DSTP Paul Austin Paul Austin
arepa-raft 3025 tcp Arepa Raft Stuart Schaefer Stuart Schaefer
arepa-raft 3025 udp Arepa Raft Stuart Schaefer Stuart Schaefer
fjsv-gssagt 3035 tcp FJSV gssagt Tomoji Koike Tomoji Koike
fjsv-gssagt 3035 udp FJSV gssagt Tomoji Koike Tomoji Koike
responsenet 3045 tcp ResponseNet Chul Yoon Chul Yoon
responsenet 3045 udp ResponseNet Chul Yoon Chul Yoon
gds-db 3050 tcp gds_db

IANA assigned this well-formed service name as a replacement for "gds_db".
Madhukar N. Thakur Madhukar N. Thakur
gds_db 3050 tcp gds_db Madhukar N. Thakur Madhukar N. Thakur This entry is an alias to "gds-db". This entry is now historic, not usable for use with many common service discovery mechanisms.
gds-db 3050 udp gds_db

IANA assigned this well-formed service name as a replacement for "gds_db".
Madhukar N. Thakur Madhukar N. Thakur
gds_db 3050 udp gds_db Madhukar N. Thakur Madhukar N. Thakur This entry is an alias to "gds-db". This entry is now historic, not usable for use with many common service discovery mechanisms.
galaxy-server 3051 tcp Galaxy Server Michael Andre Michael Andre
galaxy-server 3051 udp Galaxy Server Michael Andre Michael Andre
apc-3052 3052 tcp APC 3052 American Power Conversion American Power Conversion
apc-3052 3052 udp APC 3052 American Power Conversion American Power Conversion
dsom-server 3053 tcp dsom-server Daniel Sisk Daniel Sisk
dsom-server 3053 udp dsom-server Daniel Sisk Daniel Sisk
amt-cnf-prot 3054 tcp AMT CNF PROT Marco Marcucci Marco Marcucci
amt-cnf-prot 3054 udp AMT CNF PROT Marco Marcucci Marco Marcucci
policyserver 3055 tcp Policy Server Mark Garti Mark Garti
policyserver 3055 udp Policy Server Mark Garti Mark Garti
cdl-server 3056 tcp CDL Server Paul Roberts Paul Roberts
cdl-server 3056 udp CDL Server Paul Roberts Paul Roberts
goahead-fldup 3057 tcp GoAhead FldUp Alan Pickrell Alan Pickrell
goahead-fldup 3057 udp GoAhead FldUp Alan Pickrell Alan Pickrell
videobeans 3058 tcp videobeans Hiroyuki Takahashi Hiroyuki Takahashi
videobeans 3058 udp videobeans Hiroyuki Takahashi Hiroyuki Takahashi
qsoft 3059 tcp qsoft James Kunz James Kunz
qsoft 3059 udp qsoft James Kunz James Kunz
slinterbase 3065 tcp slinterbase Bie Tie Bie Tie
slinterbase 3065 udp slinterbase Bie Tie Bie Tie
orbix-locator 3075 tcp Orbix 2000 Locator
orbix-locator 3075 udp Orbix 2000 Locator
pcihreq 3085 tcp PCIHReq Paul Sanders Paul Sanders
pcihreq 3085 udp PCIHReq Paul Sanders Paul Sanders
panasas 3095 tcp Panasas rendezvous port Patrick Keane Patrick Keane 2017-08-17
panasas 3095 udp Panasas rendezvous port Patrick Keane Patrick Keane 2017-08-17

Contact Information

Name Organization Contact URI Last Updated
Alan Pickrell alanp&goahead.com
American Power Conversion ports&apcc.com 2002-02
AstroNova, Inc. ctate&astronovainc.com 2020-03-03
Bie Tie stie&interbase.com
Brent Foster brent.foster&onstreamsystems.com 2006-04
Cameron Young Cameron_Young&inetco.com
Chris Tate ctate&astronovainc.com 2020-03-03
Christian Zietz czietz&gmx.net
Chul Yoon cyoon&responsenetworks.com
Daniel Sisk danrsisk&gmail.com 2025-03-27
David Stephenson david_stephenson&hp.com
Devrex Labs robert.friberg&devrex.se 2013-03-29
Dimitrios Souflis dsouflis&altera.gr
Dino Ciano DCiano&tickets.com 2011-03-02
Eric Pulsipher eric_pulsipher&hp.com
G.E. Ozz Nixon Jr. ozznixon&gmail.com 2009-01-13
Hiroki Kawano kawano&saint.nm.fujitsu.co.jp
Hiroyuki Takahashi hiro.takahashi&eng.sun.com
Israel Beniaminy israel.beniaminy&clickservice.com
Jakob Spies Jakob.Spies&genius.de
James Kunz jkunz&earlhaig.com
Jeff Eaton jeaton&intermec.com
Joe Graham joe&edaconsulting.com
John Trudeau jtrudeau&cup.hp.com
Jonathan Mergy mergy&natus.com
Lyndon Ong LyOng&ciena.com
Madhukar N. Thakur mthakur&interbase.com
Marco Marcucci mmarcucci.amtec&interbusiness.it
Mark Garti mgarti&sonusnet.com
Michael Andre mandre&gts-tkts.com
Michael Cahill Michael.Cahill&bullant.net
Norbert Sendetzky norbert&linuxnetworks.de
Patrick Keane pkeane&panasas.com 2017-08-17
Paul Austin paul.austin&natinst.com
Paul Roberts PaulRoberts&engineer.com
Paul Sanders p.sanders&dial.pipex.com
Robert Friberg Devrex Labs robert.friberg&devrex.se 2013-03-29
Robert Reimiller bob&certsoft.com
Shuji Okubo okubo&yk.fujitsu.co.jp
Stuart Schaefer sschaefer&softricity.com
Ted Ross ross&toplayer.com
Tom Haapanen tomh&metrics.com
Tom Taylor taylor&nortelnetworks.com
Tom Taylor taylor&nortel.com 2006-09
Tomoji Koike koike&ael.fujitsu.co.jp
Toru Murai murai&saint.nm.fujitsu.co.jp
Yoshiaki Tokumoto toku&pfu.co.jp