Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
icslap 2869 udp ICSLAP Richard Lamb Richard Lamb
sps-tunnel 2876 tcp SPS Tunnel Bill McIntosh Bill McIntosh
sps-tunnel 2876 udp SPS Tunnel Bill McIntosh Bill McIntosh
responselogic 2886 tcp RESPONSELOGIC Bruce Casey Bruce Casey
responselogic 2886 udp RESPONSELOGIC Bruce Casey Bruce Casey
ecovisiong6-1 2896 tcp ECOVISIONG6-1 Henrik Holst Henrik Holst
ecovisiong6-1 2896 udp ECOVISIONG6-1 Henrik Holst Henrik Holst
m3ua 2905 tcp M3UA Lyndon Ong Lyndon Ong RFC 4666
m3ua 2905 sctp M3UA Lyndon Ong Lyndon Ong RFC 4666
caller9 2906 tcp CALLER9 Shams Naqi Shams Naqi
caller9 2906 udp CALLER9 Shams Naqi Shams Naqi
elvin-server 2916 tcp Elvin Server

IANA assigned this well-formed service name as a replacement for "elvin_server".
elvin_server 2916 tcp Elvin Server This entry is an alias to "elvin-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
elvin-server 2916 udp Elvin Server

IANA assigned this well-formed service name as a replacement for "elvin_server".
elvin_server 2916 udp Elvin Server This entry is an alias to "elvin-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
mobile-file-dl 2926 tcp MOBILE-FILE-DL Mitsuji Toda Mitsuji Toda
mobile-file-dl 2926 udp MOBILE-FILE-DL Mitsuji Toda Mitsuji Toda
otpatch 2936 tcp OTPatch Brett Goldstein Brett Goldstein
otpatch 2936 udp OTPatch Brett Goldstein Brett Goldstein
fjsvmpor 2946 tcp FJSVmpor Naoki Hayashi Naoki Hayashi
fjsvmpor 2946 udp FJSVmpor Naoki Hayashi Naoki Hayashi
ovrimosdbman 2956 tcp OVRIMOSDBMAN Dimitrios Souflis Dimitrios Souflis
ovrimosdbman 2956 udp OVRIMOSDBMAN Dimitrios Souflis Dimitrios Souflis
jmact6 2958 tcp JAMCT6
jmact6 2958 udp JAMCT6
dfoxserver 2960 tcp DFOXSERVER David Holden David Holden
dfoxserver 2960 udp DFOXSERVER David Holden David Holden
boldsoft-lm 2961 tcp BOLDSOFT-LM Fredrik Haglund Fredrik Haglund
boldsoft-lm 2961 udp BOLDSOFT-LM Fredrik Haglund Fredrik Haglund
iph-policy-cli 2962 tcp IPH-POLICY-CLI
iph-policy-cli 2962 udp IPH-POLICY-CLI
iph-policy-adm 2963 tcp IPH-POLICY-ADM Shai Herzog Shai Herzog
iph-policy-adm 2963 udp IPH-POLICY-ADM Shai Herzog Shai Herzog
bullant-srap 2964 tcp BULLANT SRAP
bullant-srap 2964 udp BULLANT SRAP
bullant-rap 2965 tcp BULLANT RAP Michael Cahill Michael Cahill
bullant-rap 2965 udp BULLANT RAP Michael Cahill Michael Cahill
idp-infotrieve 2966 tcp IDP-INFOTRIEVE Kevin Bruckert Kevin Bruckert
idp-infotrieve 2966 udp IDP-INFOTRIEVE Kevin Bruckert Kevin Bruckert
ssc-agent 2967 tcp SSC-AGENT George Dzieciol George Dzieciol
ssc-agent 2967 udp SSC-AGENT George Dzieciol George Dzieciol
enpp 2968 tcp ENPP Kazuhito Gassho Kazuhito Gassho
enpp 2968 udp ENPP Kazuhito Gassho Kazuhito Gassho
essp 2969 tcp ESSP Hitoshi Ishida Hitoshi Ishida
essp 2969 udp ESSP Hitoshi Ishida Hitoshi Ishida
cns-srv-port 2976 tcp CNS Server Port Ram Golla Ram Golla
cns-srv-port 2976 udp CNS Server Port Ram Golla Ram Golla
h263-video 2979 tcp H.263 Video Streaming Jauvane C. de Oliveira Jauvane C. de Oliveira
h263-video 2979 udp H.263 Video Streaming Jauvane C. de Oliveira Jauvane C. de Oliveira
stonefalls 2986 tcp STONEFALLS Scott Grau Scott Grau
stonefalls 2986 udp STONEFALLS Scott Grau Scott Grau
vsixml 2996 tcp vsixml Rob Juergens Rob Juergens
vsixml 2996 udp vsixml Rob Juergens Rob Juergens
origo-native 3001 tcp OrigoDB Server Native Interface Devrex Labs Robert Friberg 2013-03-29 port 3001 previously "Removed on 2006-05-25"
3001 udp Reserved 2013-03-29 port 3001 previously "Removed on 2006-05-25"
ii-admin 3006 tcp Instant Internet Admin PerfTech, Inc. Lewis Donzis 2019-12-19
ii-admin 3006 udp Instant Internet Admin PerfTech, Inc. Lewis Donzis 2019-12-19
notify-srvr 3016 tcp Notify Server

IANA assigned this well-formed service name as a replacement for "notify_srvr".
Hugo Parra Hugo Parra
notify_srvr 3016 tcp Notify Server Hugo Parra Hugo Parra This entry is an alias to "notify-srvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
notify-srvr 3016 udp Notify Server

IANA assigned this well-formed service name as a replacement for "notify_srvr".
Hugo Parra Hugo Parra
notify_srvr 3016 udp Notify Server Hugo Parra Hugo Parra This entry is an alias to "notify-srvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
agri-gateway 3026 tcp AGRI Gateway Agri Datalog Agri Datalog
agri-gateway 3026 udp AGRI Gateway Agri Datalog Agri Datalog
hagel-dump 3036 tcp Hagel DUMP Haim Gelfenbeyn Haim Gelfenbeyn
hagel-dump 3036 udp Hagel DUMP Haim Gelfenbeyn Haim Gelfenbeyn
di-ase 3046 tcp di-ase Carlos Hung Carlos Hung
di-ase 3046 udp di-ase Carlos Hung Carlos Hung
cdl-server 3056 tcp CDL Server Paul Roberts Paul Roberts
cdl-server 3056 udp CDL Server Paul Roberts Paul Roberts
interserver 3060 tcp interserver Madhukar N. Thakur Madhukar N. Thakur Known Unauthorized Use on port 3060
interserver 3060 udp interserver Madhukar N. Thakur Madhukar N. Thakur Known Unauthorized Use on port 3060
cautcpd 3061 tcp cautcpd
cautcpd 3061 udp cautcpd
ncacn-ip-tcp 3062 tcp ncacn-ip-tcp
ncacn-ip-tcp 3062 udp ncacn-ip-tcp
ncadg-ip-udp 3063 tcp ncadg-ip-udp Gabi Kalmar Gabi Kalmar
ncadg-ip-udp 3063 udp ncadg-ip-udp Gabi Kalmar Gabi Kalmar
rprt 3064 tcp Remote Port Redirector Robin Johnston Robin Johnston
rprt 3064 udp Remote Port Redirector Robin Johnston Robin Johnston
slinterbase 3065 tcp slinterbase Bie Tie Bie Tie
slinterbase 3065 udp slinterbase Bie Tie Bie Tie
netattachsdmp 3066 tcp NETATTACHSDMP Mike Young Mike Young
netattachsdmp 3066 udp NETATTACHSDMP Mike Young Mike Young
fjhpjp 3067 tcp FJHPJP Ryozo Furutani Ryozo Furutani
fjhpjp 3067 udp FJHPJP Ryozo Furutani Ryozo Furutani
ls3bcast 3068 tcp ls3 Broadcast
ls3bcast 3068 udp ls3 Broadcast
ls3 3069 tcp ls3 Jim Thompson Jim Thompson
ls3 3069 udp ls3 Jim Thompson Jim Thompson
orbix-config 3076 tcp Orbix 2000 Config
orbix-config 3076 udp Orbix 2000 Config
jdl-dbkitchen 3086 tcp JDL-DBKitchen Hideo Wakabayashi Hideo Wakabayashi
jdl-dbkitchen 3086 udp JDL-DBKitchen Hideo Wakabayashi Hideo Wakabayashi
ndl-aps 3096 tcp Active Print Server Port Martin Norman Martin Norman
ndl-aps 3096 udp Active Print Server Port Martin Norman Martin Norman
cardbox-http 3106 tcp Cardbox HTTP Martin Kochanski Martin Kochanski
cardbox-http 3106 udp Cardbox HTTP Martin Kochanski Martin Kochanski
mctet-gateway 3116 tcp MCTET Gateway
mctet-gateway 3116 udp MCTET Gateway
3126 Unassigned 2007-10-04
grubd 3136 tcp Grub Server Port Kord Campbell Kord Campbell

Contact Information

Name Organization Contact URI Last Updated
Agri Datalog contact&agri-datalog.com
Bie Tie stie&interbase.com
Bill McIntosh bmcintosh&fortresstech.com
Brett Goldstein bgoldstein&opentable.com
Bruce Casey bcasey&responselogic.com
Carlos Hung chung&digisle.net
David Holden mdh&rentek.net
Devrex Labs robert.friberg&devrex.se 2013-03-29
Dimitrios Souflis dsouflis&altera.gr
Fredrik Haglund fredik.haglund&boldsoft.com
Gabi Kalmar kalga01&cai.com
George Dzieciol gdzieciol&symantec.com 2002-07
Haim Gelfenbeyn haim&hageltech.com
Henrik Holst henrik.holst&ecovision.se
Hideo Wakabayashi hiwaka&alles.or.jp
Hitoshi Ishida ishida.hitoshi&exc.epson.co.jp
Hugo Parra hparra&novell.com
Jauvane C. de Oliveira jauvane&acm.org
Jim Thompson jim.thompson&powerware.com
Kazuhito Gassho Gassho.Kasuhito&exc.epson.co.jp
Kevin Bruckert kbruckert&idpco.com
Kord Campbell kord&grub.org
Lewis Donzis lew&perftech.com 2019-12-19
Lyndon Ong LyOng&ciena.com
Madhukar N. Thakur mthakur&interbase.com
Martin Kochanski martin&cardbox.co.uk
Martin Norman martin&ndl.co.uk
Michael Cahill Michael.Cahill&bullant.net
Mike Young myong&netattach.com
Mitsuji Toda toda&mmedia.mci.mei.co.jp
Naoki Hayashi ha&fjh.se.fujitsu.co.jp
Paul Roberts PaulRoberts&engineer.com
PerfTech, Inc. contact&perftech.com 2019-12-19
Ram Golla rgolla&cisco.com
Richard Lamb rlamb&microsoft.com
Rob Juergens robj&vsi.com
Robert Friberg Devrex Labs robert.friberg&devrex.se 2013-03-29
Robin Johnston robinj&learningtree.com
Ryozo Furutani furutani&np.lps.cs.fujitsu.co.jp
Scott Grau sgrau&stonefalls.com
Shai Herzog herzog&iphighway.com
Shams Naqi SSNAQVI&aol.com