Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| odi-port | 3187 | tcp | Open Design Listen Port | Phivos Aristides | Phivos Aristides | ||||||
| odi-port | 3187 | udp | Open Design Listen Port | Phivos Aristides | Phivos Aristides | ||||||
| embrace-dp-s | 3197 | tcp | Embrace Device Protocol Server | ||||||||
| embrace-dp-s | 3197 | udp | Embrace Device Protocol Server | ||||||||
| isns | 3205 | tcp | iSNS Server Port | RFC 4171 | |||||||
| isns | 3205 | udp | iSNS Server Port | RFC 4171 | |||||||
| vx-auth-port | 3207 | tcp | Veritas Authentication Port | Senthil Ponnuswamy | Senthil Ponnuswamy | ||||||
| vx-auth-port | 3207 | udp | Veritas Authentication Port | Senthil Ponnuswamy | Senthil Ponnuswamy | ||||||
| neon24x7 | 3213 | tcp | NEON 24X7 Mission Control | Tony Lubrano | Tony Lubrano | ||||||
| neon24x7 | 3213 | udp | NEON 24X7 Mission Control | Tony Lubrano | Tony Lubrano | ||||||
| unite | 3217 | tcp | Unified IP & Telecom Environment | Christer Gunnarsson | Christer Gunnarsson | 2009-03-26 | |||||
| unite | 3217 | udp | Unified IP & Telecom Environment | Christer Gunnarsson | Christer Gunnarsson | 2009-03-26 | |||||
| dwnmshttp | 3227 | tcp | DiamondWave NMS Server | ||||||||
| dwnmshttp | 3227 | udp | DiamondWave NMS Server | ||||||||
| apparenet-tps | 3237 | tcp | appareNet Test Packet Sequencer | ||||||||
| apparenet-tps | 3237 | udp | appareNet Test Packet Sequencer | ||||||||
| dvt-data | 3247 | tcp | DVT DATA LINK | Phillip Heil | Phillip Heil | 2002-02 | |||||
| dvt-data | 3247 | udp | DVT DATA LINK | Phillip Heil | Phillip Heil | 2002-02 | |||||
| cpqrpm-server | 3257 | tcp | Compaq RPM Server Port | Royal King | Royal King | 2002-02 | |||||
| cpqrpm-server | 3257 | udp | Compaq RPM Server Port | Royal King | Royal King | 2002-02 | |||||
| iscsi-target | 3260 | tcp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| iscsi-target | 3260 | udp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| ibm-dial-out | 3267 | tcp | IBM Dial Out | Skip Booth | Skip Booth | ||||||
| ibm-dial-out | 3267 | udp | IBM Dial Out | Skip Booth | Skip Booth | ||||||
| verismart | 3270 | tcp | Verismart | Jay Weber | Jay Weber | ||||||
| verismart | 3270 | udp | Verismart | Jay Weber | Jay Weber | ||||||
| csoft-prev | 3271 | tcp | CSoft Prev Port | Nedelcho Stanev | Nedelcho Stanev | ||||||
| csoft-prev | 3271 | udp | CSoft Prev Port | Nedelcho Stanev | Nedelcho Stanev | ||||||
| user-manager | 3272 | tcp | Fujitsu User Manager | Yukihiko Sakurai | Yukihiko Sakurai | ||||||
| user-manager | 3272 | udp | Fujitsu User Manager | Yukihiko Sakurai | Yukihiko Sakurai | ||||||
| sxmp | 3273 | tcp | Simple Extensible Multiplexed Protocol | admin | admin | ||||||
| sxmp | 3273 | udp | Simple Extensible Multiplexed Protocol | admin | admin | ||||||
| ordinox-server | 3274 | tcp | Ordinox Server | Denis Ducharme | Denis Ducharme | ||||||
| ordinox-server | 3274 | udp | Ordinox Server | Denis Ducharme | Denis Ducharme | ||||||
| samd | 3275 | tcp | SAMD | Edgar Circenis | Edgar Circenis | ||||||
| samd | 3275 | udp | SAMD | Edgar Circenis | Edgar Circenis | ||||||
| maxim-asics | 3276 | tcp | Maxim ASICs | Dave Inman | Dave Inman | ||||||
| maxim-asics | 3276 | udp | Maxim ASICs | Dave Inman | Dave Inman | ||||||
| awg-proxy | 3277 | tcp | AWG Proxy | Alex McDonald | Alex McDonald | ||||||
| awg-proxy | 3277 | udp | AWG Proxy | Alex McDonald | Alex McDonald | ||||||
| lkcmserver | 3278 | tcp | LKCM Server | Javier Jimenez | Javier Jimenez | ||||||
| lkcmserver | 3278 | udp | LKCM Server | Javier Jimenez | Javier Jimenez | ||||||
| admind | 3279 | tcp | admind | Jeff Haynes | Jeff Haynes | ||||||
| admind | 3279 | udp | admind | Jeff Haynes | Jeff Haynes | ||||||
| directvdata | 3287 | tcp | DIRECTVDATA | Michael Friedman | Michael Friedman | ||||||
| directvdata | 3287 | udp | DIRECTVDATA | Michael Friedman | Michael Friedman | ||||||
| cytel-lm | 3297 | tcp | Cytel License Manager | Yogesh P. Gajjar | Yogesh P. Gajjar | ||||||
| cytel-lm | 3297 | udp | Cytel License Manager | Yogesh P. Gajjar | Yogesh P. Gajjar | ||||||
| opsession-prxy | 3307 | tcp | OP Session Proxy | Amir Blich | Amir Blich | ||||||
| opsession-prxy | 3307 | udp | OP Session Proxy | Amir Blich | Amir Blich | ||||||
| vsaiport | 3317 | tcp | VSAI PORT | Rieko Asai | Rieko Asai | ||||||
| vsaiport | 3317 | udp | VSAI PORT | Rieko Asai | Rieko Asai | ||||||
| bbars | 3327 | tcp | BBARS | Lou Harris | Lou Harris | ||||||
| bbars | 3327 | udp | BBARS | Lou Harris | Lou Harris | ||||||
| directv-catlg | 3337 | tcp | Direct TV Data Catalog | Michael Friedman | Michael Friedman | ||||||
| directv-catlg | 3337 | udp | Direct TV Data Catalog | Michael Friedman | Michael Friedman | ||||||
| phoenix-rpc | 3347 | tcp | Phoenix RPC | Ian Anderson | Ian Anderson | ||||||
| phoenix-rpc | 3347 | udp | Phoenix RPC | Ian Anderson | Ian Anderson | ||||||
| adtech-test | 3357 | tcp | Adtech Test IP | Robin Uyeshiro | Robin Uyeshiro | ||||||
| adtech-test | 3357 | udp | Adtech Test IP | Robin Uyeshiro | Robin Uyeshiro | ||||||
| satvid-datalnk | 3367-3371 | Satellite Video Data Link | Scott Engel | Scott Engel | |||||||
| tip2 | 3372 | tcp | TIP 2 | Keith Evans | Keith Evans | ||||||
| tip2 | 3372 | udp | TIP 2 | Keith Evans | Keith Evans | ||||||
| lavenir-lm | 3373 | tcp | Lavenir License Manager | Marius Matioc | Marius Matioc | ||||||
| lavenir-lm | 3373 | udp | Lavenir License Manager | Marius Matioc | Marius Matioc | ||||||
| cluster-disc | 3374 | tcp | Cluster Disc | Jeff Hughes | Jeff Hughes | ||||||
| cluster-disc | 3374 | udp | Cluster Disc | Jeff Hughes | Jeff Hughes | ||||||
| vsnm-agent | 3375 | tcp | VSNM Agent | Venkat Rangan | Venkat Rangan | ||||||
| vsnm-agent | 3375 | udp | VSNM Agent | Venkat Rangan | Venkat Rangan | ||||||
| cdbroker | 3376 | tcp | CD Broker | Moon Ho Chung | Moon Ho Chung | ||||||
| cdbroker | 3376 | udp | CD Broker | Moon Ho Chung | Moon Ho Chung | ||||||
| cogsys-lm | 3377 | tcp | Cogsys Network License Manager | Simon Chinnick | Simon Chinnick | ||||||
| cogsys-lm | 3377 | udp | Cogsys Network License Manager | Simon Chinnick | Simon Chinnick | ||||||
| wsicopy | 3378 | tcp | WSICOPY | James Overby | James Overby | ||||||
| wsicopy | 3378 | udp | WSICOPY | James Overby | James Overby | ||||||
| socorfs | 3379 | tcp | SOCORFS | Hugo Charbonneau | Hugo Charbonneau | ||||||
| socorfs | 3379 | udp | SOCORFS | Hugo Charbonneau | Hugo Charbonneau | ||||||
| backroomnet | 3387 | tcp | Back Room Net | Clayton Wilkinson | Clayton Wilkinson | ||||||
| backroomnet | 3387 | udp | Back Room Net | Clayton Wilkinson | Clayton Wilkinson | ||||||
| cloanto-lm | 3397 | tcp | Cloanto License Manager | Takeo Sato | Takeo Sato | 2010-04-30 | |||||
| cloanto-lm | 3397 | udp | Cloanto License Manager | Takeo Sato | Takeo Sato | 2010-04-30 | |||||
| ldap-admin | 3407 | tcp | LDAP admin server port | Stephen Tsun | Stephen Tsun | 2002-02 | |||||
| ldap-admin | 3407 | udp | LDAP admin server port | Stephen Tsun | Stephen Tsun | 2002-02 | |||||
| csvr | 3417 | tcp | ConServR file translation | Albert Leung | Albert Leung | 2002-02 | |||||
| csvr | 3417 | udp | ConServR file translation | Albert Leung | Albert Leung | 2002-02 | |||||
| ifcp-port | 3420 | tcp | iFCP User Port | RFC 4172 | |||||||
| ifcp-port | 3420 | udp | iFCP User Port | RFC 4172 | |||||||
| websphere-snmp | 3427 | tcp | WebSphere SNMP | Richard Mills | Richard Mills | 2002-02 | |||||
| websphere-snmp | 3427 | udp | WebSphere SNMP | Richard Mills | Richard Mills | 2002-02 | |||||
| autocueds | 3437 | tcp | Autocue Directory Service | Geoff Back | Geoff Back | 2002-03 | |||||
| autocueds | 3437 | udp | Autocue Directory Service | Geoff Back | Geoff Back | 2002-03 | |||||
| directnet | 3447 | tcp | DirectNet IM System | Gregory Richards | Gregory Richards | 2002-04 | |||||
| directnet | 3447 | udp | DirectNet IM System | Gregory Richards | Gregory Richards | 2002-04 | |||||
| vat-control | 3457 | tcp | VAT default control | Van Jacobson | Van Jacobson | ||||||
| vat-control | 3457 | udp | VAT default control | Van Jacobson | Van Jacobson | ||||||
| rcst | 3467 | tcp | RCST | Kit Sturgeon | Kit Sturgeon | ||||||
| rcst | 3467 | udp | RCST | Kit Sturgeon | Kit Sturgeon | ||||||
| jt400 | 3470 | tcp | jt400 | ||||||||
| jt400 | 3470 | udp | jt400 | ||||||||
| jt400-ssl | 3471 | tcp | jt400-ssl | Clifton Nock | Clifton Nock | ||||||
| jt400-ssl | 3471 | udp | jt400-ssl | Clifton Nock | Clifton Nock |