Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rib-slm 3296 udp Rib License Manager Kristean Heisler Kristean Heisler
cytel-lm 3297 tcp Cytel License Manager Yogesh P. Gajjar Yogesh P. Gajjar
cytel-lm 3297 udp Cytel License Manager Yogesh P. Gajjar Yogesh P. Gajjar
deskview 3298 tcp DeskView Manfred Randelzofer Manfred Randelzofer
deskview 3298 udp DeskView Manfred Randelzofer Manfred Randelzofer
pdrncs 3299 tcp pdrncs Paul Wissenbach Paul Wissenbach
pdrncs 3299 udp pdrncs Paul Wissenbach Paul Wissenbach
tns-adv 3309 tcp TNS ADV Jerome Albin Jerome Albin
tns-adv 3309 udp TNS ADV Jerome Albin Jerome Albin
sdt-lmd 3319 tcp SDT License Manager Salvo Nassisi Salvo Nassisi
sdt-lmd 3319 udp SDT License Manager Salvo Nassisi Salvo Nassisi
hp-device-disc 3329 tcp HP Device Disc Shivaun Albright Shivaun Albright
hp-device-disc 3329 udp HP Device Disc Shivaun Albright Shivaun Albright
anet-l 3339 tcp OMF data l
anet-l 3339 udp OMF data l
chevinservices 3349 tcp Chevin Services Gus McNaughton Gus McNaughton
chevinservices 3349 udp Chevin Services Gus McNaughton Gus McNaughton
wg-netforce 3359 tcp WG NetForce Lee Wheat Lee Wheat
wg-netforce 3359 udp WG NetForce Lee Wheat Lee Wheat
socorfs 3379 tcp SOCORFS Hugo Charbonneau Hugo Charbonneau
socorfs 3379 udp SOCORFS Hugo Charbonneau Hugo Charbonneau
ms-wbt-server 3389 tcp MS WBT Server Jordan Marchese Jordan Marchese 2022-11-03
ms-wbt-server 3389 udp MS WBT Server Jordan Marchese Jordan Marchese
dsc 3390 tcp Distributed Service Coordinator Charles Honton Charles Honton
dsc 3390 udp Distributed Service Coordinator Charles Honton Charles Honton
savant 3391 tcp SAVANT Andy Bruce Andy Bruce
savant 3391 udp SAVANT Andy Bruce Andy Bruce
efi-lm 3392 tcp EFI License Management Ross E. Greinke Ross E. Greinke
efi-lm 3392 udp EFI License Management Ross E. Greinke Ross E. Greinke
d2k-tapestry1 3393 tcp D2K Tapestry Client to Server
d2k-tapestry1 3393 udp D2K Tapestry Client to Server
d2k-tapestry2 3394 tcp D2K Tapestry Server to Server Eric Lan Eric Lan
d2k-tapestry2 3394 udp D2K Tapestry Server to Server Eric Lan Eric Lan
dyna-lm 3395 tcp Dyna License Manager (Elam) Anjana Iyer Anjana Iyer
dyna-lm 3395 udp Dyna License Manager (Elam) Anjana Iyer Anjana Iyer
printer-agent 3396 tcp Printer Agent

IANA assigned this well-formed service name as a replacement for "printer_agent".
Devon Taylor Devon Taylor
printer_agent 3396 tcp Printer Agent Devon Taylor Devon Taylor This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
printer-agent 3396 udp Printer Agent

IANA assigned this well-formed service name as a replacement for "printer_agent".
Devon Taylor Devon Taylor
printer_agent 3396 udp Printer Agent Devon Taylor Devon Taylor This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
cloanto-lm 3397 tcp Cloanto License Manager Takeo Sato Takeo Sato 2010-04-30
cloanto-lm 3397 udp Cloanto License Manager Takeo Sato Takeo Sato 2010-04-30
mercantile 3398 tcp Mercantile Erik Kragh Jensen Erik Kragh Jensen
mercantile 3398 udp Mercantile Erik Kragh Jensen Erik Kragh Jensen
csms 3399 tcp CSMS
csms 3399 udp CSMS
networklens 3409 tcp NetworkLens Event Port
networklens 3409 udp NetworkLens Event Port
softaudit 3419 tcp Isogon SoftAudit Per Hellberg Per Hellberg 2002-02
softaudit 3419 udp ISogon SoftAudit Per Hellberg Per Hellberg 2002-02
gcsp 3429 tcp GCSP user port Anirban Majumder Anirban Majumder 2002-03
gcsp 3429 udp GCSP user port Anirban Majumder Anirban Majumder 2002-03
hri-port 3439 tcp HRI Interface Port John Fayos John Fayos 2002-03
hri-port 3439 udp HRI Interface Port John Fayos John Fayos 2002-03
hotu-chat 3449 tcp HotU Chat Tim Burgess Tim Burgess 2002-04
hotu-chat 3449 udp HotU Chat Tim Burgess Tim Burgess 2002-04
integral 3459 tcp TIP Integral Integral Software Olivier Mascia 2023-11-07
integral 3459 udp TIP Integral Integral Software Olivier Mascia 2023-11-07
pluribus 3469 tcp Pluribus Mark Miller Mark Miller
pluribus 3469 udp Pluribus Mark Miller Mark Miller
stun 3478 tcp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
stun 3478 udp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
twrpc 3479 tcp 2Wire RPC 2Wire IANA Contact 2Wire IANA Contact 2002-04
twrpc 3479 udp 2Wire RPC 2Wire IANA Contact 2Wire IANA Contact 2002-04
dtp-dia 3489 tcp DTP/DIA Alexei V. Soloviev Alexei V. Soloviev 2002-05
dtp-dia 3489 udp DTP/DIA Alexei V. Soloviev Alexei V. Soloviev 2002-05
colubris 3490 tcp Colubris Management Port Gilbert Moineau Gilbert Moineau 2002-05
colubris 3490 udp Colubris Management Port Gilbert Moineau Gilbert Moineau 2002-05
swr-port 3491 tcp SWR Port Ian Manning Ian Manning 2002-05
swr-port 3491 udp SWR Port Ian Manning Ian Manning 2002-05
tvdumtray-port 3492 tcp TVDUM Tray Port Peter Boers Peter Boers 2002-05
tvdumtray-port 3492 udp TVDUM Tray Port Peter Boers Peter Boers 2002-05
nut 3493 tcp Network UPS Tools Network UPS Tools Project Evgeny Klimov 2002-05 2022-05-18 RFC 9271
nut 3493 udp Network UPS Tools Network UPS Tools Project Evgeny Klimov 2002-05 2020-12-16
ibm3494 3494 tcp IBM 3494 Jeffrey Pilch Jeffrey Pilch
ibm3494 3494 udp IBM 3494 Jeffrey Pilch Jeffrey Pilch
seclayer-tcp 3495 tcp securitylayer over tcp
seclayer-tcp 3495 udp securitylayer over tcp
seclayer-tls 3496 tcp securitylayer over tls Arno Hollosi Arno Hollosi 2002-03
seclayer-tls 3496 udp securitylayer over tls Arno Hollosi Arno Hollosi 2002-03
ipether232port 3497 tcp ipEther232Port Marcus Leufgen Marcus Leufgen 2002-05
ipether232port 3497 udp ipEther232Port Marcus Leufgen Marcus Leufgen 2002-05
dashpas-port 3498 tcp DASHPAS user port Albrecht Mayer Albrecht Mayer 2002-05
dashpas-port 3498 udp DASHPAS user port Albrecht Mayer Albrecht Mayer 2002-05
sccip-media 3499 tcp SccIP Media David Yon David Yon 2002-05
sccip-media 3499 udp SccIP Media David Yon David Yon 2002-05
lsp-ping 3503 tcp MPLS LSP-echo Port RFC 8029
lsp-ping 3503 udp MPLS LSP-echo Port RFC 8029
vt-ssl 3509 tcp Virtual Token SSL Port Libor Sykora Libor Sykora 2002-05
vt-ssl 3509 udp Virtual Token SSL Port Libor Sykora Libor Sykora 2002-05
nvmsgd 3519 tcp Netvion Messenger Port
galileo 3519 udp Netvion Galileo Port
jboss-iiop-ssl 3529 tcp JBoss IIOP/SSL Francisco Reverbel Francisco Reverbel 2002-06
jboss-iiop-ssl 3529 udp JBoss IIOP/SSL Francisco Reverbel Francisco Reverbel 2002-06
ibm-diradm-ssl 3539 tcp IBM Directory Server SSL Mark Cavage Mark Cavage 2002-07
ibm-diradm-ssl 3539 udp IBM Directory Server SSL Mark Cavage Mark Cavage 2002-07
tellumat-nms 3549 tcp Tellumat MDR NMS Hennie van der Merwe Hennie van der Merwe 2002-07
tellumat-nms 3549 udp Tellumat MDR NMS Hennie van der Merwe Hennie van der Merwe 2002-07
cctv-port 3559 tcp CCTV control port John Skidmore John Skidmore 2002-07
cctv-port 3559 udp CCTV control port John Skidmore John Skidmore 2002-07
mbg-ctrl 3569 tcp Meinberg Control Service Meinberg Funkuhren GmbH & Co. KG Meinberg IANA Registrations 2002-08 2019-04-23
mbg-ctrl 3569 udp Meinberg Control Service Meinberg Funkuhren GmbH & Co. KG Meinberg IANA Registrations 2002-08 2019-04-23

Contact Information

Name Organization Contact URI Last Updated
Albrecht Mayer albrecht.mayer&infineon.com 2002-05
Alexei V. Soloviev avsolov&lab127.karelia.ru 2002-05
Andy Bruce franklin_yah&yahoo.com
Anirban Majumder majumderanirban&lycos.com 2002-03
Anjana Iyer anjana&dyna.com
Arno Hollosi arno.hollosi&cio.gv.at 2002-03
Charles Honton chas&honton.org
David Yon dyon&dialout.net 2002-05
Devon Taylor dtaylor&novell.com
Eric Lan elan&d2k.com
Erik Kragh Jensen kragh&inet.uni2.dk
Evgeny Klimov jimklimov+nut&gmail.com 2020-12-16
Francisco Reverbel reverbel&ime.usp.br 2002-06
Gilbert Moineau gilbert.moineau&colubris.com 2002-05
Gus McNaughton gus&chevin.com
Hennie van der Merwe hvandermerwe&tellumat.com 2002-07
Hugo Charbonneau
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ian Manning imanning&dtsuk.com 2002-05
Integral Software om&integral.software 2023-11-07
Jeffrey Pilch jpilch&us.ibm.com
Jerome Albin albin&taec.enet.dec.com
John Fayos john.fayos&criticallink.com 2002-03
John Skidmore JSkidmore&vicon-cctv.com 2002-07
Jordan Marchese jordanm&microsoft.com 2022-11-03
Kristean Heisler kh&rib.de
Lee Wheat wheat&wg.com
Libor Sykora libor.sykora&st.com 2002-05
Manfred Randelzofer manfred.randelzofer&fujitsu-siemens.com
Marcus Leufgen leufgen&ipcas.de 2002-05
Mark Cavage mcavage&us.ibm.com 2002-07
Mark Miller markm&caplet.com
Meinberg Funkuhren GmbH & Co. KG martin.burnicki&meinberg.de 2019-04-23
Meinberg IANA Registrations iana-admin&meinberg.de 2019-04-23
Network UPS Tools Project iana&networkupstools.org 2020-12-16
Olivier Mascia om&integral.software 2023-11-07
Paul Wissenbach paulwi&vnd.tek.com
Per Hellberg phellberg&isogon.com 2002-02
Peter Boers boers&isisglobal.nl 2002-05
Ross E. Greinke greinker&execpc.com
Salvo Nassisi sdtech&tin.it
Shivaun Albright shivaun_albright&hp.com 2002-04
Takeo Sato ts-iana&cloanto.net 2010-04-30
Tim Burgess tim&hotu.com 2002-04
2Wire IANA Contact iana&2wire.com 2002-04
Yogesh P. Gajjar yogesh&cytel.com