Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| panasas | 3095 | udp | Panasas rendezvous port | Patrick Keane | Patrick Keane | 2017-08-17 | |||||
| itu-bicc-stc | 3097 | sctp | ITU-T Q.1902.1/Q.2150.3 | Greg Sidebottom | Greg Sidebottom | ||||||
| cardbox | 3105 | tcp | Cardbox | ||||||||
| cardbox | 3105 | udp | Cardbox | ||||||||
| mctet-master | 3115 | tcp | MCTET Master | ||||||||
| mctet-master | 3115 | udp | MCTET Master | ||||||||
| a13-an | 3125 | tcp | A13-AN Interface | Douglas Knisely | Douglas Knisely | ||||||
| a13-an | 3125 | udp | A13-AN Interface | Douglas Knisely | Douglas Knisely | ||||||
| peerbook-port | 3135 | tcp | PeerBook Port | John Flowers | John Flowers | ||||||
| peerbook-port | 3135 | udp | PeerBook Port | John Flowers | John Flowers | ||||||
| csi-lfap | 3145 | tcp | CSI-LFAP | Paul Amsden | Paul Amsden | Known UNAUTHORIZED USE: port 3145 | |||||
| csi-lfap | 3145 | udp | CSI-LFAP | Paul Amsden | Paul Amsden | Known UNAUTHORIZED USE: port 3145 | |||||
| nm-asses-admin | 3150 | tcp | NetMike Assessor Administrator | ||||||||
| nm-asses-admin | 3150 | udp | NetMike Assessor Administrator | ||||||||
| nm-assessor | 3151 | tcp | NetMike Assessor | Andrew Sharpe | Andrew Sharpe | ||||||
| nm-assessor | 3151 | udp | NetMike Assessor | Andrew Sharpe | Andrew Sharpe | ||||||
| feitianrockey | 3152 | tcp | FeiTian Port | Huang Yu | Huang Yu | ||||||
| feitianrockey | 3152 | udp | FeiTian Port | Huang Yu | Huang Yu | ||||||
| s8-client-port | 3153 | tcp | S8Cargo Client Port | Jon S. Kyle | Jon S. Kyle | ||||||
| s8-client-port | 3153 | udp | S8Cargo Client Port | Jon S. Kyle | Jon S. Kyle | ||||||
| ccmrmi | 3154 | tcp | ON RMI Registry | Ram Sudama | Ram Sudama | ||||||
| ccmrmi | 3154 | udp | ON RMI Registry | Ram Sudama | Ram Sudama | ||||||
| jpegmpeg | 3155 | tcp | JpegMpeg Port | Richard Bassous | Richard Bassous | ||||||
| jpegmpeg | 3155 | udp | JpegMpeg Port | Richard Bassous | Richard Bassous | ||||||
| indura | 3156 | tcp | Indura Collector | Bruce Kosbab | Bruce Kosbab | ||||||
| indura | 3156 | udp | Indura Collector | Bruce Kosbab | Bruce Kosbab | ||||||
| lsa-comm | 3157 | tcp | LSA Communicator | Brian Carnell | Brian Carnell | 2024-03-18 | |||||
| lsa-comm | 3157 | udp | LSA Communicator | Brian Carnell | Brian Carnell | 2024-03-18 | |||||
| stvp | 3158 | tcp | SmashTV Protocol | Christian Wolff | Christian Wolff | ||||||
| stvp | 3158 | udp | SmashTV Protocol | Christian Wolff | Christian Wolff | ||||||
| navegaweb-port | 3159 | tcp | NavegaWeb Tarification | Miguel Angel Fernandez | Miguel Angel Fernandez | ||||||
| navegaweb-port | 3159 | udp | NavegaWeb Tarification | Miguel Angel Fernandez | Miguel Angel Fernandez | ||||||
| newgenpay | 3165 | tcp | Newgenpay Engine Service | Ilan Zisser | Ilan Zisser | ||||||
| newgenpay | 3165 | udp | Newgenpay Engine Service | Ilan Zisser | Ilan Zisser | ||||||
| t1-e1-over-ip | 3175 | tcp | T1_E1_Over_IP | Mark Doyle | Mark Doyle | ||||||
| t1-e1-over-ip | 3175 | udp | T1_E1_Over_IP | Mark Doyle | Mark Doyle | ||||||
| smpppd | 3185 | tcp | SuSE Meta PPPD | Arvin Schnell | Arvin Schnell | ||||||
| smpppd | 3185 | udp | SuSE Meta PPPD | Arvin Schnell | Arvin Schnell | ||||||
| ncu-1 | 3195 | tcp | Network Control Unit | ||||||||
| ncu-1 | 3195 | udp | Network Control Unit | ||||||||
| isns | 3205 | tcp | iSNS Server Port | RFC 4171 | |||||||
| isns | 3205 | udp | iSNS Server Port | RFC 4171 | |||||||
| jmq-daemon-2 | 3215 | tcp | JMQ Daemon Port 2 | Martin West | Martin West | ||||||
| jmq-daemon-2 | 3215 | udp | JMQ Daemon Port 2 | Martin West | Martin West | ||||||
| fcip-port | 3225 | tcp | FCIP | RFC 3821 | |||||||
| fcip-port | 3225 | udp | FCIP | RFC 3821 | |||||||
| mdtp | 3232 | tcp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| mdtp | 3232 | udp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| mdap-port | 3235 | tcp | MDAP port | Johan Deleu | Johan Deleu | 2002-02 | |||||
| mdap-port | 3235 | udp | MDAP Port | Johan Deleu | Johan Deleu | 2002-02 | |||||
| vieo-fe | 3245 | tcp | VIEO Fabric Executive | James Cox | James Cox | 2002-02 | |||||
| vieo-fe | 3245 | udp | VIEO Fabric Executive | James Cox | James Cox | 2002-02 | |||||
| hicp | 3250 | tcp | HMS hicp port | Joel Palsson | Joel Palsson | 2002-02 | |||||
| hicp | 3250 | udp | HMS hicp port | Joel Palsson | Joel Palsson | 2002-02 | |||||
| sysscanner | 3251 | tcp | Sys Scanner | Dick Georges | Dick Georges | 2002-02 | |||||
| sysscanner | 3251 | udp | Sys Scanner | Dick Georges | Dick Georges | 2002-02 | |||||
| dhe | 3252 | tcp | DHE port | Fabrizio Massimo Ferrara | Fabrizio Massimo Ferrara | 2002-02 | |||||
| dhe | 3252 | udp | DHE port | Fabrizio Massimo Ferrara | Fabrizio Massimo Ferrara | 2002-02 | |||||
| pda-data | 3253 | tcp | PDA Data | ||||||||
| pda-data | 3253 | udp | PDA Data | ||||||||
| pda-sys | 3254 | tcp | PDA System | Jian Fan | Jian Fan | 2002-02 | |||||
| pda-sys | 3254 | udp | PDA System | Jian Fan | Jian Fan | 2002-02 | |||||
| semaphore | 3255 | tcp | Semaphore Connection Port | Jay Eckles | Jay Eckles | 2002-02 | |||||
| semaphore | 3255 | udp | Semaphore Connection Port | Jay Eckles | Jay Eckles | 2002-02 | |||||
| cpqrpm-agent | 3256 | tcp | Compaq RPM Agent Port | ||||||||
| cpqrpm-agent | 3256 | udp | Compaq RPM Agent Port | ||||||||
| cpqrpm-server | 3257 | tcp | Compaq RPM Server Port | Royal King | Royal King | 2002-02 | |||||
| cpqrpm-server | 3257 | udp | Compaq RPM Server Port | Royal King | Royal King | 2002-02 | |||||
| ivecon-port | 3258 | tcp | Ivecon Server Port | Serguei Tevs | Serguei Tevs | 2002-02 | |||||
| ivecon-port | 3258 | udp | Ivecon Server Port | Serguei Tevs | Serguei Tevs | 2002-02 | |||||
| epncdp2 | 3259 | tcp | Epson Network Common Devi | Oishi Toshiaki | Oishi Toshiaki | 2002-02 | |||||
| epncdp2 | 3259 | udp | Epson Network Common Devi | Oishi Toshiaki | Oishi Toshiaki | 2002-02 | |||||
| altav-tunnel | 3265 | tcp | Altav Tunnel | Gary M. Allen | Gary M. Allen | ||||||
| altav-tunnel | 3265 | udp | Altav Tunnel | Gary M. Allen | Gary M. Allen | ||||||
| samd | 3275 | tcp | SAMD | Edgar Circenis | Edgar Circenis | ||||||
| samd | 3275 | udp | SAMD | Edgar Circenis | Edgar Circenis | ||||||
| plato | 3285 | tcp | Plato | Jim Battin | Jim Battin | ||||||
| plato | 3285 | udp | Plato | Jim Battin | Jim Battin | ||||||
| dyniplookup | 3295 | tcp | Dynamic IP Lookup | Eugene Osovetsky | Eugene Osovetsky | ||||||
| dyniplookup | 3295 | udp | Dynamic IP Lookup | Eugene Osovetsky | Eugene Osovetsky | ||||||
| odette-ftp | 3305 | tcp | ODETTE-FTP | David Nash | David Nash | RFC 5024 | |||||
| odette-ftp | 3305 | udp | ODETTE-FTP | David Nash | David Nash | RFC 5024 | |||||
| cdid | 3315 | tcp | CDID | Andrew Borisov | Andrew Borisov | ||||||
| cdid | 3315 | udp | CDID | Andrew Borisov | Andrew Borisov | ||||||
| active-net | 3322-3325 | Active Networks | Bob Braden | Bob Braden | |||||||
| directv-soft | 3335 | tcp | Direct TV Software Updates | ||||||||
| directv-soft | 3335 | udp | Direct TV Software Updates | ||||||||
| influence | 3345 | tcp | Influence | Russ Ferriday | Russ Ferriday | ||||||
| influence | 3345 | udp | Influence | Russ Ferriday | Russ Ferriday | ||||||
| findviatv | 3350 | tcp | FINDVIATV | Oran Davis | Oran Davis | ||||||
| findviatv | 3350 | udp | FINDVIATV | Oran Davis | Oran Davis | ||||||
| btrieve | 3351 | tcp | Btrieve port | ||||||||
| btrieve | 3351 | udp | Btrieve port | ||||||||
| ssql | 3352 | tcp | Scalable SQL | Chuck Talk | Chuck Talk | ||||||
| ssql | 3352 | udp | Scalable SQL | Chuck Talk | Chuck Talk | ||||||
| fatpipe | 3353 | tcp | FATPIPE | Sanchaita Datta | Sanchaita Datta | ||||||
| fatpipe | 3353 | udp | FATPIPE | Sanchaita Datta | Sanchaita Datta | ||||||
| suitjd | 3354 | tcp | SUITJD | Todd Moyer | Todd Moyer | ||||||
| suitjd | 3354 | udp | SUITJD | Todd Moyer | Todd Moyer | ||||||
| ordinox-dbase | 3355 | tcp | Ordinox Dbase | Denis Ducharme | Denis Ducharme | ||||||
| ordinox-dbase | 3355 | udp | Ordinox Dbase | Denis Ducharme | Denis Ducharme |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrew Borisov | hdr&chat.ru | ||
| Andrew Sharpe | help&smartsims.com | ||
| Arvin Schnell | arvin&suse.de | ||
| Bob Braden | braden&isi.edu | ||
| Brian Carnell | brian&carnellcrew.com | 2024-03-18 | |
| Bruce Kosbab | bruce.kosbab&indurasoft.com | ||
| Christian Wolff | stvp&smash.tv | ||
| Chuck Talk | ctalk&pervasive.com | ||
| David Nash | dnash&ford.com | ||
| Denis Ducharme | dducharme&softek.com | ||
| Dick Georges | georges&monaco.net | 2002-02 | |
| Douglas Knisely | dnk&lucent.com | ||
| Edgar Circenis | ec&fc.hp.com | ||
| Eugene Osovetsky | eugeneo&geocities.com | ||
| Fabrizio Massimo Ferrara | fmf&gesi.it | 2002-02 | |
| Gary M. Allen | gallen&symantec.com | ||
| Greg Sidebottom | gregside&home.com | ||
| Huang Yu | llw&ftsafe.com | ||
| Ilan Zisser | ilan&newgenpay.com | ||
| James Cox | jocox&view.com | 2002-02 | |
| Jay Eckles | ecklesweb&yahoo.com | 2002-02 | |
| Jian Fan | fjian&dmfsys.com | 2002-02 | |
| Jim Battin | battin&tro.com | ||
| Joel Palsson | HMS Industrial Networks AB | ianacontact&hms.se | 2002-02 |
| Johan Deleu | johan.deleu&alcatel.be | 2002-02 | |
| John Flowers | jf&gigamediaaccess.com | ||
| Jon S. Kyle | JKyle&speedwaysoftware.com | ||
| Mark Doyle | mark&engagecom.com | ||
| Martin West | Martin.West&spirit-soft.com | ||
| Miguel Angel Fernandez | mafg&tid.es | ||
| Oishi Toshiaki | SEIKO EPSON Corporation | Oishi.Toshiaki&exc.epson.co.jp | 2002-02 |
| Oran Davis | oran&8x8.com | ||
| Patrick Keane | pkeane&panasas.com | 2017-08-17 | |
| Paul Amsden | amsden@.ctron.com | ||
| Ram Sudama | ram&fikus.net | 2018-01-05 | |
| Richard Bassous | rbassous&yahoo.com | ||
| Royal King | royal.king&compaq.com | 2002-02 | |
| Russ Ferriday | russf&topia.com | ||
| Sanchaita Datta | sdatta&ragula.com | ||
| Serguei Tevs | STevs&ivecon.com | 2002-02 | |
| Todd Moyer | tsm&unx.dec.com |