Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| grubd | 3136 | tcp | Grub Server Port | Kord Campbell | Kord Campbell | ||||||
| grubd | 3136 | udp | Grub Server Port | Kord Campbell | Kord Campbell | ||||||
| bears-02 | 3146 | tcp | bears-02 | Bruce McKinnon | Bruce McKinnon | ||||||
| bears-02 | 3146 | udp | bears-02 | Bruce McKinnon | Bruce McKinnon | ||||||
| indura | 3156 | tcp | Indura Collector | Bruce Kosbab | Bruce Kosbab | ||||||
| indura | 3156 | udp | Indura Collector | Bruce Kosbab | Bruce Kosbab | ||||||
| tip-app-server | 3160 | tcp | TIP Application Server | Integral Software | Olivier Mascia | 2023-11-07 | |||||
| tip-app-server | 3160 | udp | TIP Application Server | Integral Software | Olivier Mascia | 2023-11-07 | |||||
| doc1lm | 3161 | tcp | DOC1 License Manager | Greg Goodson | Greg Goodson | ||||||
| doc1lm | 3161 | udp | DOC1 License Manager | Greg Goodson | Greg Goodson | ||||||
| sflm | 3162 | tcp | SFLM | System Administrator | System Administrator | ||||||
| sflm | 3162 | udp | SFLM | System Administrator | System Administrator | ||||||
| res-sap | 3163 | tcp | RES-SAP | Bob Janssen | Bob Janssen | ||||||
| res-sap | 3163 | udp | RES-SAP | Bob Janssen | Bob Janssen | ||||||
| imprs | 3164 | tcp | IMPRS | Lars Bohn | Lars Bohn | ||||||
| imprs | 3164 | udp | IMPRS | Lars Bohn | Lars Bohn | ||||||
| newgenpay | 3165 | tcp | Newgenpay Engine Service | Ilan Zisser | Ilan Zisser | ||||||
| newgenpay | 3165 | udp | Newgenpay Engine Service | Ilan Zisser | Ilan Zisser | ||||||
| sossecollector | 3166 | tcp | Quest Spotlight Out-Of-Process Collector | Greg Cottman | Greg Cottman | 2008-10-23 | |||||
| sossecollector | 3166 | udp | Quest Spotlight Out-Of-Process Collector | Greg Cottman | Greg Cottman | 2008-10-23 | |||||
| nowcontact | 3167 | tcp | Now Contact Public Server | ||||||||
| nowcontact | 3167 | udp | Now Contact Public Server | ||||||||
| poweronnud | 3168 | tcp | Now Up-to-Date Public Server | John Wallace | John Wallace | ||||||
| poweronnud | 3168 | udp | Now Up-to-Date Public Server | John Wallace | John Wallace | ||||||
| serverview-as | 3169 | tcp | SERVERVIEW-AS | ||||||||
| serverview-as | 3169 | udp | SERVERVIEW-AS | ||||||||
| ars-master | 3176 | tcp | ARS Master | Portnoy Boxman | Portnoy Boxman | ||||||
| ars-master | 3176 | udp | ARS Master | Portnoy Boxman | Portnoy Boxman | ||||||
| iiw-port | 3186 | tcp | IIW Monitor User Port | Corey Burnett | Corey Burnett | ||||||
| iiw-port | 3186 | udp | IIW Monitor User Port | Corey Burnett | Corey Burnett | ||||||
| ncu-2 | 3196 | tcp | Network Control Unit | Charlie Hundre | Charlie Hundre | ||||||
| ncu-2 | 3196 | udp | Network Control Unit | Charlie Hundre | Charlie Hundre | ||||||
| ironmail | 3206 | tcp | IronMail POP Proxy | Mike Hudack | Mike Hudack | ||||||
| ironmail | 3206 | udp | IronMail POP Proxy | Mike Hudack | Mike Hudack | ||||||
| ferrari-foam | 3216 | tcp | Ferrari electronic FOAM | Johann Deutinger | Johann Deutinger | ||||||
| ferrari-foam | 3216 | udp | Ferrari electronic FOAM | Johann Deutinger | Johann Deutinger | ||||||
| isi-irp | 3226 | tcp | ISI Industry Software IRP | Peter Sandstrom | Peter Sandstrom | ||||||
| isi-irp | 3226 | udp | ISI Industry Software IRP | Peter Sandstrom | Peter Sandstrom | ||||||
| mdtp | 3232 | tcp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| mdtp | 3232 | udp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| apparenet-ts | 3236 | tcp | appareNet Test Server | ||||||||
| apparenet-ts | 3236 | udp | appareNet Test Server | ||||||||
| dvt-system | 3246 | tcp | DVT SYSTEM PORT | ||||||||
| dvt-system | 3246 | udp | DVT SYSTEM PORT | ||||||||
| cpqrpm-agent | 3256 | tcp | Compaq RPM Agent Port | ||||||||
| cpqrpm-agent | 3256 | udp | Compaq RPM Agent Port | ||||||||
| iscsi-target | 3260 | tcp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| iscsi-target | 3260 | udp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| winshadow | 3261 | tcp | winShadow | Colin Barry | Colin Barry | ||||||
| winshadow | 3261 | udp | winShadow | Colin Barry | Colin Barry | ||||||
| necp | 3262 | tcp | NECP | Alberto Cerpa | Alberto Cerpa | ||||||
| necp | 3262 | udp | NECP | Alberto Cerpa | Alberto Cerpa | ||||||
| ecolor-imager | 3263 | tcp | E-Color Enterprise Imager | Tamara Baker | Tamara Baker | ||||||
| ecolor-imager | 3263 | udp | E-Color Enterprise Imager | Tamara Baker | Tamara Baker | ||||||
| ccmail | 3264 | tcp | cc:mail/lotus | brockman | brockman | ||||||
| ccmail | 3264 | udp | cc:mail/lotus | brockman | brockman | ||||||
| altav-tunnel | 3265 | tcp | Altav Tunnel | Gary M. Allen | Gary M. Allen | ||||||
| altav-tunnel | 3265 | udp | Altav Tunnel | Gary M. Allen | Gary M. Allen | ||||||
| ns-cfg-server | 3266 | tcp | NS CFG Server | Aivi Lie | Aivi Lie | ||||||
| ns-cfg-server | 3266 | udp | NS CFG Server | Aivi Lie | Aivi Lie | ||||||
| ibm-dial-out | 3267 | tcp | IBM Dial Out | Skip Booth | Skip Booth | ||||||
| ibm-dial-out | 3267 | udp | IBM Dial Out | Skip Booth | Skip Booth | ||||||
| msft-gc | 3268 | tcp | Microsoft Global Catalog | ||||||||
| msft-gc | 3268 | udp | Microsoft Global Catalog | ||||||||
| msft-gc-ssl | 3269 | tcp | Microsoft Global Catalog with LDAP/SSL | Asaf Kashi | Asaf Kashi | ||||||
| msft-gc-ssl | 3269 | udp | Microsoft Global Catalog with LDAP/SSL | Asaf Kashi | Asaf Kashi | ||||||
| maxim-asics | 3276 | tcp | Maxim ASICs | Dave Inman | Dave Inman | ||||||
| maxim-asics | 3276 | udp | Maxim ASICs | Dave Inman | Dave Inman | ||||||
| e-net | 3286 | tcp | E-Net | Steven Grigsby | Steven Grigsby | ||||||
| e-net | 3286 | udp | E-Net | Steven Grigsby | Steven Grigsby | ||||||
| rib-slm | 3296 | tcp | Rib License Manager | Kristean Heisler | Kristean Heisler | ||||||
| rib-slm | 3296 | udp | Rib License Manager | Kristean Heisler | Kristean Heisler | ||||||
| mysql | 3306 | tcp | MySQL | Monty | Monty | ||||||
| mysql | 3306 | udp | MySQL | Monty | Monty | ||||||
| aicc-cmi | 3316 | tcp | AICC/CMI | William McDonald | William McDonald | ||||||
| aicc-cmi | 3316 | udp | AICC/CMI | William McDonald | William McDonald | ||||||
| sftu | 3326 | tcp | SFTU | Eduardo Rosenberg de Moura | Eduardo Rosenberg de Moura | ||||||
| sftu | 3326 | udp | SFTU | Eduardo Rosenberg de Moura | Eduardo Rosenberg de Moura | ||||||
| directv-tick | 3336 | tcp | Direct TV Tickers | ||||||||
| directv-tick | 3336 | udp | Direct TV Tickers | ||||||||
| trnsprntproxy | 3346 | tcp | Trnsprnt Proxy | Grant Kirby | Grant Kirby | ||||||
| trnsprntproxy | 3346 | udp | Trnsprnt Proxy | Grant Kirby | Grant Kirby | ||||||
| upnotifyps | 3356 | tcp | UPNOTIFYPS | Mark Fox | Mark Fox | ||||||
| upnotifyps | 3356 | udp | UPNOTIFYPS | Mark Fox | Mark Fox | ||||||
| kv-server | 3360 | tcp | KV Server | ||||||||
| kv-server | 3360 | udp | KV Server | ||||||||
| kv-agent | 3361 | tcp | KV Agent | Thomas Soranno | Thomas Soranno | ||||||
| kv-agent | 3361 | udp | KV Agent | Thomas Soranno | Thomas Soranno | ||||||
| dj-ilm | 3362 | tcp | DJ ILM | Don Tyson | Don Tyson | ||||||
| dj-ilm | 3362 | udp | DJ ILM | Don Tyson | Don Tyson | ||||||
| nati-vi-server | 3363 | tcp | NATI Vi Server | National Instruments | Jeff Peters | ||||||
| nati-vi-server | 3363 | udp | NATI Vi Server | National Instruments | Jeff Peters | ||||||
| creativeserver | 3364 | tcp | Creative Server | ||||||||
| creativeserver | 3364 | udp | Creative Server | ||||||||
| contentserver | 3365 | tcp | Content Server | ||||||||
| contentserver | 3365 | udp | Content Server | ||||||||
| creativepartnr | 3366 | tcp | Creative Partner | Jesus Ortiz | Jesus Ortiz | ||||||
| creativepartnr | 3366 | udp | Creative Partner | Jesus Ortiz | Jesus Ortiz | ||||||
| satvid-datalnk | 3367-3371 | Satellite Video Data Link | Scott Engel | Scott Engel | |||||||
| cdbroker | 3376 | tcp | CD Broker | Moon Ho Chung | Moon Ho Chung | ||||||
| cdbroker | 3376 | udp | CD Broker | Moon Ho Chung | Moon Ho Chung |