Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| mbg-ctrl | 3569 | udp | Meinberg Control Service | Meinberg Funkuhren GmbH & Co. KG | Meinberg IANA Registrations | 2002-08 | 2019-04-23 | ||||
| ttat3lb | 3579 | tcp | Tarantella Load Balancing | Jim Musgrave | Jim Musgrave | 2002-08 | |||||
| ttat3lb | 3579 | udp | Tarantella Load Balancing | Jim Musgrave | Jim Musgrave | 2002-08 | |||||
| isomair | 3589 | tcp | isomair | Richard Fleming | Richard Fleming | 2002-08 | |||||
| isomair | 3589 | udp | isomair | Richard Fleming | Richard Fleming | 2002-08 | |||||
| wv-csp-sms | 3590 | tcp | WV CSP SMS Binding | Matti Salmi | Matti Salmi | 2002-08 | |||||
| wv-csp-sms | 3590 | udp | WV CSP SMS Binding | Matti Salmi | Matti Salmi | 2002-08 | |||||
| gtrack-server | 3591 | tcp | LOCANIS G-TRACK Server | ||||||||
| gtrack-server | 3591 | udp | LOCANIS G-TRACK Server | ||||||||
| gtrack-ne | 3592 | tcp | LOCANIS G-TRACK NE Port | Juergen Edelhaeuser | Juergen Edelhaeuser | 2002-08 | |||||
| gtrack-ne | 3592 | udp | LOCANIS G-TRACK NE Port | Juergen Edelhaeuser | Juergen Edelhaeuser | 2002-08 | |||||
| bpmd | 3593 | tcp | BP Model Debugger | Keith Fligg | Keith Fligg | 2002-09 | |||||
| bpmd | 3593 | udp | BP Model Debugger | Keith Fligg | Keith Fligg | 2002-09 | |||||
| mediaspace | 3594 | tcp | MediaSpace | ||||||||
| mediaspace | 3594 | udp | MediaSpace | ||||||||
| shareapp | 3595 | tcp | ShareApp | Jeff King | Jeff King | 2002-09 | |||||
| shareapp | 3595 | udp | ShareApp | Jeff King | Jeff King | 2002-09 | |||||
| iw-mmogame | 3596 | tcp | Illusion Wireless MMOG | Jan Vrsinsky | Jan Vrsinsky | 2002-09 | |||||
| iw-mmogame | 3596 | udp | Illusion Wireless MMOG | Jan Vrsinsky | Jan Vrsinsky | 2002-09 | |||||
| a14 | 3597 | tcp | A14 (AN-to-SC/MM) | ||||||||
| a14 | 3597 | udp | A14 (AN-to-SC/MM) | ||||||||
| a15 | 3598 | tcp | A15 (AN-to-AN) | David Ott | David Ott | 2002-09 | |||||
| a15 | 3598 | udp | A15 (AN-to-AN) | David Ott | David Ott | 2002-09 | |||||
| quasar-server | 3599 | tcp | Quasar Accounting Server | Brad Pepers | Brad Pepers | 2002-09 | |||||
| quasar-server | 3599 | udp | Quasar Accounting Server | Brad Pepers | Brad Pepers | 2002-09 | |||||
| cpdi-pidas-cm | 3609 | tcp | CPDI PIDAS Connection Mon | Tony Splaver | Tony Splaver | 2002-09 | |||||
| cpdi-pidas-cm | 3609 | udp | CPDI PIDAS Connection Mon | Tony Splaver | Tony Splaver | 2002-09 | |||||
| aairnet-2 | 3619 | tcp | AAIR-Network 2 | James Mealey | James Mealey | 2002-10 | |||||
| aairnet-2 | 3619 | udp | AAIR-Network 2 | James Mealey | James Mealey | 2002-10 | |||||
| escvpnet | 3629 | tcp | ESC/VP.net | Hiroyuki Hashimoto | Hiroyuki Hashimoto | 2002-10 | |||||
| escvpnet | 3629 | udp | ESC/VP.net | Hiroyuki Hashimoto | Hiroyuki Hashimoto | 2002-10 | |||||
| xap-ha | 3639 | tcp | Extensible Automation | Mark Harrison | Mark Harrison | 2002-11 | |||||
| xap-ha | 3639 | udp | Extensible Automation | Mark Harrison | Mark Harrison | 2002-11 | |||||
| nmmp | 3649 | tcp | Nishioka Miyuki Msg Protocol | TAKEDA Hiroyuki | TAKEDA Hiroyuki | 2003-01 | |||||
| nmmp | 3649 | udp | Nishioka Miyuki Msg Protocol | TAKEDA Hiroyuki | TAKEDA Hiroyuki | 2003-01 | |||||
| apple-sasl | 3659 | tcp | Apple SASL | David M. O'Rourke | David M. O'Rourke | 2003-01 | |||||
| apple-sasl | 3659 | udp | Apple SASL | David M. O'Rourke | David M. O'Rourke | 2003-01 | |||||
| casanswmgmt | 3669 | tcp | CA SAN Switch Management | Emre Tunar | Emre Tunar | 2003-01 | |||||
| casanswmgmt | 3669 | udp | CA SAN Switch Management | Emre Tunar | Emre Tunar | 2003-01 | |||||
| newton-dock | 3679 | tcp | Newton Dock | Paul Guyot | Paul Guyot | 2025-01-23 | |||||
| newton-dock | 3679 | udp | Newton Dock | Paul Guyot | Paul Guyot | 2025-01-23 | |||||
| daap | 3689 | tcp | Digital Audio Access Protocol (iTunes) | Amandeep Jawa | Amandeep Jawa | 2003-01 | Defined TXT keys: txtvers, Version, iTSh Version, Machine ID, Database ID, Machine Name, Password | ||||
| daap | 3689 | udp | Digital Audio Access Protocol (iTunes) | Amandeep Jawa | Amandeep Jawa | 2003-01 | Defined TXT keys: txtvers, Version, iTSh Version, Machine ID, Database ID, Machine Name, Password | ||||
| svn | 3690 | tcp | Subversion | Greg Hudson | Greg Hudson | 2003-01 | |||||
| svn | 3690 | udp | Subversion | Greg Hudson | Greg Hudson | 2003-01 | |||||
| magaya-network | 3691 | tcp | Magaya Network Port | Jesus David Rodriguez | Jesus David Rodriguez | 2003-02 | |||||
| magaya-network | 3691 | udp | Magaya Network Port | Jesus David Rodriguez | Jesus David Rodriguez | 2003-02 | |||||
| intelsync | 3692 | tcp | Brimstone IntelSync | Davey Taylor | Davey Taylor | 2003-02 | |||||
| intelsync | 3692 | udp | Brimstone IntelSync | Davey Taylor | Davey Taylor | 2003-02 | |||||
| easl | 3693 | tcp | Emergency Automatic Structure Lockdown System | Mele Associates | Greg Hansen; Randy Yates | 2014-11-26 | This port was previously removed on 2007-04-05. | ||||
| 3693 | udp | Reserved | 2014-11-26 | This port was previously removed on 2007-04-05. | |||||||
| 3694 | Unassigned | 2007-04-05 | |||||||||
| bmc-data-coll | 3695 | tcp | BMC Data Collection | Portnoy Boxman | Portnoy Boxman | 2003-02 | |||||
| bmc-data-coll | 3695 | udp | BMC Data Collection | Portnoy Boxman | Portnoy Boxman | 2003-02 | |||||
| telnetcpcd | 3696 | tcp | Telnet Com Port Control | Thomas J. Pinkl | Thomas J. Pinkl | 2003-02 | |||||
| telnetcpcd | 3696 | udp | Telnet Com Port Control | Thomas J. Pinkl | Thomas J. Pinkl | 2003-02 | |||||
| nw-license | 3697 | tcp | NavisWorks License System | Tim Wiegand | Tim Wiegand | 2003-02 | |||||
| nw-license | 3697 | udp | NavisWorks License System | Tim Wiegand | Tim Wiegand | 2003-02 | |||||
| sagectlpanel | 3698 | tcp | SAGECTLPANEL | Mark Gamble | Mark Gamble | 2003-02 | |||||
| sagectlpanel | 3698 | udp | SAGECTLPANEL | Mark Gamble | Mark Gamble | 2003-02 | |||||
| kpn-icw | 3699 | tcp | Internet Call Waiting | B. J. Kortekaas | B. J. Kortekaas | 2003-02 | |||||
| kpn-icw | 3699 | udp | Internet Call Waiting | B. J. Kortekaas | B. J. Kortekaas | 2003-02 | |||||
| ca-idms | 3709 | tcp | CA-IDMS Server | Dave Ross | Dave Ross | ||||||
| ca-idms | 3709 | udp | CA-IDMS Server | Dave Ross | Dave Ross | ||||||
| itelserverport | 3719 | tcp | iTel Server Port | Mark Hendricks | Mark Hendricks | 2003-03 | |||||
| itelserverport | 3719 | udp | iTel Server Port | Mark Hendricks | Mark Hendricks | 2003-03 | |||||
| fksp-audit | 3729 | tcp | Fireking Audit Port | Richard Thurman | Richard Thurman | 2003-04 | |||||
| fksp-audit | 3729 | udp | Fireking Audit Port | Richard Thurman | Richard Thurman | 2003-04 | |||||
| launchbird-lm | 3739 | tcp | Launchbird LicenseManager | Tom Hawkins | Tom Hawkins | 2003-04 | |||||
| launchbird-lm | 3739 | udp | Launchbird LicenseManager | Tom Hawkins | Tom Hawkins | 2003-04 | |||||
| cimtrak | 3749 | tcp | CimTrak | Robert E. Johnson III | Robert E. Johnson III | 2003-04 | |||||
| cimtrak | 3749 | udp | CimTrak | Robert E. Johnson III | Robert E. Johnson III | 2003-04 | |||||
| exapt-lmgr | 3759 | tcp | Exapt License Manager | Christoph Kukulies | Christoph Kukulies | 2003-04 | |||||
| exapt-lmgr | 3759 | udp | Exapt License Manager | Christoph Kukulies | Christoph Kukulies | 2003-04 | |||||
| sitewatch-s | 3766 | tcp | SSL e-watch sitewatch server | e-Watch Corporation | John M Baird | 2014-05-13 | this port was previously updated on 2009-06-19 | ||||
| 3766 | udp | Reserved | this port was previously updated on 2009-06-19 | ||||||||
| haipe-otnk | 3769 | tcp | HAIPE Network Keying | Mike Irani | Mike Irani | 2003-06 | |||||
| haipe-otnk | 3769 | udp | HAIPE Network Keying | Mike Irani | Mike Irani | 2003-06 | |||||
| cognima | 3779 | tcp | Cognima Replication | Ralph Greenwell | Ralph Greenwell | 2003-06 | |||||
| cognima | 3779 | udp | Cognima Replication | Ralph Greenwell | Ralph Greenwell | 2003-06 | |||||
| remotedeploy | 3789 | tcp | RemoteDeploy Administration Port [July 2003] | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| remotedeploy | 3789 | udp | RemoteDeploy Administration Port [July 2003] | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| quickbooksrds | 3790 | tcp | QuickBooks RDS | Almira | Almira | 2003-07 | |||||
| quickbooksrds | 3790 | udp | QuickBooks RDS | Almira | Almira | 2003-07 | |||||
| tvnetworkvideo | 3791 | tcp | TV NetworkVideo Data port | Kevin Brunner | Kevin Brunner | 2003-07 | |||||
| tvnetworkvideo | 3791 | udp | TV NetworkVideo Data port | Kevin Brunner | Kevin Brunner | 2003-07 | |||||
| sitewatch | 3792 | tcp | e-Watch Corporation SiteWatch | John M. Baird | John M. Baird | 2003-07 | |||||
| sitewatch | 3792 | udp | e-Watch Corporation SiteWatch | John M. Baird | John M. Baird | 2003-07 | |||||
| dcsoftware | 3793 | tcp | DataCore Software | Andre Cato | Andre Cato | 2003-07 | |||||
| dcsoftware | 3793 | udp | DataCore Software | Andre Cato | Andre Cato | 2003-07 | |||||
| jaus | 3794 | tcp | JAUS Robots | Steven B. Cliff | Steven B. Cliff | 2003-07 | |||||
| jaus | 3794 | udp | JAUS Robots | Steven B. Cliff | Steven B. Cliff | 2003-07 | |||||
| myblast | 3795 | tcp | myBLAST Mekentosj port | Alexander Griekspoor | Alexander Griekspoor | 2003-07 | |||||
| myblast | 3795 | udp | myBLAST Mekentosj port | Alexander Griekspoor | Alexander Griekspoor | 2003-07 | |||||
| spw-dialer | 3796 | tcp | Spaceway Dialer | Patrick Fisher | Patrick Fisher | 2003-07 | |||||
| spw-dialer | 3796 | udp | Spaceway Dialer | Patrick Fisher | Patrick Fisher | 2003-07 | |||||
| idps | 3797 | tcp | idps | Jean-Francois Rabasse | Jean-Francois Rabasse | 2003-07 | |||||
| idps | 3797 | udp | idps | Jean-Francois Rabasse | Jean-Francois Rabasse | 2003-07 | |||||
| minilock | 3798 | tcp | Minilock | Daniel Julio Reyes | Daniel Julio Reyes | 2003-08 | |||||
| minilock | 3798 | udp | Minilock | Daniel Julio Reyes | Daniel Julio Reyes | 2003-08 | |||||
| radius-dynauth | 3799 | tcp | RADIUS Dynamic Authorization | RFC 3576 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alexander Griekspoor | a.griekspoor&nki.nl | 2003-07 | |
| Almira | almira_niciu&intuit.com | 2003-07 | |
| Amandeep Jawa | daap&apple.com | 2003-01 | |
| Andre Cato | andre.cato&datacore.com | 2003-07 | |
| B. J. Kortekaas | b.j.kortekaas&kpn.com | 2003-02 | |
| Brad Pepers | brad&linuxcanada.com | 2002-09 | |
| Christoph Kukulies | info&exapt.de | 2003-04 | |
| Daniel Julio Reyes | danieljreyes&yahoo.com | 2003-08 | |
| Dave Ross | david.ross&ca.com | ||
| Davey Taylor | davey.taylor&brimstone.net | 2003-02 | |
| David M. O'Rourke | daveo&apple.com | 2003-01 | |
| David Ott | dott&qualcomm.com | 2010-10-15 | |
| Detlef Rothe | detlef.rothe&ts.fujitsu.com | 2009-05-15 | |
| e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 | |
| Emre Tunar | emre.tunar&ca.com | 2004-11 | |
| Greg Hansen | Mele Associates | greg.hansen&meleassociates.com | 2014-11-26 |
| Greg Hudson | ghudson&mit.edu | 2023-11-17 | |
| Hiroyuki Hashimoto | easymp&exc.epson.co.jp | 2002-10 | |
| James Mealey | jymealey&yahoo.com | 2002-10 | |
| Jan Vrsinsky | jan.vrsinsky&illusionsoftworks.com | 2002-09 | |
| Jean-Francois Rabasse | jfr&idps.org | 2003-07 | |
| Jeff King | jking&wave3software.com | 2002-09 | |
| Jesus David Rodriguez | jesusdavid&magaya.com | 2003-02 | |
| Jim Musgrave | jimm&tarantella.com | 2002-08 | |
| John M. Baird | jbaird&e-watch.com | 2003-07 | |
| John M Baird | e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 |
| Juergen Edelhaeuser | Juergen.Edelhaeuser&locanis.com | 2002-08 | |
| Keith Fligg | keith&projtech.com | 2002-09 | |
| Kevin Brunner | brunner&tivo.com | 2003-07 | |
| Mark Gamble | mark.gamble&sage.com | 2003-02 | |
| Mark Harrison | Mark&xapautomation.org | 2002-11 | |
| Mark Hendricks | markah&copper.net | 2003-03 | |
| Matti Salmi | matti.salmi&nokia.com | 2002-08 | |
| Meinberg Funkuhren GmbH & Co. KG | martin.burnicki&meinberg.de | 2019-04-23 | |
| Meinberg IANA Registrations | iana-admin&meinberg.de | 2019-04-23 | |
| Mele Associates | easl&meleassociates.com | 2014-11-26 | |
| Mike Irani | irani&spawar.navy.mil | 2003-06 | |
| Patrick Fisher | pfisher&hns.com | 2004-12 | |
| Paul Guyot | pguyot&kallisys.net | 2003-01 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Randy Yates | Digital Signal Labs | yates&digitalsignallabs.com | 2014-11-26 |
| Ralph Greenwell | iana&cognima.com | 2012-03-15 | |
| Richard Fleming | richard&apoapsis.com | 2002-08 | |
| Richard Thurman | richt&fireking.com | 2003-04 | |
| Robert E. Johnson III | johnson.robert&cimcor.com | 2003-04 | |
| Steven B. Cliff | scliff&remotec-andros.com | 2003-07 | |
| TAKEDA Hiroyuki | takeda&atashi.net | 2003-01 | |
| Thomas J. Pinkl | tom&pinkl.com | 2003-02 | |
| Tim Wiegand | tim.wiegand&navisworks.com | 2003-02 | |
| Tom Hawkins | tom1&launchbird.com | 2003-04 | |
| Tony Splaver | tony&cpdi.com | 2002-09 |