Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ordinox-dbase | 3355 | udp | Ordinox Dbase | Denis Ducharme | Denis Ducharme | ||||||
| upnotifyps | 3356 | tcp | UPNOTIFYPS | Mark Fox | Mark Fox | ||||||
| upnotifyps | 3356 | udp | UPNOTIFYPS | Mark Fox | Mark Fox | ||||||
| adtech-test | 3357 | tcp | Adtech Test IP | Robin Uyeshiro | Robin Uyeshiro | ||||||
| adtech-test | 3357 | udp | Adtech Test IP | Robin Uyeshiro | Robin Uyeshiro | ||||||
| mpsysrmsvr | 3358 | tcp | Mp Sys Rmsvr | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| mpsysrmsvr | 3358 | udp | Mp Sys Rmsvr | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| wg-netforce | 3359 | tcp | WG NetForce | Lee Wheat | Lee Wheat | ||||||
| wg-netforce | 3359 | udp | WG NetForce | Lee Wheat | Lee Wheat | ||||||
| contentserver | 3365 | tcp | Content Server | ||||||||
| contentserver | 3365 | udp | Content Server | ||||||||
| vsnm-agent | 3375 | tcp | VSNM Agent | Venkat Rangan | Venkat Rangan | ||||||
| vsnm-agent | 3375 | udp | VSNM Agent | Venkat Rangan | Venkat Rangan | ||||||
| qnxnetman | 3385 | tcp | qnxnetman | Michael Hunter | Michael Hunter | ||||||
| qnxnetman | 3385 | udp | qnxnetman | Michael Hunter | Michael Hunter | ||||||
| dyna-lm | 3395 | tcp | Dyna License Manager (Elam) | Anjana Iyer | Anjana Iyer | ||||||
| dyna-lm | 3395 | udp | Dyna License Manager (Elam) | Anjana Iyer | Anjana Iyer | ||||||
| nokia-ann-ch1 | 3405 | tcp | Nokia Announcement ch 1 | ||||||||
| nokia-ann-ch1 | 3405 | udp | Nokia Announcement ch 1 | ||||||||
| bcinameservice | 3415 | tcp | BCI Name Service | Dennis Parker | Dennis Parker | 2002-02 | |||||
| bcinameservice | 3415 | udp | BCI Name Service | Dennis Parker | Dennis Parker | 2002-02 | |||||
| agps-port | 3425 | tcp | AGPS Access Port | Kristoffer Nilsson | Kristoffer Nilsson | 2002-02 | |||||
| agps-port | 3425 | udp | AGPS Access Port | Kristoffer Nilsson | Kristoffer Nilsson | 2002-02 | |||||
| pacom | 3435 | tcp | Pacom Security User Port | Steve Barton | Steve Barton | 2002-03 | |||||
| pacom | 3435 | udp | Pacom Security User Port | Steve Barton | Steve Barton | 2002-03 | |||||
| monp | 3445 | tcp | Media Object Network Protocol | Aethercloud | Ron Herardian | 2002-03 | 2019-11-11 | ||||
| monp | 3445 | udp | Media Object Network Protocol | Aethercloud | Ron Herardian | 2002-03 | 2019-11-11 | ||||
| castorproxy | 3450 | tcp | CAStorProxy | Raymond J. Young | Raymond J. Young | 2002-04 | |||||
| castorproxy | 3450 | udp | CAStorProxy | Raymond J. Young | Raymond J. Young | 2002-04 | |||||
| asam | 3451 | tcp | ASAM Services | Mike Gossett | Mike Gossett | 2002-04 | |||||
| asam | 3451 | udp | ASAM Services | Mike Gossett | Mike Gossett | 2002-04 | |||||
| sabp-signal | 3452 | tcp | SABP-Signalling Protocol | Brendan McWilliams | Brendan McWilliams | 2002-04 | |||||
| sabp-signal | 3452 | udp | SABP-Signalling Protocol | Brendan McWilliams | Brendan McWilliams | 2002-04 | |||||
| pscupd | 3453 | tcp | PSC Update | Datalogic ADC, Inc | Reid B. Ligon | 2001-11-10 | 2014-07-31 | ||||
| pscupd | 3453 | udp | PSC Update | Datalogic ADC, Inc | Reid B. Ligon | 2001-11-10 | 2014-07-31 | ||||
| mira | 3454 | tcp | Apple Remote Access Protocol | Mike Alexander | Mike Alexander | ||||||
| mira | 3454 | udp | Apple Remote Access Protocol | Mike Alexander | Mike Alexander | ||||||
| prsvp | 3455 | tcp | RSVP Port | Bob Braden | Bob Braden | ||||||
| prsvp | 3455 | udp | RSVP Port | Bob Braden | Bob Braden | ||||||
| vat | 3456 | tcp | VAT default data | Van Jacobson | Van Jacobson | ||||||
| vat | 3456 | udp | VAT default data | Van Jacobson | Van Jacobson | ||||||
| vat-control | 3457 | tcp | VAT default control | Van Jacobson | Van Jacobson | ||||||
| vat-control | 3457 | udp | VAT default control | Van Jacobson | Van Jacobson | ||||||
| d3winosfi | 3458 | tcp | D3WinOSFI | Brad Hamilton | Brad Hamilton | ||||||
| d3winosfi | 3458 | udp | D3WinOSFI | Brad Hamilton | Brad Hamilton | ||||||
| integral | 3459 | tcp | TIP Integral | Integral Software | Olivier Mascia | 2023-11-07 | |||||
| integral | 3459 | udp | TIP Integral | Integral Software | Olivier Mascia | 2023-11-07 | |||||
| edm-mgr-cntrl | 3465 | tcp | EDM MGR Cntrl | Tom Hennessy | Tom Hennessy | ||||||
| edm-mgr-cntrl | 3465 | udp | EDM MGR Cntrl | Tom Hennessy | Tom Hennessy | ||||||
| genisar-port | 3475 | tcp | Genisar Comm Port | Candace Niccolson | Candace Niccolson | 2002-04 | |||||
| genisar-port | 3475 | udp | Genisar Comm Port | Candace Niccolson | Candace Niccolson | 2002-04 | |||||
| turn | 3478 | tcp | TURN over TCP | 2019-08-02 | RFC 8656 | ||||||
| turn | 3478 | udp | TURN over UDP | 2019-08-02 | RFC 8656 | ||||||
| stun-behavior | 3478 | tcp | STUN Behavior Discovery over TCP | RFC 5780 | |||||||
| stun-behavior | 3478 | udp | STUN Behavior Discovery over UDP | RFC 5780 | |||||||
| celatalk | 3485 | tcp | CelaTalk | Carl Blundell | Carl Blundell | 2002-05 | |||||
| celatalk | 3485 | udp | CelaTalk | Carl Blundell | Carl Blundell | 2002-05 | |||||
| seclayer-tcp | 3495 | tcp | securitylayer over tcp | ||||||||
| seclayer-tcp | 3495 | udp | securitylayer over tcp | ||||||||
| rtmp-port | 3500 | tcp | RTMP Port | Miriam Wohlgelernter | Miriam Wohlgelernter | ||||||
| rtmp-port | 3500 | udp | RTMP Port | Miriam Wohlgelernter | Miriam Wohlgelernter | ||||||
| isoft-p2p | 3501 | tcp | iSoft-P2P | David Walling | David Walling | ||||||
| isoft-p2p | 3501 | udp | iSoft-P2P | David Walling | David Walling | ||||||
| avinstalldisc | 3502 | tcp | Avocent Install Discovery | Brian S. Stewart | Brian S. Stewart | ||||||
| avinstalldisc | 3502 | udp | Avocent Install Discovery | Brian S. Stewart | Brian S. Stewart | ||||||
| lsp-ping | 3503 | tcp | MPLS LSP-echo Port | RFC 8029 | |||||||
| lsp-ping | 3503 | udp | MPLS LSP-echo Port | RFC 8029 | |||||||
| ironstorm | 3504 | tcp | IronStorm game server | Arnaud Clermonte | Arnaud Clermonte | ||||||
| ironstorm | 3504 | udp | IronStorm game server | Arnaud Clermonte | Arnaud Clermonte | ||||||
| ccmcomm | 3505 | tcp | CCM communications port | Tom Bougan | Tom Bougan | ||||||
| ccmcomm | 3505 | udp | CCM communications port | Tom Bougan | Tom Bougan | ||||||
| apc-3506 | 3506 | tcp | APC 3506 | American Power Conversion | American Power Conversion | ||||||
| apc-3506 | 3506 | udp | APC 3506 | American Power Conversion | American Power Conversion | ||||||
| nesh-broker | 3507 | tcp | Nesh Broker Port | Jeremy Maiden | Jeremy Maiden | ||||||
| nesh-broker | 3507 | udp | Nesh Broker Port | Jeremy Maiden | Jeremy Maiden | ||||||
| interactionweb | 3508 | tcp | Interaction Web | Mike Gagle | Mike Gagle | ||||||
| interactionweb | 3508 | udp | Interaction Web | Mike Gagle | Mike Gagle | ||||||
| vt-ssl | 3509 | tcp | Virtual Token SSL Port | Libor Sykora | Libor Sykora | 2002-05 | |||||
| vt-ssl | 3509 | udp | Virtual Token SSL Port | Libor Sykora | Libor Sykora | 2002-05 | |||||
| xss-port | 3510 | tcp | XSS Port | Joe Purcell | Joe Purcell | 2002-05 | |||||
| xss-port | 3510 | udp | XSS Port | Joe Purcell | Joe Purcell | 2002-05 | |||||
| webmail-2 | 3511 | tcp | WebMail/2 | Dimitris Michelinakis | Dimitris Michelinakis | 2002-05 | |||||
| webmail-2 | 3511 | udp | WebMail/2 | Dimitris Michelinakis | Dimitris Michelinakis | 2002-05 | |||||
| aztec | 3512 | tcp | Aztec Distribution Port | Alan Francis | Alan Francis | 2002-05 | |||||
| aztec | 3512 | udp | Aztec Distribution Port | Alan Francis | Alan Francis | 2002-05 | |||||
| arcpd | 3513 | tcp | Adaptec Remote Protocol | Hardy Doelfel | Hardy Doelfel | 2002-05 | |||||
| arcpd | 3513 | udp | Adaptec Remote Protocol | Hardy Doelfel | Hardy Doelfel | 2002-05 | |||||
| must-p2p | 3514 | tcp | MUST Peer to Peer | ||||||||
| must-p2p | 3514 | udp | MUST Peer to Peer | ||||||||
| must-backplane | 3515 | tcp | MUST Backplane | Rick Stefanik | Rick Stefanik | 2002-05 | |||||
| must-backplane | 3515 | udp | MUST Backplane | Rick Stefanik | Rick Stefanik | 2002-05 | |||||
| smartcard-port | 3516 | tcp | Smartcard Port | Scott Guthery | Scott Guthery | 2002-05 | |||||
| smartcard-port | 3516 | udp | Smartcard Port | Scott Guthery | Scott Guthery | 2002-05 | |||||
| 802-11-iapp | 3517 | tcp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| 802-11-iapp | 3517 | udp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| artifact-msg | 3518 | tcp | Artifact Message Server | Ron Capwell | Ron Capwell | 2002-06 | |||||
| artifact-msg | 3518 | udp | Artifact Message Server | Ron Capwell | Ron Capwell | 2002-06 | |||||
| nvmsgd | 3519 | tcp | Netvion Messenger Port | ||||||||
| galileo | 3519 | udp | Netvion Galileo Port | ||||||||
| galileolog | 3520 | tcp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 | |||||
| galileolog | 3520 | udp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Aethercloud | rherardi&aethercloud.net | 2019-11-11 | |
| Alan Francis | AlanF&zonal.co.uk | 2002-05 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Anjana Iyer | anjana&dyna.com | ||
| Arnaud Clermonte | clermonte&4xtechnologies.com | ||
| Bob Braden | Braden&isi.edu | ||
| Brad Hamilton | bh&picksys.com | ||
| Brendan McWilliams | brendan.mcwilliams&vf.vodafone.co.uk | 2002-04 | |
| Brian S. Stewart | Brian.Stewart&avovent.com | ||
| Candace Niccolson | cniccolson&genisar.com | 2002-04 | |
| Carl Blundell | cblundell&celador.co.uk | 2002-05 | |
| Datalogic ADC, Inc | ReceptionBLQ&datalogic.com | 2014-07-31 | |
| David Walling | dwalling&isoft.com | ||
| Denis Ducharme | dducharme&softek.com | ||
| Dennis Parker | dparker&broadcloud.com | 2002-02 | |
| Dimitris Michelinakis | dimitris&michelinakis.gr | 2002-05 | |
| Hardy Doelfel | hardy_doelfel&adaptec.com | 2002-05 | |
| Hiroyuki Kawabuchi | buchi&ael.fujitsu.co.jp | ||
| Integral Software | om&integral.software | 2023-11-07 | |
| Jeremy Maiden | jeremy&3507.uk | 2020-05-01 | |
| Joe Purcell | jpurcell&ensuretech.com | 2003-01 | |
| Kristoffer Nilsson | kristoffer.nilsson&hutchison3g.com | 2002-02 | |
| Lee Wheat | wheat&wg.com | ||
| Libor Sykora | libor.sykora&st.com | 2002-05 | |
| Mark Fox | markf&uplanet.com | ||
| Michael Hunter | mphunter&qnx.com | ||
| Mike Alexander | mta&um.cc.umich.edu | ||
| Mike Gagle | mikeg&inin.com | 2006-05 | |
| Mike Gossett | mike&omnibond.com | 2002-04 | |
| Miriam Wohlgelernter | miriamw&adirtech.com | ||
| Olivier Mascia | om&integral.software | 2023-11-07 | |
| Ray Caruso | ray.caruso&netvion.com | 2002-06 | |
| Raymond J. Young | Raymond.Young&ca.com | 2002-04 | |
| Reid B. Ligon | Reid.Ligon&datalogic.com | 2014-07-31 | |
| Rick Stefanik | r.stefanik&gatelinx.com | 2002-05 | |
| Robin Uyeshiro | robin_u&adtech-inc.com | ||
| Ron Capwell | ron&artifactsoftware.com | 2002-06 | |
| Ron Herardian | rherardi&aethercloud.net | 2019-11-11 | |
| Scott Guthery | sguthery&mobile-mind.com | 2002-05 | |
| Steve Barton | steveb&pacom.com | 2002-03 | |
| Stuart J. Kerry | Chair IEEE 802.11 WG | stuart&ok-brit.com | 2002-05 |
| Tom Bougan | tomb&apptechsys.com | ||
| Tom Hennessy | thenn&novadigm.com | ||
| Van Jacobson | van&ee.lbl.gov | ||
| Venkat Rangan | venkatr&vitalsigns.com |