Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| cdbroker | 3376 | udp | CD Broker | Moon Ho Chung | Moon Ho Chung | ||||||
| gprs-data | 3386 | tcp | GPRS Data | ||||||||
| gprs-sig | 3386 | udp | GPRS SIG | Ansgar Bergmann | Ansgar Bergmann | ||||||
| printer-agent | 3396 | tcp | Printer Agent IANA assigned this well-formed service name as a replacement for "printer_agent". |
Devon Taylor | Devon Taylor | ||||||
| printer_agent | 3396 | tcp | Printer Agent | Devon Taylor | Devon Taylor | This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| printer-agent | 3396 | udp | Printer Agent IANA assigned this well-formed service name as a replacement for "printer_agent". |
Devon Taylor | Devon Taylor | ||||||
| printer_agent | 3396 | udp | Printer Agent | Devon Taylor | Devon Taylor | This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| nokia-ann-ch2 | 3406 | tcp | Nokia Announcement ch 2 | Morteza Kalhour | Morteza Kalhour | 2002-02 | |||||
| nokia-ann-ch2 | 3406 | udp | Nokia Announcement ch 2 | Morteza Kalhour | Morteza Kalhour | 2002-02 | |||||
| commandport | 3416 | tcp | AirMobile IS Command Port | Mike Klein | Mike Klein | 2002-02 | |||||
| commandport | 3416 | udp | AirMobile IS Command Port | Mike Klein | Mike Klein | 2002-02 | |||||
| arkivio | 3426 | tcp | Arkivio Storage Protocol | Bruce Greenblatt | Bruce Greenblatt | 2002-02 | |||||
| arkivio | 3426 | udp | Arkivio Storage Protocol | Bruce Greenblatt | Bruce Greenblatt | 2002-02 | |||||
| gc-config | 3436 | tcp | GuardControl Exchange Protocol | Andreas Schwarz | Andreas Schwarz | 2002-03 | |||||
| gc-config | 3436 | udp | GuardControl Exchange Protocol | Andreas Schwarz | Andreas Schwarz | 2002-03 | |||||
| 3comfaxrpc | 3446 | tcp | 3Com FAX RPC port | Christopher Wells | Christopher Wells | 2002-04 | |||||
| 3comfaxrpc | 3446 | udp | 3Com FAX RPC port | Christopher Wells | Christopher Wells | 2002-04 | |||||
| vat | 3456 | tcp | VAT default data | Van Jacobson | Van Jacobson | ||||||
| vat | 3456 | udp | VAT default data | Van Jacobson | Van Jacobson | ||||||
| edm-manager | 3460 | tcp | EDM Manger | ||||||||
| edm-manager | 3460 | udp | EDM Manger | ||||||||
| edm-stager | 3461 | tcp | EDM Stager | ||||||||
| edm-stager | 3461 | udp | EDM Stager | ||||||||
| edm-std-notify | 3462 | tcp | EDM STD Notify | ||||||||
| edm-std-notify | 3462 | udp | EDM STD Notify | ||||||||
| edm-adm-notify | 3463 | tcp | EDM ADM Notify | ||||||||
| edm-adm-notify | 3463 | udp | EDM ADM Notify | ||||||||
| edm-mgr-sync | 3464 | tcp | EDM MGR Sync | ||||||||
| edm-mgr-sync | 3464 | udp | EDM MGR Sync | ||||||||
| edm-mgr-cntrl | 3465 | tcp | EDM MGR Cntrl | Tom Hennessy | Tom Hennessy | ||||||
| edm-mgr-cntrl | 3465 | udp | EDM MGR Cntrl | Tom Hennessy | Tom Hennessy | ||||||
| workflow | 3466 | tcp | WORKFLOW | Robert Hufsky | Robert Hufsky | ||||||
| workflow | 3466 | udp | WORKFLOW | Robert Hufsky | Robert Hufsky | ||||||
| rcst | 3467 | tcp | RCST | Kit Sturgeon | Kit Sturgeon | ||||||
| rcst | 3467 | udp | RCST | Kit Sturgeon | Kit Sturgeon | ||||||
| ttcmremotectrl | 3468 | tcp | TTCM Remote Controll | Yossi Cohen-Shahar | Yossi Cohen-Shahar | ||||||
| ttcmremotectrl | 3468 | udp | TTCM Remote Controll | Yossi Cohen-Shahar | Yossi Cohen-Shahar | ||||||
| pluribus | 3469 | tcp | Pluribus | Mark Miller | Mark Miller | ||||||
| pluribus | 3469 | udp | Pluribus | Mark Miller | Mark Miller | ||||||
| nppmp | 3476 | tcp | NVIDIA Mgmt Protocol | Gilbert Yeung | Gilbert Yeung | 2002-04 | |||||
| nppmp | 3476 | udp | NVIDIA Mgmt Protocol | Gilbert Yeung | Gilbert Yeung | 2002-04 | |||||
| turn | 3478 | tcp | TURN over TCP | 2019-08-02 | RFC 8656 | ||||||
| turn | 3478 | udp | TURN over UDP | 2019-08-02 | RFC 8656 | ||||||
| ifsf-hb-port | 3486 | tcp | IFSF Heartbeat Port | IFSF Secretary | IFSF Secretary | 2002-05 | |||||
| ifsf-hb-port | 3486 | udp | IFSF Heartbeat Port | IFSF Secretary | IFSF Secretary | 2002-05 | |||||
| seclayer-tls | 3496 | tcp | securitylayer over tls | Arno Hollosi | Arno Hollosi | 2002-03 | |||||
| seclayer-tls | 3496 | udp | securitylayer over tls | Arno Hollosi | Arno Hollosi | 2002-03 | |||||
| apc-3506 | 3506 | tcp | APC 3506 | American Power Conversion | American Power Conversion | ||||||
| apc-3506 | 3506 | udp | APC 3506 | American Power Conversion | American Power Conversion | ||||||
| smartcard-port | 3516 | tcp | Smartcard Port | Scott Guthery | Scott Guthery | 2002-05 | |||||
| smartcard-port | 3516 | udp | Smartcard Port | Scott Guthery | Scott Guthery | 2002-05 | |||||
| starquiz-port | 3526 | tcp | starQuiz Port | Adam Ernst | Adam Ernst | 2002-06 | |||||
| starquiz-port | 3526 | udp | starQuiz Port | Adam Ernst | Adam Ernst | 2002-06 | |||||
| snac | 3536 | tcp | SNAC | Tatsuya Igarashi | Tatsuya Igarashi | 2002-07 | |||||
| snac | 3536 | udp | SNAC | Tatsuya Igarashi | Tatsuya Igarashi | 2002-07 | |||||
| 3546 | Unassigned | 2002-09 | |||||||||
| sky-transport | 3556 | tcp | Sky Transport Protocol | Michael Paddon | Michael Paddon | 2002-07 | |||||
| sky-transport | 3556 | udp | Sky Transport Protocol | Michael Paddon | Michael Paddon | 2002-07 | |||||
| iniserve-port | 3560 | tcp | INIServe port | Peter Moylan | Peter Moylan | 2002-08 | |||||
| iniserve-port | 3560 | udp | INIServe port | Peter Moylan | Peter Moylan | 2002-08 | |||||
| bmc-onekey | 3561 | tcp | BMC-OneKey | Portnoy Boxman | Portnoy Boxman | 2002-08 | |||||
| bmc-onekey | 3561 | udp | BMC-OneKey | Portnoy Boxman | Portnoy Boxman | 2002-08 | |||||
| sdbproxy | 3562 | tcp | SDBProxy | Eric Grange | Eric Grange | 2002-08 | |||||
| sdbproxy | 3562 | udp | SDBProxy | Eric Grange | Eric Grange | 2002-08 | |||||
| watcomdebug | 3563 | tcp | Watcom Debug | Dave Neudoerffer | Dave Neudoerffer | ||||||
| watcomdebug | 3563 | udp | Watcom Debug | Dave Neudoerffer | Dave Neudoerffer | ||||||
| esimport | 3564 | tcp | Electromed SIM port | Francois Marchand | Francois Marchand | 2002-08 | |||||
| esimport | 3564 | udp | Electromed SIM port | Francois Marchand | Francois Marchand | 2002-08 | |||||
| m2pa | 3565 | tcp | M2PA | RFC 4165 | |||||||
| 3565 | udp | Reserved | |||||||||
| m2pa | 3565 | sctp | M2PA | RFC 4165 | |||||||
| quest-data-hub | 3566 | tcp | Quest Data Hub | Greg Cottman | Greg Cottman | 2010-10-18 | |||||
| 3566 | udp | Reserved | 2010-10-18 | ||||||||
| dof-eps | 3567 | tcp | DOF Protocol Stack | OpenDOF | Bryant Eastham | 2002-08 | 2015-04-23 | ||||
| dof-eps | 3567 | udp | DOF Protocol Stack | OpenDOF | Bryant Eastham | 2002-08 | 2015-04-23 | ||||
| dof-tunnel-sec | 3568 | tcp | DOF Secure Tunnel | OpenDOF | Bryant Eastham | 2003-01 | 2015-04-23 | ||||
| dof-tunnel-sec | 3568 | udp | DOF Secure Tunnel | OpenDOF | Bryant Eastham | 2003-01 | 2015-04-23 | ||||
| mbg-ctrl | 3569 | tcp | Meinberg Control Service | Meinberg Funkuhren GmbH & Co. KG | Meinberg IANA Registrations | 2002-08 | 2019-04-23 | ||||
| mbg-ctrl | 3569 | udp | Meinberg Control Service | Meinberg Funkuhren GmbH & Co. KG | Meinberg IANA Registrations | 2002-08 | 2019-04-23 | ||||
| cmc-port | 3576 | tcp | Coalsere CMC Port | Chris Hawkinson | Chris Hawkinson | 2002-08 | |||||
| cmc-port | 3576 | udp | Coalsere CMC Port | Chris Hawkinson | Chris Hawkinson | 2002-08 | |||||
| emprise-lsc | 3586 | tcp | License Server Console | James J. Diaz | James J. Diaz | 2002-08 | |||||
| emprise-lsc | 3586 | udp | License Server Console | James J. Diaz | James J. Diaz | 2002-08 | |||||
| iw-mmogame | 3596 | tcp | Illusion Wireless MMOG | Jan Vrsinsky | Jan Vrsinsky | 2002-09 | |||||
| iw-mmogame | 3596 | udp | Illusion Wireless MMOG | Jan Vrsinsky | Jan Vrsinsky | 2002-09 | |||||
| trap-daemon | 3600 | tcp | text relay-answer | John Willis | John Willis | 2002-09 | 2017-07-26 | ||||
| trap-daemon | 3600 | udp | text relay-answer | John Willis | John Willis | 2002-09 | 2017-07-26 | ||||
| visinet-gui | 3601 | tcp | Visinet Gui | Jeff Douglass | Jeff Douglass | 2002-09 | |||||
| visinet-gui | 3601 | udp | Visinet Gui | Jeff Douglass | Jeff Douglass | 2002-09 | |||||
| infiniswitchcl | 3602 | tcp | InfiniSwitch Mgr Client | Lee VanTine | Lee VanTine | 2002-09 | |||||
| infiniswitchcl | 3602 | udp | InfiniSwitch Mgr Client | Lee VanTine | Lee VanTine | 2002-09 | |||||
| int-rcv-cntrl | 3603 | tcp | Integrated Rcvr Control | Dave Stone | Dave Stone | 2002-09 | |||||
| int-rcv-cntrl | 3603 | udp | Integrated Rcvr Control | Dave Stone | Dave Stone | 2002-09 | |||||
| bmc-jmx-port | 3604 | tcp | BMC JMX Port | Portnoy Boxman | Portnoy Boxman | 2002-09 | |||||
| bmc-jmx-port | 3604 | udp | BMC JMX Port | Portnoy Boxman | Portnoy Boxman | 2002-09 | |||||
| comcam-io | 3605 | tcp | ComCam IO Port | Don Gilbreath | Don Gilbreath | 2002-09 | |||||
| comcam-io | 3605 | udp | ComCam IO Port | Don Gilbreath | Don Gilbreath | 2002-09 | |||||
| splitlock | 3606 | tcp | Splitlock Server | Andrew Tune | Andrew Tune | 2002-09 | |||||
| splitlock | 3606 | udp | Splitlock Server | Andrew Tune | Andrew Tune | 2002-09 | |||||
| precise-i3 | 3607 | tcp | Precise I3 | Tomer Shain | Tomer Shain | 2002-09 | |||||
| precise-i3 | 3607 | udp | Precise I3 | Tomer Shain | Tomer Shain | 2002-09 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adam Ernst | contact&cosmicsoft.net | 2002-06 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Andreas Schwarz | andi&trancefield.de | 2002-03 | |
| Andrew Tune | Andrew.Tune&splitlock.com | 2003-01 | |
| Ansgar Bergmann | Ansgar.Bergmann&etsi.fr | ||
| Arno Hollosi | arno.hollosi&cio.gv.at | 2002-03 | |
| Bruce Greenblatt | bruce&arkivio.com | 2002-02 | |
| Bryant Eastham | OenDOF | protocol&opendof.org | 2015-04-23 |
| Chris Hawkinson | chawkinson&coalsere.com | 2002-08 | |
| Christopher Wells | christopher_wells&3com.com | 2002-04 | |
| Dave Neudoerffer | Dave.Neudoerffer&ianywhere.com | ||
| Dave Stone | dstone01&harris.com | 2002-09 | |
| Devon Taylor | dtaylor&novell.com | ||
| Don Gilbreath | don&comcam.net | 2002-09 | |
| Eric Grange | egrange&creative-it.net | 2002-08 | |
| Francois Marchand | francois.marchand&electromed.com | 2002-08 | |
| Gilbert Yeung | gyeung&nvidia.com | 2002-04 | |
| Greg Cottman | Greg.Cottman&quest.com | 2010-10-18 | |
| IFSF Secretary | secretary&ifsf.org | 2002-05 | |
| James J. Diaz | JDiaz&emprisecorporation.com | 2002-08 | |
| Jan Vrsinsky | jan.vrsinsky&illusionsoftworks.com | 2002-09 | |
| Jeff Douglass | ist&att.net | 2002-09 | |
| John Willis | jpw&coherent-logic.com | 2017-07-26 | |
| Kit Sturgeon | Kit&remotecontrolsextoys.com | ||
| Lee VanTine | lvantine&infiniswitc.com | 2002-09 | |
| Mark Miller | markm&caplet.com | ||
| Meinberg Funkuhren GmbH & Co. KG | martin.burnicki&meinberg.de | 2019-04-23 | |
| Meinberg IANA Registrations | iana-admin&meinberg.de | 2019-04-23 | |
| Michael Paddon | michael.paddon&activesky.com | 2002-07 | |
| Mike Klein | m.klein&motorla.com | 2002-02 | |
| Moon Ho Chung | mchung&esps.com | ||
| Morteza Kalhour | Morteza.Kalhour&nokia.com | 2002-02 | |
| OpenDOF | protocol&opendof.org | 2015-04-23 | |
| Peter Moylan | peter&ee.newcastle.edu.au | 2002-08 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Robert Hufsky | rhufsky&csesys.co.at | ||
| Scott Guthery | sguthery&mobile-mind.com | 2002-05 | |
| Tatsuya Igarashi | Tatsuya.Igarashi&jp.sony.com | 2002-07 | |
| Tom Hennessy | thenn&novadigm.com | ||
| Tomer Shain | tshain&precise.com | 2002-09 | |
| Van Jacobson | van&ee.lbl.gov | ||
| Yossi Cohen-Shahar | yossi&proxy.co.il |