Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
radius-dynauth 3799 tcp RADIUS Dynamic Authorization RFC 3576
radius-dynauth 3799 udp RADIUS Dynamic Authorization RFC 3576
apocd 3809 tcp Java Desktop System Configuration Agent Geoff Higgins Geoff Higgins 2006-03
apocd 3809 udp Java Desktop System Configuration Agent Geoff Higgins Geoff Higgins 2006-03
epl-slp 3819 tcp EPL Sequ Layer Protocol Hans Weibel Hans Weibel 2004-10
epl-slp 3819 udp EPL Sequ Layer Protocol Hans Weibel Hans Weibel 2004-10
neteh-ext 3829 tcp Netadmin Systems Event Handler External Jonas Krogell Jonas Krogell 2007-07-10
neteh-ext 3829 udp Netadmin Systems Event Handler External Jonas Krogell Jonas Krogell 2007-07-10
amx-rms 3839 tcp AMX Resource Management Suite Ron Barber Ron Barber 2003-11
amx-rms 3839 udp AMX Resource Management Suite Ron Barber Ron Barber 2003-11
spw-dnspreload 3849 tcp SPACEWAY DNS Preload Daniel Friedman Daniel Friedman 2003-08
spw-dnspreload 3849 udp SPACEWAY DNS Preload Daniel Friedman Daniel Friedman 2003-08
nav-port 3859 tcp Navini Port Chris Sanders Chris Sanders 2003-08
nav-port 3859 udp Navini Port Chris Sanders Chris Sanders 2003-08
ovsam-mgmt 3869 tcp hp OVSAM MgmtServer Disco Mike Pontillo Mike Pontillo 2003-08
ovsam-mgmt 3869 udp hp OVSAM MgmtServer Disco Mike Pontillo Mike Pontillo 2003-08
appss-lm 3879 tcp appss license manager Peter Krueger Peter Krueger 2003-10
appss-lm 3879 udp appss license manager Peter Krueger Peter Krueger 2003-10
dandv-tester 3889 tcp D and V Tester Control Port Voiko Loukanov Voiko Loukanov 2003-10
dandv-tester 3889 udp D and V Tester Control Port Voiko Loukanov Voiko Loukanov 2003-10
ndsconnect 3890 tcp Niche Data Server Connect Roland Schneider Roland Schneider 2003-10
ndsconnect 3890 udp Niche Data Server Connect Roland Schneider Roland Schneider 2003-10
rtc-pm-port 3891 tcp Oracle RTC-PM port PV Shivkumar PV Shivkumar 2003-10
rtc-pm-port 3891 udp Oracle RTC-PM port PV Shivkumar PV Shivkumar 2003-10
pcc-image-port 3892 tcp PCC-image-port Shiro Tamoto Shiro Tamoto 2003-10
pcc-image-port 3892 udp PCC-image-port Shiro Tamoto Shiro Tamoto 2003-10
cgi-starapi 3893 tcp CGI StarAPI Server Garry Moore Garry Moore 2003-10
cgi-starapi 3893 udp CGI StarAPI Server Garry Moore Garry Moore 2003-10
syam-agent 3894 tcp SyAM Agent Port Michael Daniele Michael Daniele 2003-10
syam-agent 3894 udp SyAM Agent Port Michael Daniele Michael Daniele 2003-10
syam-smc 3895 tcp SyAm SMC Service Port Michael Daniele Michael Daniele 2003-10
syam-smc 3895 udp SyAm SMC Service Port Michael Daniele Michael Daniele 2003-10
sdo-tls 3896 tcp Simple Distributed Objects over TLS Alexander Philippou Alexander Philippou 2003-10
sdo-tls 3896 udp Simple Distributed Objects over TLS Alexander Philippou Alexander Philippou 2003-10
sdo-ssh 3897 tcp Simple Distributed Objects over SSH Alexander Philippou Alexander Philippou 2003-10
sdo-ssh 3897 udp Simple Distributed Objects over SSH Alexander Philippou Alexander Philippou 2003-10
senip 3898 tcp IAS, Inc. SmartEye NET Internet Protocol Matt Nowicki Matt Nowicki 2003-10
senip 3898 udp IAS, Inc. SmartEye NET Internet Protocol Matt Nowicki Matt Nowicki 2003-10
itv-control 3899 tcp ITV Port Alex Nicu Alex Nicu 2003-10
itv-control 3899 udp ITV Port Alex Nicu Alex Nicu 2003-10
udt-os 3900 tcp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 tcp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
udt-os 3900 udp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 udp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
nimsh 3901 tcp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimsh 3901 udp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 tcp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 udp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
charsetmgr 3903 tcp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
charsetmgr 3903 udp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
omnilink-port 3904 tcp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
omnilink-port 3904 udp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
mupdate 3905 tcp Mailbox Update (MUPDATE) protocol RFC 3656
mupdate 3905 udp Mailbox Update (MUPDATE) protocol RFC 3656
topovista-data 3906 tcp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
topovista-data 3906 udp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
imoguia-port 3907 tcp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
imoguia-port 3907 udp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
hppronetman 3908 tcp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
hppronetman 3908 udp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
surfcontrolcpa 3909 tcp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
surfcontrolcpa 3909 udp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
prnrequest 3910 tcp Printer Request Port Brett Green Brett Green 2003-11
prnrequest 3910 udp Printer Request Port Brett Green Brett Green 2003-11
prnstatus 3911 tcp Printer Status Port Brett Green Brett Green 2003-11
prnstatus 3911 udp Printer Status Port Brett Green Brett Green 2003-11
gbmt-stars 3912 tcp Global Maintech Stars Harry Goldschmitt Harry Goldschmitt 2003-11
gbmt-stars 3912 udp Global Maintech Stars Harry Goldschmitt Harry Goldschmitt 2003-11
listcrt-port 3913 tcp ListCREATOR Port Tomokazu Asai Tomokazu Asai 2003-11
listcrt-port 3913 udp ListCREATOR Port Tomokazu Asai Tomokazu Asai 2003-11
listcrt-port-2 3914 tcp ListCREATOR Port 2 Tomokazu Asai Tomokazu Asai 2003-11
listcrt-port-2 3914 udp ListCREATOR Port 2 Tomokazu Asai Tomokazu Asai 2003-11
agcat 3915 tcp Auto-Graphics Cataloging Paul Cope Paul Cope 2003-11
agcat 3915 udp Auto-Graphics Cataloging Paul Cope Paul Cope 2003-11
wysdmc 3916 tcp WysDM Controller Jim McDonald Jim McDonald 2003-11
wysdmc 3916 udp WysDM Controller Jim McDonald Jim McDonald 2003-11
aftmux 3917 tcp AFT multiplex port Alfred Schmidt Alfred Schmidt 2003-11
aftmux 3917 udp AFT multiplex port Alfred Schmidt Alfred Schmidt 2003-11
pktcablemmcops 3918 tcp PacketCableMultimediaCOPS Eric Rosenfeld Eric Rosenfeld 2003-11
pktcablemmcops 3918 udp PacketCableMultimediaCOPS Eric Rosenfeld Eric Rosenfeld 2003-11
hyperip 3919 tcp HyperIP Network Executive Software, Inc. Nancy Golio 2003-11 2017-01-25
hyperip 3919 udp HyperIP Network Executive Software, Inc. Nancy Golio 2003-11 2017-01-25
exasoftport1 3920 tcp Exasoft IP Port Alan Malik Alan Malik 2003-11
exasoftport1 3920 udp Exasoft IP Port Alan Malik Alan Malik 2003-11
herodotus-net 3921 tcp Herodotus Net Adam Gawne-Cain Adam Gawne-Cain 2003-11
herodotus-net 3921 udp Herodotus Net Adam Gawne-Cain Adam Gawne-Cain 2003-11
sor-update 3922 tcp Soronti Update Port Carleton Watkins Carleton Watkins 2003-11
sor-update 3922 udp Soronti Update Port Carleton Watkins Carleton Watkins 2003-11
symb-sb-port 3923 tcp Symbian Service Broker Ian McDowall Ian McDowall 2003-11
symb-sb-port 3923 udp Symbian Service Broker Ian McDowall Ian McDowall 2003-11
mpl-gprs-port 3924 tcp MPL_GPRS_PORT David Barrass David Barrass 2003-11
mpl-gprs-port 3924 udp MPL_GPRS_Port David Barrass David Barrass 2003-11
zmp 3925 tcp Zoran Media Port Gerard Cerchio Gerard Cerchio 2003-11
zmp 3925 udp Zoran Media Port Gerard Cerchio Gerard Cerchio 2003-11
winport 3926 tcp WINPort Alwin Egger Alwin Egger 2003-11
winport 3926 udp WINPort Alwin Egger Alwin Egger 2003-11
natdataservice 3927 tcp ScsTsr Ghanshyam Patel Ghanshyam Patel 2003-11
natdataservice 3927 udp ScsTsr Ghanshyam Patel Ghanshyam Patel 2003-11
netboot-pxe 3928 tcp PXE NetBoot Manager Markus Treinen Markus Treinen 2003-11
netboot-pxe 3928 udp PXE NetBoot Manager Markus Treinen Markus Treinen 2003-11
smauth-port 3929 tcp AMS Port Angelique Dokos Angelique Dokos 2003-11

Contact Information

Name Organization Contact URI Last Updated
Adam Gawne-Cain adam&gawncainresearch.co.uk 2003-11
Alan Malik alan&exasoft.co.uk 2003-11
Alex Nicu alex.nicu&philips.com 2003-10
Alexander Philippou alex&noemax.com 2003-10
Alfred Schmidt a.schmidt&aft-werdohl.de 2003-11
Alwin Egger alwin.egger&tegonal.com 2003-11
Angelique Dokos angelique.dokos&hp.com 2003-11
Brett Green brett_green&hp.com 2003-11
Carleton Watkins carleton&soronti.com 2003-11
Chris Sanders csanders&navini.com 2003-08
Daniel Friedman dfriedman&hns.com 2003-08
David Barrass david.barrass&minorplante.com 2003-11
Devon Dawson devon.dawson&hp.com 2003-11
Emidio Cunha emidio&janeladigital.com 2003-11
Eric Rosenfeld e.rosenfeld&cablelabs.com 2003-11
Garry Moore garry.moore&cgi.com 2003-10
Geoff Higgins geoff.higgins&sun.com 2006-03
Gerard Cerchio gjpc&circlesoft.com 2003-11
Ghanshyam Patel gpatel&natinc.com 2003-11
Gregg Townsend gmt&cs.arizona.edu 2003-11
Hans Weibel hans.weibel&zhwin.ch 2004-10
Harry Goldschmitt hgoldschmitt&hgac.com 2003-11
Hywel Morgan hywelm&surfcontrol.com 2003-11
Ian McDowall ian.mcdowall&symbian.com 2003-11
James Powell james&mailhost.unidata.com
Jim McDonald jim.mcdonald&sysdm.com 2003-11
Jonas Krogell jonas.krogell&netadmin.se 2007-07-10
Markus Treinen markus.treinen&siemens.com 2006-02
Matt Nowicki nowickim&iasdirect.com 2003-10
Michael Daniele michael.daniele&syamsoftware.com 2003-11
Mike Pontillo pontillo&hp.com 2003-08
Nancy Golio nancy.golio&netex.com 2017-01-25
Network Executive Software, Inc. support&netex.com 2017-01-25
Paul B. Finley pfinley&us.ibm.com 2003-10
Paul Cope prc&auto-graphics.com 2003-11
Peter Krueger krueger&appss.de 2003-10
PV Shivkumar p.shivkumar&oracle.com 2003-10
Roland Schneider rsch&nicherms.com 2003-10
Ron Barber ron.barber&amx.com 2003-11
Ronen Shaul ronen&arnetsystems.com 2003-10
Shiro Tamoto tamoto.shiro&jp.panasonic.com 2003-10
Tatsuya Ueda tatsu&ist.fujitsu.com 2003-10
Tomokazu Asai asai.tomokazu&pfu.fujitsu.com 2003-11
Voiko Loukanov v.loukanov&dvelectronics.com 2003-10