Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| emfis-data | 140 | udp | EMFIS Data Service | ||||||||
| emfis-cntl | 141 | tcp | EMFIS Control Service | [Gerd_Beling] | [Gerd_Beling] | ||||||
| emfis-cntl | 141 | udp | EMFIS Control Service | [Gerd_Beling] | [Gerd_Beling] | ||||||
| bl-idm | 142 | tcp | Britton-Lee IDM | [Susie_Snitzer] | [Susie_Snitzer] | ||||||
| bl-idm | 142 | udp | Britton-Lee IDM | [Susie_Snitzer] | [Susie_Snitzer] | ||||||
| iso-tp0 | 146 | tcp | ISO-IP0 | ||||||||
| iso-tp0 | 146 | udp | ISO-IP0 | ||||||||
| iso-ip | 147 | tcp | ISO-IP | [Marshall_Rose] | [Marshall_Rose] | ||||||
| iso-ip | 147 | udp | ISO-IP | [Marshall_Rose] | [Marshall_Rose] | ||||||
| aed-512 | 149 | tcp | AED 512 Emulation Service | [Albert_G_Broscius] | [Albert_G_Broscius] | ||||||
| aed-512 | 149 | udp | AED 512 Emulation Service | [Albert_G_Broscius] | [Albert_G_Broscius] | ||||||
| sql-net | 150 | tcp | SQL-NET | [Martin_Picard] | [Martin_Picard] | ||||||
| sql-net | 150 | udp | SQL-NET | [Martin_Picard] | [Martin_Picard] | ||||||
| netsc-prod | 154 | tcp | NETSC | ||||||||
| netsc-prod | 154 | udp | NETSC | ||||||||
| netsc-dev | 155 | tcp | NETSC | [Sergio_Heker] | [Sergio_Heker] | ||||||
| netsc-dev | 155 | udp | NETSC | [Sergio_Heker] | [Sergio_Heker] | ||||||
| knet-cmp | 157 | tcp | KNET/VM Command/Message Protocol | [Gary_S_Malkin] | [Gary_S_Malkin] | ||||||
| knet-cmp | 157 | udp | KNET/VM Command/Message Protocol | [Gary_S_Malkin] | [Gary_S_Malkin] | ||||||
| pcmail-srv | 158 | tcp | PCMail Server | [Mark_L_Lambert] | [Mark_L_Lambert] | ||||||
| pcmail-srv | 158 | udp | PCMail Server | [Mark_L_Lambert] | [Mark_L_Lambert] | ||||||
| nss-routing | 159 | tcp | NSS-Routing | [Yakov_Rekhter] | [Yakov_Rekhter] | ||||||
| nss-routing | 159 | udp | NSS-Routing | [Yakov_Rekhter] | [Yakov_Rekhter] | ||||||
| sgmp-traps | 160 | tcp | SGMP-TRAPS | [Marty_Schoffstahl] | [Marty_Schoffstahl] | ||||||
| sgmp-traps | 160 | udp | SGMP-TRAPS | [Marty_Schoffstahl] | [Marty_Schoffstahl] | ||||||
| cmip-man | 163 | tcp | CMIP/TCP Manager | ||||||||
| cmip-man | 163 | udp | CMIP/TCP Manager | ||||||||
| cmip-agent | 164 | tcp | CMIP/TCP Agent | [Amatzia_Ben_Artzi] | [Amatzia_Ben_Artzi] | ||||||
| cmip-agent | 164 | udp | CMIP/TCP Agent | [Amatzia_Ben_Artzi] | [Amatzia_Ben_Artzi] | ||||||
| xns-courier | 165 | tcp | Xerox | [Susie_Armstrong_2] | [Susie_Armstrong_2] | ||||||
| xns-courier | 165 | udp | Xerox | [Susie_Armstrong_2] | [Susie_Armstrong_2] | ||||||
| s-net | 166 | tcp | Sirius Systems | [Brian_Lloyd] | [Brian_Lloyd] | ||||||
| s-net | 166 | udp | Sirius Systems | [Brian_Lloyd] | [Brian_Lloyd] | ||||||
| print-srv | 170 | tcp | Network PostScript | [Brian_Reid] | [Brian_Reid] | ||||||
| print-srv | 170 | udp | Network PostScript | [Brian_Reid] | [Brian_Reid] | ||||||
| cl-1 | 172 | tcp | Network Innovations CL/1 IANA assigned this well-formed service name as a replacement for "cl/1". |
[Kevin_DeVault] | [Kevin_DeVault] | ||||||
| cl/1 | 172 | tcp | Network Innovations CL/1 | [Kevin_DeVault] | [Kevin_DeVault] | This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| cl-1 | 172 | udp | Network Innovations CL/1 IANA assigned this well-formed service name as a replacement for "cl/1". |
[Kevin_DeVault] | [Kevin_DeVault] | ||||||
| cl/1 | 172 | udp | Network Innovations CL/1 | [Kevin_DeVault] | [Kevin_DeVault] | This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| xyplex-mux | 173 | tcp | Xyplex | [Bob_Stewart] | [Bob_Stewart] | ||||||
| xyplex-mux | 173 | udp | Xyplex | [Bob_Stewart] | [Bob_Stewart] | ||||||
| genrad-mux | 176 | tcp | GENRAD-MUX | [Ron_Thornton] | [Ron_Thornton] | ||||||
| genrad-mux | 176 | udp | GENRAD-MUX | [Ron_Thornton] | [Ron_Thornton] | ||||||
| remote-kis | 185 | tcp | Remote-KIS | ||||||||
| remote-kis | 185 | udp | Remote-KIS | ||||||||
| osu-nms | 192 | tcp | OSU Network Monitoring System | [Doug_Karl] | [Doug_Karl] | ||||||
| osu-nms | 192 | udp | OSU Network Monitoring System | [Doug_Karl] | [Doug_Karl] | ||||||
| dn6-nlm-aud | 195 | tcp | DNSIX Network Level Module Audit | ||||||||
| dn6-nlm-aud | 195 | udp | DNSIX Network Level Module Audit | ||||||||
| dn6-smm-red | 196 | tcp | DNSIX Session Mgt Module Audit Redir | [Lawrence_Lebahn] | [Lawrence_Lebahn] | ||||||
| dn6-smm-red | 196 | udp | DNSIX Session Mgt Module Audit Redir | [Lawrence_Lebahn] | [Lawrence_Lebahn] | ||||||
| dls-mon | 198 | tcp | Directory Location Service Monitor | [Scott_Bellew] | [Scott_Bellew] | ||||||
| dls-mon | 198 | udp | Directory Location Service Monitor | [Scott_Bellew] | [Scott_Bellew] | ||||||
| at-rtmp | 201 | tcp | AppleTalk Routing Maintenance | ||||||||
| at-rtmp | 201 | udp | AppleTalk Routing Maintenance | ||||||||
| at-nbp | 202 | tcp | AppleTalk Name Binding | ||||||||
| at-nbp | 202 | udp | AppleTalk Name Binding | ||||||||
| at-3 | 203 | tcp | AppleTalk Unused | ||||||||
| at-3 | 203 | udp | AppleTalk Unused | ||||||||
| at-echo | 204 | tcp | AppleTalk Echo | ||||||||
| at-echo | 204 | udp | AppleTalk Echo | ||||||||
| at-5 | 205 | tcp | AppleTalk Unused | ||||||||
| at-5 | 205 | udp | AppleTalk Unused | ||||||||
| at-zis | 206 | tcp | AppleTalk Zone Information | ||||||||
| at-zis | 206 | udp | AppleTalk Zone Information | ||||||||
| at-7 | 207 | tcp | AppleTalk Unused | ||||||||
| at-7 | 207 | udp | AppleTalk Unused | ||||||||
| at-8 | 208 | tcp | AppleTalk Unused | [Rob_Chandhok] | [Rob_Chandhok] | ||||||
| at-8 | 208 | udp | AppleTalk Unused | [Rob_Chandhok] | [Rob_Chandhok] | ||||||
| z39-50 | 210 | tcp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
[Mark_H_Needleman] | [Mark_H_Needleman] | ||||||
| z39.50 | 210 | tcp | ANSI Z39.50 | [Mark_H_Needleman] | [Mark_H_Needleman] | This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| z39-50 | 210 | udp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
[Mark_H_Needleman] | [Mark_H_Needleman] | ||||||
| z39.50 | 210 | udp | ANSI Z39.50 | [Mark_H_Needleman] | [Mark_H_Needleman] | This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 914c-g | 211 | tcp | Texas Instruments 914C/G Terminal IANA assigned this well-formed service name as a replacement for "914c/g". |
[Bill_Harrell] | [Bill_Harrell] | ||||||
| 914c/g | 211 | tcp | Texas Instruments 914C/G Terminal | [Bill_Harrell] | [Bill_Harrell] | This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 914c-g | 211 | udp | Texas Instruments 914C/G Terminal IANA assigned this well-formed service name as a replacement for "914c/g". |
[Bill_Harrell] | [Bill_Harrell] | ||||||
| 914c/g | 211 | udp | Texas Instruments 914C/G Terminal | [Bill_Harrell] | [Bill_Harrell] | This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| fln-spx | 221 | tcp | Berkeley rlogind with SPX auth | ||||||||
| fln-spx | 221 | udp | Berkeley rlogind with SPX auth | ||||||||
| rsh-spx | 222 | tcp | Berkeley rshd with SPX auth | ||||||||
| rsh-spx | 222 | udp | Berkeley rshd with SPX auth | ||||||||
| 225-241 | Reserved | 2024-12-20 | [RFC 1060] | ||||||||
| sur-meas | 243 | tcp | Survey Measurement | [Dave_Clark] | [Dave_Clark] | ||||||
| sur-meas | 243 | udp | Survey Measurement | [Dave_Clark] | [Dave_Clark] | ||||||
| subntbcst-tftp | 247 | tcp | SUBNTBCST_TFTP IANA assigned this well-formed service name as a replacement for "subntbcst_tftp". |
[John_Fake] | [John_Fake] | ||||||
| subntbcst_tftp | 247 | tcp | SUBNTBCST_TFTP | [John_Fake] | [John_Fake] | This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| subntbcst-tftp | 247 | udp | SUBNTBCST_TFTP IANA assigned this well-formed service name as a replacement for "subntbcst_tftp". |
[John_Fake] | [John_Fake] | ||||||
| subntbcst_tftp | 247 | udp | SUBNTBCST_TFTP | [John_Fake] | [John_Fake] | This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 249-255 | Reserved | 2024-12-20 | [RFC 1060] | ||||||||
| esro-gen | 259 | tcp | Efficient Short Remote Operations | [Mohsen_Banan] | [Mohsen_Banan] | ||||||
| esro-gen | 259 | udp | Efficient Short Remote Operations | [Mohsen_Banan] | [Mohsen_Banan] | ||||||
| x-bone-ctl | 265 | tcp | X-Bone CTL | [Joe_Touch] | [Joe_Touch] | ||||||
| x-bone-ctl | 265 | udp | X-Bone CTL | [Joe_Touch] | [Joe_Touch] | ||||||
| td-service | 267 | tcp | Tobit David Service Layer | ||||||||
| td-service | 267 | udp | Tobit David Service Layer | ||||||||
| td-replica | 268 | tcp | Tobit David Replica | [Franz_Josef_Leuders] | [Franz_Josef_Leuders] | ||||||
| td-replica | 268 | udp | Tobit David Replica | [Franz_Josef_Leuders] | [Franz_Josef_Leuders] | ||||||
| gist | 270 | udp | Q-mode encapsulation for GIST messages | [RFC 5971] | |||||||
| pt-tls | 271 | tcp | IETF Network Endpoint Assessment (NEA) Posture Transport Protocol over TLS (PT-TLS) | [IESG] | [IETF_Chair] | 2012-07-31 | [RFC 6876] | ||||
| 272-279 | Unassigned | ||||||||||
| http-mgmt | 280 | tcp | http-mgmt | [Adrian_Pell] | [Adrian_Pell] |