Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cfdptkt 120 udp CFDPTKT John Ioannidis John Ioannidis
erpc 121 tcp Encore Expedited Remote Pro.Call Jack O'Neil Jack O'Neil
erpc 121 udp Encore Expedited Remote Pro.Call Jack O'Neil Jack O'Neil
smakynet 122 tcp SMAKYNET Pierre Arnaud Pierre Arnaud
smakynet 122 udp SMAKYNET Pierre Arnaud Pierre Arnaud
ntp 123 tcp Network Time Protocol Dave Mills Dave Mills RFC 5905
ntp 123 udp Network Time Protocol Dave Mills Dave Mills RFC 5905
ansatrader 124 tcp ANSA REX Trader Nicola J. Howarth Nicola J. Howarth
ansatrader 124 udp ANSA REX Trader Nicola J. Howarth Nicola J. Howarth
locus-map 125 tcp Locus PC-Interface Net Map Ser Eric Peterson Eric Peterson
locus-map 125 udp Locus PC-Interface Net Map Ser Eric Peterson Eric Peterson
nxedit 126 tcp NXEdit Don Payette Don Payette Port 126 Previously assigned to application below unitary 126/tcp Unisys Unitary Login unitary 126/udp Unisys Unitary Login <feil&kronos.nisd.cam.unisys.com> Port 126 Previously assigned to application above
nxedit 126 udp NXEdit Don Payette Don Payette Port 126 Previously assigned to application below unitary 126/tcp Unisys Unitary Login unitary 126/udp Unisys Unitary Login <feil&kronos.nisd.cam.unisys.com> Port 126 Previously assigned to application above
locus-con 127 tcp Locus PC-Interface Conn Server Eric Peterson Eric Peterson
locus-con 127 udp Locus PC-Interface Conn Server Eric Peterson Eric Peterson
gss-xlicen 128 tcp GSS X License Verification John Light John Light
gss-xlicen 128 udp GSS X License Verification John Light John Light
pwdgen 129 tcp Password Generator Protocol Frank J. Wacho Frank J. Wacho
pwdgen 129 udp Password Generator Protocol Frank J. Wacho Frank J. Wacho
cisco-fna 130 tcp cisco FNATIVE
cisco-fna 130 udp cisco FNATIVE
cisco-tna 131 tcp cisco TNATIVE
cisco-tna 131 udp cisco TNATIVE
cisco-sys 132 tcp cisco SYSMAINT
cisco-sys 132 udp cisco SYSMAINT
statsrv 133 tcp Statistics Service Dave Mills Dave Mills
statsrv 133 udp Statistics Service Dave Mills Dave Mills
ingres-net 134 tcp INGRES-NET Service Mike Berrow Mike Berrow
ingres-net 134 udp INGRES-NET Service Mike Berrow Mike Berrow
epmap 135 tcp DCE endpoint resolution Joe Pato Joe Pato
epmap 135 udp DCE endpoint resolution Joe Pato Joe Pato
profile 136 tcp PROFILE Naming System Larry Peterson Larry Peterson
profile 136 udp PROFILE Naming System Larry Peterson Larry Peterson
netbios-ns 137 tcp NETBIOS Name Service
netbios-ns 137 udp NETBIOS Name Service
netbios-dgm 138 tcp NETBIOS Datagram Service
netbios-dgm 138 udp NETBIOS Datagram Service
netbios-ssn 139 tcp NETBIOS Session Service Jon Postel Jon Postel
netbios-ssn 139 udp NETBIOS Session Service Jon Postel Jon Postel
emfis-data 140 tcp EMFIS Data Service
emfis-data 140 udp EMFIS Data Service
emfis-cntl 141 tcp EMFIS Control Service Gerd Beling Gerd Beling
emfis-cntl 141 udp EMFIS Control Service Gerd Beling Gerd Beling
bl-idm 142 tcp Britton-Lee IDM Susie Snitzer Susie Snitzer
bl-idm 142 udp Britton-Lee IDM Susie Snitzer Susie Snitzer
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
143 udp Reserved 2021-02-22 RFC 9051
uma 144 tcp Universal Management Architecture Jay Whitney Jay Whitney
uma 144 udp Universal Management Architecture Jay Whitney Jay Whitney
uaac 145 tcp UAAC Protocol David A. Gomberg David A. Gomberg
uaac 145 udp UAAC Protocol David A. Gomberg David A. Gomberg
iso-tp0 146 tcp ISO-IP0
iso-tp0 146 udp ISO-IP0
iso-ip 147 tcp ISO-IP Marshall Rose Marshall Rose
iso-ip 147 udp ISO-IP Marshall Rose Marshall Rose
jargon 148 tcp Jargon Bill Weinman Bill Weinman
jargon 148 udp Jargon Bill Weinman Bill Weinman
aed-512 149 tcp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
aed-512 149 udp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
sql-net 150 tcp SQL-NET Martin Picard Martin Picard
sql-net 150 udp SQL-NET Martin Picard Martin Picard
hems 151 tcp HEMS
hems 151 udp HEMS
bftp 152 tcp Background File Transfer Program Annette DeSchon Annette DeSchon
bftp 152 udp Background File Transfer Program Annette DeSchon Annette DeSchon
sgmp 153 tcp SGMP Marty Schoffstahl Marty Schoffstahl
sgmp 153 udp SGMP Marty Schoffstahl Marty Schoffstahl
netsc-prod 154 tcp NETSC
netsc-prod 154 udp NETSC
netsc-dev 155 tcp NETSC Sergio Heker Sergio Heker
netsc-dev 155 udp NETSC Sergio Heker Sergio Heker
sqlsrv 156 tcp SQL Service Craig Rogers Craig Rogers
sqlsrv 156 udp SQL Service Craig Rogers Craig Rogers
knet-cmp 157 tcp KNET/VM Command/Message Protocol Gary S. Malkin Gary S. Malkin
knet-cmp 157 udp KNET/VM Command/Message Protocol Gary S. Malkin Gary S. Malkin
pcmail-srv 158 tcp PCMail Server Mark L. Lambert Mark L. Lambert
pcmail-srv 158 udp PCMail Server Mark L. Lambert Mark L. Lambert
nss-routing 159 tcp NSS-Routing Yakov Rekhter Yakov Rekhter
nss-routing 159 udp NSS-Routing Yakov Rekhter Yakov Rekhter
sgmp-traps 160 tcp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
sgmp-traps 160 udp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
snmp 161 tcp SNMP
snmp 161 udp SNMP
snmptrap 162 tcp SNMPTRAP Marshall Rose Marshall Rose
snmptrap 162 udp SNMPTRAP Marshall Rose Marshall Rose
cmip-man 163 tcp CMIP/TCP Manager
cmip-man 163 udp CMIP/TCP Manager
cmip-agent 164 tcp CMIP/TCP Agent Amatzia Ben-Artzi Amatzia Ben-Artzi
cmip-agent 164 udp CMIP/TCP Agent Amatzia Ben-Artzi Amatzia Ben-Artzi
xns-courier 165 tcp Xerox Susie Armstrong Susie Armstrong
xns-courier 165 udp Xerox Susie Armstrong Susie Armstrong
s-net 166 tcp Sirius Systems Brian Lloyd Brian Lloyd
s-net 166 udp Sirius Systems Brian Lloyd Brian Lloyd
namp 167 tcp NAMP Marty Schoffstahl Marty Schoffstahl
namp 167 udp NAMP Marty Schoffstahl Marty Schoffstahl
rsvd 168 tcp RSVD Alan Sandell Alan Sandell 2008-05-01
rsvd 168 udp RSVD Alan Sandell Alan Sandell 2008-05-01
send 169 tcp SEND William Oldwin William Oldwin 2019-04-22
send 169 udp SEND William Oldwin William Oldwin 2019-04-22
print-srv 170 tcp Network PostScript Brian Reid Brian Reid
print-srv 170 udp Network PostScript Brian Reid Brian Reid

Contact Information

Name Organization Contact URI Last Updated
Alan Sandell alan.sandell&ist.co.uk 2008-05-01
Albert G. Broscius broscius&dsl.cis.upenn.edu
Amatzia Ben-Artzi
Annette DeSchon DESCHON&isi.edu
Bill Weinman wew&bearnet.com
Brian Lloyd brian&lloyd.com
Brian Reid reid&decwrl.dec.com
Craig Rogers Rogers&isi.edu
Dave Mills mills&udel.edu 2022-06-03
Dave Mills Mills&huey.udel.edu
David A. Gomberg gomberg&gateway.mitre.org
Don Payette Don.Payette&unisys.com
Eric Peterson lcc.eric&seas.ucla.edu
Frank J. Wacho WANCHO&wsmr-simtel20.army.mil
Gary S. Malkin GMALKIN&xylogics.com
Gerd Beling GBELING&isi.edu
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jack O'Neil
Jay Whitney jw&powercenter.com
Joe Pato pato&apollo.hp.com
John Ioannidis ji&close.cs.columbia.ed
John Light johnl&gssc.gss.com
Jon Postel postel&isi.edu
Larry Peterson llp&arizona.edu
Mark L. Lambert markl&ptt.lcs.mit.edu
Marshall Rose mrose17&gmail.com 2024-07-29
Martin Picard
Marty Schoffstahl schoff&nisc.nyser.net
Mike Berrow
Nicola J. Howarth njh&ansa.co.uk
Pierre Arnaud pierre.arnaud&iname.com
Sergio Heker heker&jvncc.csc.org
Susie Armstrong Armstrong.wbst128&xerox.com
Susie Snitzer
William Oldwin william&bitsome.ie 2022-01-28
Yakov Rekhter Yakov&ibm.com