Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
redstorm-info 2348 tcp Information to query for game status

IANA assigned this well-formed service name as a replacement for "redstorm_info".
redstorm_info 2348 tcp Information to query for game status This entry is an alias to "redstorm-info". This entry is now historic, not usable for use with many common service discovery mechanisms.
redstorm-info 2348 udp Information to query for game status

IANA assigned this well-formed service name as a replacement for "redstorm_info".
redstorm_info 2348 udp Information to query for game status This entry is an alias to "redstorm-info". This entry is now historic, not usable for use with many common service discovery mechanisms.
redstorm-diag 2349 tcp Diagnostics Port

IANA assigned this well-formed service name as a replacement for "redstorm_diag".
David Weinstein David Weinstein
redstorm_diag 2349 tcp Diagnostics Port David Weinstein David Weinstein This entry is an alias to "redstorm-diag". This entry is now historic, not usable for use with many common service discovery mechanisms.
redstorm-diag 2349 udp Diagnostics Port

IANA assigned this well-formed service name as a replacement for "redstorm_diag".
David Weinstein David Weinstein
redstorm_diag 2349 udp Diagnostics Port David Weinstein David Weinstein This entry is an alias to "redstorm-diag". This entry is now historic, not usable for use with many common service discovery mechanisms.
pxc-epmap 2434 tcp pxc-epmap Jun Nakamura Jun Nakamura
pxc-epmap 2434 udp pxc-epmap Jun Nakamura Jun Nakamura
combox-web-acc 2534 tcp Combox Web Access Yochai Cohen Yochai Cohen
combox-web-acc 2534 udp Combox Web Access Yochai Cohen Yochai Cohen
pk-electronics 2634 tcp PK Electronics Seb Ibis Seb Ibis
pk-electronics 2634 udp PK Electronics Seb Ibis Seb Ibis
ccs-software 2734 tcp CCS Software Bertus Jacobs Bertus Jacobs
ccs-software 2734 udp CCS Software Bertus Jacobs Bertus Jacobs
evtp 2834 tcp EVTP
evtp 2834 udp EVTP
4-tieropmcli 2934 tcp 4-TIER OPM CLI Francois Peloffy Francois Peloffy
4-tieropmcli 2934 udp 4-TIER OPM CLI Francois Peloffy Francois Peloffy
osmosis-aeea 3034 tcp Osmosis / Helix (R) AEEA Port Larry Atkin Larry Atkin
osmosis-aeea 3034 udp Osmosis / Helix (R) AEEA Port Larry Atkin Larry Atkin
ecp 3134 tcp Extensible Code Protocol Jim Trek; Mark Bocko Jim Trek; Mark Bocko
ecp 3134 udp Extensible Code Protocol Jim Trek; Mark Bocko Jim Trek; Mark Bocko
alchemy 3234 tcp Alchemy Server Mikhail Belov Mikhail Belov 2002-02
alchemy 3234 udp Alchemy Server Mikhail Belov Mikhail Belov 2002-02
directv-web 3334 tcp Direct TV Webcasting
directv-web 3334 udp Direct TV Webcasting
anet-m 3340 tcp OMF data m
anet-m 3340 udp OMF data m
anet-h 3341 tcp OMF data h Per Sahlqvist Per Sahlqvist
anet-h 3341 udp OMF data h Per Sahlqvist Per Sahlqvist
webtie 3342 tcp WebTIE Kevin Frender Kevin Frender
webtie 3342 udp WebTIE Kevin Frender Kevin Frender
ms-cluster-net 3343 tcp MS Cluster Net David Dion David Dion 2009-02-12
ms-cluster-net 3343 udp MS Cluster Net David Dion David Dion 2009-02-12
bnt-manager 3344 tcp BNT Manager Engineering Dept. Engineering Dept.
bnt-manager 3344 udp BNT Manager Engineering Dept. Engineering Dept.
influence 3345 tcp Influence Russ Ferriday Russ Ferriday
influence 3345 udp Influence Russ Ferriday Russ Ferriday
trnsprntproxy 3346 tcp Trnsprnt Proxy Grant Kirby Grant Kirby
trnsprntproxy 3346 udp Trnsprnt Proxy Grant Kirby Grant Kirby
phoenix-rpc 3347 tcp Phoenix RPC Ian Anderson Ian Anderson
phoenix-rpc 3347 udp Phoenix RPC Ian Anderson Ian Anderson
pangolin-laser 3348 tcp Pangolin Laser William Benner William Benner
pangolin-laser 3348 udp Pangolin Laser William Benner William Benner
chevinservices 3349 tcp Chevin Services Gus McNaughton Gus McNaughton
chevinservices 3349 udp Chevin Services Gus McNaughton Gus McNaughton
csms2 3400 tcp CSMS2 Markus Michels Markus Michels
csms2 3400 udp CSMS2 Markus Michels Markus Michels
filecast 3401 tcp filecast Eden Sherry Eden Sherry
filecast 3401 udp filecast Eden Sherry Eden Sherry
fxaengine-net 3402 tcp FXa Engine Network Port Lucas Alonso Lucas Alonso 2002-02
fxaengine-net 3402 udp FXa Engine Network Port Lucas Alonso Lucas Alonso 2002-02
3403 De-registered 2006-10-27
3404 Removed 2002-05-01
nokia-ann-ch1 3405 tcp Nokia Announcement ch 1
nokia-ann-ch1 3405 udp Nokia Announcement ch 1
nokia-ann-ch2 3406 tcp Nokia Announcement ch 2 Morteza Kalhour Morteza Kalhour 2002-02
nokia-ann-ch2 3406 udp Nokia Announcement ch 2 Morteza Kalhour Morteza Kalhour 2002-02
ldap-admin 3407 tcp LDAP admin server port Stephen Tsun Stephen Tsun 2002-02
ldap-admin 3407 udp LDAP admin server port Stephen Tsun Stephen Tsun 2002-02
BESApi 3408 tcp BES Api Port Colin Griffiths Colin Griffiths 2002-02
BESApi 3408 udp BES Api Port Colin Griffiths Colin Griffiths 2002-02
networklens 3409 tcp NetworkLens Event Port
networklens 3409 udp NetworkLens Event Port
networklenss 3410 tcp NetworkLens SSL Event Greg Bailey Greg Bailey 2002-02
networklenss 3410 udp NetworkLens SSL Event Greg Bailey Greg Bailey 2002-02
biolink-auth 3411 tcp BioLink Authenteon server BioLink Support BioLink Support 2002-02
biolink-auth 3411 udp BioLink Authenteon server BioLink Support BioLink Support 2002-02
xmlblaster 3412 tcp xmlBlaster Marcel Ruff Marcel Ruff 2002-02
xmlblaster 3412 udp xmlBlaster Marcel Ruff Marcel Ruff 2002-02
svnet 3413 tcp SpecView Networking Richard Dickins Richard Dickins 2002-02
svnet 3413 udp SpecView Networking Richard Dickins Richard Dickins 2002-02
wip-port 3414 tcp BroadCloud WIP Port
wip-port 3414 udp BroadCloud WIP Port
bcinameservice 3415 tcp BCI Name Service Dennis Parker Dennis Parker 2002-02
bcinameservice 3415 udp BCI Name Service Dennis Parker Dennis Parker 2002-02
commandport 3416 tcp AirMobile IS Command Port Mike Klein Mike Klein 2002-02
commandport 3416 udp AirMobile IS Command Port Mike Klein Mike Klein 2002-02
csvr 3417 tcp ConServR file translation Albert Leung Albert Leung 2002-02
csvr 3417 udp ConServR file translation Albert Leung Albert Leung 2002-02
rnmap 3418 tcp Remote nmap Tuomo Makinen Tuomo Makinen 2002-02
rnmap 3418 udp Remote nmap Tuomo Makinen Tuomo Makinen 2002-02
softaudit 3419 tcp Isogon SoftAudit Per Hellberg Per Hellberg 2002-02
softaudit 3419 udp ISogon SoftAudit Per Hellberg Per Hellberg 2002-02
ifcp-port 3420 tcp iFCP User Port RFC 4172
ifcp-port 3420 udp iFCP User Port RFC 4172
bmap 3421 tcp Bull Apprise portmapper Jeremy Gilbert Jeremy Gilbert
bmap 3421 udp Bull Apprise portmapper Jeremy Gilbert Jeremy Gilbert
rusb-sys-port 3422 tcp Remote USB System Port Steven Klein Steven Klein 2002-02
rusb-sys-port 3422 udp Remote USB System Port Steven Klein Steven Klein 2002-02
xtrm 3423 tcp xTrade Reliable Messaging
xtrm 3423 udp xTrade Reliable Messaging
xtrms 3424 tcp xTrade over TLS/SSL Mats Nilsson Mats Nilsson 2002-02
xtrms 3424 udp xTrade over TLS/SSL Mats Nilsson Mats Nilsson 2002-02
agps-port 3425 tcp AGPS Access Port Kristoffer Nilsson Kristoffer Nilsson 2002-02
agps-port 3425 udp AGPS Access Port Kristoffer Nilsson Kristoffer Nilsson 2002-02
arkivio 3426 tcp Arkivio Storage Protocol Bruce Greenblatt Bruce Greenblatt 2002-02
arkivio 3426 udp Arkivio Storage Protocol Bruce Greenblatt Bruce Greenblatt 2002-02
websphere-snmp 3427 tcp WebSphere SNMP Richard Mills Richard Mills 2002-02

Contact Information

Name Contact URI Last Updated
Albert Leung aleung&biscom.com 2006-04
Bertus Jacobs bertus&ccs-software.co.za
Bruce Greenblatt bruce&arkivio.com 2002-02
Colin Griffiths colin.griffiths&interlinksoftware.com 2002-02
David Dion David.Dion&microsoft.com 2009-02-12
David Weinstein david.weinstein&redstorm.com
Dennis Parker dparker&broadcloud.com 2002-02
Eden Sherry eden&pair.com
Engineering Dept. domains&badgernt.com
Francois Peloffy fpeloffy&4tier.com
Grant Kirby grant_kirby&ccm.al.intel.com
Greg Bailey gbailey&lxpro.com 2003-04
Gus McNaughton gus&chevin.com
Ian Anderson ian_anderson&phoenix.com
Jeremy Gilbert J.Gilbert&ma30.bull.com
Jim Trek jtrek&rochester.rr.com
Jun Nakamura jnakamur&cp10.es.xerox.com
Kevin Frender kbf&ngdc.noaa.gov
Kristoffer Nilsson kristoffer.nilsson&hutchison3g.com 2002-02
Larry Atkin latkin&commongrnd.com
Lucas Alonso luke&demiurgestudios.com 2002-02
Marcel Ruff mr&marcelruff.info 2002-02
Mark Bocko bocko&ece.rochester.edu
Markus Michels mmi&cedros.com
Mats Nilsson mats.nilsson&xware.se 2002-02
Mike Klein m.klein&motorla.com 2002-02
Mikhail Belov mikhail&imrgold.com 2002-02
Morteza Kalhour Morteza.Kalhour&nokia.com 2002-02
Per Hellberg phellberg&isogon.com 2002-02
Per Sahlqvist psahlqvi&sw.seisy.abb.se
Richard Dickins rad&specview.com 2002-02
Richard Mills ramills&us.ibm.com 2002-02
Russ Ferriday russf&topia.com
Seb Ibis seb_ibis&pkworld.com
Stephen Tsun stsun&calient.net 2002-02
Steven Klein stevek&ionetworks.com 2002-02
Tuomo Makinen tmakinen&pp.htv.fi 2002-02
William Benner wrb2&pangolin.com 2025-03-27
Yochai Cohen yochai&combox.co.il