Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ms-olap2 | 2394 | udp | MS OLAP 2 | Mosha Pasumansky | Mosha Pasumansky | ||||||
| lan900-remote | 2395 | tcp | LAN900 Remote IANA assigned this well-formed service name as a replacement for "lan900_remote". |
Tom Quinlan | Tom Quinlan | ||||||
| lan900_remote | 2395 | tcp | LAN900 Remote | Tom Quinlan | Tom Quinlan | This entry is an alias to "lan900-remote". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| lan900-remote | 2395 | udp | LAN900 Remote IANA assigned this well-formed service name as a replacement for "lan900_remote". |
Tom Quinlan | Tom Quinlan | ||||||
| lan900_remote | 2395 | udp | LAN900 Remote | Tom Quinlan | Tom Quinlan | This entry is an alias to "lan900-remote". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| wusage | 2396 | tcp | Wusage | Thomas Boutell | Thomas Boutell | ||||||
| wusage | 2396 | udp | Wusage | Thomas Boutell | Thomas Boutell | ||||||
| ncl | 2397 | tcp | NCL | Robert Wiebe | Robert Wiebe | ||||||
| ncl | 2397 | udp | NCL | Robert Wiebe | Robert Wiebe | ||||||
| orbiter | 2398 | tcp | Orbiter | David Goldberg | David Goldberg | ||||||
| orbiter | 2398 | udp | Orbiter | David Goldberg | David Goldberg | ||||||
| fmpro-fdal | 2399 | tcp | FileMaker, Inc. - Data Access Layer | Clay Maeckel | Clay Maeckel | ||||||
| fmpro-fdal | 2399 | udp | FileMaker, Inc. - Data Access Layer | Clay Maeckel | Clay Maeckel | ||||||
| sybasedbsynch | 2439 | tcp | SybaseDBSynch | Dave Neudoerffer | Dave Neudoerffer | ||||||
| sybasedbsynch | 2439 | udp | SybaseDBSynch | Dave Neudoerffer | Dave Neudoerffer | ||||||
| vsiadmin | 2539 | tcp | VSI Admin | Rob Juergens | Rob Juergens | ||||||
| vsiadmin | 2539 | udp | VSI Admin | Rob Juergens | Rob Juergens | ||||||
| aminet | 2639 | tcp | AMInet | Alcorn McBride Inc. | Alcorn McBride Inc. | ||||||
| aminet | 2639 | udp | AMInet | Alcorn McBride Inc. | Alcorn McBride Inc. | ||||||
| tn-timing | 2739 | tcp | TN Timing | Paul Roberts | Paul Roberts | ||||||
| tn-timing | 2739 | udp | TN Timing | Paul Roberts | Paul Roberts | ||||||
| nmsigport | 2839 | tcp | NMSigPort | Peter Egli | Peter Egli | ||||||
| nmsigport | 2839 | udp | NMSigPort | Peter Egli | Peter Egli | ||||||
| sm-pas-2 | 2939 | tcp | SM-PAS-2 | ||||||||
| sm-pas-2 | 2939 | udp | SM-PAS-2 | ||||||||
| cogitate | 3039 | tcp | Cogitate, Inc. | Jim Harlan | Jim Harlan | ||||||
| cogitate | 3039 | udp | Cogitate, Inc. | Jim Harlan | Jim Harlan | ||||||
| incognitorv | 3139 | tcp | Incognito Rendez-Vous | Stephane Bourque | Stephane Bourque | ||||||
| incognitorv | 3139 | udp | Incognito Rendez-Vous | Stephane Bourque | Stephane Bourque | ||||||
| apparenet-ui | 3239 | tcp | appareNet User Interface | Fred Klassen | Fred Klassen | 2002-02 | |||||
| apparenet-ui | 3239 | udp | appareNet User Interface | Fred Klassen | Fred Klassen | 2002-02 | |||||
| anet-l | 3339 | tcp | OMF data l | ||||||||
| anet-l | 3339 | udp | OMF data l | ||||||||
| dsc | 3390 | tcp | Distributed Service Coordinator | Charles Honton | Charles Honton | ||||||
| dsc | 3390 | udp | Distributed Service Coordinator | Charles Honton | Charles Honton | ||||||
| savant | 3391 | tcp | SAVANT | Andy Bruce | Andy Bruce | ||||||
| savant | 3391 | udp | SAVANT | Andy Bruce | Andy Bruce | ||||||
| efi-lm | 3392 | tcp | EFI License Management | Ross E. Greinke | Ross E. Greinke | ||||||
| efi-lm | 3392 | udp | EFI License Management | Ross E. Greinke | Ross E. Greinke | ||||||
| d2k-tapestry1 | 3393 | tcp | D2K Tapestry Client to Server | ||||||||
| d2k-tapestry1 | 3393 | udp | D2K Tapestry Client to Server | ||||||||
| d2k-tapestry2 | 3394 | tcp | D2K Tapestry Server to Server | Eric Lan | Eric Lan | ||||||
| d2k-tapestry2 | 3394 | udp | D2K Tapestry Server to Server | Eric Lan | Eric Lan | ||||||
| dyna-lm | 3395 | tcp | Dyna License Manager (Elam) | Anjana Iyer | Anjana Iyer | ||||||
| dyna-lm | 3395 | udp | Dyna License Manager (Elam) | Anjana Iyer | Anjana Iyer | ||||||
| printer-agent | 3396 | tcp | Printer Agent IANA assigned this well-formed service name as a replacement for "printer_agent". |
Devon Taylor | Devon Taylor | ||||||
| printer_agent | 3396 | tcp | Printer Agent | Devon Taylor | Devon Taylor | This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| printer-agent | 3396 | udp | Printer Agent IANA assigned this well-formed service name as a replacement for "printer_agent". |
Devon Taylor | Devon Taylor | ||||||
| printer_agent | 3396 | udp | Printer Agent | Devon Taylor | Devon Taylor | This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| cloanto-lm | 3397 | tcp | Cloanto License Manager | Takeo Sato | Takeo Sato | 2010-04-30 | |||||
| cloanto-lm | 3397 | udp | Cloanto License Manager | Takeo Sato | Takeo Sato | 2010-04-30 | |||||
| mercantile | 3398 | tcp | Mercantile | Erik Kragh Jensen | Erik Kragh Jensen | ||||||
| mercantile | 3398 | udp | Mercantile | Erik Kragh Jensen | Erik Kragh Jensen | ||||||
| csms | 3399 | tcp | CSMS | ||||||||
| csms | 3399 | udp | CSMS | ||||||||
| hri-port | 3439 | tcp | HRI Interface Port | John Fayos | John Fayos | 2002-03 | |||||
| hri-port | 3439 | udp | HRI Interface Port | John Fayos | John Fayos | 2002-03 | |||||
| ibm-diradm-ssl | 3539 | tcp | IBM Directory Server SSL | Mark Cavage | Mark Cavage | 2002-07 | |||||
| ibm-diradm-ssl | 3539 | udp | IBM Directory Server SSL | Mark Cavage | Mark Cavage | 2002-07 | |||||
| xap-ha | 3639 | tcp | Extensible Automation | Mark Harrison | Mark Harrison | 2002-11 | |||||
| xap-ha | 3639 | udp | Extensible Automation | Mark Harrison | Mark Harrison | 2002-11 | |||||
| launchbird-lm | 3739 | tcp | Launchbird LicenseManager | Tom Hawkins | Tom Hawkins | 2003-04 | |||||
| launchbird-lm | 3739 | udp | Launchbird LicenseManager | Tom Hawkins | Tom Hawkins | 2003-04 | |||||
| amx-rms | 3839 | tcp | AMX Resource Management Suite | Ron Barber | Ron Barber | 2003-11 | |||||
| amx-rms | 3839 | udp | AMX Resource Management Suite | Ron Barber | Ron Barber | 2003-11 | |||||
| udt-os | 3900 | tcp | Unidata UDT OS IANA assigned this well-formed service name as a replacement for "udt_os". |
James Powell | James Powell | ||||||
| udt_os | 3900 | tcp | Unidata UDT OS | James Powell | James Powell | This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| udt-os | 3900 | udp | Unidata UDT OS IANA assigned this well-formed service name as a replacement for "udt_os". |
James Powell | James Powell | ||||||
| udt_os | 3900 | udp | Unidata UDT OS | James Powell | James Powell | This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| nimsh | 3901 | tcp | NIM Service Handler | Paul B. Finley | Paul B. Finley | 2003-10 | |||||
| nimsh | 3901 | udp | NIM Service Handler | Paul B. Finley | Paul B. Finley | 2003-10 | |||||
| nimaux | 3902 | tcp | NIMsh Auxiliary Port | Paul B. Finley | Paul B. Finley | 2003-10 | |||||
| nimaux | 3902 | udp | NIMsh Auxiliary Port | Paul B. Finley | Paul B. Finley | 2003-10 | |||||
| charsetmgr | 3903 | tcp | CharsetMGR | Tatsuya Ueda | Tatsuya Ueda | 2003-10 | |||||
| charsetmgr | 3903 | udp | CharsetMGR | Tatsuya Ueda | Tatsuya Ueda | 2003-10 | |||||
| omnilink-port | 3904 | tcp | Arnet Omnilink Port | Ronen Shaul | Ronen Shaul | 2003-10 | |||||
| omnilink-port | 3904 | udp | Arnet Omnilink Port | Ronen Shaul | Ronen Shaul | 2003-10 | |||||
| mupdate | 3905 | tcp | Mailbox Update (MUPDATE) protocol | RFC 3656 | |||||||
| mupdate | 3905 | udp | Mailbox Update (MUPDATE) protocol | RFC 3656 | |||||||
| topovista-data | 3906 | tcp | TopoVista elevation data | Gregg Townsend | Gregg Townsend | 2003-11 | |||||
| topovista-data | 3906 | udp | TopoVista elevation data | Gregg Townsend | Gregg Townsend | 2003-11 | |||||
| imoguia-port | 3907 | tcp | Imoguia Port | Emidio Cunha | Emidio Cunha | 2003-11 | |||||
| imoguia-port | 3907 | udp | Imoguia Port | Emidio Cunha | Emidio Cunha | 2003-11 | |||||
| hppronetman | 3908 | tcp | HP Procurve NetManagement | Devon Dawson | Devon Dawson | 2003-11 | |||||
| hppronetman | 3908 | udp | HP Procurve NetManagement | Devon Dawson | Devon Dawson | 2003-11 | |||||
| surfcontrolcpa | 3909 | tcp | SurfControl CPA | Hywel Morgan | Hywel Morgan | 2003-11 | |||||
| surfcontrolcpa | 3909 | udp | SurfControl CPA | Hywel Morgan | Hywel Morgan | 2003-11 | |||||
| prnrequest | 3910 | tcp | Printer Request Port | Brett Green | Brett Green | 2003-11 | |||||
| prnrequest | 3910 | udp | Printer Request Port | Brett Green | Brett Green | 2003-11 | |||||
| prnstatus | 3911 | tcp | Printer Status Port | Brett Green | Brett Green | 2003-11 | |||||
| prnstatus | 3911 | udp | Printer Status Port | Brett Green | Brett Green | 2003-11 | |||||
| gbmt-stars | 3912 | tcp | Global Maintech Stars | Harry Goldschmitt | Harry Goldschmitt | 2003-11 | |||||
| gbmt-stars | 3912 | udp | Global Maintech Stars | Harry Goldschmitt | Harry Goldschmitt | 2003-11 | |||||
| listcrt-port | 3913 | tcp | ListCREATOR Port | Tomokazu Asai | Tomokazu Asai | 2003-11 | |||||
| listcrt-port | 3913 | udp | ListCREATOR Port | Tomokazu Asai | Tomokazu Asai | 2003-11 | |||||
| listcrt-port-2 | 3914 | tcp | ListCREATOR Port 2 | Tomokazu Asai | Tomokazu Asai | 2003-11 | |||||
| listcrt-port-2 | 3914 | udp | ListCREATOR Port 2 | Tomokazu Asai | Tomokazu Asai | 2003-11 | |||||
| agcat | 3915 | tcp | Auto-Graphics Cataloging | Paul Cope | Paul Cope | 2003-11 | |||||
| agcat | 3915 | udp | Auto-Graphics Cataloging | Paul Cope | Paul Cope | 2003-11 | |||||
| wysdmc | 3916 | tcp | WysDM Controller | Jim McDonald | Jim McDonald | 2003-11 | |||||
| wysdmc | 3916 | udp | WysDM Controller | Jim McDonald | Jim McDonald | 2003-11 |