Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rmtserver 2416 tcp RMT Server Yvon Marineau Yvon Marineau
rmtserver 2416 udp RMT Server Yvon Marineau Yvon Marineau
composit-server 2417 tcp Composit Server Katsuaki Naoi Katsuaki Naoi
composit-server 2417 udp Composit Server Katsuaki Naoi Katsuaki Naoi
cas 2418 tcp cas Akiyoshi Ochi Akiyoshi Ochi
cas 2418 udp cas Akiyoshi Ochi Akiyoshi Ochi
attachmate-s2s 2419 tcp Attachmate S2S Chris Rominski Chris Rominski
attachmate-s2s 2419 udp Attachmate S2S Chris Rominski Chris Rominski
pvsw-inet 2441 tcp Pervasive I*net Data Server Chuck Talk Chuck Talk
pvsw-inet 2441 udp Pervasive I*net Data Server Chuck Talk Chuck Talk
lonworks2 2541 tcp LonWorks2 Gary Bartlett Gary Bartlett
lonworks2 2541 udp LonWorks2 Gary Bartlett Gary Bartlett
hdl-srv 2641 tcp HDL Server David Ely David Ely
hdl-srv 2641 udp HDL Server David Ely David Ely
tsb 2741 tcp TSB
tsb 2741 udp TSB
l3-ranger 2841 tcp l3-ranger
l3-ranger 2841 udp l3-ranger
sm-pas-4 2941 tcp SM-PAS-4
sm-pas-4 2941 udp SM-PAS-4
di-traceware 3041 tcp di-traceware Carlos Hung Carlos Hung
di-traceware 3041 udp di-traceware Carlos Hung Carlos Hung
vmodem 3141 tcp VMODEM Ray Gwinn Ray Gwinn
vmodem 3141 udp VMODEM Ray Gwinn Ray Gwinn
isns 3205 tcp iSNS Server Port RFC 4171
isns 3205 udp iSNS Server Port RFC 4171
sysorb 3241 tcp SysOrb Monitoring Server Jakob Oestergaard Jakob Oestergaard 2002-02
sysorb 3241 udp SysOrb Monitoring Server Jakob Oestergaard Jakob Oestergaard 2002-02
anet-h 3341 tcp OMF data h Per Sahlqvist Per Sahlqvist
anet-h 3341 udp OMF data h Per Sahlqvist Per Sahlqvist
networklenss 3410 tcp NetworkLens SSL Event Greg Bailey Greg Bailey 2002-02
networklenss 3410 udp NetworkLens SSL Event Greg Bailey Greg Bailey 2002-02
biolink-auth 3411 tcp BioLink Authenteon server BioLink Support BioLink Support 2002-02
biolink-auth 3411 udp BioLink Authenteon server BioLink Support BioLink Support 2002-02
xmlblaster 3412 tcp xmlBlaster Marcel Ruff Marcel Ruff 2002-02
xmlblaster 3412 udp xmlBlaster Marcel Ruff Marcel Ruff 2002-02
svnet 3413 tcp SpecView Networking Richard Dickins Richard Dickins 2002-02
svnet 3413 udp SpecView Networking Richard Dickins Richard Dickins 2002-02
wip-port 3414 tcp BroadCloud WIP Port
wip-port 3414 udp BroadCloud WIP Port
bcinameservice 3415 tcp BCI Name Service Dennis Parker Dennis Parker 2002-02
bcinameservice 3415 udp BCI Name Service Dennis Parker Dennis Parker 2002-02
commandport 3416 tcp AirMobile IS Command Port Mike Klein Mike Klein 2002-02
commandport 3416 udp AirMobile IS Command Port Mike Klein Mike Klein 2002-02
csvr 3417 tcp ConServR file translation Albert Leung Albert Leung 2002-02
csvr 3417 udp ConServR file translation Albert Leung Albert Leung 2002-02
rnmap 3418 tcp Remote nmap Tuomo Makinen Tuomo Makinen 2002-02
rnmap 3418 udp Remote nmap Tuomo Makinen Tuomo Makinen 2002-02
softaudit 3419 tcp Isogon SoftAudit Per Hellberg Per Hellberg 2002-02
softaudit 3419 udp ISogon SoftAudit Per Hellberg Per Hellberg 2002-02
ifcp-port 3420 tcp iFCP User Port RFC 4172
ifcp-port 3420 udp iFCP User Port RFC 4172
connect-client 3441 tcp OC Connect Client
connect-client 3441 udp OC Connect Client
voispeed-port 3541 tcp VoiSpeed Port Virgilio Lattanzi Virgilio Lattanzi 2002-07
voispeed-port 3541 udp VoiSpeed Port Virgilio Lattanzi Virgilio Lattanzi 2002-07
m2pa 3565 tcp M2PA RFC 4165
m2pa 3565 sctp M2PA RFC 4165
netplay-port2 3641 tcp Netplay Port 2 Predrag Filipovic Predrag Filipovic 2002-11
netplay-port2 3641 udp Netplay Port 2 Predrag Filipovic Predrag Filipovic 2002-11
wysdma 3741 tcp WysDM Agent Jim McDonald Jim McDonald 2003-04
wysdma 3741 udp WysDM Agent Jim McDonald Jim McDonald 2003-04
shiprush-db-svr 3841 tcp ShipRush Database Server Z-Firm LLC Rafael Zimberoff 2003-11 2014-08-22
3841 udp Reserved 2003-11 2014-08-22
homeportal-web 3941 tcp Home Portal Web Server Christian Beaumont Christian Beaumont 2003-11
homeportal-web 3941 udp Home Portal Web Server Christian Beaumont Christian Beaumont 2003-11
houston 4041 tcp Rocketeer-Houston Johnny C. Norris II Johnny C. Norris II
houston 4041 udp Rocketeer-Houston Johnny C. Norris II Johnny C. Norris II
igo-incognito 4100 tcp IGo Incognito Data Port Paul Reddy Paul Reddy 2002-02
igo-incognito 4100 udp IGo Incognito Data Port Paul Reddy Paul Reddy 2002-02
brlp-0 4101 tcp Braille protocol
brlp-0 4101 udp Braille protocol
brlp-1 4102 tcp Braille protocol
brlp-1 4102 udp Braille protocol
brlp-2 4103 tcp Braille protocol
brlp-2 4103 udp Braille protocol
brlp-3 4104 tcp Braille protocol Sébastien Hinderer Sébastien Hinderer 2006-03
brlp-3 4104 udp Braille protocol Sébastien Hinderer Sébastien Hinderer 2006-03
shofar 4105 tcp Shofar ShofarNexus.com John Kozlowski 2006-07 2012-02-20
shofar 4105 udp Shofar ShofarNexus.com John Kozlowski 2006-07 2012-02-20
synchronite 4106 tcp Synchronite James Figgins James Figgins 2006-07
synchronite 4106 udp Synchronite James Figgins James Figgins 2006-07
j-ac 4107 tcp JDL Accounting LAN Service Takashi Sahara Takashi Sahara 2006-09
j-ac 4107 udp JDL Accounting LAN Service Takashi Sahara Takashi Sahara 2006-09
accel 4108 tcp ACCEL Masahiro Koiwai Masahiro Koiwai 2006-10
accel 4108 udp ACCEL Masahiro Koiwai Masahiro Koiwai 2006-10
izm 4109 tcp Instantiated Zero-control Messaging David Miller David Miller 2007-02
izm 4109 udp Instantiated Zero-control Messaging David Miller David Miller 2007-02
g2tag 4110 tcp G2 RFID Tag Telemetry Data David Goodall David Goodall 2007-02
g2tag 4110 udp G2 RFID Tag Telemetry Data David Goodall David Goodall 2007-02
xgrid 4111 tcp Xgrid David Kramer David Kramer 2004-11
xgrid 4111 udp Xgrid David Kramer David Kramer 2004-11
apple-vpns-rp 4112 tcp Apple VPN Server Reporting Protocol Christophe Allie Christophe Allie 2006-08
apple-vpns-rp 4112 udp Apple VPN Server Reporting Protocol Christophe Allie Christophe Allie 2006-08
aipn-reg 4113 tcp AIPN LS Registration Qiang Zhang Qiang Zhang 2006-10
aipn-reg 4113 udp AIPN LS Registration Qiang Zhang Qiang Zhang 2006-10
jomamqmonitor 4114 tcp JomaMQMonitor Marcel Hofstetter Marcel Hofstetter 2003-01
jomamqmonitor 4114 udp JomaMQMonitor Marcel Hofstetter Marcel Hofstetter 2003-01
cds 4115 tcp CDS Transfer Agent Neil Coggins Neil Coggins 2006-07
cds 4115 udp CDS Transfer Agent Neil Coggins Neil Coggins 2006-07
smartcard-tls 4116 tcp smartcard-TLS Ilan Mahalal Ilan Mahalal 2006-04

Contact Information

Name Organization Contact URI Last Updated
Akiyoshi Ochi akiyoshi&net.paso.fujitsu.co.jp
Albert Leung aleung&biscom.com 2006-04
Carlos Hung chung&digisle.net
Chris Rominski ChrisRom&attachmate.com
Christian Beaumont chrisb&lantronix.com 2003-11
Christophe Allie callie&apple.com 2006-08
Chuck Talk ctalk&pervasive.com
David Ely dely&cnri.reston.va.us
David Goodall david.goodall&g2microsystems.com 2007-02
David Kramer dkramer&apple.com 2004-11
David Miller dave.dsm&gmail.com 2007-02
Dennis Parker dparker&broadcloud.com 2002-02
Gary Bartlett garyb&echelon.com
Greg Bailey gbailey&lxpro.com 2003-04
Ilan Mahalal imahalal&axalto.com 2006-04
Jakob Oestergaard joe&sysorb.com 2002-02
James Figgins james.figgins&durodata.co.uk 2006-07
Jim McDonald Jim.McDonald&sysdm.com 2003-04
John Kozlowski ShofarNexus.com John.Kozlowski&ShofarNexus.com 2012-02-20
Johnny C. Norris II jnorris&uiuc.edu
Katsuaki Naoi naoi&pfu.co.jp
Marcel Hofstetter marcel.hofstetter&jomasoft.ch 2003-01
Marcel Ruff mr&marcelruff.info 2002-02
Masahiro Koiwai Koiwai.Masahiro&exc.epson.co.jp 2006-10
Mike Klein m.klein&motorla.com 2002-02
Neil Coggins neil.coggins&6thsight.com 2006-07
Paul Reddy support&igo-incognito.com 2002-02
Per Hellberg phellberg&isogon.com 2002-02
Per Sahlqvist psahlqvi&sw.seisy.abb.se
Predrag Filipovic pfilipovic&digital5.com 2002-11
Qiang Zhang iad&iwncomm.com 2006-10
Rafael Zimberoff rafael&zfirmllc.com 2003-11
Ray Gwinn p00321&psilink.com
Richard Dickins rad&specview.com 2002-02
Sébastien Hinderer Sebastien.Hinderer&ens-lyon.org 2006-03
ShofarNexus.com John.Kozlowski&ShofarNexus.com 2012-02-20
Takashi Sahara sahara&jdl.co.jp 2006-09
Tuomo Makinen tmakinen&pp.htv.fi 2002-02
Virgilio Lattanzi virgilio&harpax.com 2002-07
Yvon Marineau yvon&simware.com
Z-Firm LLC rafael&zfirmllc.com 2014-08-22