Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
lv-auth 2147 udp Live Vault Authentication Ted Hess Ted Hess
antidotemgrsvr 2247 tcp Antidote Deployment Manager Service Rod Waltermann Rod Waltermann 2006-02
antidotemgrsvr 2247 udp Antidote Deployment Manager Service Rod Waltermann Rod Waltermann 2006-02
redstorm-find 2347 tcp Game Announcement and Location

IANA assigned this well-formed service name as a replacement for "redstorm_find".
redstorm_find 2347 tcp Game Announcement and Location This entry is an alias to "redstorm-find". This entry is now historic, not usable for use with many common service discovery mechanisms.
redstorm-find 2347 udp Game Announcement and Location

IANA assigned this well-formed service name as a replacement for "redstorm_find".
redstorm_find 2347 udp Game Announcement and Location This entry is an alias to "redstorm-find". This entry is now historic, not usable for use with many common service discovery mechanisms.
ovwdb 2447 tcp OpenView NNM daemon Eric Pulsipher Eric Pulsipher
ovwdb 2447 udp OpenView NNM daemon Eric Pulsipher Eric Pulsipher
taskman-port 2470 tcp taskman port Boris Panteleev Boris Panteleev
taskman-port 2470 udp taskman port Boris Panteleev Boris Panteleev
seaodbc 2471 tcp SeaODBC Adrian Hornby Adrian Hornby
seaodbc 2471 udp SeaODBC Adrian Hornby Adrian Hornby
c3 2472 tcp C3 Eckhard Grieger Eckhard Grieger
c3 2472 udp C3 Eckhard Grieger Eckhard Grieger
aker-cdp 2473 tcp Aker-cdp Rodrigo Ormonde Rodrigo Ormonde
aker-cdp 2473 udp Aker-cdp Rodrigo Ormonde Rodrigo Ormonde
vitalanalysis 2474 tcp Vital Analysis Srinivas Reddy Srinivas Reddy
vitalanalysis 2474 udp Vital Analysis Srinivas Reddy Srinivas Reddy
ace-server 2475 tcp ACE Server
ace-server 2475 udp ACE Server
ace-svr-prop 2476 tcp ACE Server Propagation
ace-svr-prop 2476 udp ACE Server Propagation
ssm-cvs 2477 tcp SecurSight Certificate Valifation Service
ssm-cvs 2477 udp SecurSight Certificate Valifation Service
ssm-cssps 2478 tcp SecurSight Authentication Server (SSL)
ssm-cssps 2478 udp SecurSight Authentication Server (SSL)
ssm-els 2479 tcp SecurSight Event Logging Server (SSL) John Linn John Linn
ssm-els 2479 udp SecurSight Event Logging Server (SSL) John Linn John Linn
vytalvaultvsmp 2547 tcp vytalvaultvsmp
vytalvaultvsmp 2547 udp vytalvaultvsmp
syncserver 2647 tcp SyncServer Shawn Casey Shawn Casey
syncserver 2647 udp SyncServer Shawn Casey Shawn Casey
fjippol-swrly 2747 tcp
fjippol-swrly 2747 udp
aimpp-port-req 2847 tcp AIMPP Port Req Brian Martinicky Brian Martinicky
aimpp-port-req 2847 udp AIMPP Port Req Brian Martinicky Brian Martinicky
gpsd 2947 tcp GPS Daemon request/response protocol Eric S. Raymond Eric S. Raymond 2010-04-19
gpsd 2947 udp GPS Daemon request/response protocol Eric S. Raymond Eric S. Raymond 2010-04-19
hlserver 3047 tcp Fast Security HL Server Safenet Inc. Michael Zunke 2014-07-02
hlserver 3047 udp Fast Security HL Server Safenet Inc. Michael Zunke 2014-07-02
rfio 3147 tcp RFIO Frederic Hemmer Frederic Hemmer
rfio 3147 udp RFIO Frederic Hemmer Frederic Hemmer
dvt-data 3247 tcp DVT DATA LINK Phillip Heil Phillip Heil 2002-02
dvt-data 3247 udp DVT DATA LINK Phillip Heil Phillip Heil 2002-02
phoenix-rpc 3347 tcp Phoenix RPC Ian Anderson Ian Anderson
phoenix-rpc 3347 udp Phoenix RPC Ian Anderson Ian Anderson
directnet 3447 tcp DirectNet IM System Gregory Richards Gregory Richards 2002-04
directnet 3447 udp DirectNet IM System Gregory Richards Gregory Richards 2002-04
jt400 3470 tcp jt400
jt400 3470 udp jt400
jt400-ssl 3471 tcp jt400-ssl Clifton Nock Clifton Nock
jt400-ssl 3471 udp jt400-ssl Clifton Nock Clifton Nock
jaugsremotec-1 3472 tcp JAUGS N-G Remotec 1
jaugsremotec-1 3472 udp JAUGS N-G Remotec 1
jaugsremotec-2 3473 tcp JAUGS N-G Remotec 2 Steven B. Cliff Steven B. Cliff 2002-04
jaugsremotec-2 3473 udp JAUGS N-G Remotec 2 Steven B. Cliff Steven B. Cliff 2002-04
ttntspauto 3474 tcp TSP Automation Arnie Koster Arnie Koster 2002-04
ttntspauto 3474 udp TSP Automation Arnie Koster Arnie Koster 2002-04
genisar-port 3475 tcp Genisar Comm Port Candace Niccolson Candace Niccolson 2002-04
genisar-port 3475 udp Genisar Comm Port Candace Niccolson Candace Niccolson 2002-04
nppmp 3476 tcp NVIDIA Mgmt Protocol Gilbert Yeung Gilbert Yeung 2002-04
nppmp 3476 udp NVIDIA Mgmt Protocol Gilbert Yeung Gilbert Yeung 2002-04
ecomm 3477 tcp eComm link port Thomas Soerensen Thomas Soerensen 2002-04
ecomm 3477 udp eComm link port Thomas Soerensen Thomas Soerensen 2002-04
stun 3478 tcp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
stun 3478 udp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
turn 3478 tcp TURN over TCP 2019-08-02 RFC 8656
turn 3478 udp TURN over UDP 2019-08-02 RFC 8656
stun-behavior 3478 tcp STUN Behavior Discovery over TCP RFC 5780
stun-behavior 3478 udp STUN Behavior Discovery over UDP RFC 5780
twrpc 3479 tcp 2Wire RPC 2Wire IANA Contact 2Wire IANA Contact 2002-04
twrpc 3479 udp 2Wire RPC 2Wire IANA Contact 2Wire IANA Contact 2002-04
symantec-sim 3547 tcp Symantec SIM George Dzieciol George Dzieciol 2002-07
symantec-sim 3547 udp Symantec SIM George Dzieciol George Dzieciol 2002-07
splitlock-gw 3647 tcp Splitlock Gateway Andrew Tune Andrew Tune 2003-01
splitlock-gw 3647 udp Splitlock Gateway Andrew Tune Andrew Tune 2003-01
linktest-s 3747 tcp LXPRO.COM LinkTest SSL Greg Bailey Greg Bailey 2003-04
linktest-s 3747 udp LXPRO.COM LinkTest SSL Greg Bailey Greg Bailey 2003-04
msfw-control 3847 tcp MS Firewall Control Oren Trutner Oren Trutner 2003-08
msfw-control 3847 udp MS Firewall Control Oren Trutner Oren Trutner 2003-08
ccp 3947 tcp Connect and Control Protocol for Consumer, Commercial, and Industrial Electronic Devices Aaron Myer Aaron Myer 2004-06
ccp 3947 udp Connect and Control Protocol for Consumer, Commercial, and Industrial Electronic Devices Aaron Myer Aaron Myer 2004-06
ctp-state 4047 tcp Context Transfer Protocol Hesham Soliman Hesham Soliman 2005-11
ctp-state 4047 udp Context Transfer Protocol Hesham Soliman Hesham Soliman 2005-11
vrxpservman 4147 tcp Multum Service Manager Scott Mager Scott Mager 2006-10
vrxpservman 4147 udp Multum Service Manager Scott Mager Scott Mager 2006-10
lansurveyor 4347 tcp LAN Surveyor Michael Swan Michael Swan
lansurveyor 4347 udp LAN Surveyor Michael Swan Michael Swan
n1-rmgmt 4447 tcp N1-RMGMT Lori Tassin Lori Tassin
n1-rmgmt 4447 udp N1-RMGMT Lori Tassin Lori Tassin
4461-4479 Unassigned
lanner-lm 4547 tcp Lanner License Manager Les Enstone Les Enstone
lanner-lm 4547 udp Lanner License Manager Les Enstone Les Enstone
4647-4657 Unassigned
netxms-agent 4700 tcp NetXMS Agent
netxms-agent 4700 udp NetXMS Agent
netxms-mgmt 4701 tcp NetXMS Management
netxms-mgmt 4701 udp NetXMS Management
netxms-sync 4702 tcp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
netxms-sync 4702 udp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07

Contact Information

Name Organization Contact URI Last Updated
Aaron Myer aaron.myer&in2nets.com 2004-06
Adrian Hornby Adrian.Hornby&aran.co.uk
Andrew Tune Andrew.Tune&splitlock.com 2003-01
Arnie Koster akoster&teltone.com 2002-04
Boris Panteleev bpanteleev&himel.com
Brian Martinicky Brian_Martinicky&automationintelligence.com
Candace Niccolson cniccolson&genisar.com 2002-04
Clifton Nock cnock&us.ibm.com
Eckhard Grieger e.grieger&com-on.de
Eric Pulsipher eric_pulsipher&fc.hp.com
Eric S. Raymond esr&thyrsus.com 2010-04-19
Frederic Hemmer Frederic.Hemmer&cern.ch
George Dzieciol gdzieciol&symantec.com 2002-07
Gilbert Yeung gyeung&nvidia.com 2002-04
Greg Bailey gbailey&lxpro.com 2003-04
Gregory Richards Richards&codu.org 2002-04
Hesham Soliman H.Soliman&flarion.com 2005-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ian Anderson ian_anderson&phoenix.com
John Linn jlinn&securitydynamics.com
Les Enstone lenstone&lanner.co.uk
Lori Tassin Ramsey&network-1.com
Michael Swan swan&neon.com 2004-04
Michael Zunke Safenet Inc. michael.zunke&safenet-inc.com 2014-07-02
Oren Trutner orentrut&microsoft.com 2003-08
Phillip Heil phil.heil&dvtsensors.com 2002-02
Rod Waltermann walterma&us.lenovo.com 2006-02
Rodrigo Ormonde ormonde&aker.com.br
Safenet Inc. michael.zunke&safenet-inc.com 2014-07-02
Scott Mager Scott.Mager&cerner.com 2006-10
Shawn Casey Shawn.Casey&matrixone.com
Srinivas Reddy sreddy&vitalsigns.com
Steven B. Cliff scliff&remotec-andros.com 2003-07
Ted Hess thess&livevault.com
Thomas Soerensen thomassoerensen&stofanet.dk 2002-04
Victor Kirhenshtein victor&opticom.lv 2006-07
2Wire IANA Contact iana&2wire.com 2002-04