Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dn6-nlm-aud 195 tcp DNSIX Network Level Module Audit
dn6-nlm-aud 195 udp DNSIX Network Level Module Audit
at-5 205 tcp AppleTalk Unused
at-5 205 udp AppleTalk Unused
z39-50 210 tcp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 tcp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
z39-50 210 udp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 udp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
softpc 215 tcp Insignia Solutions Martyn Thomas Martyn Thomas
softpc 215 udp Insignia Solutions Martyn Thomas Martyn Thomas
225-241 Reserved 2024-12-20 RFC 1060
link 245 tcp LINK
link 245 udp LINK
249-255 Reserved 2024-12-20 RFC 1060
rap 256 tcp RAP J. S. Greenfield J. S. Greenfield
rap 256 udp RAP J. S. Greenfield J. S. Greenfield
set 257 tcp Secure Electronic Transaction Donald Eastlake Donald Eastlake
set 257 udp Secure Electronic Transaction Donald Eastlake Donald Eastlake
258 Unassigned 2006-09-13
esro-gen 259 tcp Efficient Short Remote Operations Mohsen Banan Mohsen Banan
esro-gen 259 udp Efficient Short Remote Operations Mohsen Banan Mohsen Banan
x-bone-ctl 265 tcp X-Bone CTL Joe Touch Joe Touch
x-bone-ctl 265 udp X-Bone CTL Joe Touch Joe Touch
manet 269 tcp MANET Protocols RFC 5498
manet 269 udp MANET Protocols RFC 5498
gist 270 udp Q-mode encapsulation for GIST messages RFC 5971
285 Unassigned
dpsi 315 tcp DPSI Tony Scamurra Tony Scamurra
dpsi 315 udp DPSI Tony Scamurra Tony Scamurra
325-332 Unassigned
pawserv 345 tcp Perf Analysis Workbench
pawserv 345 udp Perf Analysis Workbench
matip-type-a 350 tcp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-a 350 udp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-b 351 tcp MATIP Type B Alain Robert Alain Robert RFC 2351
matip-type-b 351 udp MATIP Type B Alain Robert Alain Robert RFC 2351
bhoetty 351 tcp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoetty 351 udp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
dtag-ste-sb 352 tcp DTAG Ruediger Wald Ruediger Wald (assigned long ago)
dtag-ste-sb 352 udp DTAG Ruediger Wald Ruediger Wald (assigned long ago)
bhoedap4 352 tcp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 udp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
ndsauth 353 tcp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
ndsauth 353 udp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
bh611 354 tcp bh611 John Kelly John Kelly
bh611 354 udp bh611 John Kelly John Kelly
datex-asn 355 tcp DATEX-ASN Kenneth Vaughn Kenneth Vaughn
datex-asn 355 udp DATEX-ASN Kenneth Vaughn Kenneth Vaughn
cloanto-net-1 356 tcp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
cloanto-net-1 356 udp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
bhevent 357 tcp bhevent John Kelly John Kelly
bhevent 357 udp bhevent John Kelly John Kelly
shrinkwrap 358 tcp Shrinkwrap Bill Simpson Bill Simpson
shrinkwrap 358 udp Shrinkwrap Bill Simpson Bill Simpson
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
dtk 365 tcp DTK Fred Cohen Fred Cohen
dtk 365 udp DTK Fred Cohen Fred Cohen
hassle 375 tcp Hassle Reinhard Doelz Reinhard Doelz
hassle 375 udp Hassle Reinhard Doelz Reinhard Doelz
ibm-app 385 tcp IBM Application Lisa Tomita Lisa Tomita
ibm-app 385 udp IBM Application Lisa Tomita Lisa Tomita
meta5 393 tcp Meta5 Jim Kanzler Jim Kanzler
meta5 393 udp Meta5 Jim Kanzler Jim Kanzler
netcp 395 tcp NetScout Control Protocol Ashwani Singhal Ashwani Singhal 2010-04-07
netcp 395 udp NetScout Control Protocol Ashwani Singhal Ashwani Singhal 2010-04-07
ncld 405 tcp ncld Richard Jones Richard Jones
ncld 405 udp ncld Richard Jones Richard Jones
bnet 415 tcp BNet Jim Mertz Jim Mertz
bnet 415 udp BNet Jim Mertz Jim Mertz
icad-el 425 tcp ICAD Larry Stone Larry Stone
icad-el 425 udp ICAD Larry Stone Larry Stone
mobilip-mn 435 tcp MobilIP-MN Kannan Alagappan Kannan Alagappan
mobilip-mn 435 udp MobilIP-MN Kannan Alagappan Kannan Alagappan
snpp 444 tcp Simple Network Paging Protocol RFC 1568
snpp 444 udp Simple Network Paging Protocol RFC 1568
microsoft-ds 445 tcp Microsoft-DS Pradeep Bahl Pradeep Bahl
microsoft-ds 445 udp Microsoft-DS Pradeep Bahl Pradeep Bahl
tserver 450 tcp Computer Supported Telecomunication Applications Harvey S. Schultz Harvey S. Schultz
tserver 450 udp Computer Supported Telecomunication Applications Harvey S. Schultz Harvey S. Schultz
sfs-smp-net 451 tcp Cray Network Semaphore server
sfs-smp-net 451 udp Cray Network Semaphore server
sfs-config 452 tcp Cray SFS config server Walter Poxon Walter Poxon
sfs-config 452 udp Cray SFS config server Walter Poxon Walter Poxon
creativeserver 453 tcp CreativeServer
creativeserver 453 udp CreativeServer
contentserver 454 tcp ContentServer
contentserver 454 udp ContentServer
creativepartnr 455 tcp CreativePartnr Jesus Ortiz Jesus Ortiz
creativepartnr 455 udp CreativePartnr Jesus Ortiz Jesus Ortiz
macon-tcp 456 tcp macon-tcp Yoshinobu Inoue Yoshinobu Inoue
macon-udp 456 udp macon-udp Yoshinobu Inoue Yoshinobu Inoue
scohelp 457 tcp scohelp Faith Zack Faith Zack
scohelp 457 udp scohelp Faith Zack Faith Zack
appleqtc 458 tcp apple quick time Murali Ranganathan Murali Ranganathan
appleqtc 458 udp apple quick time Murali Ranganathan Murali Ranganathan
ampr-rcmd 459 tcp ampr-rcmd Rob Janssen Rob Janssen
ampr-rcmd 459 udp ampr-rcmd Rob Janssen Rob Janssen
urd 465 tcp URL Rendezvous Directory for SSM Toerless Eckert Toerless Eckert
submissions 465 tcp Message Submission over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
igmpv3lite 465 udp IGMP over UDP for SSM Toerless Eckert Toerless Eckert

Contact Information

Name Organization Contact URI Last Updated
Alain Robert arobert&par.sita.int
Ashwani Singhal Ashwani.Singhal&netscout.com 2010-04-07
Bill Simpson wsimpson&greendragon.com
Donald Eastlake d3e3e3&gmail.com
Faith Zack faithz&sco.com
Fred Cohen fc&all.net
Harvey S. Schultz harvey&acm.org
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J. S. Greenfield greeny&raleigh.ibm.com
Jayakumar Ramalingam jayakumar&novell.com
Jesus Ortiz jesus_ortiz&emotion.com
Jim Kanzler jim.kanzler&meta5.com
Jim Mertz JMertz+RV09&rvdc.unisys.com
Joe Touch touch&strayalpha.com 2020-02-07
John Kelly johnk&bellhow.com
Kannan Alagappan kannan&sejour.lkg.dec.com
Kenneth Vaughn kvaughn&mail.viggen.com
Larry Stone lcs&icad.com
Lisa Tomita
Mark H. Needleman markn&sirsi.com
Martyn Thomas
Michael Battilana mcb-iana&cloanto.net 2010-04-30
Mohsen Banan mohsen&rostam.neda.com
Murali Ranganathan murali_ranganathan&quickmail.apple.com
Pradeep Bahl pradeepb&microsoft.com
Reinhard Doelz doelz&comp.bioz.unibas.ch
Richard Jones
Rob Janssen rob&sys3.pe1chl.ampr.org
Ruediger Wald wald&ez-darmstadt.telekom.de
Toerless Eckert eckert&cisco.com
Tony Scamurra Tony&desktoppaging.com
Walter Poxon wdp&ironwood.cray.com
Yoshinobu Inoue