Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| psbserver | 2350 | udp | Pharos Booking Server | ||||||||
| netadmin | 2450 | tcp | netadmin | ||||||||
| netadmin | 2450 | udp | netadmin | ||||||||
| rtsserv | 2500 | tcp | Resource Tracking system server | ||||||||
| rtsserv | 2500 | udp | Resource Tracking system server | ||||||||
| rtsclient | 2501 | tcp | Resource Tracking system client | Aubrey Turner | Aubrey Turner | ||||||
| rtsclient | 2501 | udp | Resource Tracking system client | Aubrey Turner | Aubrey Turner | ||||||
| kentrox-prot | 2502 | tcp | Kentrox Protocol | Anil Lakhwara | Anil Lakhwara | ||||||
| kentrox-prot | 2502 | udp | Kentrox Protocol | Anil Lakhwara | Anil Lakhwara | ||||||
| nms-dpnss | 2503 | tcp | NMS-DPNSS | Jean-Christophe Desire | Jean-Christophe Desire | ||||||
| nms-dpnss | 2503 | udp | NMS-DPNSS | Jean-Christophe Desire | Jean-Christophe Desire | ||||||
| wlbs | 2504 | tcp | WLBS | William Bain | William Bain | ||||||
| wlbs | 2504 | udp | WLBS | William Bain | William Bain | ||||||
| ppcontrol | 2505 | tcp | PowerPlay Control | Max Magliaro | Max Magliaro | 2004-11 | |||||
| ppcontrol | 2505 | udp | PowerPlay Control | Max Magliaro | Max Magliaro | 2004-11 | |||||
| jbroker | 2506 | tcp | jbroker | Rohit Garg | Rohit Garg | ||||||
| jbroker | 2506 | udp | jbroker | Rohit Garg | Rohit Garg | ||||||
| spock | 2507 | tcp | spock | Jon A. Christopher | Jon A. Christopher | ||||||
| spock | 2507 | udp | spock | Jon A. Christopher | Jon A. Christopher | ||||||
| jdatastore | 2508 | tcp | JDataStore | Tod Landis | Tod Landis | ||||||
| jdatastore | 2508 | udp | JDataStore | Tod Landis | Tod Landis | ||||||
| fjmpss | 2509 | tcp | fjmpss | Makoto Watanabe | Makoto Watanabe | ||||||
| fjmpss | 2509 | udp | fjmpss | Makoto Watanabe | Makoto Watanabe | ||||||
| ads | 2550 | tcp | ADS | Michael O'Connor | Michael O'Connor | ||||||
| ads | 2550 | udp | ADS | Michael O'Connor | Michael O'Connor | ||||||
| eristwoguns | 2650 | tcp | eristwoguns | Jason Lockett; Melanie Kacerek | Jason Lockett; Melanie Kacerek | 2008-12-16 | |||||
| eristwoguns | 2650 | udp | eristwoguns | Jason Lockett; Melanie Kacerek | Jason Lockett; Melanie Kacerek | 2008-12-16 | |||||
| fjippol-port1 | 2750 | tcp | |||||||||
| fjippol-port1 | 2750 | udp | |||||||||
| metaconsole | 2850 | tcp | MetaConsole | Rakesh Mahajan | Rakesh Mahajan | ||||||
| metaconsole | 2850 | udp | MetaConsole | Rakesh Mahajan | Rakesh Mahajan | ||||||
| astronova-main | 2864 | tcp | main 5001 cmd | AstroNova, Inc. | Chris Tate | 2020-03-03 | |||||
| astronova-main | 2864 | udp | main 5001 cmd | AstroNova, Inc. | Chris Tate | 2020-03-03 | |||||
| esip | 2950 | tcp | ESIP | David Stephenson | David Stephenson | ||||||
| esip | 2950 | udp | ESIP | David Stephenson | David Stephenson | ||||||
| gds-db | 3050 | tcp | gds_db IANA assigned this well-formed service name as a replacement for "gds_db". |
Madhukar N. Thakur | Madhukar N. Thakur | ||||||
| gds_db | 3050 | tcp | gds_db | Madhukar N. Thakur | Madhukar N. Thakur | This entry is an alias to "gds-db". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| gds-db | 3050 | udp | gds_db IANA assigned this well-formed service name as a replacement for "gds_db". |
Madhukar N. Thakur | Madhukar N. Thakur | ||||||
| gds_db | 3050 | udp | gds_db | Madhukar N. Thakur | Madhukar N. Thakur | This entry is an alias to "gds-db". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| itu-bicc-stc | 3097 | sctp | ITU-T Q.1902.1/Q.2150.3 | Greg Sidebottom | Greg Sidebottom | ||||||
| nm-asses-admin | 3150 | tcp | NetMike Assessor Administrator | ||||||||
| nm-asses-admin | 3150 | udp | NetMike Assessor Administrator | ||||||||
| hicp | 3250 | tcp | HMS hicp port | Joel Palsson | Joel Palsson | 2002-02 | |||||
| hicp | 3250 | udp | HMS hicp port | Joel Palsson | Joel Palsson | 2002-02 | |||||
| odette-ftp | 3305 | tcp | ODETTE-FTP | David Nash | David Nash | RFC 5024 | |||||
| odette-ftp | 3305 | udp | ODETTE-FTP | David Nash | David Nash | RFC 5024 | |||||
| findviatv | 3350 | tcp | FINDVIATV | Oran Davis | Oran Davis | ||||||
| findviatv | 3350 | udp | FINDVIATV | Oran Davis | Oran Davis | ||||||
| castorproxy | 3450 | tcp | CAStorProxy | Raymond J. Young | Raymond J. Young | 2002-04 | |||||
| castorproxy | 3450 | udp | CAStorProxy | Raymond J. Young | Raymond J. Young | 2002-04 | |||||
| rtmp-port | 3500 | tcp | RTMP Port | Miriam Wohlgelernter | Miriam Wohlgelernter | ||||||
| rtmp-port | 3500 | udp | RTMP Port | Miriam Wohlgelernter | Miriam Wohlgelernter | ||||||
| isoft-p2p | 3501 | tcp | iSoft-P2P | David Walling | David Walling | ||||||
| isoft-p2p | 3501 | udp | iSoft-P2P | David Walling | David Walling | ||||||
| avinstalldisc | 3502 | tcp | Avocent Install Discovery | Brian S. Stewart | Brian S. Stewart | ||||||
| avinstalldisc | 3502 | udp | Avocent Install Discovery | Brian S. Stewart | Brian S. Stewart | ||||||
| lsp-ping | 3503 | tcp | MPLS LSP-echo Port | RFC 8029 | |||||||
| lsp-ping | 3503 | udp | MPLS LSP-echo Port | RFC 8029 | |||||||
| ironstorm | 3504 | tcp | IronStorm game server | Arnaud Clermonte | Arnaud Clermonte | ||||||
| ironstorm | 3504 | udp | IronStorm game server | Arnaud Clermonte | Arnaud Clermonte | ||||||
| ccmcomm | 3505 | tcp | CCM communications port | Tom Bougan | Tom Bougan | ||||||
| ccmcomm | 3505 | udp | CCM communications port | Tom Bougan | Tom Bougan | ||||||
| apc-3506 | 3506 | tcp | APC 3506 | American Power Conversion | American Power Conversion | ||||||
| apc-3506 | 3506 | udp | APC 3506 | American Power Conversion | American Power Conversion | ||||||
| nesh-broker | 3507 | tcp | Nesh Broker Port | Jeremy Maiden | Jeremy Maiden | ||||||
| nesh-broker | 3507 | udp | Nesh Broker Port | Jeremy Maiden | Jeremy Maiden | ||||||
| interactionweb | 3508 | tcp | Interaction Web | Mike Gagle | Mike Gagle | ||||||
| interactionweb | 3508 | udp | Interaction Web | Mike Gagle | Mike Gagle | ||||||
| vt-ssl | 3509 | tcp | Virtual Token SSL Port | Libor Sykora | Libor Sykora | 2002-05 | |||||
| vt-ssl | 3509 | udp | Virtual Token SSL Port | Libor Sykora | Libor Sykora | 2002-05 | |||||
| ssmpp | 3550 | tcp | Secure SMPP | Cormac Long | Cormac Long | 2002-07 | |||||
| ssmpp | 3550 | udp | Secure SMPP | Cormac Long | Cormac Long | 2002-07 | |||||
| prismiq-plugin | 3650 | tcp | PRISMIQ VOD plug-in | Richard Hodges | Richard Hodges | 2003-01 | |||||
| prismiq-plugin | 3650 | udp | PRISMIQ VOD plug-in | Richard Hodges | Richard Hodges | 2003-01 | |||||
| cbos-ip-port | 3750 | tcp | CBOS/IP ncapsalation port | Thomas Dannemiller | Thomas Dannemiller | 2003-04 | |||||
| cbos-ip-port | 3750 | udp | CBOS/IP ncapsalation port | Thomas Dannemiller | Thomas Dannemiller | 2003-04 | |||||
| qtms-bootstrap | 3850 | tcp | QTMS Bootstrap Protocol | Phil Willis | Phil Willis | 2003-08 | |||||
| qtms-bootstrap | 3850 | udp | QTMS Bootstrap Protocol | Phil Willis | Phil Willis | 2003-08 | |||||
| namemunge | 3950 | tcp | Name Munging | John C. Klensin | John C. Klensin | 2004-07 | |||||
| namemunge | 3950 | udp | Name Munging | John C. Klensin | John C. Klensin | 2004-07 | |||||
| cisco-wafs | 4050 | tcp | Wide Area File Services | Etai Lev-Ran | Etai Lev-Ran | 2005-02 | |||||
| cisco-wafs | 4050 | udp | Wide Area File Services | Etai Lev-Ran | Etai Lev-Ran | 2005-02 | |||||
| PowerAlert-nsa | 4150 | tcp | PowerAlert Network Shutdown Agent | Mike Delgrosso | Mike Delgrosso | 2007-07-02 | |||||
| PowerAlert-nsa | 4150 | udp | PowerAlert Network Shutdown Agent | Mike Delgrosso | Mike Delgrosso | 2007-07-02 | |||||
| net-device | 4350 | tcp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| net-device | 4350 | udp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| camp | 4450 | tcp | Common ASCII Messaging Protocol | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| camp | 4450 | udp | Common ASCII Messaging Protocol | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ipsec-nat-t | 4500 | tcp | IPsec NAT-Traversal | 2022-09-15 | RFC 9329 | ||||||
| ipsec-nat-t | 4500 | udp | IPsec NAT-Traversal | 2017-07-07 | RFC 3948; RFC 7296 | ||||||
| 4501 | Unassigned | IANA | IANA | De-registered 08 June 2001 | |||||||
| a25-fap-fgw | 4502 | sctp | A25 (FAP-FGW) | 3GPP2 | Zhiming Li | 2012-01-11 | |||||
| 4503 | tcp | Reserved | |||||||||
| m-bus-oms | 4503 | udp | M-Bus-OMS over UDP | OMS-Group e. V. (Open Metering System Group) | Ahmed Kasttet | 2025-05-19 | |||||
| 4504-4533 | Unassigned | ||||||||||
| gds-adppiw-db | 4550 | tcp | Perman I Interbase Server | Leo Lesage | Leo Lesage | 2006-04 | |||||
| gds-adppiw-db | 4550 | udp | Perman I Interbase Server | Leo Lesage | Leo Lesage | 2006-04 | |||||
| ssad | 4750 | tcp | Simple Service Auto Discovery | Dr Horst Herb | Dr Horst Herb | 2005-12 | |||||
| ssad | 4750 | udp | Simple Service Auto Discovery | Dr Horst Herb | Dr Horst Herb | 2005-12 | |||||
| sun-as-nodeagt | 4850 | tcp | Sun App Server - NA | Kedar Mhaswade | Kedar Mhaswade | 2004-11 | |||||
| sun-as-nodeagt | 4850 | udp | Sun App Server - NA | Kedar Mhaswade | Kedar Mhaswade | 2004-11 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP2 | lizhiming&huawei.com | 2012-01-11 | |
| Ahmed Kasttet | OMS-Group e. V. (Open Metering System Group) | ahmed.kasttet&oms-group.org | 2025-05-19 |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Anil Lakhwara | anil_lakhwara&kentrox.com | ||
| Arnaud Clermonte | clermonte&4xtechnologies.com | ||
| AstroNova, Inc. | ctate&astronovainc.com | 2020-03-03 | |
| Aubrey Turner | S95525ta%25etsuacad.bitnet@ETSUADMN.ETSU.EDU | ||
| Brian S. Stewart | Brian.Stewart&avovent.com | ||
| Chris Tate | ctate&astronovainc.com | 2020-03-03 | |
| Clint Eskew | Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 |
| Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 | |
| Cormac Long | webmaster&smsforum.net | 2002-07 | |
| David Nash | dnash&ford.com | ||
| David Stephenson | david_stephenson&hp.com | ||
| David Walling | dwalling&isoft.com | ||
| Dr Horst Herb | horst&dorrigomedical.com | 2005-12 | |
| Etai Lev-Ran | elevran&cisco.com | 2005-02 | |
| Glenn Peterson | glennpµsoft.com | ||
| Greg Sidebottom | gregside&home.com | ||
| IANA | iana&iana.org | ||
| Jason Lockett | Jay.Lockett&quest.com | 2008-12-16 | |
| Jean-Christophe Desire | Jean-Christophe_Desire&nms-europe.com | ||
| Jeremy Maiden | jeremy&3507.uk | 2020-05-01 | |
| Joel Palsson | HMS Industrial Networks AB | ianacontact&hms.se | 2002-02 |
| John C. Klensin | klensin&jck.com | 2004-07 | |
| Jon A. Christopher | jac8792&tamu.edu | ||
| Kedar Mhaswade | kedar.Mhaswade&sun.com | 2004-11 | |
| Leo Lesage | leo.lesage&adp.nl | 2006-04 | |
| Libor Sykora | libor.sykora&st.com | 2002-05 | |
| Madhukar N. Thakur | mthakur&interbase.com | ||
| Makoto Watanabe | makoto&saint.nm.fujitsu.co.jp | ||
| Max Magliaro | mmagliaro&bnisolutions.com | 2004-11 | |
| Melanie Kacerek | melanie.kacerek&quest.com | 2008-12-16 | |
| Michael O'Connor | moconnor&adobe.com | ||
| Mike Delgrosso | Mike_Delgrosso&tripplite.com | 2007-07-02 | |
| Mike Gagle | mikeg&inin.com | 2006-05 | |
| Miriam Wohlgelernter | miriamw&adirtech.com | ||
| OMS-Group e. V. (Open Metering System Group) | office&oms-group.org | 2025-05-19 | |
| Oran Davis | oran&8x8.com | ||
| Phil Willis | phil.willis&prism-uk.com | 2003-08 | |
| Rakesh Mahajan | rmahajan&netaphor-software.com | ||
| Raymond J. Young | Raymond.Young&ca.com | 2002-04 | |
| Richard Hodges | rhodges&prismiq.com | 2003-01 | |
| Rohit Garg | rohit&objectscape.com | ||
| Thomas Dannemiller | tom.dannemiller&rolls-royce.com | 2003-04 | |
| Tod Landis | tlandis&inprise.com | ||
| Tom Bougan | tomb&apptechsys.com | ||
| William Bain | bbainµsoft.com | ||
| Zhiming Li | 3GPP2 | lizhiming&huawei.com | 2012-01-11 |