Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| qke-llc-v3 | 2523 | tcp | Qke LLC V.3 | Joerg Niehoff | Joerg Niehoff | ||||||
| qke-llc-v3 | 2523 | udp | Qke LLC V.3 | Joerg Niehoff | Joerg Niehoff | ||||||
| optiwave-lm | 2524 | tcp | Optiwave License Management | Slawomir Krzesinski | Slawomir Krzesinski | ||||||
| optiwave-lm | 2524 | udp | Optiwave License Management | Slawomir Krzesinski | Slawomir Krzesinski | ||||||
| ms-v-worlds | 2525 | tcp | MS V-Worlds | Pete Wong | Pete Wong | ||||||
| ms-v-worlds | 2525 | udp | MS V-Worlds | Pete Wong | Pete Wong | ||||||
| ema-sent-lm | 2526 | tcp | EMA License Manager | Thaddeus Perala | Thaddeus Perala | ||||||
| ema-sent-lm | 2526 | udp | EMA License Manager | Thaddeus Perala | Thaddeus Perala | ||||||
| iqserver | 2527 | tcp | IQ Server | Nick Straguzzi | Nick Straguzzi | ||||||
| iqserver | 2527 | udp | IQ Server | Nick Straguzzi | Nick Straguzzi | ||||||
| ncr-ccl | 2528 | tcp | NCR CCL IANA assigned this well-formed service name as a replacement for "ncr_ccl". |
Amitava Dutta | Amitava Dutta | ||||||
| ncr_ccl | 2528 | tcp | NCR CCL | Amitava Dutta | Amitava Dutta | This entry is an alias to "ncr-ccl". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| ncr-ccl | 2528 | udp | NCR CCL IANA assigned this well-formed service name as a replacement for "ncr_ccl". |
Amitava Dutta | Amitava Dutta | ||||||
| ncr_ccl | 2528 | udp | NCR CCL | Amitava Dutta | Amitava Dutta | This entry is an alias to "ncr-ccl". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| utsftp | 2529 | tcp | UTS FTP | David Moore | David Moore | ||||||
| utsftp | 2529 | udp | UTS FTP | David Moore | David Moore | ||||||
| call-logging | 2552 | tcp | Call Logging | Dean Webb | Dean Webb | ||||||
| call-logging | 2552 | udp | Call Logging | Dean Webb | Dean Webb | ||||||
| interpathpanel | 2652 | tcp | InterPathPanel | Stephen Misel | Stephen Misel | ||||||
| interpathpanel | 2652 | udp | InterPathPanel | Stephen Misel | Stephen Misel | ||||||
| rsisysaccess | 2752 | tcp | RSISYS ACCESS | Christophe Besant | Christophe Besant | ||||||
| rsisysaccess | 2752 | udp | RSISYS ACCESS | Christophe Besant | Christophe Besant | ||||||
| bears-01 | 2852 | tcp | bears-01 | Bruce McKinnon | Bruce McKinnon | ||||||
| bears-01 | 2852 | udp | bears-01 | Bruce McKinnon | Bruce McKinnon | ||||||
| mpfwsas | 2952 | tcp | MPFWSAS | Toru Murai | Toru Murai | ||||||
| mpfwsas | 2952 | udp | MPFWSAS | Toru Murai | Toru Murai | ||||||
| apc-3052 | 3052 | tcp | APC 3052 | American Power Conversion | American Power Conversion | ||||||
| apc-3052 | 3052 | udp | APC 3052 | American Power Conversion | American Power Conversion | ||||||
| feitianrockey | 3152 | tcp | FeiTian Port | Huang Yu | Huang Yu | ||||||
| feitianrockey | 3152 | udp | FeiTian Port | Huang Yu | Huang Yu | ||||||
| dhe | 3252 | tcp | DHE port | Fabrizio Massimo Ferrara | Fabrizio Massimo Ferrara | 2002-02 | |||||
| dhe | 3252 | udp | DHE port | Fabrizio Massimo Ferrara | Fabrizio Massimo Ferrara | 2002-02 | |||||
| ssql | 3352 | tcp | Scalable SQL | Chuck Talk | Chuck Talk | ||||||
| ssql | 3352 | udp | Scalable SQL | Chuck Talk | Chuck Talk | ||||||
| sabp-signal | 3452 | tcp | SABP-Signalling Protocol | Brendan McWilliams | Brendan McWilliams | 2002-04 | |||||
| sabp-signal | 3452 | udp | SABP-Signalling Protocol | Brendan McWilliams | Brendan McWilliams | 2002-04 | |||||
| galileolog | 3520 | tcp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 | |||||
| galileolog | 3520 | udp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 | |||||
| mc3ss | 3521 | tcp | Telequip Labs MC3SS | Michael Sparks | Michael Sparks | 2002-06 | |||||
| mc3ss | 3521 | udp | Telequip Labs MC3SS | Michael Sparks | Michael Sparks | 2002-06 | |||||
| nssocketport | 3522 | tcp | DO over NSSocketPort | Douglas Davidson | Douglas Davidson | 2002-06 | |||||
| nssocketport | 3522 | udp | DO over NSSocketPort | Douglas Davidson | Douglas Davidson | 2002-06 | |||||
| odeumservlink | 3523 | tcp | Odeum Serverlink | Mads Peter Back | Mads Peter Back | 2002-06 | |||||
| odeumservlink | 3523 | udp | Odeum Serverlink | Mads Peter Back | Mads Peter Back | 2002-06 | |||||
| ecmport | 3524 | tcp | ECM Server port | ||||||||
| ecmport | 3524 | udp | ECM Server port | ||||||||
| eisport | 3525 | tcp | EIS Server port | Paul Kraus | Paul Kraus | 2002-06 | |||||
| eisport | 3525 | udp | EIS Server port | Paul Kraus | Paul Kraus | 2002-06 | |||||
| starquiz-port | 3526 | tcp | starQuiz Port | Adam Ernst | Adam Ernst | 2002-06 | |||||
| starquiz-port | 3526 | udp | starQuiz Port | Adam Ernst | Adam Ernst | 2002-06 | |||||
| beserver-msg-q | 3527 | tcp | VERITAS Backup Exec Server | Katherine Wattwood | Katherine Wattwood | 2002-06 | |||||
| beserver-msg-q | 3527 | udp | VERITAS Backup Exec Server | Katherine Wattwood | Katherine Wattwood | 2002-06 | |||||
| jboss-iiop | 3528 | tcp | JBoss IIOP | ||||||||
| jboss-iiop | 3528 | udp | JBoss IIOP | ||||||||
| jboss-iiop-ssl | 3529 | tcp | JBoss IIOP/SSL | Francisco Reverbel | Francisco Reverbel | 2002-06 | |||||
| jboss-iiop-ssl | 3529 | udp | JBoss IIOP/SSL | Francisco Reverbel | Francisco Reverbel | 2002-06 | |||||
| taserver | 3552 | tcp | TeamAgenda Server Port | Dany Ayotte | Dany Ayotte | 2002-07 | |||||
| taserver | 3552 | udp | TeamAgenda Server Port | Dany Ayotte | Dany Ayotte | 2002-07 | |||||
| vxcrnbuport | 3652 | tcp | VxCR NBU Default Port | Boris Star | Boris Star | 2003-01 | |||||
| vxcrnbuport | 3652 | udp | VxCR NBU Default Port | Boris Star | Boris Star | 2003-01 | |||||
| vipremoteagent | 3752 | tcp | Vigil-IP RemoteAgent | Bryan Alvord | Bryan Alvord | 2003-04 | |||||
| vipremoteagent | 3752 | udp | Vigil-IP RemoteAgent | Bryan Alvord | Bryan Alvord | 2003-04 | |||||
| sse-app-config | 3852 | tcp | SSE App Configuration | Tim Wilson | Tim Wilson | 2003-08 | |||||
| sse-app-config | 3852 | udp | SSE App Configuration | Tim Wilson | Tim Wilson | 2003-08 | |||||
| asap-udp | 3863 | udp | asap udp port | RFC 5352 | |||||||
| asap-sctp | 3863 | sctp | asap sctp | RFC 5352 | |||||||
| asap-tcp-tls | 3864 | tcp | asap/tls tcp port | RFC 5352 | |||||||
| asap-sctp-tls | 3864 | sctp | asap-sctp/tls | RFC 5352 | |||||||
| i3-sessionmgr | 3952 | tcp | I3 Session Manager | Mike Gagle | Mike Gagle | 2004-08 | |||||
| i3-sessionmgr | 3952 | udp | I3 Session Manager | Mike Gagle | Mike Gagle | 2004-08 | |||||
| interact | 4052 | tcp | VoiceConnect Interact | Jonathan Custance | Jonathan Custance | 2006-07 | |||||
| interact | 4052 | udp | VoiceConnect Interact | Jonathan Custance | Jonathan Custance | 2006-07 | |||||
| idig-mux | 4152 | tcp | iDigTech Multiplex IANA assigned this well-formed service name as a replacement for "idig_mux". |
Robin Findley | Robin Findley | 2007-05 | |||||
| idig_mux | 4152 | tcp | iDigTech Multiplex | Robin Findley | Robin Findley | 2007-05 | This entry is an alias to "idig-mux". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| idig-mux | 4152 | udp | iDigTech Multiplex IANA assigned this well-formed service name as a replacement for "idig_mux". |
Robin Findley | Robin Findley | 2007-05 | |||||
| idig_mux | 4152 | udp | iDigTech Multiplex | Robin Findley | Robin Findley | 2007-05 | This entry is an alias to "idig-mux". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| pjlink | 4352 | tcp | Projector Link | Mitsuo Kodama | Mitsuo Kodama | 2005-06 | |||||
| pjlink | 4352 | udp | Projector Link | Mitsuo Kodama | Mitsuo Kodama | 2005-06 | |||||
| krb524 | 4444 | tcp | KRB524 | B. Clifford Neuman | B. Clifford Neuman | krb524 assigned the port, nv used it without an assignment | |||||
| krb524 | 4444 | udp | KRB524 | B. Clifford Neuman | B. Clifford Neuman | krb524 assigned the port, nv used it without an assignment | |||||
| nv-video | 4444 | tcp | NV Video default | Ron Frederick | Ron Frederick | krb524 assigned the port, nv used it without an assignment | |||||
| nv-video | 4444 | udp | NV Video default | Ron Frederick | Ron Frederick | krb524 assigned the port, nv used it without an assignment | |||||
| ctiprogramload | 4452 | tcp | CTI Program Load | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctiprogramload | 4452 | udp | CTI Program Load | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| menandmice-mon | 4552 | tcp | Men and Mice Monitoring | Carsten Strotmann | Carsten Strotmann | 2009-05-20 | |||||
| menandmice-mon | 4552 | udp | Men and Mice Monitoring | Carsten Strotmann | Carsten Strotmann | 2009-05-20 | |||||
| snap | 4752 | tcp | Simple Network Audio Protocol | Dameon Wagner | Dameon Wagner | 2002-02 | |||||
| snap | 4752 | udp | Simple Network Audio Protocol | Dameon Wagner | Dameon Wagner | 2002-02 | |||||
| 4852-4866 | Unassigned | ||||||||||
| sagxtsds | 4952 | tcp | SAG Directory Server | Michael Chirila | Michael Chirila | 2006-01 | |||||
| sagxtsds | 4952 | udp | SAG Directory Server | Michael Chirila | Michael Chirila | 2006-01 | |||||
| ita-manager | 5052 | tcp | ITA Manager | Don Merrell | Don Merrell | ||||||
| ita-manager | 5052 | udp | ITA Manager | Don Merrell | Don Merrell | ||||||
| esri-sde | 5151 | tcp | ESRI SDE Instance IANA assigned this well-formed service name as a replacement for "esri_sde". |
Peter Aronson | Peter Aronson | Unauthorized Use Known on ports 5151 and 5152 | |||||
| esri-sde | 5151 | udp | ESRI SDE Remote Start IANA assigned this well-formed service name as a replacement for "esri_sde". |
Peter Aronson | Peter Aronson | Unauthorized Use Known on ports 5151 and 5152 | |||||
| sde-discovery | 5152 | tcp | ESRI SDE Instance Discovery | Peter Aronson | Peter Aronson | Unauthorized Use Known on ports 5151 and 5152 | |||||
| sde-discovery | 5152 | udp | ESRI SDE Instance Discovery | Peter Aronson | Peter Aronson | Unauthorized Use Known on ports 5151 and 5152 | |||||
| targus-getdata | 5200 | tcp | TARGUS GetData | John Keaveney | John Keaveney | ||||||
| targus-getdata | 5200 | udp | TARGUS GetData | John Keaveney | John Keaveney | ||||||
| targus-getdata1 | 5201 | tcp | TARGUS GetData 1 | John Keaveney | John Keaveney | ||||||
| targus-getdata1 | 5201 | udp | TARGUS GetData 1 | John Keaveney | John Keaveney |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adam Ernst | contact&cosmicsoft.net | 2002-06 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Amitava Dutta | Amitava.Dutta&woodbridgenj.ncr.com | ||
| B. Clifford Neuman | bcn&isi.edu | 2022-02-18 | |
| Boris Star | boris.star&veritas.com | 2003-01 | |
| Brendan McWilliams | brendan.mcwilliams&vf.vodafone.co.uk | 2002-04 | |
| Bruce McKinnon | brucemck&bears.aust.com | ||
| Bryan Alvord | bryan&vaticor.com | 2003-04 | |
| Carsten Strotmann | carsten.strotmann&menandmice.com | 2009-05-20 | |
| Christophe Besant | |||
| Chuck Talk | ctalk&pervasive.com | ||
| Clint Eskew | Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 |
| Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 | |
| Dameon Wagner | d.wagner&freemail.absa.co.za | 2002-02 | |
| Dany Ayotte | ayotte&teamsoft.com | 2002-07 | |
| David Moore | dmoore&uttc-uts.com | ||
| Dean Webb | dean.webb&ascend.com | ||
| Don Merrell | donmer&axent.com | ||
| Douglas Davidson | drd&apple.com | 2002-06 | |
| Fabrizio Massimo Ferrara | fmf&gesi.it | 2002-02 | |
| Francisco Reverbel | reverbel&ime.usp.br | 2002-06 | |
| Huang Yu | llw&ftsafe.com | ||
| Joerg Niehoff | joerg.niehoff&alcatel-ke.de | ||
| John Keaveney | johnkeaveney&targusinfo.com | ||
| Jonathan Custance | jevc&camrivox.com | 2006-07 | |
| Katherine Wattwood | katherine.wattwood&veritas.com | 2002-06 | |
| Mads Peter Back | iana-contact&webhouse.dk | 2002-06 | |
| Michael Chirila | Michael.Chirila&softwareag.com | 2006-01 | |
| Michael Sparks | msparks&telequiplabs.com | 2002-06 | |
| Mike Gagle | mikeg&inin.com | 2006-05 | |
| Mitsuo Kodama | kodama&jbmia.or.jp | 2005-06 | |
| Nick Straguzzi | Nick_Straguzzi&akbs.com | ||
| Paul Kraus | paul.kraus&veritas.com | 2002-06 | |
| Pete Wong | petewongµsoft.com | ||
| Peter Aronson | paronson&esri.com | ||
| Ray Caruso | ray.caruso&netvion.com | 2002-06 | |
| Robin Findley | rfindley&usa.net | 2007-05 | |
| Ron Frederick | frederick&parc.xerox.com | ||
| Slawomir Krzesinski | slavek&optiwave.com | ||
| Stephen Misel | steve.misel&interpath.net | ||
| Thaddeus Perala | trperala&emaden.com | ||
| Tim Wilson | tim.wilson&motorola.com | 2003-08 | |
| Toru Murai | murai&saint.nm.fujitsu.co.jp |