Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
nicetec-mgmt 2557 tcp nicetec-mgmt Joerg Paulus Joerg Paulus
nicetec-mgmt 2557 udp nicetec-mgmt Joerg Paulus Joerg Paulus
pclemultimedia 2558 tcp PCLE Multi Media Jacob Gsoedl Jacob Gsoedl
pclemultimedia 2558 udp PCLE Multi Media Jacob Gsoedl Jacob Gsoedl
lstp 2559 tcp LSTP Waiki Wright Waiki Wright
lstp 2559 udp LSTP Waiki Wright Waiki Wright
unglue 2655 tcp UNIX Nt Glue Peter Santoro Peter Santoro
unglue 2655 udp UNIX Nt Glue Peter Santoro Peter Santoro
expresspay 2755 tcp Express Pay Ben Higgins Ben Higgins
expresspay 2755 udp Express Pay Ben Higgins Ben Higgins
msrp 2855 tcp MSRP over TCP 2014-04-09 RFC 4976
2855 udp Reserved 2014-04-09
csnotify 2955 tcp CSNOTIFY Israel Beniaminy Israel Beniaminy
csnotify 2955 udp CSNOTIFY Israel Beniaminy Israel Beniaminy
policyserver 3055 tcp Policy Server Mark Garti Mark Garti
policyserver 3055 udp Policy Server Mark Garti Mark Garti
jpegmpeg 3155 tcp JpegMpeg Port Richard Bassous Richard Bassous
jpegmpeg 3155 udp JpegMpeg Port Richard Bassous Richard Bassous
semaphore 3255 tcp Semaphore Connection Port Jay Eckles Jay Eckles 2002-02
semaphore 3255 udp Semaphore Connection Port Jay Eckles Jay Eckles 2002-02
ordinox-dbase 3355 tcp Ordinox Dbase Denis Ducharme Denis Ducharme
ordinox-dbase 3355 udp Ordinox Dbase Denis Ducharme Denis Ducharme
prsvp 3455 tcp RSVP Port Bob Braden Bob Braden
prsvp 3455 udp RSVP Port Bob Braden Bob Braden
ssmpp 3550 tcp Secure SMPP Cormac Long Cormac Long 2002-07
ssmpp 3550 udp Secure SMPP Cormac Long Cormac Long 2002-07
apcupsd 3551 tcp Apcupsd Information Port Riccardo Facchetti Riccardo Facchetti 2002-07
apcupsd 3551 udp Apcupsd Information Port Riccardo Facchetti Riccardo Facchetti 2002-07
taserver 3552 tcp TeamAgenda Server Port Dany Ayotte Dany Ayotte 2002-07
taserver 3552 udp TeamAgenda Server Port Dany Ayotte Dany Ayotte 2002-07
rbr-discovery 3553 tcp Red Box Recorder ADP Simon Jolly Simon Jolly 2002-07
rbr-discovery 3553 udp Red Box Recorder ADP Simon Jolly Simon Jolly 2002-07
questnotify 3554 tcp Quest Notification Server Rob Griffin Rob Griffin 2002-07
questnotify 3554 udp Quest Notification Server Rob Griffin Rob Griffin 2002-07
razor 3555 tcp Vipul's Razor Vipul Ved Prakash Vipul Ved Prakash 2002-07
razor 3555 udp Vipul's Razor Vipul Ved Prakash Vipul Ved Prakash 2002-07
sky-transport 3556 tcp Sky Transport Protocol Michael Paddon Michael Paddon 2002-07
sky-transport 3556 udp Sky Transport Protocol Michael Paddon Michael Paddon 2002-07
personalos-001 3557 tcp PersonalOS Comm Port Shane Roberts Shane Roberts 2002-07
personalos-001 3557 udp PersonalOS Comm Port Shane Roberts Shane Roberts 2002-07
mcp-port 3558 tcp MCP user port Professor Paul S. Wang Professor Paul S. Wang 2002-07
mcp-port 3558 udp MCP user port Professor Paul S. Wang Professor Paul S. Wang 2002-07
cctv-port 3559 tcp CCTV control port John Skidmore John Skidmore 2002-07
cctv-port 3559 udp CCTV control port John Skidmore John Skidmore 2002-07
tsp 3653 tcp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
tsp 3653 udp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
abatemgr 3655 tcp ActiveBatch Exec Agent
abatemgr 3655 udp ActiveBatch Exec Agent
sas-remote-hlp 3755 tcp SAS Remote Help Server Gary T. Ciampa Gary T. Ciampa 2003-04
sas-remote-hlp 3755 udp SAS Remote Help Server Gary T. Ciampa Gary T. Ciampa 2003-04
opentrac 3855 tcp OpenTRAC Scott Miller Scott Miller 2003-08
opentrac 3855 udp OpenTRAC Scott Miller Scott Miller 2003-08
p2pcommunity 3955 tcp p2pCommunity Tiago Bittencourt Silva Tiago Bittencourt Silva 2005-08
p2pcommunity 3955 udp p2pCommunity Tiago Bittencourt Silva Tiago Bittencourt Silva 2005-08
ccu-comm-3 4055 tcp CosmoCall Universe Communications Port 3 Steve Dellutri Steve Dellutri 2006-07
ccu-comm-3 4055 udp CosmoCall Universe Communications Port 3 Steve Dellutri Steve Dellutri 2006-07
bzr 4155 tcp Bazaar version control system Martin Pool Martin Pool 2007-02
bzr 4155 udp Bazaar version control system Martin Pool Martin Pool 2007-02
dsmipv6 4191 udp Dual Stack MIPv6 NAT Traversal RFC 5555
qsnet-workst 4355 tcp QSNet Workstation
qsnet-workst 4355 udp QSNet Workstation
prchat-user 4455 tcp PR Chat User
prchat-user 4455 udp PR Chat User
gds-adppiw-db 4550 tcp Perman I Interbase Server Leo Lesage Leo Lesage 2006-04
gds-adppiw-db 4550 udp Perman I Interbase Server Leo Lesage Leo Lesage 2006-04
ieee-mih 4551 tcp MIH Services RFC 5677
ieee-mih 4551 udp MIH Services RFC 5677
menandmice-mon 4552 tcp Men and Mice Monitoring Carsten Strotmann Carsten Strotmann 2009-05-20
menandmice-mon 4552 udp Men and Mice Monitoring Carsten Strotmann Carsten Strotmann 2009-05-20
icshostsvc 4553 tcp ICS host services Gordan Vosicki Gordan Vosicki 2009-09-23
4553 udp Reserved
msfrs 4554 tcp MS FRS Replication Kev George Kev George 2006-09
msfrs 4554 udp MS FRS Replication Kev George Kev George 2006-09
rsip 4555 tcp RSIP Port RFC 3103
rsip 4555 udp RSIP Port RFC 3103
dtn-bundle 4556 tcp DTN Bundle TCP CL Protocol IESG IETF Chair 2021-02-22 RFC 9174
dtn-bundle 4556 udp DTN Bundle UDP CL Protocol 2006-11 2014-02-21 RFC 7122
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985
4557 tcp Reserved
mtcevrunqss 4557 udp Marathon everRun Quorum Service Server David Schwartz David Schwartz 2009-06-18
4558 tcp Reserved
mtcevrunqman 4558 udp Marathon everRun Quorum Service Manager David Schwartz David Schwartz 2009-06-18
hylafax 4559 tcp HylaFAX Lee Howard Lee Howard 2002-03
hylafax 4559 udp HylaFAX Lee Howard Lee Howard 2002-03
4755 tcp Reserved
gre-udp-dtls 4755 udp GRE-in-UDP Encapsulation with DTLS IESG IETF Chair 2016-10-05 RFC 8086
avt-profile-1 5004 tcp RTP media data RFC 3551; RFC 4571
avt-profile-1 5004 udp RTP media data RFC 3551
avt-profile-1 5004 dccp RTP media data RFC 3551; RFC 5762
avt-profile-2 5005 tcp RTP control protocol RFC 3551; RFC 4571
avt-profile-2 5005 udp RTP control protocol RFC 3551
avt-profile-2 5005 dccp RTP control protocol RFC 3551; RFC 5762
unot 5055 tcp UNOT Gordon Mohr Gordon Mohr
unot 5055 udp UNOT Gordon Mohr Gordon Mohr
asctrl-agent 5155 tcp Oracle asControl Agent Todd Guay Todd Guay 2005-08
asctrl-agent 5155 udp Oracle asControl Agent Todd Guay Todd Guay 2005-08
snmpssh 5161 tcp SNMP over SSH Transport Model RFC 5592
snmpssh-trap 5162 tcp SNMP Notification over SSH Transport Model RFC 5592 Known Unauthorized Use on port 5162
5255-5263 Unassigned
llmnr 5355 tcp LLMNR Bernard Aboba Bernard Aboba 2004-06
llmnr 5355 udp LLMNR Bernard Aboba Bernard Aboba 2004-06

Contact Information

Name Organization Contact URI Last Updated
Ben Higgins bhiggins&netcom.ca
Bernard Aboba bernarda&microsoft.com 2004-06
Bob Braden Braden&isi.edu
Carsten Strotmann carsten.strotmann&menandmice.com 2009-05-20
Cormac Long webmaster&smsforum.net 2002-07
Dany Ayotte ayotte&teamsoft.com 2002-07
David Schwartz david.schwartz&marathontechnologies.com 2009-06-18
Denis Ducharme dducharme&softek.com
Gary T. Ciampa Gary.Ciampa&sas.com 2003-04
Gordan Vosicki admin&icsa.ch 2009-09-23
Gordon Mohr gmohr&cmgisolutions.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Israel Beniaminy israel.beniaminy&clickservice.com
Jacob Gsoedl jgsoedl&pinnaclesys.com
Jay Eckles ecklesweb&yahoo.com 2002-02
Joerg Paulus tech&nicetec.de
John Skidmore JSkidmore&vicon-cctv.com 2002-07
Kev George Kev.George&smiths-aerospace.com 2006-09
Lee Howard iana&hylafax.org 2002-03
Leo Lesage leo.lesage&adp.nl 2006-04
Marc Blanchet marc.blanchet&viagenie.ca 2003-01
Mark Garti mgarti&sonusnet.com
Martin Pool mbp&canonical.com 2007-02
Michael Paddon michael.paddon&activesky.com 2002-07
Peter Santoro peter&pscomp.com
Professor Paul S. Wang pwang&cs.kent.edu 2002-07
Riccardo Facchetti riccardo&inetcosmos.org 2002-07
Richard Bassous rbassous&yahoo.com
Rob Griffin quest_iana&oz.quest.com 2002-07
Scott Miller scott&opentrac.org 2003-08
Shane Roberts iana&shaneroberts.com 2014-12-18
Simon Jolly simon.jolly&origin-data.co.uk 2002-07
Steve Dellutri sdellutri&cosmocom.com 2006-07
Tiago Bittencourt Silva tiagobs&ufpr.br 2005-08
Todd Guay todd.guay&oracle.com 2005-08
Vipul Ved Prakash mail&vipul.net 2002-07
Waiki Wright waiki&us.ibm.com