Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
blockade-bpsp 2574 udp Blockade BPSP VP - Research & Development VP - Research & Development
hl7 2575 tcp HL7 Tim Jacobs Tim Jacobs
hl7 2575 udp HL7 Tim Jacobs Tim Jacobs
tclprodebugger 2576 tcp TCL Pro Debugger
tclprodebugger 2576 udp TCL Pro Debugger
scipticslsrvr 2577 tcp Scriptics Lsrvr Brent Welch Brent Welch
scipticslsrvr 2577 udp Scriptics Lsrvr Brent Welch Brent Welch
rvs-isdn-dcp 2578 tcp RVS ISDN DCP Michael Zirpel Michael Zirpel
rvs-isdn-dcp 2578 udp RVS ISDN DCP Michael Zirpel Michael Zirpel
mpfoncl 2579 tcp mpfoncl Itaru Kimura Itaru Kimura
mpfoncl 2579 udp mpfoncl Itaru Kimura Itaru Kimura
sns-dispatcher 2657 tcp SNS Dispatcher
sns-dispatcher 2657 udp SNS Dispatcher
cnrp 2757 tcp CNRP Jacob Ulmert Jacob Ulmert
cnrp 2757 udp CNRP Jacob Ulmert Jacob Ulmert
simctlp 2857 tcp SimCtIP Christian Zietz Christian Zietz
simctlp 2857 udp SimCtIP Christian Zietz Christian Zietz
jmact5 2957 tcp JAMCT5
jmact5 2957 udp JAMCT5
goahead-fldup 3057 tcp GoAhead FldUp Alan Pickrell Alan Pickrell
goahead-fldup 3057 udp GoAhead FldUp Alan Pickrell Alan Pickrell
lsa-comm 3157 tcp LSA Communicator Brian Carnell Brian Carnell 2024-03-18
lsa-comm 3157 udp LSA Communicator Brian Carnell Brian Carnell 2024-03-18
cpqrpm-server 3257 tcp Compaq RPM Server Port Royal King Royal King 2002-02
cpqrpm-server 3257 udp Compaq RPM Server Port Royal King Royal King 2002-02
adtech-test 3357 tcp Adtech Test IP Robin Uyeshiro Robin Uyeshiro
adtech-test 3357 udp Adtech Test IP Robin Uyeshiro Robin Uyeshiro
vat-control 3457 tcp VAT default control Van Jacobson Van Jacobson
vat-control 3457 udp VAT default control Van Jacobson Van Jacobson
stun-behavior 3478 tcp STUN Behavior Discovery over TCP RFC 5780
stun-behavior 3478 udp STUN Behavior Discovery over UDP RFC 5780
personalos-001 3557 tcp PersonalOS Comm Port Shane Roberts Shane Roberts 2002-07
personalos-001 3557 udp PersonalOS Comm Port Shane Roberts Shane Roberts 2002-07
mccwebsvr-port 3570 tcp MCC Web Server Port
mccwebsvr-port 3570 udp MCC Web Server Port
megardsvr-port 3571 tcp MegaRAID Server Port
megardsvr-port 3571 udp MegaRAID Server Port
megaregsvrport 3572 tcp Registration Server Port Sreenivas Bagalkote Sreenivas Bagalkote 2002-08
megaregsvrport 3572 udp Registration Server Port Sreenivas Bagalkote Sreenivas Bagalkote 2002-08
tag-ups-1 3573 tcp Advantage Group UPS Suite James Goddard James Goddard 2002-08
tag-ups-1 3573 udp Advantage Group UPS Suite James Goddard James Goddard 2002-08
dmaf-server 3574 tcp DMAF Server
dmaf-caster 3574 udp DMAF Caster Ramakrishna Nadendla Ramakrishna Nadendla 2002-08
ccm-port 3575 tcp Coalsere CCM Port
ccm-port 3575 udp Coalsere CCM Port
cmc-port 3576 tcp Coalsere CMC Port Chris Hawkinson Chris Hawkinson 2002-08
cmc-port 3576 udp Coalsere CMC Port Chris Hawkinson Chris Hawkinson 2002-08
config-port 3577 tcp Configuration Port
config-port 3577 udp Configuration Port
data-port 3578 tcp Data Port Anupam Bharali Anupam Bharali 2002-08
data-port 3578 udp Data Port Anupam Bharali Anupam Bharali 2002-08
ttat3lb 3579 tcp Tarantella Load Balancing Jim Musgrave Jim Musgrave 2002-08
ttat3lb 3579 udp Tarantella Load Balancing Jim Musgrave Jim Musgrave 2002-08
tsp 3653 tcp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
tsp 3653 udp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
immedianet-bcn 3657 tcp ImmediaNet Beacon Bill Homan Bill Homan 2003-01
immedianet-bcn 3657 udp ImmediaNet Beacon Bill Homan Bill Homan 2003-01
grf-port 3757 tcp GRF Server Port Robert Banfill Robert Banfill 2003-04
grf-port 3757 udp GRF Server Port Robert Banfill Robert Banfill 2003-04
radius-dynauth 3799 tcp RADIUS Dynamic Authorization RFC 3576
radius-dynauth 3799 udp RADIUS Dynamic Authorization RFC 3576
trap-port 3857 tcp Trap Port Norm Freedman Norm Freedman 2003-08
trap-port 3857 udp Trap Port Norm Freedman Norm Freedman 2003-08
mqe-broker 3957 tcp MQEnterprise Broker
mqe-broker 3957 udp MQEnterprise Broker
wfm 4057 tcp Servigistics WFM server Yuri Machkasov Yuri Machkasov 2006-08
wfm 4057 udp Servigistics WFM server Yuri Machkasov Yuri Machkasov 2006-08
stat-scanner 4157 tcp STAT Scanner Control
stat-scanner 4157 udp STAT Scanner Control
qsnet-cond 4357 tcp QSNet Conductor
qsnet-cond 4357 udp QSNet Conductor
prRegister 4457 tcp PR Register Donny Gilor Donny Gilor
prRegister 4457 udp PR Register Donny Gilor Donny Gilor
4557 tcp Reserved
mtcevrunqss 4557 udp Marathon everRun Quorum Service Server David Schwartz David Schwartz 2009-06-18
deploymentmap 4570 tcp Service to distribute and update within a site deployment information for Oracle Communications Suite Oracle Corp. Dan Newman 2013-09-20
4570 udp Reserved
4571-4572 Unassigned
cardifftec-back 4573 tcp A port for communication between a server and client for a custom backup system CardiffTec Benjamin Misell 2016-05-19
4573 udp Reserved
4574-4589 Unassigned
4647-4657 Unassigned
4757-4773 Unassigned
avt-profile-1 5004 tcp RTP media data RFC 3551; RFC 4571
avt-profile-1 5004 dccp RTP media data RFC 3551; RFC 5762
avt-profile-2 5005 tcp RTP control protocol RFC 3551; RFC 4571
avt-profile-2 5005 dccp RTP control protocol RFC 3551; RFC 5762
intecom-ps2 5057 tcp Intecom Pointspan 2 David Meermans David Meermans
intecom-ps2 5057 udp Intecom Pointspan 2 David Meermans David Meermans
mediat 5157 tcp Mediat Remote Object Exchange Oliver Anan Oliver Anan 2010-09-02
5157 udp Reserved
stun-behaviors 5349 tcp STUN Behavior Discovery over TLS RFC 5780
stun-behaviors 5349 udp Reserved for a future enhancement of STUN-BEHAVIOR RFC 5780
wsdapi 5357 tcp Web Services for Devices Henry Rawas Henry Rawas 2005-08
wsdapi 5357 udp Web Services for Devices Henry Rawas Henry Rawas 2005-08
5457-5460 Unassigned
farenet 5557 tcp Sandlab FARENET Kay T. Labinsky Kay T. Labinsky 2010-05-03
5557 udp Reserved
5570-5572 Unassigned Known UNAUTHORIZED USE on Port 5570
sdmmp 5573 tcp SAS Domain Management Messaging Protocol Ron Zuckerman Ron Zuckerman 2007-08-30
sdmmp 5573 udp SAS Domain Management Messaging Protocol Ron Zuckerman Ron Zuckerman 2007-08-30

Contact Information

Name Organization Contact URI Last Updated
Alan Pickrell alanp&goahead.com
Anupam Bharali ianaports&juniper.net 2002-08
Benjamin Misell beninjam174&gmail.com 2016-05-19
Bill Homan bhoman&spanworks.com 2003-01
VP - Research & Development development&blockade.com
Brent Welch welch&scriptics.com
Brian Carnell brian&carnellcrew.com 2024-03-18
CardiffTec beninjam174&gmail.com 2016-05-19
Chris Hawkinson chawkinson&coalsere.com 2002-08
Christian Zietz czietz&gmx.net
Dan Newman Oracle Corp. dan.c.newman&oracle.com 2013-09-20
David Meermans david.meermans&aastra.com
David Schwartz david.schwartz&marathontechnologies.com 2009-06-18
Donny Gilor dgilor&pop01.ny.us.ibm.net
Henry Rawas henryr&microsoft.com 2005-08
Itaru Kimura kimura&kel.fujitsu.co.jp
Jacob Ulmert Jacob.Ulmert&se.abb.com
James Goddard jamesg&taglim.com 2005-08
Jim Musgrave jimm&tarantella.com 2002-08
Kay T. Labinsky Kay.Labinsky&sandlab.de 2010-05-03
Marc Blanchet marc.blanchet&viagenie.ca 2003-01
Michael Zirpel mbz&rvscom.com
Norm Freedman normfree&san.rr.com 2003-08
Oliver Anan oliver&ananit.de 2010-09-02
Oracle Corp. dan.c.newman&oracle.com 2013-09-20
Ramakrishna Nadendla rama_nadendla&agilent.com 2002-08
Robert Banfill robert&banfill.net 2003-04
Robin Uyeshiro robin_u&adtech-inc.com
Ron Zuckerman ron.zuckerman&lsi.com 2007-08-30
Royal King royal.king&compaq.com 2002-02
Shane Roberts iana&shaneroberts.com 2014-12-18
Sreenivas Bagalkote sreenib&lsil.com 2002-08
Tim Jacobs
Van Jacobson van&ee.lbl.gov
Yuri Machkasov ymachkasov&servigistics.com 2006-08