Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cyaserv 2584 udp cyaserv Morgan Jones Morgan Jones
netx-server 2585 tcp NETX Server
netx-server 2585 udp NETX Server
netx-agent 2586 tcp NETX Agent Brett Dolecheck Brett Dolecheck
netx-agent 2586 udp NETX Agent Brett Dolecheck Brett Dolecheck
masc 2587 tcp MASC Pavlin Ivanov Radoslavov Pavlin Ivanov Radoslavov
masc 2587 udp MASC Pavlin Ivanov Radoslavov Pavlin Ivanov Radoslavov
privilege 2588 tcp Privilege Gil Hecht Gil Hecht
privilege 2588 udp Privilege Gil Hecht Gil Hecht
quartus-tcl 2589 tcp quartus tcl Subroto Datta Subroto Datta
quartus-tcl 2589 udp quartus tcl Subroto Datta Subroto Datta
sns-admin 2658 tcp SNS Admin
sns-admin 2658 udp SNS Admin
apollo-status 2758 tcp APOLLO Status
apollo-status 2758 udp APOLLO Status
ecnp 2858 tcp ECNP Robert Reimiller Robert Reimiller
ecnp 2858 udp ECNP Robert Reimiller Robert Reimiller
jmact6 2958 tcp JAMCT6
jmact6 2958 udp JAMCT6
videobeans 3058 tcp videobeans Hiroyuki Takahashi Hiroyuki Takahashi
videobeans 3058 udp videobeans Hiroyuki Takahashi Hiroyuki Takahashi
stvp 3158 tcp SmashTV Protocol Christian Wolff Christian Wolff
stvp 3158 udp SmashTV Protocol Christian Wolff Christian Wolff
ivecon-port 3258 tcp Ivecon Server Port Serguei Tevs Serguei Tevs 2002-02
ivecon-port 3258 udp Ivecon Server Port Serguei Tevs Serguei Tevs 2002-02
mpsysrmsvr 3358 tcp Mp Sys Rmsvr Hiroyuki Kawabuchi Hiroyuki Kawabuchi
mpsysrmsvr 3358 udp Mp Sys Rmsvr Hiroyuki Kawabuchi Hiroyuki Kawabuchi
d3winosfi 3458 tcp D3WinOSFI Brad Hamilton Brad Hamilton
d3winosfi 3458 udp D3WinOSFI Brad Hamilton Brad Hamilton
mcp-port 3558 tcp MCP user port Professor Paul S. Wang Professor Paul S. Wang 2002-07
mcp-port 3558 udp MCP user port Professor Paul S. Wang Professor Paul S. Wang 2002-07
nati-svrloc 3580 tcp NATI-ServiceLocator Jason Case Jason Case 2002-08
nati-svrloc 3580 udp NATI-ServiceLocator Jason Case Jason Case 2002-08
kfxaclicensing 3581 tcp Ascent Capture Licensing Brad Hamilton Brad Hamilton 2002-08
kfxaclicensing 3581 udp Ascent Capture Licensing Brad Hamilton Brad Hamilton 2002-08
press 3582 tcp PEG PRESS Server Jim DeLisle Jim DeLisle 2002-08
press 3582 udp PEG PRESS Server Jim DeLisle Jim DeLisle 2002-08
canex-watch 3583 tcp CANEX Watch System Peter Kollath Peter Kollath 2002-08
canex-watch 3583 udp CANEX Watch System Peter Kollath Peter Kollath 2002-08
u-dbap 3584 tcp U-DBase Access Protocol Bodo Rueskamp Bodo Rueskamp 2002-08
u-dbap 3584 udp U-DBase Access Protocol Bodo Rueskamp Bodo Rueskamp 2002-08
emprise-lls 3585 tcp Emprise License Server
emprise-lls 3585 udp Emprise License Server
emprise-lsc 3586 tcp License Server Console James J. Diaz James J. Diaz 2002-08
emprise-lsc 3586 udp License Server Console James J. Diaz James J. Diaz 2002-08
p2pgroup 3587 tcp Peer to Peer Grouping Igor Kostic Igor Kostic 2002-08
p2pgroup 3587 udp Peer to Peer Grouping Igor Kostic Igor Kostic 2002-08
sentinel 3588 tcp Sentinel Server Ian Gordon Ian Gordon 2002-08
sentinel 3588 udp Sentinel Server Ian Gordon Ian Gordon 2002-08
isomair 3589 tcp isomair Richard Fleming Richard Fleming 2002-08
isomair 3589 udp isomair Richard Fleming Richard Fleming 2002-08
ps-ams 3658 tcp PlayStation AMS (Secure) Edgar Alan Tu Edgar Alan Tu 2003-01
ps-ams 3658 udp PlayStation AMS (Secure) Edgar Alan Tu Edgar Alan Tu 2003-01
apw-registry 3758 tcp apw RMI registry Dan Davis Dan Davis 2003-04
apw-registry 3758 udp apw RMI registry Dan Davis Dan Davis 2003-04
bfd-control 3784 tcp BFD Control Protocol RFC 5881
bfd-control 3784 udp BFD Control Protocol RFC 5881
bfd-echo 3785 tcp BFD Echo Protocol RFC 5881
bfd-echo 3785 udp BFD Echo Protocol RFC 5881
trap-port-mom 3858 tcp Trap Port MOM Norm Freedman Norm Freedman 2003-08
trap-port-mom 3858 udp Trap Port MOM Norm Freedman Norm Freedman 2003-08
diameter 3868 sctp DIAMETER RFC 3588
mqe-agent 3958 tcp MQEnterprise Agent Bob Lauria Bob Lauria 2005-08
mqe-agent 3958 udp MQEnterprise Agent Bob Lauria Bob Lauria 2005-08
kingfisher 4058 tcp Kingfisher protocol Vaughan Wesson Vaughan Wesson 2006-10
kingfisher 4058 udp Kingfisher protocol Vaughan Wesson Vaughan Wesson 2006-10
stat-cc 4158 tcp STAT Command Center Darwin Ammala Darwin Ammala 2007-03
stat-cc 4158 udp STAT Command Center Darwin Ammala Darwin Ammala 2007-03
4190 udp Reserved RFC 5804
qsnet-nucl 4358 tcp QSNet Nucleus Neer Kleinman Neer Kleinman
qsnet-nucl 4358 udp QSNet Nucleus Neer Kleinman Neer Kleinman
mcp 4458 tcp Matrix Configuration Protocol Tim DeBaillie Tim DeBaillie 2006-12
mcp 4458 udp Matrix Configuration Protocol Tim DeBaillie Tim DeBaillie 2006-12
4558 tcp Reserved
mtcevrunqman 4558 udp Marathon everRun Quorum Service Manager David Schwartz David Schwartz 2009-06-18
4574-4589 Unassigned
playsta2-app 4658 tcp PlayStation2 App Port
playsta2-app 4658 udp PlayStation2 App Port
5058 tcp Reserved
locus-disc 5058 udp Locus Discovery Alan King Alan King 2009-08-13
5158-5160 Unassigned
wsdapi-s 5358 tcp WS for Devices Secured Henry Rawas Henry Rawas 2005-08
wsdapi-s 5358 udp WS for Devices Secured Henry Rawas Henry Rawas 2005-08
pmip6-cntl 5436 udp pmip6-cntl RFC 5844
pmip6-data 5437 udp pmip6-data RFC 5844
5558-5564 Unassigned
tmosms0 5580 tcp T-Mobile SMS Protocol Message 0 Ezinne Oji Ezinne Oji 2006-06
tmosms0 5580 udp T-Mobile SMS Protocol Message 0 Ezinne Oji Ezinne Oji 2006-06
tmosms1 5581 tcp T-Mobile SMS Protocol Message 1 Ezinne Oji Ezinne Oji 2006-06
tmosms1 5581 udp T-Mobile SMS Protocol Message 1 Ezinne Oji Ezinne Oji 2006-06
fac-restore 5582 tcp T-Mobile SMS Protocol Message 3 Jessica Yan Jessica Yan 2008-02-19
fac-restore 5582 udp T-Mobile SMS Protocol Message 3 Jessica Yan Jessica Yan 2008-02-19
tmo-icon-sync 5583 tcp T-Mobile SMS Protocol Message 2 Donghwan Lim Donghwan Lim 2008-01-22
tmo-icon-sync 5583 udp T-Mobile SMS Protocol Message 2 Donghwan Lim Donghwan Lim 2008-01-22
bis-web 5584 tcp BeInSync-Web Adi Ruppin Adi Ruppin 2005-08
bis-web 5584 udp BeInSync-Web Adi Ruppin Adi Ruppin 2005-08
bis-sync 5585 tcp BeInSync-sync Adi Ruppin Adi Ruppin 2005-08
bis-sync 5585 udp BeInSync-sync Adi Ruppin Adi Ruppin 2005-08
att-mt-sms 5586 tcp Planning to send mobile terminated SMS to the specific port so that the SMS is not visible to the client AT&T Dhillesh Sigilipelli 2014-08-21
5586 udp Reserved
5587-5596 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Adi Ruppin adi.ruppin&data-pod.com 2005-08
Alan King Enabling Technology Pty. Ltd. aking&etdesigners.com 2009-08-13
AT&T ds978v&att.com 2014-08-21
Bob Lauria bob.lauria&asg.com 2005-08
Bodo Rueskamp iana+spam&pinda.de 2020-06-04
Brad Hamilton bh&picksys.com
Brad Hamilton brad_hamilton&kofax.com 2002-08
Brett Dolecheck Dolecheck&ipmetrics.com
Christian Wolff stvp&smash.tv
Dan Davis Dan.A.Davis&hp.com 2003-04
Darwin Ammala dammala&harris.com 2007-03
David Schwartz david.schwartz&marathontechnologies.com 2009-06-18
Dhillesh Sigilipelli AT&T ds978v&att.com 2014-08-21
Donghwan Lim donghwan.lim&t-mobile.com 2008-01-22
Edgar Alan Tu Edgar_Tu&playstation.sony.com 2003-01
Ezinne Oji ezinne.oji&t-mobile.com 2006-06
Gil Hecht GilH&aks.com
Henry Rawas henryr&microsoft.com 2005-08
Hiroyuki Kawabuchi buchi&ael.fujitsu.co.jp
Hiroyuki Takahashi hiro.takahashi&eng.sun.com
Ian Gordon ian.s.gordon&btopenworld.com 2002-08
Igor Kostic igorko&microsoft.com 2002-08
James J. Diaz JDiaz&emprisecorporation.com 2002-08
Jason Case jason.case&ni.com 2002-08
Jessica Yan jessica.yan2&t-mobile.com 2008-02-19
Jim DeLisle jdelisle&swellsoftware.com 2002-08
Morgan Jones mwj&cyasolutions.com
Neer Kleinman neer&qsr.co.il
Norm Freedman normfree&san.rr.com 2003-08
Pavlin Ivanov Radoslavov pavlin&catarina.usc.edu
Peter Kollath peter.kollath&canex.sk 2002-08
Professor Paul S. Wang pwang&cs.kent.edu 2002-07
Richard Fleming richard&apoapsis.com 2002-08
Robert Reimiller bob&certsoft.com
Serguei Tevs STevs&ivecon.com 2002-02
Subroto Datta subrotod&altera.com
Tim DeBaillie debaillie&ciholas.com 2006-12
Vaughan Wesson vaughanw&rtunet.com 2006-10