Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
225-241 Reserved 2024-12-20 RFC 1060
dsp3270 246 tcp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
dsp3270 246 udp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
249-255 Reserved 2024-12-20 RFC 1060
rap 256 tcp RAP J. S. Greenfield J. S. Greenfield
rap 256 udp RAP J. S. Greenfield J. S. Greenfield
openport 260 tcp Openport John Marland John Marland
openport 260 udp Openport John Marland John Marland
nsiiops 261 tcp IIOP Name Service over TLS/SSL Jeff Stewart Jeff Stewart
nsiiops 261 udp IIOP Name Service over TLS/SSL Jeff Stewart Jeff Stewart
arcisdms 262 tcp Arcisdms Russell Crook Russell Crook
arcisdms 262 udp Arcisdms Russell Crook Russell Crook
hdap 263 tcp HDAP Troy Gau Troy Gau
hdap 263 udp HDAP Troy Gau Troy Gau
bgmp 264 tcp BGMP Dave Thaler Dave Thaler
bgmp 264 udp BGMP Dave Thaler Dave Thaler
x-bone-ctl 265 tcp X-Bone CTL Joe Touch Joe Touch
x-bone-ctl 265 udp X-Bone CTL Joe Touch Joe Touch
sst 266 tcp SCSI on ST Donald D. Woelz Donald D. Woelz
sst 266 udp SCSI on ST Donald D. Woelz Donald D. Woelz
td-service 267 tcp Tobit David Service Layer
td-service 267 udp Tobit David Service Layer
td-replica 268 tcp Tobit David Replica Franz-Josef Leuders Franz-Josef Leuders
td-replica 268 udp Tobit David Replica Franz-Josef Leuders Franz-Josef Leuders
manet 269 tcp MANET Protocols RFC 5498
manet 269 udp MANET Protocols RFC 5498
pt-tls 271 tcp IETF Network Endpoint Assessment (NEA) Posture Transport Protocol over TLS (PT-TLS) IESG IETF Chair 2012-07-31 RFC 6876
fxp 286 tcp FXP Communication James Darnall James Darnall
fxp 286 udp FXP Communication James Darnall James Darnall
decauth 316 tcp decAuth Michael Agishtein Michael Agishtein
decauth 316 udp decAuth Michael Agishtein Michael Agishtein
rpki-rtr 323 tcp Resource PKI to Router Protocol IESG IETF Chair RFC 6810
rpki-rtr-tls 324 tcp Resource PKI to Router Protocol over TLS IESG IETF Chair RFC 6810
zserv 346 tcp Zebra server
zserv 346 udp Zebra server
bh611 354 tcp bh611 John Kelly John Kelly
bh611 354 udp bh611 John Kelly John Kelly
cloanto-net-1 356 tcp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
cloanto-net-1 356 udp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
scoi2odialog 360 tcp scoi2odialog Keith Petley Keith Petley
scoi2odialog 360 udp scoi2odialog Keith Petley Keith Petley
semantix 361 tcp Semantix Semantix Semantix
semantix 361 udp Semantix Semantix Semantix
srssend 362 tcp SRS Send Curt Mayer Curt Mayer
srssend 362 udp SRS Send Curt Mayer Curt Mayer
rsvp-tunnel 363 tcp RSVP Tunnel

IANA assigned this well-formed service name as a replacement for "rsvp_tunnel".
Andreas Terzis Andreas Terzis
rsvp_tunnel 363 tcp RSVP Tunnel Andreas Terzis Andreas Terzis This entry is an alias to "rsvp-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
rsvp-tunnel 363 udp RSVP Tunnel

IANA assigned this well-formed service name as a replacement for "rsvp_tunnel".
Andreas Terzis Andreas Terzis
rsvp_tunnel 363 udp RSVP Tunnel Andreas Terzis Andreas Terzis This entry is an alias to "rsvp-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
aurora-cmgr 364 tcp Aurora CMGR Philip Budne Philip Budne
aurora-cmgr 364 udp Aurora CMGR Philip Budne Philip Budne
dtk 365 tcp DTK Fred Cohen Fred Cohen
dtk 365 udp DTK Fred Cohen Fred Cohen
odmr 366 tcp ODMR Randall Gellens Randall Gellens
odmr 366 udp ODMR Randall Gellens Randall Gellens
mortgageware 367 tcp MortgageWare Ole Hellevik Ole Hellevik
mortgageware 367 udp MortgageWare Ole Hellevik Ole Hellevik
qbikgdp 368 tcp QbikGDP Adrien de Croy Adrien de Croy
qbikgdp 368 udp QbikGDP Adrien de Croy Adrien de Croy
rpc2portmap 369 tcp rpc2portmap
rpc2portmap 369 udp rpc2portmap
nip 376 tcp Amiga Envoy Network Inquiry Protocol Heinz Wrobel Heinz Wrobel 2020-10-02
nip 376 udp Amiga Envoy Network Inquiry Protocol Heinz Wrobel Heinz Wrobel 2020-10-02
asa 386 tcp ASA Message Router Object Def. Steve Laitinen Steve Laitinen
asa 386 udp ASA Message Router Object Def. Steve Laitinen Steve Laitinen
netware-ip 396 tcp Novell Netware over IP
netware-ip 396 udp Novell Netware over IP
imsp 406 tcp Interactive Mail Support Protocol John Myers John Myers
imsp 406 udp Interactive Mail Support Protocol John Myers John Myers
silverplatter 416 tcp Silverplatter Peter Ciuffetti Peter Ciuffetti
silverplatter 416 udp Silverplatter Peter Ciuffetti Peter Ciuffetti
smartsdp 426 tcp smartsdp Marie-Pierre Belanger Marie-Pierre Belanger
smartsdp 426 udp smartsdp Marie-Pierre Belanger Marie-Pierre Belanger
dna-cml 436 tcp DNA-CML Dan Flowers Dan Flowers
dna-cml 436 udp DNA-CML Dan Flowers Dan Flowers
https 443 sctp HTTPS Randall Stewart Randall Stewart 2022-02-07 RFC 9260
snpp 444 tcp Simple Network Paging Protocol RFC 1568
snpp 444 udp Simple Network Paging Protocol RFC 1568
ddm-rdb 446 tcp DDM-Remote Relational Database Access
ddm-rdb 446 udp DDM-Remote Relational Database Access
macon-tcp 456 tcp macon-tcp Yoshinobu Inoue Yoshinobu Inoue
macon-udp 456 udp macon-udp Yoshinobu Inoue Yoshinobu Inoue
skronk 460 tcp skronk Henry Strickland Henry Strickland
skronk 460 udp skronk Henry Strickland Henry Strickland
datasurfsrv 461 tcp DataRampSrv
datasurfsrv 461 udp DataRampSrv
datasurfsrvsec 462 tcp DataRampSrvSec Diane Downie Diane Downie
datasurfsrvsec 462 udp DataRampSrvSec Diane Downie Diane Downie
alpes 463 tcp alpes Alain Durand Alain Durand
alpes 463 udp alpes Alain Durand Alain Durand
kpasswd 464 tcp kpasswd Greg Hudson Greg Hudson 2023-11-17
kpasswd 464 udp kpasswd Greg Hudson Greg Hudson 2023-11-17
urd 465 tcp URL Rendezvous Directory for SSM Toerless Eckert Toerless Eckert
submissions 465 tcp Message Submission over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
igmpv3lite 465 udp IGMP over UDP for SSM Toerless Eckert Toerless Eckert
digital-vrc 466 tcp digital-vrc Peter Higginson Peter Higginson
digital-vrc 466 udp digital-vrc Peter Higginson Peter Higginson
mylex-mapd 467 tcp mylex-mapd Gary Lewis Gary Lewis
mylex-mapd 467 udp mylex-mapd Gary Lewis Gary Lewis

Contact Information

Name Organization Contact URI Last Updated
Adrien de Croy adrien&qbik.com
Alain Durand Alain.Durand&imag.fr
Andreas Terzis terzis&cs.ucla.edu
Curt Mayer curt&emergent.com
Dan Flowers flowers&smaug.lkg.dec.com
Dave Thaler dave.thaler.ietf&gmail.com 2024-07-23
Diane Downie downie&jibe.mv.com
Donald D. Woelz don&genroco.com
Franz-Josef Leuders development&tobit.com
Fred Cohen fc&all.net
Gary Lewis GaryL&hq.mylex.com
Greg Hudson ghudson&mit.edu 2023-11-17
Heinz Wrobel hwrobel&gmx.de
Henry Strickland strick&yak.net
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J. S. Greenfield greeny&raleigh.ibm.com
James Darnall james_r_darnall&sbcglobal.net
Jeff Stewart jstewart&netscape.com
Joe Touch touch&strayalpha.com 2020-02-07
John Kelly johnk&bellhow.com
John Marland jmarland&dean.openport.com
John Myers jgm+&cmu.edu
Keith Petley keithp&sco.com
Marie-Pierre Belanger belanger_marie&emc.com
Michael Agishtein misha&unx.dec.com
Michael Battilana mcb-iana&cloanto.net 2010-04-30
Ole Hellevik oleh&interlinq.com
Peter Ciuffetti petec&silverplatter.com
Peter Higginson higginson&mail.dec.com
Philip Budne budne&auroratech.com
Randall Gellens rg+ietf&coretechnologyconsulting.com 2024-07-29
Randall Stewart IETF TSVWG rrs&lakerest.net
Russell Crook rmc&sni.ca
Semantix xsSupport&semantix.com
Steve Laitinen laitinen&brutus.aa.ab.com
Toerless Eckert eckert&cisco.com
Troy Gau troy&zyxel.com
Weldon J. Showalter Gamma&mintaka.dca.mil
Yoshinobu Inoue