Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| icg-bridge | 2063 | udp | ICG Bridge Port | ||||||||
| navisphere-sec | 2163 | tcp | Navisphere Secure | Andreas Bauer | Andreas Bauer | ||||||
| navisphere-sec | 2163 | udp | Navisphere Secure | Andreas Bauer | Andreas Bauer | ||||||
| ecwcfg | 2263 | tcp | ECweb Configuration Service | Anders Hjelm | Anders Hjelm | 2006-03 | |||||
| ecwcfg | 2263 | udp | ECweb Configuration Service | Anders Hjelm | Anders Hjelm | 2006-03 | |||||
| mediacntrlnfsd | 2363 | tcp | Media Central NFSD | Shivakumar S. Govindarajapuram | Shivakumar S. Govindarajapuram | ||||||
| mediacntrlnfsd | 2363 | udp | Media Central NFSD | Shivakumar S. Govindarajapuram | Shivakumar S. Govindarajapuram | ||||||
| lsi-raid-mgmt | 2463 | tcp | LSI RAID Management | NetApp, Inc. | MSW architecture team | 2014-07-18 | |||||
| lsi-raid-mgmt | 2463 | udp | LSI RAID Management | NetApp, Inc. | MSW architecture team | 2014-07-18 | |||||
| cti-redwood | 2563 | tcp | CTI Redwood | Songwon Chi | Songwon Chi | ||||||
| cti-redwood | 2563 | udp | CTI Redwood | Songwon Chi | Songwon Chi | ||||||
| sitaramgmt | 2630 | tcp | Sitara Management | ||||||||
| sitaramgmt | 2630 | udp | Sitara Management | ||||||||
| sitaradir | 2631 | tcp | Sitara Dir | Manickam R.Sridhar | Manickam R.Sridhar | ||||||
| sitaradir | 2631 | udp | Sitara Dir | Manickam R.Sridhar | Manickam R.Sridhar | ||||||
| irdg-post | 2632 | tcp | IRdg Post | IRdg, Inc. | IRdg, Inc. | ||||||
| irdg-post | 2632 | udp | IRdg Post | IRdg, Inc. | IRdg, Inc. | ||||||
| interintelli | 2633 | tcp | InterIntelli | Mike Gagle | Mike Gagle | ||||||
| interintelli | 2633 | udp | InterIntelli | Mike Gagle | Mike Gagle | ||||||
| pk-electronics | 2634 | tcp | PK Electronics | Seb Ibis | Seb Ibis | ||||||
| pk-electronics | 2634 | udp | PK Electronics | Seb Ibis | Seb Ibis | ||||||
| backburner | 2635 | tcp | Back Burner | Kevin Teiskoetter | Kevin Teiskoetter | ||||||
| backburner | 2635 | udp | Back Burner | Kevin Teiskoetter | Kevin Teiskoetter | ||||||
| solve | 2636 | tcp | Solve | Peter Morrison | Peter Morrison | ||||||
| solve | 2636 | udp | Solve | Peter Morrison | Peter Morrison | ||||||
| imdocsvc | 2637 | tcp | Import Document Service | Zia Bhatti | Zia Bhatti | ||||||
| imdocsvc | 2637 | udp | Import Document Service | Zia Bhatti | Zia Bhatti | ||||||
| sybaseanywhere | 2638 | tcp | Sybase Anywhere | SAP | Jason Noack | 2021-12-03 | |||||
| sybaseanywhere | 2638 | udp | Sybase Anywhere | SAP | Jason Noack | 2021-12-03 | |||||
| aminet | 2639 | tcp | AMInet | Alcorn McBride Inc. | Alcorn McBride Inc. | ||||||
| aminet | 2639 | udp | AMInet | Alcorn McBride Inc. | Alcorn McBride Inc. | ||||||
| bintec-tapi | 2663 | tcp | BinTec-TAPI | ||||||||
| bintec-tapi | 2663 | udp | BinTec-TAPI | ||||||||
| desktop-dna | 2763 | tcp | Desktop DNA | Jon Walker | Jon Walker | ||||||
| desktop-dna | 2763 | udp | Desktop DNA | Jon Walker | Jon Walker | ||||||
| sonardata | 2863 | tcp | Sonar Data | Ian Higginbottom | Ian Higginbottom | ||||||
| sonardata | 2863 | udp | Sonar Data | Ian Higginbottom | Ian Higginbottom | ||||||
| iph-policy-adm | 2963 | tcp | IPH-POLICY-ADM | Shai Herzog | Shai Herzog | ||||||
| iph-policy-adm | 2963 | udp | IPH-POLICY-ADM | Shai Herzog | Shai Herzog | ||||||
| h263-video | 2979 | tcp | H.263 Video Streaming | Jauvane C. de Oliveira | Jauvane C. de Oliveira | ||||||
| h263-video | 2979 | udp | H.263 Video Streaming | Jauvane C. de Oliveira | Jauvane C. de Oliveira | ||||||
| ncadg-ip-udp | 3063 | tcp | ncadg-ip-udp | Gabi Kalmar | Gabi Kalmar | ||||||
| ncadg-ip-udp | 3063 | udp | ncadg-ip-udp | Gabi Kalmar | Gabi Kalmar | ||||||
| res-sap | 3163 | tcp | RES-SAP | Bob Janssen | Bob Janssen | ||||||
| res-sap | 3163 | udp | RES-SAP | Bob Janssen | Bob Janssen | ||||||
| ecolor-imager | 3263 | tcp | E-Color Enterprise Imager | Tamara Baker | Tamara Baker | ||||||
| ecolor-imager | 3263 | udp | E-Color Enterprise Imager | Tamara Baker | Tamara Baker | ||||||
| nati-vi-server | 3363 | tcp | NATI Vi Server | National Instruments | Jeff Peters | ||||||
| nati-vi-server | 3363 | udp | NATI Vi Server | National Instruments | Jeff Peters | ||||||
| edm-adm-notify | 3463 | tcp | EDM ADM Notify | ||||||||
| edm-adm-notify | 3463 | udp | EDM ADM Notify | ||||||||
| watcomdebug | 3563 | tcp | Watcom Debug | Dave Neudoerffer | Dave Neudoerffer | ||||||
| watcomdebug | 3563 | udp | Watcom Debug | Dave Neudoerffer | Dave Neudoerffer | ||||||
| cs-remote-db | 3630 | tcp | C&S Remote Database Port | ||||||||
| cs-remote-db | 3630 | udp | C&S Remote Database Port | ||||||||
| cs-services | 3631 | tcp | C&S Web Services Port | Computer Software GmbH | Computer Software GmbH | 2002-10 | |||||
| cs-services | 3631 | udp | C&S Web Services Port | Computer Software GmbH | Computer Software GmbH | 2002-10 | |||||
| distcc | 3632 | tcp | distributed compiler | Martin Pool | Martin Pool | 2002-11 | Defined TXT keys: None | ||||
| distcc | 3632 | udp | distributed compiler | Martin Pool | Martin Pool | 2002-11 | Defined TXT keys: None | ||||
| wacp | 3633 | tcp | Wyrnix AIS port | Harry T. Vennik | Harry T. Vennik | 2002-11 | |||||
| wacp | 3633 | udp | Wyrnix AIS port | Harry T. Vennik | Harry T. Vennik | 2002-11 | |||||
| hlibmgr | 3634 | tcp | hNTSP Library Manager | Kenji Tetsuyama | Kenji Tetsuyama | 2002-11 | |||||
| hlibmgr | 3634 | udp | hNTSP Library Manager | Kenji Tetsuyama | Kenji Tetsuyama | 2002-11 | |||||
| sdo | 3635 | tcp | Simple Distributed Objects | Alexander Philippou | Alexander Philippou | 2002-11 | |||||
| sdo | 3635 | udp | Simple Distributed Objects | Alexander Philippou | Alexander Philippou | 2002-11 | |||||
| servistaitsm | 3636 | tcp | SerVistaITSM | Ralph Campbell | Ralph Campbell | 2002-11 | |||||
| servistaitsm | 3636 | udp | SerVistaITSM | Ralph Campbell | Ralph Campbell | 2002-11 | |||||
| scservp | 3637 | tcp | Customer Service Port | Jonathan A. Zdziarski | Jonathan A. Zdziarski | 2002-11 | |||||
| scservp | 3637 | udp | Customer Service Port | Jonathan A. Zdziarski | Jonathan A. Zdziarski | 2002-11 | |||||
| ehp-backup | 3638 | tcp | EHP Backup Protocol | Ed Fair | Ed Fair | 2002-11 | |||||
| ehp-backup | 3638 | udp | EHP Backup Protocol | Ed Fair | Ed Fair | 2002-11 | |||||
| xap-ha | 3639 | tcp | Extensible Automation | Mark Harrison | Mark Harrison | 2002-11 | |||||
| xap-ha | 3639 | udp | Extensible Automation | Mark Harrison | Mark Harrison | 2002-11 | |||||
| dtp | 3663 | tcp | DIRECWAY Tunnel Protocol | John Border | John Border | 2003-01 | |||||
| dtp | 3663 | udp | DIRECWAY Tunnel Protocol | John Border | John Border | 2003-01 | |||||
| xo-wave | 3763 | tcp | XO Wave Control Port | Bjorn Dittmer-Roche | Bjorn Dittmer-Roche | 2003-06 | |||||
| xo-wave | 3763 | udp | XO Wave Control Port | Bjorn Dittmer-Roche | Bjorn Dittmer-Roche | 2003-06 | |||||
| asap-tcp | 3863 | tcp | asap tcp port | ||||||||
| asap-udp | 3863 | udp | asap udp port | RFC 5352 | |||||||
| asap-sctp | 3863 | sctp | asap sctp | RFC 5352 | |||||||
| thrp | 3963 | tcp | Teran Hybrid Routing Protocol | Spencer Teran | Spencer Teran | 2005-08 | |||||
| thrp | 3963 | udp | Teran Hybrid Routing Protocol | Spencer Teran | Spencer Teran | 2005-08 | |||||
| ice-router | 4063 | tcp | Ice Firewall Traversal Service (TCP) | ||||||||
| ice-router | 4063 | udp | Ice Firewall Traversal Service (TCP) | ||||||||
| silverpeakpeer | 4163 | tcp | Silver Peak Peer Protocol | Damon Ennis | Damon Ennis | 2007-03 | |||||
| silverpeakpeer | 4163 | udp | Silver Peak Peer Protocol | Damon Ennis | Damon Ennis | 2007-03 | |||||
| 4363-4365 | Unassigned | ||||||||||
| amahi-anywhere | 4563 | tcp | Amahi Anywhere | Amahi | Carlos Puchol | 2014-02-27 | |||||
| 4563 | udp | Reserved | |||||||||
| noteit | 4663 | tcp | Note It! Message Service | Pedro Alpedrinha | Pedro Alpedrinha | 2006-02 | |||||
| noteit | 4663 | udp | Note It! Message Service | Pedro Alpedrinha | Pedro Alpedrinha | 2006-02 | |||||
| sip | 5060 | tcp | SIP | 2014-04-09 | RFC 3263 | ||||||
| sip | 5060 | udp | SIP | 2014-04-09 | RFC 3263 | ||||||
| sips | 5061 | tcp | SIP-TLS | 2014-04-09 | RFC 3263 | ||||||
| sips | 5061 | udp | SIP-TLS | 2014-04-09 | RFC 3263 | ||||||
| csrpc | 5063 | tcp | centrify secure RPC | Paul Moore | Paul Moore | 2009-10-28 | |||||
| 5063 | udp | Reserved | |||||||||
| sbackup | 5163 | tcp | Shadow Backup | Glenn Allen | Glenn Allen | 2009-08-05 | |||||
| 5163 | udp | Reserved | |||||||||
| 5255-5263 | Unassigned | ||||||||||
| net-projection | 5363 | tcp | Windows Network Projection | Rob Williams | Rob Williams | 2009-02-17 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alcorn McBride Inc. | support&alcorn.com | ||
| Alexander Philippou | alex&noemax.com | 2003-10 | |
| Amahi | iana&amahi.org | 2014-02-27 | |
| Anders Hjelm | anders.hjelm&ec.se | 2006-03 | |
| Andreas Bauer | bauer_andreas&emc.com | ||
| Bjorn Dittmer-Roche | bjorn&xowave.com | 2003-06 | |
| Bob Janssen | bob&res.nl | ||
| Carlos Puchol | Amahi | iana&amahi.org | 2014-02-27 |
| Computer Software GmbH | BrunoRistok&cs-ag.de | 2002-10 | |
| Damon Ennis | damon&silver-peak.com | 2007-03 | |
| Dave Neudoerffer | Dave.Neudoerffer&ianywhere.com | ||
| Ed Fair | ed_fair&yahoo.com | 2002-11 | |
| Gabi Kalmar | kalga01&cai.com | ||
| Glenn Allen | gallen&goorooinc.com | 2009-08-05 | |
| Harry T. Vennik | htvennik&zonnet.nl | 2002-11 | |
| IRdg, Inc. | jtaylor&irdg.com | ||
| Ian Higginbottom | sonardata&sonardata.com | ||
| Jason Noack | SAP | jason.noack&sap.com | 2021-12-03 |
| Jauvane C. de Oliveira | jauvane&acm.org | ||
| Jeff Peters | National Instruments | VI.Server.Admin&ni.com | 2023-01-03 |
| John Border | border&hns.com | 2003-01 | |
| Jon Walker | jwalker&miramarsys.com | ||
| Jonathan A. Zdziarski | johathan&networkdweebs.com | 2002-11 | |
| Kenji Tetsuyama | kenji&onkyo.co.jp | 2002-11 | |
| Kevin Teiskoetter | kevint&metacreations.com | ||
| Manickam R.Sridhar | msridhar&sitaranetworks.com | ||
| Mark Harrison | Mark&xapautomation.org | 2002-11 | |
| Martin Pool | mbp&samba.org | 2002-11 | |
| Mike Gagle | MikeG&inter-intelli.com | ||
| MSW architecture team | NetApp | mswarch&netapp.com | 2014-07-18 |
| National Instruments | VI.Server.Admin&ni.com | 2023-01-03 | |
| NetApp, Inc. | mswarch&netapp.com | 2014-07-18 | |
| Paul Moore | paul.moore¢rify.com | 2009-10-28 | |
| Pedro Alpedrinha | pedro.alpedrinha&redevirtual.com | 2006-02 | |
| Peter Morrison | peter_morrison&sydney.sterling.com | ||
| Ralph Campbell | ralph.campbell&xasystems.com | 2002-11 | |
| Rob Williams | rob.williamsµsoft.com | 2009-02-17 | |
| SAP | jason.noack&sap.com | 2021-12-03 | |
| Seb Ibis | seb_ibis&pkworld.com | ||
| Shai Herzog | herzog&iphighway.com | ||
| Shivakumar S. Govindarajapuram | shivak&eng.sun.com | ||
| Songwon Chi | swchi&daou.co.kr | ||
| Spencer Teran | steran&dotalot.com | 2005-08 | |
| Tamara Baker | tbaker&ecolor.com | ||
| Zia Bhatti | zia&netright.com |