Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| patrol-mq-gm | 2664 | tcp | Patrol for MQ GM | ||||||||
| patrol-mq-gm | 2664 | udp | Patrol for MQ GM | ||||||||
| patrol-mq-nm | 2665 | tcp | Patrol for MQ NM | Portnoy Boxman | Portnoy Boxman | ||||||
| patrol-mq-nm | 2665 | udp | Patrol for MQ NM | Portnoy Boxman | Portnoy Boxman | ||||||
| extensis | 2666 | tcp | extensis | Milton Sagen | Milton Sagen | ||||||
| extensis | 2666 | udp | extensis | Milton Sagen | Milton Sagen | ||||||
| alarm-clock-s | 2667 | tcp | Alarm Clock Server | ||||||||
| alarm-clock-s | 2667 | udp | Alarm Clock Server | ||||||||
| alarm-clock-c | 2668 | tcp | Alarm Clock Client | ||||||||
| alarm-clock-c | 2668 | udp | Alarm Clock Client | ||||||||
| toad | 2669 | tcp | TOAD | Michael Marking | Michael Marking | ||||||
| toad | 2669 | udp | TOAD | Michael Marking | Michael Marking | ||||||
| compaq-scp | 2766 | tcp | Compaq SCP | Ferruccio Barletta | Ferruccio Barletta | ||||||
| compaq-scp | 2766 | udp | Compaq SCP | Ferruccio Barletta | Ferruccio Barletta | ||||||
| iwlistener | 2866 | tcp | iwlistener | Fred Surr | Fred Surr | ||||||
| iwlistener | 2866 | udp | iwlistener | Fred Surr | Fred Surr | ||||||
| m3ua | 2905 | tcp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| m3ua | 2905 | sctp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| idp-infotrieve | 2966 | tcp | IDP-INFOTRIEVE | Kevin Bruckert | Kevin Bruckert | ||||||
| idp-infotrieve | 2966 | udp | IDP-INFOTRIEVE | Kevin Bruckert | Kevin Bruckert | ||||||
| netattachsdmp | 3066 | tcp | NETATTACHSDMP | Mike Young | Mike Young | ||||||
| netattachsdmp | 3066 | udp | NETATTACHSDMP | Mike Young | Mike Young | ||||||
| sossecollector | 3166 | tcp | Quest Spotlight Out-Of-Process Collector | Greg Cottman | Greg Cottman | 2008-10-23 | |||||
| sossecollector | 3166 | udp | Quest Spotlight Out-Of-Process Collector | Greg Cottman | Greg Cottman | 2008-10-23 | |||||
| ns-cfg-server | 3266 | tcp | NS CFG Server | Aivi Lie | Aivi Lie | ||||||
| ns-cfg-server | 3266 | udp | NS CFG Server | Aivi Lie | Aivi Lie | ||||||
| creativepartnr | 3366 | tcp | Creative Partner | Jesus Ortiz | Jesus Ortiz | ||||||
| creativepartnr | 3366 | udp | Creative Partner | Jesus Ortiz | Jesus Ortiz | ||||||
| workflow | 3466 | tcp | WORKFLOW | Robert Hufsky | Robert Hufsky | ||||||
| workflow | 3466 | udp | WORKFLOW | Robert Hufsky | Robert Hufsky | ||||||
| quest-data-hub | 3566 | tcp | Quest Data Hub | Greg Cottman | Greg Cottman | 2010-10-18 | |||||
| 3566 | udp | Reserved | 2010-10-18 | ||||||||
| can-nds-ssl | 3660 | tcp | IBM Tivoli Directory Service using SSL | ||||||||
| can-nds-ssl | 3660 | udp | IBM Tivoli Directory Service using SSL | ||||||||
| can-ferret-ssl | 3661 | tcp | IBM Tivoli Directory Service using SSL | Nic Catrambone | Nic Catrambone | 2003-01 | |||||
| can-ferret-ssl | 3661 | udp | IBM Tivoli Directory Service using SSL | Nic Catrambone | Nic Catrambone | 2003-01 | |||||
| pserver | 3662 | tcp | pserver | Patrick Furlong | Patrick Furlong | 2003-01 | |||||
| pserver | 3662 | udp | pserver | Patrick Furlong | Patrick Furlong | 2003-01 | |||||
| dtp | 3663 | tcp | DIRECWAY Tunnel Protocol | John Border | John Border | 2003-01 | |||||
| dtp | 3663 | udp | DIRECWAY Tunnel Protocol | John Border | John Border | 2003-01 | |||||
| ups-engine | 3664 | tcp | UPS Engine Port | ||||||||
| ups-engine | 3664 | udp | UPS Engine Port | ||||||||
| ent-engine | 3665 | tcp | Enterprise Engine Port | Mike Delgrosso | Mike Delgrosso | 2003-01 | |||||
| ent-engine | 3665 | udp | Enterprise Engine Port | Mike Delgrosso | Mike Delgrosso | 2003-01 | |||||
| eserver-pap | 3666 | tcp | IBM eServer PAP | Dave Gimpl | Dave Gimpl | 2003-01 | |||||
| eserver-pap | 3666 | udp | IBM EServer PAP | Dave Gimpl | Dave Gimpl | 2003-01 | |||||
| infoexch | 3667 | tcp | IBM Information Exchange | Paul Ford-Hutchinson | Paul Ford-Hutchinson | 2003-01 | |||||
| infoexch | 3667 | udp | IBM Information Exchange | Paul Ford-Hutchinson | Paul Ford-Hutchinson | 2003-01 | |||||
| dell-rm-port | 3668 | tcp | Dell Remote Management | Bradley Bransom | Bradley Bransom | 2003-01 | |||||
| dell-rm-port | 3668 | udp | Dell Remote Management | Bradley Bransom | Bradley Bransom | 2003-01 | |||||
| casanswmgmt | 3669 | tcp | CA SAN Switch Management | Emre Tunar | Emre Tunar | 2003-01 | |||||
| casanswmgmt | 3669 | udp | CA SAN Switch Management | Emre Tunar | Emre Tunar | 2003-01 | |||||
| sitewatch-s | 3766 | tcp | SSL e-watch sitewatch server | e-Watch Corporation | John M Baird | 2014-05-13 | this port was previously updated on 2009-06-19 | ||||
| 3766 | udp | Reserved | this port was previously updated on 2009-06-19 | ||||||||
| dzdaemon | 3866 | tcp | Sun SDViz DZDAEMON Port | Kevin Rushforth | Kevin Rushforth | 2003-08 | |||||
| dzdaemon | 3866 | udp | Sun SDViz DZDAEMON Port | Kevin Rushforth | Kevin Rushforth | 2003-08 | |||||
| bflckmgr | 3966 | tcp | BuildForge Lock Manager | Joe Senner | Joe Senner | 2005-08 | |||||
| bflckmgr | 3966 | udp | BuildForge Lock Manager | Joe Senner | Joe Senner | 2005-08 | |||||
| pmas | 4066 | tcp | Performance Measurement and Analysis | Zenon Fortuna | Zenon Fortuna | 2007-02 | |||||
| pmas | 4066 | udp | Performance Measurement and Analysis | Zenon Fortuna | Zenon Fortuna | 2007-02 | |||||
| joost | 4166 | tcp | Joost Peer to Peer Protocol | Colm MacCarthaigh | Colm MacCarthaigh | 2007-04 | |||||
| joost | 4166 | udp | Joost Peer to Peer Protocol | Colm MacCarthaigh | Colm MacCarthaigh | 2007-04 | |||||
| shadowstream | 4366 | udp | ShadowStream System | StorageCraft Technology Corporation | David McConkie | 2014-12-17 | |||||
| 4366 | tcp | Reserved | |||||||||
| kwtc | 4566 | tcp | Kids Watch Time Control Service | Larry Zarou | Larry Zarou | 2006-10 | |||||
| kwtc | 4566 | udp | Kids Watch Time Control Service | Larry Zarou | Larry Zarou | 2006-10 | |||||
| smaclmgr | 4660 | tcp | smaclmgr | Hiromi Taki | Hiromi Taki | ||||||
| smaclmgr | 4660 | udp | smaclmgr | Hiromi Taki | Hiromi Taki | ||||||
| kar2ouche | 4661 | tcp | Kar2ouche Peer location service | Andy Krouwel | Andy Krouwel | ||||||
| kar2ouche | 4661 | udp | Kar2ouche Peer location service | Andy Krouwel | Andy Krouwel | ||||||
| oms | 4662 | tcp | OrbitNet Message Service | Roy Davies | Roy Davies | 2005-08 | |||||
| oms | 4662 | udp | OrbitNet Message Service | Roy Davies | Roy Davies | 2005-08 | |||||
| noteit | 4663 | tcp | Note It! Message Service | Pedro Alpedrinha | Pedro Alpedrinha | 2006-02 | |||||
| noteit | 4663 | udp | Note It! Message Service | Pedro Alpedrinha | Pedro Alpedrinha | 2006-02 | |||||
| ems | 4664 | tcp | Rimage Messaging Server | David V. Raskin | David V. Raskin | 2006-02 | |||||
| ems | 4664 | udp | Rimage Messaging Server | David V. Raskin | David V. Raskin | 2006-02 | |||||
| contclientms | 4665 | tcp | Container Client Message Service | Bruce Thompson | Bruce Thompson | 2006-02 | |||||
| contclientms | 4665 | udp | Container Client Message Service | Bruce Thompson | Bruce Thompson | 2006-02 | |||||
| eportcomm | 4666 | tcp | E-Port Message Service | ||||||||
| eportcomm | 4666 | udp | E-Port Message Service | ||||||||
| mmacomm | 4667 | tcp | MMA Comm Services | ||||||||
| mmacomm | 4667 | udp | MMA Comm Services | ||||||||
| mmaeds | 4668 | tcp | MMA EDS Service | Robert Shaffer | Robert Shaffer | 2006-02 | |||||
| mmaeds | 4668 | udp | MMA EDS Service | Robert Shaffer | Robert Shaffer | 2006-02 | |||||
| eportcommdata | 4669 | tcp | E-Port Data Service | Robert Shaffer | Robert Shaffer | 2006-02 | |||||
| eportcommdata | 4669 | udp | E-Port Data Service | Robert Shaffer | Robert Shaffer | 2006-02 | |||||
| 4852-4866 | Unassigned | ||||||||||
| stanag-5066 | 5066 | tcp | STANAG-5066-SUBNET-INTF | Rickard Berg | Rickard Berg | 2025-10-22 | |||||
| stanag-5066 | 5066 | udp | STANAG-5066-SUBNET-INTF | Rickard Berg | Rickard Berg | 2025-10-22 | |||||
| winpcs | 5166 | tcp | WinPCS Service Connection | Complan Network AS | Complan Network AS | 2006-02 | |||||
| winpcs | 5166 | udp | WinPCS Service Connection | Complan Network AS | Complan Network AS | 2006-02 | |||||
| 5266-5268 | Unassigned | ||||||||||
| 5466-5469 | Unassigned | ||||||||||
| westec-connect | 5566 | tcp | Westec Connect | Jon Bolen | Jon Bolen | 2009-03-18 | |||||
| 5566 | udp | Reserved | |||||||||
| 5647-5665 | Unassigned | ||||||||||
| nrpe | 5666 | tcp | Nagios Remote Plugin Executor | Nagios Enterprises, LLC | Bryan Heden | 2017-09-06 | |||||
| 5666 | udp | Reserved | |||||||||
| 5667-5669 | Unassigned | ||||||||||
| openmailns | 5766 | tcp | OpenMail NewMail Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| openmailns | 5766 | udp | OpenMail NewMail Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Aivi Lie | LIEA&netsoft.com | ||
| Andy Krouwel | andy&kar2ouche.com | ||
| Bradley Bransom | bradley_bransom&dell.com | 2003-01 | |
| Bruce Thompson | brucet&actioninformationsystems.com | 2006-02 | |
| Bryan Heden | bheden&nagios.com | 2017-09-06 | |
| Colm MacCarthaigh | colm.maccarthaigh&joost.com | 2007-04 | |
| Complan Network AS | knut&winpcs.com | 2006-02 | |
| Dave Gimpl | gimpl&us.ibm.com | 2003-01 | |
| David McConkie | StorageCraft Technology Corporation | dave.mcconkie&storagecraft.com | 2014-12-17 |
| David V. Raskin | draskin&rimage.com | 2006-02 | |
| Don Loughry | DON_LOUGHRY&hp-cupertino-om4.om.hp.com | ||
| e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 | |
| Emre Tunar | emre.tunar&ca.com | 2004-11 | |
| Ferruccio Barletta | ferruccio.barletta&compaq.com | ||
| Fred Surr | quest_iana&oz.quest.com | ||
| Greg Cottman | greg.cottman&quest.com | 2008-10-23 | |
| Greg Cottman | Greg.Cottman&quest.com | 2010-10-18 | |
| Hiromi Taki | stg-togo&saint.nm.fujitsu.co.jp | ||
| Jesus Ortiz | Jesus_A._Ortiz¬es.emotion.com | ||
| Joe Senner | jsenner&buildforge.com | 2005-08 | |
| John Border | border&hns.com | 2003-01 | |
| John M Baird | e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 |
| Jon Bolen | jon.bolen&westec.net | 2009-03-18 | |
| Kevin Bruckert | kbruckert&idpco.com | ||
| Kevin Rushforth | kevin.rushforth&sun.com | 2003-08 | |
| Larry Zarou | zarla01&cbsits.com | 2006-10 | |
| Lyndon Ong | LyOng&ciena.com | ||
| Michael Marking | marking&tatanka.com | ||
| Mike Delgrosso | mdelgros&tripplite.com | 2003-01 | |
| Mike Young | myong&netattach.com | ||
| Milton Sagen | msagen&extensis.com | ||
| Nagios Enterprises, LLC | techteam&nagios.com | 2017-09-06 | |
| Nic Catrambone | ncatramb&us.ibm.com | 2003-01 | |
| OpenMail Encyclopedia | opencyc&hpopd.pwd.hp.com | ||
| Patrick Furlong | pfurlong&darkknight.ca | 2003-01 | |
| Paul Ford-Hutchinson | paulfordh&uk.ibm.com | 2003-01 | |
| Pedro Alpedrinha | pedro.alpedrinha&redevirtual.com | 2006-02 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Rickard Berg | rickard.berg&fmv.se | 2025-10-22 | |
| Robert Hufsky | rhufsky&csesys.co.at | ||
| Robert Shaffer | bob.shaffer&micmod.com | 2006-02 | |
| Roy Davies | rdavies&daq.net | 2005-08 | |
| StorageCraft Technology Corporation | dave.mcconkie&storagecraft.com | 2014-12-17 | |
| Zenon Fortuna | zenon&mips.com | 2007-02 |