Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
270 tcp Reserved
gist 270 udp Q-mode encapsulation for GIST messages RFC 5971
pt-tls 271 tcp IETF Network Endpoint Assessment (NEA) Posture Transport Protocol over TLS (PT-TLS) IESG IETF Chair 2012-07-31 RFC 6876
271 udp Reserved
272-279 Unassigned
k-block 287 tcp K-BLOCK Simon P Jackson Simon P Jackson
k-block 287 udp K-BLOCK Simon P Jackson Simon P Jackson
tacacss 300 tcp TLS Secure Login Host Protocol (TACACSS) IESG IETF Chair 2025-07-15 RFC 9887
301-307 Unassigned
zannet 317 tcp Zannet Zan Oliphant Zan Oliphant
zannet 317 udp Zannet Zan Oliphant Zan Oliphant
fatserv 347 tcp Fatmen Server
fatserv 347 udp Fatmen Server
bhoetty 351 tcp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoetty 351 udp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 tcp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 udp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhevent 357 tcp bhevent John Kelly John Kelly
bhevent 357 udp bhevent John Kelly John Kelly
mortgageware 367 tcp MortgageWare Ole Hellevik Ole Hellevik
mortgageware 367 udp MortgageWare Ole Hellevik Ole Hellevik
codaauth2 370 tcp codaauth2 Robert Watson Robert Watson
codaauth2 370 udp codaauth2 Robert Watson Robert Watson
clearcase 371 tcp Clearcase Dave LeBlang Dave LeBlang
clearcase 371 udp Clearcase Dave LeBlang Dave LeBlang
ulistproc 372 tcp ListProcessor Anastasios Kotsikonas Anastasios Kotsikonas
ulistproc 372 udp ListProcessor Anastasios Kotsikonas Anastasios Kotsikonas
legent-1 373 tcp Legent Corporation
legent-1 373 udp Legent Corporation
legent-2 374 tcp Legent Corporation Keith Boyce Keith Boyce
legent-2 374 udp Legent Corporation Keith Boyce Keith Boyce
hassle 375 tcp Hassle Reinhard Doelz Reinhard Doelz
hassle 375 udp Hassle Reinhard Doelz Reinhard Doelz
nip 376 tcp Amiga Envoy Network Inquiry Protocol Heinz Wrobel Heinz Wrobel 2020-10-02
nip 376 udp Amiga Envoy Network Inquiry Protocol Heinz Wrobel Heinz Wrobel 2020-10-02
tnETOS 377 tcp NEC Corporation
tnETOS 377 udp NEC Corporation
dsETOS 378 tcp NEC Corporation Tomoo Fujita Tomoo Fujita
dsETOS 378 udp NEC Corporation Tomoo Fujita Tomoo Fujita
is99c 379 tcp TIA/EIA/IS-99 modem client
is99c 379 udp TIA/EIA/IS-99 modem client
aurp 387 tcp Appletalk Update-Based Routing Pro. Chris Ranch Chris Ranch
aurp 387 udp Appletalk Update-Based Routing Pro. Chris Ranch Chris Ranch
mptn 397 tcp Multi Protocol Trans. Net. Soumitra Sarkar Soumitra Sarkar
mptn 397 udp Multi Protocol Trans. Net. Soumitra Sarkar Soumitra Sarkar
timbuktu 407 tcp Timbuktu Marc Epard Marc Epard
timbuktu 407 udp Timbuktu Marc Epard Marc Epard
onmux 417 tcp Onmux Stephen Hanna Stephen Hanna
onmux 417 udp Onmux Stephen Hanna Stephen Hanna
svrloc 427 tcp Server Location Veizades Veizades
svrloc 427 udp Server Location Veizades Veizades
nnsp 433 tcp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
nnsp 433 udp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
comscm 437 tcp comscm Jim Teague Jim Teague
comscm 437 udp comscm Jim Teague Jim Teague
ddm-dfm 447 tcp DDM-Distributed File Management Steven Ritland Steven Ritland
ddm-dfm 447 udp DDM-Distributed File Management Steven Ritland Steven Ritland
scohelp 457 tcp scohelp Faith Zack Faith Zack
scohelp 457 udp scohelp Faith Zack Faith Zack
mylex-mapd 467 tcp mylex-mapd Gary Lewis Gary Lewis
mylex-mapd 467 udp mylex-mapd Gary Lewis Gary Lewis
scx-proxy 470 tcp scx-proxy Scott Narveson Scott Narveson
scx-proxy 470 udp scx-proxy Scott Narveson Scott Narveson
mondex 471 tcp Mondex Bill Reding Bill Reding
mondex 471 udp Mondex Bill Reding Bill Reding
ljk-login 472 tcp ljk-login LJK Software, Cambridge, Massachusetts LJK Software, Cambridge, Massachusetts
ljk-login 472 udp ljk-login LJK Software, Cambridge, Massachusetts LJK Software, Cambridge, Massachusetts
hybrid-pop 473 tcp hybrid-pop Rami Rubin Rami Rubin
hybrid-pop 473 udp hybrid-pop Rami Rubin Rami Rubin
tn-tl-w1 474 tcp tn-tl-w1
tn-tl-w2 474 udp tn-tl-w2 Ed Kress Ed Kress
tcpnethaspsrv 475 tcp tcpnethaspsrv Michael Zunke Michael Zunke 2010-07-23
tcpnethaspsrv 475 udp tcpnethaspsrv Michael Zunke Michael Zunke 2010-07-23
tn-tl-fd1 476 tcp tn-tl-fd1 Ed Kress Ed Kress
tn-tl-fd1 476 udp tn-tl-fd1 Ed Kress Ed Kress
ss7ns 477 tcp ss7ns Jean-Michel URSCH Jean-Michel URSCH
ss7ns 477 udp ss7ns Jean-Michel URSCH Jean-Michel URSCH
spsc 478 tcp spsc Mike Rieker Mike Rieker
spsc 478 udp spsc Mike Rieker Mike Rieker
iafserver 479 tcp iafserver
iafserver 479 udp iafserver
saft 487 tcp saft Simple Asynchronous File Transfer Ulli Horlacher Ulli Horlacher
saft 487 udp saft Simple Asynchronous File Transfer Ulli Horlacher Ulli Horlacher
retrospect 497 tcp Retrospect backup and restore service Retrospect, Inc. JG Heithcock 2012-02-02
retrospect 497 udp Retrospect backup and restore service Retrospect, Inc. JG Heithcock 2012-02-02
crs 507 tcp crs Brad Wright Brad Wright
crs 507 udp crs Brad Wright Brad Wright
talk 517 tcp like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established)
talk 517 udp like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established)
stx 527 tcp Stock IXChange Ferdi Ladeira Ferdi Ladeira 2022-01-25
stx 527 udp Stock IXChange Ferdi Ladeira Ferdi Ladeira 2022-01-25
nmsp 537 tcp Networked Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
nmsp 537 udp Networked Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
dhcpv6-server 547 tcp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 5460
dhcpv6-server 547 udp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 9915
openvms-sysipc 557 tcp openvms-sysipc Alan Potter Alan Potter
openvms-sysipc 557 udp openvms-sysipc Alan Potter Alan Potter
banyan-rpc 567 tcp banyan-rpc Tom Lemaire Tom Lemaire
banyan-rpc 567 udp banyan-rpc Tom Lemaire Tom Lemaire
meter 570 tcp demon
meter 570 udp demon

Contact Information

Name Organization Contact URI Last Updated
Alan Potter potter&movies.enet.dec.com
Anastasios Kotsikonas tasos&cs.bu.edu
Bill Reding redingb&nwdt.natwest.co.uk
Brad Wright bradwr&microsoft.com
Chris Ranch cranch&novell.com
Dave LeBlang leglang&atria.com
Ed Kress eskress&thinknet.com
Faith Zack faithz&sco.com
Ferdi Ladeira f.lad.mail&gmail.com 2022-01-25
Gary Lewis GaryL&hq.mylex.com
Heinz Wrobel hwrobel&gmx.de
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jean-Michel URSCH ursch&taec.enet.dec.com
JG Heithcock Retrospect, Inc. JG.Heithcock&retrospect.com 2012-02-02
Jim Teague teague&zso.dec.com
John Kelly johnk&bellhow.com
Keith Boyce
LJK Software, Cambridge, Massachusetts support&ljk.com
Marc Epard marc&netopia.com
Michael Zunke michael.zunke&ealaddin.com 2010-07-23
Mike Rieker mikea&sp32.com
Ole Hellevik oleh&interlinq.com
Paul Santinelli Jr. psantinelli&narrative.com
Rami Rubin rami&hybrid.com
Reinhard Doelz doelz&comp.bioz.unibas.ch
Retrospect, Inc. JG.Heithcock&retrospect.com 2012-02-02
Robert Watson robert&cyrus.watson.org
Scott Narveson sjn&cray.com
Simon P Jackson jacko&kring.co.uk
Soumitra Sarkar sarkar&vnet.ibm.com
Stephen Hanna hanna&world.std.com
Steven Ritland srr&us.ibm.com
Tom Lemaire toml&banyan.com
Tomoo Fujita tf&arc.bs1.fc.nec.co.jp
Ulli Horlacher framstag&rus.uni-stuttgart.de
veizades&ftp.com
Zan Oliphant zan&accessone.com