Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| h2gf-w-2m | 3179 | udp | H2GF W.2m Handover prot. | Arne Norefors | Arne Norefors | ||||||
| admind | 3279 | tcp | admind | Jeff Haynes | Jeff Haynes | ||||||
| admind | 3279 | udp | admind | Jeff Haynes | Jeff Haynes | ||||||
| socorfs | 3379 | tcp | SOCORFS | Hugo Charbonneau | Hugo Charbonneau | ||||||
| socorfs | 3379 | udp | SOCORFS | Hugo Charbonneau | Hugo Charbonneau | ||||||
| twrpc | 3479 | tcp | 2Wire RPC | 2Wire IANA Contact | 2Wire IANA Contact | 2002-04 | |||||
| twrpc | 3479 | udp | 2Wire RPC | 2Wire IANA Contact | 2Wire IANA Contact | 2002-04 | |||||
| ttat3lb | 3579 | tcp | Tarantella Load Balancing | Jim Musgrave | Jim Musgrave | 2002-08 | |||||
| ttat3lb | 3579 | udp | Tarantella Load Balancing | Jim Musgrave | Jim Musgrave | 2002-08 | |||||
| newton-dock | 3679 | tcp | Newton Dock | Paul Guyot | Paul Guyot | 2025-01-23 | |||||
| newton-dock | 3679 | udp | Newton Dock | Paul Guyot | Paul Guyot | 2025-01-23 | |||||
| cognima | 3779 | tcp | Cognima Replication | Ralph Greenwell | Ralph Greenwell | 2003-06 | |||||
| cognima | 3779 | udp | Cognima Replication | Ralph Greenwell | Ralph Greenwell | 2003-06 | |||||
| quickbooksrds | 3790 | tcp | QuickBooks RDS | Almira | Almira | 2003-07 | |||||
| quickbooksrds | 3790 | udp | QuickBooks RDS | Almira | Almira | 2003-07 | |||||
| tvnetworkvideo | 3791 | tcp | TV NetworkVideo Data port | Kevin Brunner | Kevin Brunner | 2003-07 | |||||
| tvnetworkvideo | 3791 | udp | TV NetworkVideo Data port | Kevin Brunner | Kevin Brunner | 2003-07 | |||||
| sitewatch | 3792 | tcp | e-Watch Corporation SiteWatch | John M. Baird | John M. Baird | 2003-07 | |||||
| sitewatch | 3792 | udp | e-Watch Corporation SiteWatch | John M. Baird | John M. Baird | 2003-07 | |||||
| dcsoftware | 3793 | tcp | DataCore Software | Andre Cato | Andre Cato | 2003-07 | |||||
| dcsoftware | 3793 | udp | DataCore Software | Andre Cato | Andre Cato | 2003-07 | |||||
| jaus | 3794 | tcp | JAUS Robots | Steven B. Cliff | Steven B. Cliff | 2003-07 | |||||
| jaus | 3794 | udp | JAUS Robots | Steven B. Cliff | Steven B. Cliff | 2003-07 | |||||
| myblast | 3795 | tcp | myBLAST Mekentosj port | Alexander Griekspoor | Alexander Griekspoor | 2003-07 | |||||
| myblast | 3795 | udp | myBLAST Mekentosj port | Alexander Griekspoor | Alexander Griekspoor | 2003-07 | |||||
| spw-dialer | 3796 | tcp | Spaceway Dialer | Patrick Fisher | Patrick Fisher | 2003-07 | |||||
| spw-dialer | 3796 | udp | Spaceway Dialer | Patrick Fisher | Patrick Fisher | 2003-07 | |||||
| idps | 3797 | tcp | idps | Jean-Francois Rabasse | Jean-Francois Rabasse | 2003-07 | |||||
| idps | 3797 | udp | idps | Jean-Francois Rabasse | Jean-Francois Rabasse | 2003-07 | |||||
| minilock | 3798 | tcp | Minilock | Daniel Julio Reyes | Daniel Julio Reyes | 2003-08 | |||||
| minilock | 3798 | udp | Minilock | Daniel Julio Reyes | Daniel Julio Reyes | 2003-08 | |||||
| radius-dynauth | 3799 | tcp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| radius-dynauth | 3799 | udp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| appss-lm | 3879 | tcp | appss license manager | Peter Krueger | Peter Krueger | 2003-10 | |||||
| appss-lm | 3879 | udp | appss license manager | Peter Krueger | Peter Krueger | 2003-10 | |||||
| smwan | 3979 | tcp | Smith Micro Wide Area Network Service | David Sperling | David Sperling | 2006-06 | |||||
| smwan | 3979 | udp | Smith Micro Wide Area Network Service | David Sperling | David Sperling | 2006-06 | |||||
| santools | 4079 | tcp | SANtools Diagnostic Server | David A. Lethe | David A. Lethe | 2008-05-01 | |||||
| santools | 4079 | udp | SANtools Diagnostic Server | David A. Lethe | David A. Lethe | 2008-05-01 | |||||
| MaxumSP | 4179 | tcp | Maxum Services | Greg Stine | Greg Stine | 2007-07-05 | |||||
| MaxumSP | 4179 | udp | Maxum Services | Greg Stine | Greg Stine | 2007-07-05 | |||||
| ctdb | 4379 | tcp | CTDB | Ronnie Sahlberg | Ronnie Sahlberg | 2007-07-05 | |||||
| ctdb | 4379 | udp | CTDB | Ronnie Sahlberg | Ronnie Sahlberg | 2007-07-05 | |||||
| 4461-4479 | Unassigned | ||||||||||
| mgesupervision | 4679 | tcp | MGE UPS Supervision | ||||||||
| mgesupervision | 4679 | udp | MGE UPS Supervision | ||||||||
| vxlan-gpe | 4790 | udp | Generic Protocol Extension for Virtual eXtensible Local Area Network (VXLAN) | Lawrence Kreeger | Lawrence Kreeger | 2014-08-26 | |||||
| 4790 | tcp | Reserved | |||||||||
| roce | 4791 | udp | IP Routable RocE | InfiniBand Trade Association (IBTA) | Diego Crupnicoff (IBTA TWG Chair) | 2014-10-17 | |||||
| 4791 | tcp | Reserved | |||||||||
| unified-bus | 4792 | tcp | IP Routable Unified Bus | Huawei | Wei Pan | 2022-07-08 | 2023-04-10 | ||||
| unified-bus | 4792 | udp | IP Routable Unified Bus | Huawei | Wei Pan | 2022-07-08 | 2023-04-10 | ||||
| 4793 | tcp | Reserved | |||||||||
| uet | 4793 | udp | Ultra Ethernet Transport | Ultra Ethernet Consortium | Vivek Kashyap | 2025-06-16 | |||||
| 4794 | tcp | Reserved | |||||||||
| veroce | 4794 | udp | veRoCE Transport Protocol | ByteDance | Dai Huichen | 2026-03-06 | |||||
| 4795-4799 | Unassigned | ||||||||||
| wsdl-event | 4879 | tcp | WSDL Event Receiver | Charles F Steele | Charles F Steele | 2011-02-15 | |||||
| 4879 | udp | Reserved | |||||||||
| 4972-4979 | Unassigned | ||||||||||
| 5079 | tcp | Reserved | |||||||||
| cp-spxrpts | 5079 | udp | Cambridge Pixel SPx Reports | Richard Warren | Richard Warren | 2008-09-17 | |||||
| 5273-5279 | Unassigned | ||||||||||
| fdtracks | 5579 | tcp | FleetDisplay Tracking Service | Henrik Woffinden | Henrik Woffinden | 2008-09-22 | |||||
| 5579 | udp | Reserved | |||||||||
| dccm | 5679 | tcp | Direct Cable Connect Manager | Mark Miller | Mark Miller | ||||||
| dccm | 5679 | udp | Direct Cable Connect Manager | Mark Miller | Mark Miller | ||||||
| 5778-5779 | Unassigned | ||||||||||
| 5788-5792 | Unassigned | ||||||||||
| xtreamx | 5793 | tcp | XtreamX Supervised Peer message | Ahmad Tajuddin Samsudin | Ahmad Tajuddin Samsudin | 2007-02 | |||||
| xtreamx | 5793 | udp | XtreamX Supervised Peer message | Ahmad Tajuddin Samsudin | Ahmad Tajuddin Samsudin | 2007-02 | |||||
| 5794 | tcp | Reserved | |||||||||
| spdp | 5794 | udp | Simple Peered Discovery Protocol | Dave Lindquist | Dave Lindquist | 2010-05-27 | |||||
| 5795-5797 | Unassigned | ||||||||||
| enlabel-dpl | 5798 | tcp | Proprietary Website deployment service | enLabel Global Services | Clay S. Didier | 2021-10-12 | |||||
| 5798 | udp | Reserved | |||||||||
| 5799-5812 | Unassigned | ||||||||||
| 6078-6079 | Unassigned | ||||||||||
| redis | 6379 | tcp | An advanced key-value cache and store | Salvatore Sanfilippo | Itamar Haber | 2015-04-23 | |||||
| 6379 | udp | Reserved | |||||||||
| 6472-6479 | Unassigned | ||||||||||
| affiliate | 6579 | tcp | Affiliate | David Catmull | David Catmull | 2006-01 | |||||
| affiliate | 6579 | udp | Affiliate | David Catmull | David Catmull | 2006-01 | |||||
| osaut | 6679 | tcp | Osorno Automation | Peter Hombach | Peter Hombach | 2011-03-16 | |||||
| osaut | 6679 | udp | Osorno Automation | Peter Hombach | Peter Hombach | 2011-03-16 | |||||
| 6779-6783 | Unassigned | ||||||||||
| hnmp | 6790 | tcp | HNMP | Jude George | Jude George | ||||||
| hnmp | 6790 | udp | HNMP | Jude George | Jude George | ||||||
| hnm | 6791 | tcp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| hnm | 6791 | udp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| 6792-6800 | Unassigned | ||||||||||
| 6971-6979 | Unassigned | ||||||||||
| 7074-7079 | Unassigned | ||||||||||
| ctxlic | 7279 | tcp | Citrix Licensing | Marc Binstock | Marc Binstock | 2008-01-29 | |||||
| ctxlic | 7279 | udp | Citrix Licensing | Marc Binstock | Marc Binstock | 2008-01-29 | |||||
| 7479-7490 | Unassigned | ||||||||||
| 7678-7679 | Unassigned | ||||||||||
| vstat | 7779 | tcp | VSTAT | Vinh Nguyn | Vinh Nguyn | ||||||
| vstat | 7779 | udp | VSTAT | Vinh Nguyn | Vinh Nguyn | ||||||
| 7790-7793 | Unassigned | ||||||||||
| q3ade | 7794 | tcp | Q3ADE Cluster Service | Uffe Harksen | Uffe Harksen | 2005-08 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Ahmad Tajuddin Samsudin | tajuddin&tmrnd.com.my | 2007-02 | |
| Alexander Griekspoor | a.griekspoor&nki.nl | 2003-07 | |
| Almira | almira_niciu&intuit.com | 2003-07 | |
| Andre Cato | andre.cato&datacore.com | 2003-07 | |
| Arne Norefors | Arne.Norefors&ericsson.com | ||
| ByteDance | daihuichen&bytedance.com | 2026-03-06 | |
| Charles F Steele | charles_steele&agilent.com | 2011-02-15 | |
| Clay S. Didier | enLabel Global Services | cdidier&enlabel.com | 2021-10-12 |
| Dai Huichen | daihuichen&bytedance.com | 2026-03-06 | |
| Daniel Julio Reyes | danieljreyes&yahoo.com | 2003-08 | |
| Dave Lindquist | dlindquist&egistix.com | 2010-05-27 | |
| David A. Lethe | david&santools.com | 2013-12-09 | |
| David Catmull | uncommon&uncommonplace.com | 2006-01 | |
| David Sperling | dsperling&smithmicro.com | 2006-06 | |
| Diego Crupnicoff (IBTA TWG Chair) | diego&mellanox.com | 2014-10-17 | |
| enLabel Global Services | support&enlabel.com | 2021-10-12 | |
| Fortra | info&fortra.com | 2023-05-24 | |
| Greg Stine | greg.stine&siemens.com | 2007-07-05 | |
| Henriët Wilkinson | henriet.wilkinson&fortra.com | 2023-05-24 | |
| Henrik Woffinden | hw&nitramlexa.com | 2008-09-22 | |
| Huawei | tarzan.pan&huawei.com | 2023-04-10 | |
| Hugo Charbonneau | |||
| Itamar Haber | Salvatore Sanfilippo | itamar&redislabs.com | 2015-04-23 |
| InfiniBand Trade Association (IBTA) | administration&infinibandta.org | 2014-10-17 | |
| Jean-Francois Rabasse | jfr&idps.org | 2003-07 | |
| Jeff Haynes | haynes&chistech.com | ||
| Jim Musgrave | jimm&tarantella.com | 2002-08 | |
| John M. Baird | jbaird&e-watch.com | 2003-07 | |
| Jude George | jude&nas.nasa.gov | ||
| Kevin Brunner | brunner&tivo.com | 2003-07 | |
| Lawrence Kreeger | kreeger&cisco.com | 2013-04-19 | |
| Marc Binstock | marc.binstock&citrix.com | 2008-01-29 | |
| Mark Miller | mmillerµsoft.com | ||
| Patrick Fisher | pfisher&hns.com | 2004-12 | |
| Paul Guyot | pguyot&kallisys.net | 2003-01 | |
| Peter Hombach | p.hombach&osorno.ca | 2011-03-16 | |
| Peter Krueger | krueger&appss.de | 2003-10 | |
| Ralph Greenwell | iana&cognima.com | 2012-03-15 | |
| Richard Warren | richard&cambridgepixel.com | 2008-09-17 | |
| Ronnie Sahlberg | ronniesahlberg&gmail.com | 2007-07-05 | |
| Salvatore Sanfilippo | antirez&gmail.com | 2015-04-23 | |
| Steven B. Cliff | scliff&remotec-andros.com | 2003-07 | |
| Uffe Harksen | uh&uhcommunications.com | 2005-08 | |
| Ultra Ethernet Consortium | vivek.kashyap&intel.com | 2025-06-16 | |
| Vinh Nguyn | vinh&sportvision.com | ||
| Vivek Kashyap | vivek.kashyap&intel.com | 2025-06-16 | |
| Wei Pan | Huawei | tarzan.pan&huawei.com | 2023-04-10 |
| 2Wire IANA Contact | iana&2wire.com | 2002-04 |