Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| btprjctrl | 2803 | tcp | btprjctrl | Huw Thomas | Huw Thomas | ||||||
| btprjctrl | 2803 | udp | btprjctrl | Huw Thomas | Huw Thomas | ||||||
| dvr-esm | 2804 | tcp | March Networks Digital Video Recorders and Enterprise Service Manager products | Paul Streatch | Paul Streatch | 2004-06 | |||||
| dvr-esm | 2804 | udp | March Networks Digital Video Recorders and Enterprise Service Manager products | Paul Streatch | Paul Streatch | 2004-06 | |||||
| wta-wsp-s | 2805 | tcp | WTA WSP-S | Sebastien Bury | Sebastien Bury | ||||||
| wta-wsp-s | 2805 | udp | WTA WSP-S | Sebastien Bury | Sebastien Bury | ||||||
| cspuni | 2806 | tcp | cspuni | ||||||||
| cspuni | 2806 | udp | cspuni | ||||||||
| cspmulti | 2807 | tcp | cspmulti | Terumasa Yoneda | Terumasa Yoneda | ||||||
| cspmulti | 2807 | udp | cspmulti | Terumasa Yoneda | Terumasa Yoneda | ||||||
| j-lan-p | 2808 | tcp | J-LAN-P | Takeshi Sahara | Takeshi Sahara | ||||||
| j-lan-p | 2808 | udp | J-LAN-P | Takeshi Sahara | Takeshi Sahara | ||||||
| corbaloc | 2809 | tcp | CORBA LOC | Ted McFadden | Ted McFadden | ||||||
| corbaloc | 2809 | udp | CORBA LOC | Ted McFadden | Ted McFadden | ||||||
| synapse | 2880 | tcp | Synapse Transport | Ali Fracyon | Ali Fracyon | ||||||
| synapse | 2880 | udp | Synapse Transport | Ali Fracyon | Ali Fracyon | ||||||
| wimd | 2980 | tcp | Instant Messaging Service | Kevin Birch | Kevin Birch | ||||||
| wimd | 2980 | udp | Instant Messaging Service | Kevin Birch | Kevin Birch | ||||||
| stm-pproc | 3080 | tcp | stm_pproc IANA assigned this well-formed service name as a replacement for "stm_pproc". |
Paul McGinnis | Paul McGinnis | ||||||
| stm_pproc | 3080 | tcp | stm_pproc | Paul McGinnis | Paul McGinnis | This entry is an alias to "stm-pproc". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| stm-pproc | 3080 | udp | stm_pproc IANA assigned this well-formed service name as a replacement for "stm_pproc". |
Paul McGinnis | Paul McGinnis | ||||||
| stm_pproc | 3080 | udp | stm_pproc | Paul McGinnis | Paul McGinnis | This entry is an alias to "stm-pproc". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| mc-brk-srv | 3180 | tcp | Millicent Broker Server | Steve Glassman | Steve Glassman | ||||||
| mc-brk-srv | 3180 | udp | Millicent Broker Server | Steve Glassman | Steve Glassman | ||||||
| vs-server | 3280 | tcp | VS Server | Scott Godlew | Scott Godlew | ||||||
| vs-server | 3280 | udp | VS Server | Scott Godlew | Scott Godlew | ||||||
| sns-channels | 3380 | tcp | SNS Channels | Shekar Pasumarthi | Shekar Pasumarthi | ||||||
| sns-channels | 3380 | udp | SNS Channels | Shekar Pasumarthi | Shekar Pasumarthi | ||||||
| stun-behavior | 3478 | tcp | STUN Behavior Discovery over TCP | RFC 5780 | |||||||
| stun-behavior | 3478 | udp | STUN Behavior Discovery over UDP | RFC 5780 | |||||||
| plethora | 3480 | tcp | Secure Virtual Workspace | Tim Simms | Tim Simms | 2002-04 | |||||
| plethora | 3480 | udp | Secure Virtual Workspace | Tim Simms | Tim Simms | 2002-04 | |||||
| lsp-ping | 3503 | tcp | MPLS LSP-echo Port | RFC 8029 | |||||||
| lsp-ping | 3503 | udp | MPLS LSP-echo Port | RFC 8029 | |||||||
| 802-11-iapp | 3517 | tcp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| 802-11-iapp | 3517 | udp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| teredo | 3544 | tcp | Teredo Port | RFC 4380 | |||||||
| teredo | 3544 | udp | Teredo Port | RFC 4380 | |||||||
| nati-svrloc | 3580 | tcp | NATI-ServiceLocator | Jason Case | Jason Case | 2002-08 | |||||
| nati-svrloc | 3580 | udp | NATI-ServiceLocator | Jason Case | Jason Case | 2002-08 | |||||
| npds-tracker | 3680 | tcp | NPDS Tracker | Paul Guyot | Paul Guyot | 2003-01 | |||||
| npds-tracker | 3680 | udp | NPDS Tracker | Paul Guyot | Paul Guyot | 2003-01 | |||||
| nnp | 3780 | tcp | Nuzzler Network Protocol | Andreas Schwarz | Andreas Schwarz | 2003-06 | |||||
| nnp | 3780 | udp | Nuzzler Network Protocol | Andreas Schwarz | Andreas Schwarz | 2003-06 | |||||
| pwgpsi | 3800 | tcp | Print Services Interface | Harry Lewis | Harry Lewis | 2003-05 | |||||
| pwgpsi | 3800 | udp | Print Services Interface | Harry Lewis | Harry Lewis | 2003-05 | |||||
| ibm-mgr | 3801 | tcp | ibm manager service | Tim Hahn | Tim Hahn | 2006-03 | |||||
| ibm-mgr | 3801 | udp | ibm manager service | Tim Hahn | Tim Hahn | 2006-03 | |||||
| vhd | 3802 | tcp | VHD | Chris Duncombe | Chris Duncombe | ||||||
| vhd | 3802 | udp | VHD | Chris Duncombe | Chris Duncombe | ||||||
| soniqsync | 3803 | tcp | SoniqSync | Ryan Melville | Ryan Melville | 2004-01 | |||||
| soniqsync | 3803 | udp | SoniqSync | Ryan Melville | Ryan Melville | 2004-01 | |||||
| iqnet-port | 3804 | tcp | Harman IQNet Port | Bruce Vander Werf | Bruce Vander Werf | 2004-02 | |||||
| iqnet-port | 3804 | udp | Harman IQNet Port | Bruce Vander Werf | Bruce Vander Werf | 2004-02 | |||||
| tcpdataserver | 3805 | tcp | ThorGuard Server Port | Joel E. Steiger | Joel E. Steiger | 2004-02 | |||||
| tcpdataserver | 3805 | udp | ThorGuard Server Port | Joel E. Steiger | Joel E. Steiger | 2004-02 | |||||
| wsmlb | 3806 | tcp | Remote System Manager | Thomas Fiege | Thomas Fiege | 2004-02 | |||||
| wsmlb | 3806 | udp | Remote System Manager | Thomas Fiege | Thomas Fiege | 2004-02 | |||||
| spugna | 3807 | tcp | SpuGNA Communication Port | Samuele Sequi | Samuele Sequi | 2004-02 | |||||
| spugna | 3807 | udp | SpuGNA Communication Port | Samuele Sequi | Samuele Sequi | 2004-02 | |||||
| sun-as-iiops-ca | 3808 | tcp | Sun App Svr-IIOPClntAuth | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| sun-as-iiops-ca | 3808 | udp | Sun App Svr-IIOPClntAuth | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| apocd | 3809 | tcp | Java Desktop System Configuration Agent | Geoff Higgins | Geoff Higgins | 2006-03 | |||||
| apocd | 3809 | udp | Java Desktop System Configuration Agent | Geoff Higgins | Geoff Higgins | 2006-03 | |||||
| igrs | 3880 | tcp | IGRS | Huang Jingnan | Huang Jingnan | 2003-10 | |||||
| igrs | 3880 | udp | IGRS | Huang Jingnan | Huang Jingnan | 2003-10 | |||||
| 3980 | tcp | Reserved | 2006-06 | 2020-12-29 | Historic usage was acms. De-Assigned on 2020-12-29 | ||||||
| 3980 | udp | Reserved | |||||||||
| lorica-in | 4080 | tcp | Lorica inside facing | ||||||||
| lorica-in | 4080 | udp | Lorica inside facing | ||||||||
| httpx | 4180 | tcp | HTTPX | Paul McGough | Paul McGough | 2007-02 | |||||
| httpx | 4180 | udp | HTTPX | Paul McGough | Paul McGough | 2007-02 | 2016-01-05 | ||||
| 4190 | udp | Reserved | RFC 5804 | ||||||||
| netconf-ch-ssh | 4334 | tcp | NETCONF Call Home (SSH) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| netconf-ch-tls | 4335 | tcp | NETCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| restconf-ch-tls | 4336 | tcp | RESTCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4380-4388 | Unassigned | ||||||||||
| agtp | 4480 | tcp | Agent Transfer Protocol | Chris Hood | Chris Hood | 2026-04-30 | |||||
| agtp-quic | 4480 | udp | Agent Transfer Protocol over QUIC | Chris Hood | Chris Hood | 2026-04-30 | |||||
| mgemanagement | 4680 | tcp | MGE UPS Management | Lecuivre J | Lecuivre J | 2005-08 | |||||
| mgemanagement | 4680 | udp | MGE UPS Management | Lecuivre J | Lecuivre J | 2005-08 | |||||
| gre-in-udp | 4754 | udp | GRE-in-UDP Encapsulation | IESG | IETF Chair | 2016-10-05 | RFC 8086 | ||||
| gre-udp-dtls | 4755 | udp | GRE-in-UDP Encapsulation with DTLS | IESG | IETF Chair | 2016-10-05 | RFC 8086 | ||||
| iims | 4800 | tcp | Icona Instant Messenging System | ||||||||
| iims | 4800 | udp | Icona Instant Messenging System | ||||||||
| iwec | 4801 | tcp | Icona Web Embedded Chat | ||||||||
| iwec | 4801 | udp | Icona Web Embedded Chat | ||||||||
| ilss | 4802 | tcp | Icona License System Server | Paul Stephen Borlie | Paul Stephen Borlie | ||||||
| ilss | 4802 | udp | Icona License System Server | Paul Stephen Borlie | Paul Stephen Borlie | ||||||
| notateit | 4803 | tcp | Notateit Messaging | ||||||||
| notateit-disc | 4803 | udp | Notateit Messaging Discovery | Ean Black | Ean Black | 2009-04-08 | |||||
| 4804 | tcp | Reserved | |||||||||
| aja-ntv4-disc | 4804 | udp | AJA ntv4 Video System Discovery | Mike Bernadett | Mike Bernadett | 2010-06-03 | |||||
| 4805-4826 | Unassigned | ||||||||||
| hislip | 4880 | tcp | IVI High-Speed LAN Instrument Protocol | Interchangeable Virtual Instruments Foundation, Inc. | Larry Ostheimer | 2021-05-06 | |||||
| 4880 | udp | Reserved | |||||||||
| ctxs-vpp | 4980 | udp | Citrix Virtual Path | Citrix Systems | Rohith Ramkumar | 2015-04-17 | |||||
| 4980 | tcp | Reserved | |||||||||
| onscreen | 5080 | tcp | OnScreen Data Collection Service | Christopher Miller | Christopher Miller | 2008-01-14 | |||||
| onscreen | 5080 | udp | OnScreen Data Collection Service | Christopher Miller | Christopher Miller | 2008-01-14 | |||||
| xmpp-bosh | 5280 | tcp | Bidirectional-streams Over Synchronous HTTP (BOSH) | Peter Saint-Andre | Peter Saint-Andre | 2009-11-25 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Abhijit Kumar | as-iana-ports&sun.com | 2005-11 | |
| Ali Fracyon | sxdev&modulardreams.com | ||
| Andreas Schwarz | andreas.schwarz&securepoint.de | 2003-06 | |
| Bruce Vander Werf | bvanderwerf&crownintl.com | 2004-02 | |
| Chris Duncombe | cduncombe&atpeng.com | 2022-03-25 | |
| Chris Hood | chris&nomotic.ai | 2026-04-30 | |
| Christopher Miller | chris.miller&versatrans.com | 2008-01-14 | |
| Citrix Systems | CloudBridge-PM&citrix.com | 2015-04-17 | |
| Ean Black | eanb&bladesoftware.co.uk | 2009-04-08 | |
| Geoff Higgins | geoff.higgins&sun.com | 2006-03 | |
| Harry Lewis | harryl&us.ibm.com | 2003-05 | |
| Huang Jingnan | huangjnb&lenovo.com | 2003-10 | |
| Huw Thomas | huw.thomas&bt.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Interchangeable Virtual Instruments Foundation, Inc. | ivi.contact&ivifoundation.org | 2021-05-06 | |
| Jason Case | jason.case&ni.com | 2002-08 | |
| Joel E. Steiger | jsteiger&eic-us.com | 2004-02 | |
| Kevin Birch | kbirch&pobox.com | ||
| Larry Ostheimer | larry_ostheimer&keysight.com | 2021-05-06 | |
| Lecuivre J | software.team&mgeups.com | 2005-08 | |
| Mike Bernadett | mjbernadett&sbcglobal.net | 2010-06-03 | |
| Paul Guyot | pguyot&kallisys.net | 2003-01 | |
| Paul McGinnis | pmcginnis&server.stmi.com | ||
| Paul McGough | paulmcgough&yahoo.com | 2016-01-05 | |
| Paul Stephen Borlie | paul&icona.it | ||
| Paul Streatch | pstreatch&marchnetworks.com | 2004-06 | |
| Peter Saint-Andre | stpeter&stpeter.im | 2009-11-25 | |
| Rohith Ramkumar | Citrix Systems | CloudBridge-PM&citrix.com | 2015-04-17 |
| Ryan Melville | ryan_melville&soniqcast.com | 2004-01 | |
| Samuele Sequi | samuelesequi&defcom.it | 2004-02 | |
| Scott Godlew | Scott&godlew.com | ||
| Sebastien Bury | WAP Forum | sebastien.bury&art.alcatel.fr | |
| Shekar Pasumarthi | shekarp&firstfloor.com | ||
| Steve Glassman | steveg&pa.dec.com | ||
| Stuart J. Kerry | Chair IEEE 802.11 WG | stuart&ok-brit.com | 2002-05 |
| Takeshi Sahara | sahara&jdl.co.jp | ||
| Ted McFadden | mcfadden&dstc.edu.au | ||
| Terumasa Yoneda | yonedat&pfu.co.jp | ||
| Thomas Fiege | tfiege&us.ibm.com | 2004-02 | |
| Tim Hahn | hahnt&us.ibm.com | 2006-03 | |
| Tim Simms | tsimms&plethoratech.com | 2002-04 |