Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-04
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| rmlnk | 2818 | udp | rmlnk | ||||||||
| fc-faultnotify | 2819 | tcp | FC Fault Notification | Dave Watkins | Dave Watkins | ||||||
| fc-faultnotify | 2819 | udp | FC Fault Notification | Dave Watkins | Dave Watkins | ||||||
| ndsp | 2881 | tcp | NDSP | ||||||||
| ndsp | 2881 | udp | NDSP | ||||||||
| mylxamport | 2981 | tcp | MYLXAMPORT | Wei Gao | Wei Gao | ||||||
| mylxamport | 2981 | udp | MYLXAMPORT | Wei Gao | Wei Gao | ||||||
| tl1-lv | 3081 | tcp | TL1-LV | ||||||||
| tl1-lv | 3081 | udp | TL1-LV | ||||||||
| bmcpatrolagent | 3181 | tcp | BMC Patrol Agent | ||||||||
| bmcpatrolagent | 3181 | udp | BMC Patrol Agent | ||||||||
| sysopt | 3281 | tcp | SYSOPT | Tony Hoffman | Tony Hoffman | ||||||
| sysopt | 3281 | udp | SYSOPT | Tony Hoffman | Tony Hoffman | ||||||
| geneous | 3381 | tcp | Geneous | Nick de Smith | Nick de Smith | ||||||
| geneous | 3381 | udp | Geneous | Nick de Smith | Nick de Smith | ||||||
| cleanerliverc | 3481 | tcp | CleanerLive remote ctrl | David Mojdehi | David Mojdehi | 2002-04 | |||||
| cleanerliverc | 3481 | udp | CleanerLive remote ctrl | David Mojdehi | David Mojdehi | 2002-04 | |||||
| kfxaclicensing | 3581 | tcp | Ascent Capture Licensing | Brad Hamilton | Brad Hamilton | 2002-08 | |||||
| kfxaclicensing | 3581 | udp | Ascent Capture Licensing | Brad Hamilton | Brad Hamilton | 2002-08 | |||||
| bts-x73 | 3681 | tcp | BTS X73 Port | Todd Cooper | Todd Cooper | 2003-01 | |||||
| bts-x73 | 3681 | udp | BTS X73 Port | Todd Cooper | Todd Cooper | 2003-01 | |||||
| abcvoice-port | 3781 | tcp | ABCvoice server port | Carlos Gonzalez-Roman Ferrer | Carlos Gonzalez-Roman Ferrer | 2003-06 | |||||
| abcvoice-port | 3781 | udp | ABCvoice server port | Carlos Gonzalez-Roman Ferrer | Carlos Gonzalez-Roman Ferrer | 2003-06 | |||||
| bfd-control | 3784 | tcp | BFD Control Protocol | RFC 5881 | |||||||
| bfd-control | 3784 | udp | BFD Control Protocol | RFC 5881 | |||||||
| bfd-echo | 3785 | tcp | BFD Echo Protocol | RFC 5881 | |||||||
| bfd-echo | 3785 | udp | BFD Echo Protocol | RFC 5881 | |||||||
| wlanauth | 3810 | tcp | WLAN AS server | Bianling Zhang | Bianling Zhang | 2004-02 | |||||
| wlanauth | 3810 | udp | WLAN AS server | Bianling Zhang | Bianling Zhang | 2004-02 | |||||
| amp | 3811 | tcp | AMP | Northon Rodrigues | Northon Rodrigues | 2004-02 | |||||
| amp | 3811 | udp | AMP | Northon Rodrigues | Northon Rodrigues | 2004-02 | |||||
| neto-wol-server | 3812 | tcp | netO WOL Server | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| neto-wol-server | 3812 | udp | netO WOL Server | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| rap-ip | 3813 | tcp | Rhapsody Interface Protocol | Paul Zander | Paul Zander | 2004-03 | |||||
| rap-ip | 3813 | udp | Rhapsody Interface Protocol | Paul Zander | Paul Zander | 2004-03 | |||||
| neto-dcs | 3814 | tcp | netO DCS | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| neto-dcs | 3814 | udp | netO DCS | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| lansurveyorxml | 3815 | tcp | LANsurveyor XML | Michael Swan | Michael Swan | 2004-04 | |||||
| lansurveyorxml | 3815 | udp | LANsurveyor XML | Michael Swan | Michael Swan | 2004-04 | |||||
| sunlps-http | 3816 | tcp | Sun Local Patch Server | Barry Greenberg | Barry Greenberg | 2004-04 | |||||
| sunlps-http | 3816 | udp | Sun Local Patch Server | Barry Greenberg | Barry Greenberg | 2004-04 | |||||
| tapeware | 3817 | tcp | Yosemite Tech Tapeware | Luke Dion | Luke Dion | 2004-04 | |||||
| tapeware | 3817 | udp | Yosemite Tech Tapeware | Luke Dion | Luke Dion | 2004-04 | |||||
| crinis-hb | 3818 | tcp | Crinis Heartbeat | Eric McMurry | Eric McMurry | 2004-04 | |||||
| crinis-hb | 3818 | udp | Crinis Heartbeat | Eric McMurry | Eric McMurry | 2004-04 | |||||
| epl-slp | 3819 | tcp | EPL Sequ Layer Protocol | Hans Weibel | Hans Weibel | 2004-10 | |||||
| epl-slp | 3819 | udp | EPL Sequ Layer Protocol | Hans Weibel | Hans Weibel | 2004-10 | |||||
| idac | 3881 | tcp | Data Acquisition and Control | Chatziandreoglou Christos | Chatziandreoglou Christos | 2003-10 | |||||
| idac | 3881 | udp | Data Acquisition and Control | Chatziandreoglou Christos | Chatziandreoglou Christos | 2003-10 | |||||
| starfish | 3981 | tcp | Starfish System Admin | Dan Razzell | Dan Razzell | 2006-06 | |||||
| starfish | 3981 | udp | Starfish System Admin | Dan Razzell | Dan Razzell | 2006-06 | |||||
| lorica-in-sec | 4081 | tcp | Lorica inside facing (SSL) | ||||||||
| lorica-in-sec | 4081 | udp | Lorica inside facing (SSL) | ||||||||
| macbak | 4181 | tcp | MacBak | Wes Peters | Wes Peters | 2007-04 | |||||
| macbak | 4181 | udp | MacBak | Wes Peters | Wes Peters | 2007-04 | |||||
| 4481-4483 | Unassigned | ||||||||||
| parliant | 4681 | tcp | Parliant Telephony System | Colin Henein | Colin Henein | 2005-08 | |||||
| parliant | 4681 | udp | Parliant Telephony System | Colin Henein | Colin Henein | 2005-08 | |||||
| 4881 | tcp | Reserved | |||||||||
| socp-t | 4881 | udp | SOCP Time Synchronization Protocol | Joe Haver | Joe Haver | 2010-05-28 | |||||
| 4981-4982 | Unassigned | ||||||||||
| sdl-ets | 5081 | tcp | SDL - Ent Trans Server | Marc Morin | Marc Morin | 2002-04 | |||||
| sdl-ets | 5081 | udp | SDL - Ent Trans Server | Marc Morin | Marc Morin | 2002-04 | |||||
| undo-lm | 5281 | tcp | Undo License Manager | Undo Ltd | Edward Moffett | 2010-04-19 | 2019-01-25 | ||||
| 5281 | udp | Reserved | |||||||||
| tmosms1 | 5581 | tcp | T-Mobile SMS Protocol Message 1 | Ezinne Oji | Ezinne Oji | 2006-06 | |||||
| tmosms1 | 5581 | udp | T-Mobile SMS Protocol Message 1 | Ezinne Oji | Ezinne Oji | 2006-06 | |||||
| ncxcp | 5681 | tcp | Net-coneX Control Protocol | Ryan Werber | Ryan Werber | 2006-06 | |||||
| ncxcp | 5681 | udp | Net-coneX Control Protocol | Ryan Werber | Ryan Werber | 2006-06 | |||||
| 3par-evts | 5781 | tcp | 3PAR Event Reporting Service | Sushil Thomas | Sushil Thomas | 2008-03-10 | |||||
| 3par-evts | 5781 | udp | 3PAR Event Reporting Service | Sushil Thomas | Sushil Thomas | 2008-03-10 | |||||
| 5799-5812 | Unassigned | ||||||||||
| icmpd | 5813 | tcp | ICMPD | Shane O'Donnell | Shane O'Donnell | ||||||
| icmpd | 5813 | udp | ICMPD | Shane O'Donnell | Shane O'Donnell | ||||||
| spt-automation | 5814 | tcp | Support Automation | Joshua Hawkins | Joshua Hawkins | 2003-11 | |||||
| spt-automation | 5814 | udp | Support Automation | Joshua Hawkins | Joshua Hawkins | 2003-11 | |||||
| 5815-5819 | Unassigned | ||||||||||
| geneve | 6081 | udp | Generic Network Virtualization Encapsulation (Geneve) | IESG | IETF Chair | 2014-03-27 | 2020-05-04 | RFC 8926 | |||
| 6081 | tcp | Reserved | |||||||||
| 6380-6381 | Unassigned | ||||||||||
| servicetags | 6481 | tcp | Service Tags | Peter Schow | Peter Schow | 2007-01 | |||||
| servicetags | 6481 | udp | Service Tags | Peter Schow | Peter Schow | 2007-01 | |||||
| parsec-peer | 6581 | tcp | Parsec Peer-to-Peer | Andreas Varga | Andreas Varga | ||||||
| parsec-peer | 6581 | udp | Parsec Peer-to-Peer | Andreas Varga | Andreas Varga | ||||||
| frc-hp | 6704 | sctp | ForCES HP (High Priority) channel | RFC 5811 | |||||||
| frc-mp | 6705 | sctp | ForCES MP (Medium Priority) channel | RFC 5811 | |||||||
| frc-lp | 6706 | sctp | ForCES LP (Low priority) channel | RFC 5811 | |||||||
| 6802-6816 | Unassigned | ||||||||||
| pentbox-sim | 6817 | tcp | PenTBox Secure IM Protocol | Alberto Ortega Llamas | Alberto Ortega Llamas | 2009-11-04 | |||||
| 6817 | udp | Reserved | |||||||||
| 6818-6830 | Unassigned | ||||||||||
| 6981-6996 | Unassigned | ||||||||||
| 7081-7087 | Unassigned | ||||||||||
| janus-disc | 7181 | udp | Janus Guidewire Enterprise Discovery Service Bus | Guidewire Software, Inc | Luca Debiasi | 2014-02-06 | |||||
| 7181 | tcp | Reserved | |||||||||
| itactionserver2 | 7281 | tcp | ITACTIONSERVER 2 | Brian Taylor | Brian Taylor | ||||||
| itactionserver2 | 7281 | udp | ITACTIONSERVER 2 | Brian Taylor | Brian Taylor | ||||||
| 7681-7682 | Unassigned | ||||||||||
| accu-lmgr | 7781 | tcp | accu-lmgr | Moises E. Hernandez | Moises E. Hernandez | ||||||
| accu-lmgr | 7781 | udp | accu-lmgr | Moises E. Hernandez | Moises E. Hernandez | ||||||
| s-bfd | 7784 | udp | Seamless Bidirectional Forwarding Detection (S-BFD) | IESG | IETF Chair | 2014-12-24 | 2016-07-14 | RFC 7881 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alberto Ortega Llamas | alberto.kun666&gmail.com | 2009-11-04 | |
| Andreas Varga | sid&parsec.org | ||
| Barry Greenberg | barry.greenberg&sun.com | 2004-04 | |
| Bianling Zhang | blzhang&iwncomm.com | 2004-02 | |
| Brad Hamilton | brad_hamilton&kofax.com | 2002-08 | |
| Brian Taylor | btaylor&imagetag.com | ||
| Carlos Gonzalez-Roman Ferrer | iana&abcdatos.com | 2003-06 | |
| Chatziandreoglou Christos | chatzi&xan.forthnet.gr | 2003-10 | |
| Colin Henein | iana&cmh.parliant.com | 2005-08 | |
| Dan Razzell | dan&starfishsystems.ca | 2006-06 | |
| Dave Watkins | davew&boi.hp.com | ||
| David Mojdehi | david.mojdehi&autodesk.com | 2002-04 | |
| Edward Moffett | Undo Ltd | office.manager&undo.io | 2019-01-25 |
| Eric McMurry | emcmurry&crinisnetworks.com | 2004-04 | |
| Ezinne Oji | ezinne.oji&t-mobile.com | 2006-06 | |
| Guidewire Software, Inc | info&guidewire.com | 2014-02-06 | |
| Hans Weibel | hans.weibel&zhwin.ch | 2004-10 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Joe Haver | joe.haver&jdsu.com | 2010-05-28 | |
| Joshua Hawkins | joshua.hawkins&hp.com | 2003-11 | |
| Luca Debiasi | Guidewire Software, Inc | ldebiasi&guidewire.com | 2014-02-06 |
| Luke Dion | ldion&tapeware.com | 2004-04 | |
| Marc Morin | mmorin&sdlintl.com | 2002-04 | |
| Martin Bestmann | martin&no.netopia.com | 2004-03 | |
| Michael Swan | swan&neon.com | 2004-04 | |
| Moises E. Hernandez | moises&accugraph.com | ||
| Nick de Smith | nick&desmith.net | ||
| Northon Rodrigues | northon.rodrigues&thomson.net | 2004-02 | |
| Paul Zander | Philips CFT | p.j.zander&philips.com | 2004-03 |
| Peter Schow | Peter.Schow&sun.com | 2007-01 | |
| Ryan Werber | ryan&ncxti.com | 2006-06 | |
| Shane O'Donnell | shane&opennms.org | ||
| Sushil Thomas | iana-comm&3par.com | 2008-03-10 | |
| Todd Cooper | todd&do11073.com | 2003-01 | |
| Tony Hoffman | ajh&unx.dec.com | ||
| Undo Ltd | office.manager&undo.io | 2019-01-25 | |
| Wei Gao | wei&mylex.com | ||
| Wes Peters | wes&softweyr.com | 2007-04 |