Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
starbot 2838 tcp Starbot Markus Sabadello Markus Sabadello
starbot 2838 udp Starbot Markus Sabadello Markus Sabadello
nmsigport 2839 tcp NMSigPort Peter Egli Peter Egli
nmsigport 2839 udp NMSigPort Peter Egli Peter Egli
ndnp 2883 tcp NDNP Khelben Blackstaff Khelben Blackstaff
ndnp 2883 udp NDNP Khelben Blackstaff Khelben Blackstaff
netplan 2983 tcp NETPLAN Thomas Driemeyer Thomas Driemeyer
netplan 2983 udp NETPLAN Thomas Driemeyer Thomas Driemeyer
tl1-telnet 3083 tcp TL1-TELNET SONET Internetworking Forum (SIF) SONET Internetworking Forum (SIF)
tl1-telnet 3083 udp TL1-TELNET SONET Internetworking Forum (SIF) SONET Internetworking Forum (SIF)
cops-tls 3183 tcp COPS/TLS Mark Stevens Mark Stevens
cops-tls 3183 udp COPS/TLS Mark Stevens Mark Stevens
net-assistant 3283 tcp Net Assistant Michael Stein Michael Stein 2025-01-23
net-assistant 3283 udp Net Assistant Michael Stein Michael Stein 2025-01-23
esp-lm 3383 tcp Enterprise Software Products License Manager George Rudy George Rudy
esp-lm 3383 udp Enterprise Software Products License Manager George Rudy George Rudy
slim-devices 3483 tcp Slim Devices Protocol Sean Adams Sean Adams 2002-05
slim-devices 3483 udp Slim Devices Protocol Sean Adams Sean Adams 2002-05
canex-watch 3583 tcp CANEX Watch System Peter Kollath Peter Kollath 2002-08
canex-watch 3583 udp CANEX Watch System Peter Kollath Peter Kollath 2002-08
bmc-ea 3683 tcp BMC EDV/EA Portnoy Boxman Portnoy Boxman 2003-01
bmc-ea 3683 udp BMC EDV/EA Portnoy Boxman Portnoy Boxman 2003-01
bim-pem 3783 tcp Impact Mgr./PEM Gateway Walter G. Giroir Walter G. Giroir 2003-07
bim-pem 3783 udp Impact Mgr./PEM Gateway Walter G. Giroir Walter G. Giroir 2003-07
cernsysmgmtagt 3830 tcp Cerner System Management Agent Mike Craft Mike Craft 2008-01-29
cernsysmgmtagt 3830 udp Cerner System Management Agent Mike Craft Mike Craft 2008-01-29
dvapps 3831 tcp Docsvault Application Service Ketul Patel Ketul Patel 2006-10
dvapps 3831 udp Docsvault Application Service Ketul Patel Ketul Patel 2006-10
xxnetserver 3832 tcp xxNETserver XXT LLC Matt Ferrari 2006-10 2012-07-12
xxnetserver 3832 udp xxNETserver XXT LLC Matt Ferrari 2006-10 2012-07-12
aipn-auth 3833 tcp AIPN LS Authentication Qiang Zhang Qiang Zhang 2006-10
aipn-auth 3833 udp AIPN LS Authentication Qiang Zhang Qiang Zhang 2006-10
spectardata 3834 tcp Spectar Data Stream Service
spectardata 3834 udp Spectar Data Stream Service
spectardb 3835 tcp Spectar Database Rights Service Jan Rutger Voorhorst Jan Rutger Voorhorst 2006-10
spectardb 3835 udp Spectar Database Rights Service Jan Rutger Voorhorst Jan Rutger Voorhorst 2006-10
markem-dcp 3836 tcp MARKEM NEXTGEN DCP
markem-dcp 3836 udp MARKEM NEXTGEN DCP
mkm-discovery 3837 tcp MARKEM Auto-Discovery Vadym Kargin Vadym Kargin 2005-08
mkm-discovery 3837 udp MARKEM Auto-Discovery Vadym Kargin Vadym Kargin 2005-08
sos 3838 tcp Scito Object Server Arno Klaassen Arno Klaassen 2003-11
sos 3838 udp Scito Object Server Arno Klaassen Arno Klaassen 2003-11
amx-rms 3839 tcp AMX Resource Management Suite Ron Barber Ron Barber 2003-11
amx-rms 3839 udp AMX Resource Management Suite Ron Barber Ron Barber 2003-11
vrpn 3883 tcp VR Peripheral Network Sensics Yuval Boger 2003-10 2015-05-04
vrpn 3883 udp VR Peripheral Network Sensics Yuval Boger 2003-10 2015-05-04
eisp 3983 tcp ESRI Image Service Keith Ryden Keith Ryden 2006-07
eisp 3983 udp ESRI Image Service Keith Ryden Keith Ryden 2006-07
lorica-out-sec 4083 tcp Lorica outside facing (SSL) Johannes Skov Frandsen Johannes Skov Frandsen 2008-02-28
lorica-out-sec 4083 udp Lorica outside facing (SSL) Johannes Skov Frandsen Johannes Skov Frandsen 2008-02-28
cyborgnet 4183 tcp CyborgNet communications protocol Gareth Nelson Gareth Nelson 2015-11-13
cyborgnet 4183 udp CyborgNet communications protocol Gareth Nelson Gareth Nelson 2015-11-13
4481-4483 Unassigned
spike 4683 tcp Spike Clipboard Service Scott Herscher Scott Herscher 2005-08
spike 4683 udp Spike Clipboard Service Scott Herscher Scott Herscher 2005-08
4775-4783 Unassigned
4828-4836 Unassigned
varadero-0 4837 tcp Varadero-0
varadero-0 4837 udp Varadero-0
varadero-1 4838 tcp Varadero-1
varadero-1 4838 udp Varadero-1
varadero-2 4839 tcp Varadero-2 Carlos Arteaga Carlos Arteaga
varadero-2 4839 udp Varadero-2 Carlos Arteaga Carlos Arteaga
wmlserver 4883 tcp Meier-Phelps License Server William Phelps William Phelps 2010-03-22
4883 udp Reserved
4983 Unassigned 2005-12-22
qfp 5083 tcp Qpur File Protocol Joachim Kluemper Joachim Kluemper 2008-03-19
qfp 5083 udp Qpur File Protocol Joachim Kluemper Joachim Kluemper 2008-03-19
5283-5297 Unassigned
tmo-icon-sync 5583 tcp T-Mobile SMS Protocol Message 2 Donghwan Lim Donghwan Lim 2008-01-22
tmo-icon-sync 5583 udp T-Mobile SMS Protocol Message 2 Donghwan Lim Donghwan Lim 2008-01-22
coap 5683 tcp Constrained Application Protocol (CoAP) IESG IETF Chair 2017-12-22 RFC 8323
coap 5683 udp Constrained Application Protocol IESG IETF Chair 2011-06-13 2013-07-25 RFC 7252
coaps 5684 tcp Constrained Application Protocol (CoAP) IESG IETF Chair 2017-12-22 RFC 7301; RFC 8323
3par-mgmt-ssl 5783 tcp 3PAR Management Service with SSL Don Marselle Don Marselle 2008-03-19
3par-mgmt-ssl 5783 udp 3PAR Management Service with SSL Don Marselle Don Marselle 2008-03-19
jute 5883 tcp Javascript Unit Test Environment Mark Ethan Trostler Mark Ethan Trostler 2011-11-23
5970-5983 Unassigned
6083 tcp Reserved
miami-bcast 6083 udp telecomsoftware miami broadcast Peter Steiner Peter Steiner 2011-02-22
6383-6388 Unassigned
SunVTS-RMI 6483 tcp SunVTS RMI Sumit Arora Sumit Arora 2007-06
SunVTS-RMI 6483 udp SunVTS RMI Sumit Arora Sumit Arora 2007-06
joaJewelSuite 6583 tcp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11
joaJewelSuite 6583 udp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11
6779-6783 Unassigned
6818-6830 Unassigned
ambit-lm 6831 tcp ambit-lm Don Hejna Don Hejna
ambit-lm 6831 udp ambit-lm Don Hejna Don Hejna
6832-6840 Unassigned
genstat 7283 tcp General Statistics Rendezvous Protocol VSN International Ltd. Sean D. Sollé 2011-09-28
7283 udp Reserved
dmt 7683 tcp Cleondris DMT Cleondris GmbH Christian Plattner 2015-03-31
7683 udp Reserved
7782-7783 Unassigned
7983-7997 Unassigned
us-srv 8083 tcp Utilistor (Server) Andy Brewerton Andy Brewerton 2005-08
us-srv 8083 udp Utilistor (Server) Andy Brewerton Andy Brewerton 2005-08
proremote 8183 tcp ProRemote Alex Lelievre Alex Lelievre 2009-08-18
8183 udp Reserved
8283-8291 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alex Lelievre alex&folabs.com 2009-08-18
Andy Brewerton andy.brewerton&otium.co.uk 2005-08
Arno Klaassen arno&ccr.jussieu.fr 2003-11
Bob Rundle rundle&rundle.com 2005-11
Carlos Arteaga carteaga&abacoinc.com
Christian Plattner Cleondris GmbH christian.plattner&cleondris.ch 2015-03-31
Cleondris GmbH noc&cleondris.ch 2015-03-31
Don Hejna djhejna&ambit.com
Don Marselle don.marselle&3par.com 2008-04-09
Donghwan Lim donghwan.lim&t-mobile.com 2008-01-22
Gareth Nelson gareth&garethnelson.com 2015-11-13
George Rudy george&entsoft.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jan Rutger Voorhorst janrutger&roadware.nl 2006-10
Joachim Kluemper ports&raikosoft.com 2008-03-19
Johannes Skov Frandsen joe&42tools.com 2008-02-28
Keith Ryden kryden&esri.com 2006-07
Ketul Patel ketulp76&yahoo.com 2006-10
Khelben Blackstaff khelben&gmx.at
Mark Ethan Trostler mark&zzo.com 2011-11-23
Mark Stevens mstevens&ellacoya.com
Markus Sabadello sabadello&starbot.org
Matt Ferrari XXT LLC xxt.matt&sbcglobal.net 2012-07-12
Michael Stein mvs&apple.com
Mike Craft mcraft&cerner.com 2008-01-29
Peter Egli peter.egli&mail.inalp.com
Peter Kollath peter.kollath&canex.sk 2002-08
Peter Steiner steiner&telecomsoftware.com 2011-02-22
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Qiang Zhang qzhang&iwncomm.com 2006-10
Ron Barber ron.barber&amx.com 2003-11
SONET Internetworking Forum (SIF) bwarijsman&lucent.com
Scott Herscher scott&porchdogsoft.com 2005-08
Sean Adams sean&slimdevices.com 2002-05
Sean D. Sollé VSN International Ltd. sean&vsni.co.uk 2011-09-28
Sensics vrpn&sensics.com 2015-05-04
Sumit Arora sumit.arora&sun.com 2007-06
Thomas Driemeyer thomas&bitrot.de
Vadym Kargin vkargin&markem.com 2005-08
VSN International Ltd. sean&vsni.co.uk 2011-09-28
Walter G. Giroir walt_giroir&bmc.com 2003-07
William Phelps william&meier-phelps.com 2010-03-22
XXT LLC xxt.matt&sbcglobal.net 2012-07-12
Yuval Boger Sensics vrpn&sensics.com 2015-05-04