Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-04

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dxmessagebase2 2875 tcp DX Message Base Transport Protocol G.E. Ozz Nixon Jr. G.E. Ozz Nixon Jr. 2009-01-13
dxmessagebase2 2875 udp DX Message Base Transport Protocol G.E. Ozz Nixon Jr. G.E. Ozz Nixon Jr. 2009-01-13
sps-tunnel 2876 tcp SPS Tunnel Bill McIntosh Bill McIntosh
sps-tunnel 2876 udp SPS Tunnel Bill McIntosh Bill McIntosh
bluelance 2877 tcp BLUELANCE Michael Padrezas Michael Padrezas
bluelance 2877 udp BLUELANCE Michael Padrezas Michael Padrezas
aap 2878 tcp AAP Stephen Hanna Stephen Hanna
aap 2878 udp AAP Stephen Hanna Stephen Hanna
ucentric-ds 2879 tcp ucentric-ds Alex Vasilevsky Alex Vasilevsky
ucentric-ds 2879 udp ucentric-ds Alex Vasilevsky Alex Vasilevsky
aironetddp 2887 tcp aironet Victor Griswold Victor Griswold
aironetddp 2887 udp aironet Victor Griswold Victor Griswold
identify 2987 tcp identify
identify 2987 udp identify
asoki-sma 3087 tcp Asoki SMA Andrew Mossberg Andrew Mossberg
asoki-sma 3087 udp Asoki SMA Andrew Mossberg Andrew Mossberg
odi-port 3187 tcp Open Design Listen Port Phivos Aristides Phivos Aristides
odi-port 3187 udp Open Design Listen Port Phivos Aristides Phivos Aristides
directvdata 3287 tcp DIRECTVDATA Michael Friedman Michael Friedman
directvdata 3287 udp DIRECTVDATA Michael Friedman Michael Friedman
backroomnet 3387 tcp Back Room Net Clayton Wilkinson Clayton Wilkinson
backroomnet 3387 udp Back Room Net Clayton Wilkinson Clayton Wilkinson
ltctcp 3487 tcp LISA TCP Transfer Channel
ltcudp 3487 udp LISA UDP Transfer Channel Pit Vetterick Pit Vetterick 2002-05
p2pgroup 3587 tcp Peer to Peer Grouping Igor Kostic Igor Kostic 2002-08
p2pgroup 3587 udp Peer to Peer Grouping Igor Kostic Igor Kostic 2002-08
simple-push 3687 tcp simple-push
simple-push 3687 udp simple-push
fintrx 3787 tcp Fintrx Peter G. L. Potgieser Peter G. L. Potgieser 2003-07
fintrx 3787 udp Fintrx Peter G. L. Potgieser Peter G. L. Potgieser 2003-07
ovsam-d-agent 3870 tcp hp OVSAM HostAgent Disco Mike Pontillo Mike Pontillo 2003-08
ovsam-d-agent 3870 udp hp OVSAM HostAgent Disco Mike Pontillo Mike Pontillo 2003-08
avocent-adsap 3871 tcp Avocent DS Authorization Eduardo Fernandez Eduardo Fernandez 2003-08
avocent-adsap 3871 udp Avocent DS Authorization Eduardo Fernandez Eduardo Fernandez 2003-08
oem-agent 3872 tcp OEM Agent Narain Jagathesan Narain Jagathesan 2003-11
oem-agent 3872 udp OEM Agent Narain Jagathesan Narain Jagathesan 2003-11
fagordnc 3873 tcp fagordnc Luis Zugasti Luis Zugasti 2003-11
fagordnc 3873 udp fagordnc Luis Zugasti Luis Zugasti 2003-11
sixxsconfig 3874 tcp SixXS Configuration Jeroen Massar Jeroen Massar 2003-11
sixxsconfig 3874 udp SixXS Configuration Jeroen Massar Jeroen Massar 2003-11
pnbscada 3875 tcp PNBSCADA Philip N. Bergstresser Philip N. Bergstresser
pnbscada 3875 udp PNBSCADA Philip N. Bergstresser Philip N. Bergstresser
dl-agent 3876 tcp DirectoryLockdown Agent

IANA assigned this well-formed service name as a replacement for "dl_agent".
Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16
dl_agent 3876 tcp DirectoryLockdown Agent Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16 This entry is an alias to "dl-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
dl-agent 3876 udp DirectoryLockdown Agent

IANA assigned this well-formed service name as a replacement for "dl_agent".
Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16
dl_agent 3876 udp DirectoryLockdown Agent Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16 This entry is an alias to "dl-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
xmpcr-interface 3877 tcp XMPCR Interface Port Christopher Carlson Christopher Carlson 2003-10
xmpcr-interface 3877 udp XMPCR Interface Port Christopher Carlson Christopher Carlson 2003-10
fotogcad 3878 tcp FotoG CAD interface Jason Szabo Jason Szabo 2003-10
fotogcad 3878 udp FotoG CAD interface Jason Szabo Jason Szabo 2003-10
appss-lm 3879 tcp appss license manager Peter Krueger Peter Krueger 2003-10
appss-lm 3879 udp appss license manager Peter Krueger Peter Krueger 2003-10
ciphire-data 3887 tcp Ciphire Data Transport Lars Eilebrecht Lars Eilebrecht 2003-10
ciphire-data 3887 udp Ciphire Data Transport Lars Eilebrecht Lars Eilebrecht 2003-10
centerline 3987 tcp Centerline Mark Simpson Mark Simpson
centerline 3987 udp Centerline Mark Simpson Mark Simpson
applusservice 4087 tcp APplus Service Alfred Weindl Marcus Schairer 2008-06-05 2021-08-09
4087 udp Reserved
csc-proxy 4187 tcp Cascade Proxy

IANA assigned this well-formed service name as a replacement for "csc_proxy".
Matt Craighead Matt Craighead 2008-09-11
csc_proxy 4187 tcp Cascade Proxy Matt Craighead Matt Craighead 2008-09-11 This entry is an alias to "csc-proxy". This entry is now historic, not usable for use with many common service discovery mechanisms.
4187 udp Reserved
prex-tcp 4487 tcp Protocol for Remote Execution over TCP Daniel Ruppert Daniel Ruppert 2010-09-16
4487 udp Reserved
nst 4687 tcp Network Scanner Tool FTP Mala Bhat Mala Bhat 2005-08
nst 4687 udp Network Scanner Tool FTP Mala Bhat Mala Bhat 2005-08
sia-ctrl-plane 4787 tcp Service Insertion Architecture (SIA) Control-Plane Shree Murthy Shree Murthy 2009-10-29
4787 udp Reserved
cc-tracking 4870 tcp Citcom Tracking Service Wolfgang Weidner Wolfgang Weidner 2005-12
cc-tracking 4870 udp Citcom Tracking Service Wolfgang Weidner Wolfgang Weidner 2005-12
wired 4871 tcp Wired Axel Andersson Axel Andersson 2006-02
wired 4871 udp Wired Axel Andersson Axel Andersson 2006-02
4872-4875 Unassigned
tritium-can 4876 tcp Tritium CAN Bus Bridge Service James Kennedy James Kennedy 2011-02-15
tritium-can 4876 udp Tritium CAN Bus Bridge Service James Kennedy James Kennedy 2011-02-15
lmcs 4877 tcp Lighting Management Control System Timothy Parry Timothy Parry 2011-02-15
lmcs 4877 udp Lighting Management Control System Timothy Parry Timothy Parry 2011-02-15
4878 tcp Reserved
inst-discovery 4878 udp Agilent Instrument Discovery Charles F Steele Charles F Steele 2011-02-15
wsdl-event 4879 tcp WSDL Event Receiver Charles F Steele Charles F Steele 2011-02-15
4879 udp Reserved
4886-4887 Unassigned
smar-se-port1 4987 tcp SMAR Ethernet Port 1
smar-se-port1 4987 udp SMAR Ethernet Port 1
biotic 5087 tcp BIOTIC - Binary Internet of Things Interoperable Communication Waher Data AB Peter Waher 2014-06-16 2015-11-25
5087 udp Reserved
pcp-multicast 5350 udp Port Control Protocol Multicast IESG IETF Chair RFC 6887
pcp 5351 udp Port Control Protocol IESG IETF Chair RFC 6887
dns-llq 5352 tcp DNS Long-Lived Queries Stuart Cheshire Stuart Cheshire 2005-08 2019-08-26 RFC 8764
dns-llq 5352 udp DNS Long-Lived Queries Stuart Cheshire Stuart Cheshire 2005-08 2019-08-26 RFC 8764
5587-5596 Unassigned
gog-multiplayer 5687 udp GOG multiplayer game protocol GOG.com Michał Gruchała 2014-07-31 2014-10-09
5687 tcp Reserved
5787 tcp Reserved
waascluster 5787 udp Cisco WAAS Cluster Protocol Winston Chou Winston Chou 2011-02-08
wbem-rmi 5987 tcp WBEM RMI Jim Davis Jim Davis
wbem-rmi 5987 udp WBEM RMI Jim Davis Jim Davis
ldss 6087 tcp Local Download Sharing Service Clifford Heath Clifford Heath 2006-05
ldss 6087 udp Local Download Sharing Service Clifford Heath Clifford Heath 2006-05
sun-sr-iiop-aut 6487 tcp Service Registry Default IIOPAuth Domain Paul Sterk Paul Sterk 2006-03
sun-sr-iiop-aut 6487 udp Service Registry Default IIOPAuth Domain Paul Sterk Paul Sterk 2006-03
6584-6587 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alex Vasilevsky alexv&204.165.216.115
Alfred Weindl alfred.weindl&assecosol.com 2021-08-09
Andrew Mossberg amossberg&asoki.net
Axel Andersson axel&zankasoftware.com 2006-02
Bill McIntosh bmcintosh&fortresstech.com
Charles F Steele charles_steele&agilent.com 2011-02-15
Christopher Carlson cjc&dobbz.com 2003-10
Clayton Wilkinson cwilkinson&carreker.com
Clifford Heath cjh&managesoft.com 2006-05
Daniel Ruppert daniel&kaffi.lu 2010-09-16
Eduardo Fernandez eduardo.fernandez&avocent.com 2003-08
G.E. Ozz Nixon Jr. ozznixon&gmail.com 2009-01-13
GOG.com admin&gog.com 2014-07-31
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Igor Kostic igorko&microsoft.com 2002-08
James Kennedy james&tritium.com.au 2011-02-15
Jason Lockett Jay.Lockett&quest.com 2008-12-16
Jason Szabo jason.szabo&vexcel.com 2003-10
Jeroen Massar jeroen&unfix.org 2005-08
Jim Davis jim.davis&wbemsolutions.com 2007-06
Lars Eilebrecht le+iana&leogic.com 2003-10
Luis Zugasti lzugasti&fagorautomation.es 2003-11
Mala Bhat bmala&ssdi.sharp.co.in 2005-08
Marcus Schairer marcus.schairer&assecosol.com 2021-08-09
Mark Simpson simpson&centerline.com
Matt Craighead matt.craighead&conifersystems.com 2008-09-11
Melanie Kacerek melanie.kacerek&quest.com 2008-12-16
Michael Friedman mfr1&worldnet.att.net
Michael Padrezas mpaderzas&bluelance.com
Michał Gruchała GOG.com admin&gog.com 2014-07-31
Mike Pontillo pontillo&hp.com 2003-08
Narain Jagathesan narain.jagathesan&oracle.com 2003-11
Paul Sterk paul.sterk&sun.com 2006-03
Peter G. L. Potgieser p.g.l.potgieser&interpay.nl 2003-07
Peter Krueger krueger&appss.de 2003-10
Peter Waher Waher Data AB peterwaher&hotmail.com 2015-11-25
Philip N. Bergstresser phil&bergstresser.org
Phivos Aristides phivos&opendesign.com
Pit Vetterick pit&3dgo.com 2002-05
Shree Murthy shree&cisco.com 2009-10-29
Stephen Hanna steve.hanna&sun.com
Stuart Cheshire cheshire&apple.com 2022-07-11
Timothy Parry tim&lumenergi.com 2011-02-15
Victor Griswold vgris&aironet.com
Waher Data AB peterwaher&hotmail.com 2015-11-25
Winston Chou wichou&cisco.com 2011-02-08
Wolfgang Weidner ww&citcom.de 2005-12