Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
z39.50 210 udp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
914c-g 211 tcp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 tcp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
914c-g 211 udp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 udp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
uarps 219 tcp Unisys ARPs Ashok Marwaha Ashok Marwaha
uarps 219 udp Unisys ARPs Ashok Marwaha Ashok Marwaha
249-255 Reserved 2024-12-20 RFC 1060
esro-gen 259 tcp Efficient Short Remote Operations Mohsen Banan Mohsen Banan
esro-gen 259 udp Efficient Short Remote Operations Mohsen Banan Mohsen Banan
manet 269 tcp MANET Protocols RFC 5498
manet 269 udp MANET Protocols RFC 5498
gist 270 udp Q-mode encapsulation for GIST messages RFC 5971
272-279 Unassigned
288-299 Unassigned
tacacss 300 tcp TLS Secure Login Host Protocol (TACACSS) IESG IETF Chair 2025-07-15 RFC 9887
entrusttime 309 tcp EntrustTime Peter Whittaker Peter Whittaker
entrusttime 309 udp EntrustTime Peter Whittaker Peter Whittaker
ptp-event 319 tcp PTP Event Kang Lee Kang Lee 2010-07-27
ptp-event 319 udp PTP Event Kang Lee Kang Lee 2010-07-27
mftp 349 tcp mftp Dave Feinleib Dave Feinleib
mftp 349 udp mftp Dave Feinleib Dave Feinleib
bhoetty 351 tcp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoetty 351 udp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 tcp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 udp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
rpc2portmap 369 tcp rpc2portmap
rpc2portmap 369 udp rpc2portmap
is99c 379 tcp TIA/EIA/IS-99 modem client
is99c 379 udp TIA/EIA/IS-99 modem client
is99s 380 tcp TIA/EIA/IS-99 modem server Frank Quick Frank Quick
is99s 380 udp TIA/EIA/IS-99 modem server Frank Quick Frank Quick
ldap 389 tcp Lightweight Directory Access Protocol Tim Howes Tim Howes
ldap 389 udp Lightweight Directory Access Protocol Tim Howes Tim Howes
uis 390 tcp UIS Ed Barron Ed Barron
uis 390 udp UIS Ed Barron Ed Barron
synotics-relay 391 tcp SynOptics SNMP Relay Port
synotics-relay 391 udp SynOptics SNMP Relay Port
synotics-broker 392 tcp SynOptics Port Broker Port Illan Raab Illan Raab
synotics-broker 392 udp SynOptics Port Broker Port Illan Raab Illan Raab
meta5 393 tcp Meta5 Jim Kanzler Jim Kanzler
meta5 393 udp Meta5 Jim Kanzler Jim Kanzler
embl-ndt 394 tcp EMBL Nucleic Data Transfer Peter Gad Peter Gad
embl-ndt 394 udp EMBL Nucleic Data Transfer Peter Gad Peter Gad
netcp 395 tcp NetScout Control Protocol Ashwani Singhal Ashwani Singhal 2010-04-07
netcp 395 udp NetScout Control Protocol Ashwani Singhal Ashwani Singhal 2010-04-07
netware-ip 396 tcp Novell Netware over IP
netware-ip 396 udp Novell Netware over IP
mptn 397 tcp Multi Protocol Trans. Net. Soumitra Sarkar Soumitra Sarkar
mptn 397 udp Multi Protocol Trans. Net. Soumitra Sarkar Soumitra Sarkar
kryptolan 398 tcp Kryptolan Peter de Laval Peter de Laval
kryptolan 398 udp Kryptolan Peter de Laval Peter de Laval
iso-tsap-c2 399 tcp ISO Transport Class 2 Non-Control over TCP Yanick Pouffary Yanick Pouffary
iso-tsap-c2 399 udp ISO Transport Class 2 Non-Control over UDP Yanick Pouffary Yanick Pouffary
prm-nm 409 tcp Prospero Resource Manager Node Man. B. Clifford Neuman B. Clifford Neuman
prm-nm 409 udp Prospero Resource Manager Node Man. B. Clifford Neuman B. Clifford Neuman
ariel1 419 tcp Ariel 1 Joel Karafin Joel Karafin
ariel1 419 udp Ariel 1 Joel Karafin Joel Karafin
ocs-amu 429 tcp OCS_AMU

IANA assigned this well-formed service name as a replacement for "ocs_amu".
Florence Wyman Florence Wyman
ocs_amu 429 tcp OCS_AMU Florence Wyman Florence Wyman This entry is an alias to "ocs-amu". This entry is now historic, not usable for use with many common service discovery mechanisms.
ocs-amu 429 udp OCS_AMU

IANA assigned this well-formed service name as a replacement for "ocs_amu".
Florence Wyman Florence Wyman
ocs_amu 429 udp OCS_AMU Florence Wyman Florence Wyman This entry is an alias to "ocs-amu". This entry is now historic, not usable for use with many common service discovery mechanisms.
nnsp 433 tcp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
nnsp 433 udp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
dasp 439 tcp dasp Thomas Obermair Thomas Obermair
dasp 439 udp dasp Thomas Obermair Thomas Obermair
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 sctp HTTPS Randall Stewart Randall Stewart 2022-02-07 RFC 9260
as-servermap 449 tcp AS Server Mapper Barbara Foss Barbara Foss
as-servermap 449 udp AS Server Mapper Barbara Foss Barbara Foss
ampr-rcmd 459 tcp ampr-rcmd Rob Janssen Rob Janssen
ampr-rcmd 459 udp ampr-rcmd Rob Janssen Rob Janssen
rcp 469 tcp Radio Control Protocol Jim Jennings Jim Jennings
rcp 469 udp Radio Control Protocol Jim Jennings Jim Jennings
iafserver 479 tcp iafserver
iafserver 479 udp iafserver
nest-protocol 489 tcp nest-protocol Gilles Gameiro Gilles Gameiro
nest-protocol 489 udp nest-protocol Gilles Gameiro Gilles Gameiro
micom-pfs 490 tcp micom-pfs David Misunas David Misunas
micom-pfs 490 udp micom-pfs David Misunas David Misunas
go-login 491 tcp go-login Troy Morrison Troy Morrison
go-login 491 udp go-login Troy Morrison Troy Morrison
ticf-1 492 tcp Transport Independent Convergence for FNA
ticf-1 492 udp Transport Independent Convergence for FNA
ticf-2 493 tcp Transport Independent Convergence for FNA Mamoru Ito Mamoru Ito
ticf-2 493 udp Transport Independent Convergence for FNA Mamoru Ito Mamoru Ito
pov-ray 494 tcp POV-Ray POV-Team Co-ordinator POV-Team Co-ordinator
pov-ray 494 udp POV-Ray POV-Team Co-ordinator POV-Team Co-ordinator
intecourier 495 tcp intecourier Steve Favor Steve Favor
intecourier 495 udp intecourier Steve Favor Steve Favor
pim-rp-disc 496 tcp PIM-RP-DISC Dino Farinacci Dino Farinacci
pim-rp-disc 496 udp PIM-RP-DISC Dino Farinacci Dino Farinacci
retrospect 497 tcp Retrospect backup and restore service Retrospect, Inc. JG Heithcock 2012-02-02
retrospect 497 udp Retrospect backup and restore service Retrospect, Inc. JG Heithcock 2012-02-02
siam 498 tcp siam Philippe Gilbert Philippe Gilbert
siam 498 udp siam Philippe Gilbert Philippe Gilbert
iso-ill 499 tcp ISO ILL Protocol Mark H. Needleman Mark H. Needleman
iso-ill 499 udp ISO ILL Protocol Mark H. Needleman Mark H. Needleman

Contact Information

Name Organization Contact URI Last Updated
Ashok Marwaha
Ashwani Singhal Ashwani.Singhal&netscout.com 2010-04-07
B. Clifford Neuman bcn&isi.edu 2022-02-18
Barbara Foss BGFOSS&rchvmv.vnet.ibm.com
Bill Harrell
Dave Feinleib davefe&microsoft.com
David Misunas DMisunas&micom.com
Dino Farinacci dino&cisco.com 2008-08-21
Ed Barron
Florence Wyman wyman&peabody.plk.af.mil
Frank Quick fquick&qualcomm.com
Gilles Gameiro ggameiro&birdland.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Illan Raab iraab&synoptics.com
JG Heithcock Retrospect, Inc. JG.Heithcock&retrospect.com 2012-02-02
Jim Jennings tel:+1-708-538-7241
Jim Kanzler jim.kanzler&meta5.com
Joel Karafin jkarafin&infotrieve.com
John Kelly johnk&bellhow.com
Kang Lee I&M Society TC-9 kang.lee&nist.gov 2010-07-27
Mamoru Ito Ito&pcnet.ks.pfu.co.jp
Mark H. Needleman markn&sirsi.com
Mohsen Banan mohsen&rostam.neda.com
Peter Gad peter&bmc.uu.se
Peter Whittaker pww&entrust.com
Peter de Laval pdl&sectra.se
Philippe Gilbert pgilbert&cal.fr
POV-Team Co-ordinator iana-port.remove-spamguard&povray.org
Randall Stewart IETF TSVWG rrs&lakerest.net
Retrospect, Inc. JG.Heithcock&retrospect.com 2012-02-02
Rob Janssen rob&sys3.pe1chl.ampr.org
Soumitra Sarkar sarkar&vnet.ibm.com
Steve Favor sfavor&tigger.intecom.com
Thomas Obermair tommy&inlab.m.eunet.de
Tim Howes Tim.Howes&terminator.cc.umich.edu
Troy Morrison troy&graphon.com
Yanick Pouffary pouffary&taec.enet.dec.com