Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
quicksuite 2900 tcp QUICKSUITE William Egge William Egge
quicksuite 2900 udp QUICKSUITE William Egge William Egge
allstorcns 2901 tcp ALLSTORCNS Steve Dobson Steve Dobson
allstorcns 2901 udp ALLSTORCNS Steve Dobson Steve Dobson
netaspi 2902 tcp NET ASPI Johnson Luo Johnson Luo
netaspi 2902 udp NET ASPI Johnson Luo Johnson Luo
suitcase 2903 tcp SUITCASE Milton E. Sagen Milton E. Sagen
suitcase 2903 udp SUITCASE Milton E. Sagen Milton E. Sagen
m2ua 2904 tcp M2UA Lyndon Ong Lyndon Ong
m2ua 2904 udp M2UA Lyndon Ong Lyndon Ong
m2ua 2904 sctp M2UA Lyndon Ong Lyndon Ong
m3ua 2905 tcp M3UA Lyndon Ong Lyndon Ong RFC 4666
2905 udp De-registered 2001-06-07
m3ua 2905 sctp M3UA Lyndon Ong Lyndon Ong RFC 4666
caller9 2906 tcp CALLER9 Shams Naqi Shams Naqi
caller9 2906 udp CALLER9 Shams Naqi Shams Naqi
webmethods-b2b 2907 tcp WEBMETHODS B2B Joseph Hines Joseph Hines
webmethods-b2b 2907 udp WEBMETHODS B2B Joseph Hines Joseph Hines
mao 2908 tcp mao Marc Baudoin Marc Baudoin
mao 2908 udp mao Marc Baudoin Marc Baudoin
funk-dialout 2909 tcp Funk Dialout Cimarron Boozer Cimarron Boozer
funk-dialout 2909 udp Funk Dialout Cimarron Boozer Cimarron Boozer
boscap 2990 tcp BOSCAP Dirk Hillbrecht Dirk Hillbrecht
boscap 2990 udp BOSCAP Dirk Hillbrecht Dirk Hillbrecht
stss 3090 tcp Senforce Session Services Peter Boucher Peter Boucher
stss 3090 udp Senforce Session Services Peter Boucher Peter Boucher
itu-bicc-stc 3097 sctp ITU-T Q.1902.1/Q.2150.3 Greg Sidebottom Greg Sidebottom
csvr-proxy 3190 tcp ConServR Proxy
csvr-proxy 3190 udp ConServR Proxy
caps-lm 3290 tcp CAPS LOGISTICS TOOLKIT - LM Joseph Krebs Joseph Krebs
caps-lm 3290 udp CAPS LOGISTICS TOOLKIT - LM Joseph Krebs Joseph Krebs
dsc 3390 tcp Distributed Service Coordinator Charles Honton Charles Honton
dsc 3390 udp Distributed Service Coordinator Charles Honton Charles Honton
colubris 3490 tcp Colubris Management Port Gilbert Moineau Gilbert Moineau 2002-05
colubris 3490 udp Colubris Management Port Gilbert Moineau Gilbert Moineau 2002-05
wv-csp-sms 3590 tcp WV CSP SMS Binding Matti Salmi Matti Salmi 2002-08
wv-csp-sms 3590 udp WV CSP SMS Binding Matti Salmi Matti Salmi 2002-08
svn 3690 tcp Subversion Greg Hudson Greg Hudson 2003-01
svn 3690 udp Subversion Greg Hudson Greg Hudson 2003-01
quickbooksrds 3790 tcp QuickBooks RDS Almira Almira 2003-07
quickbooksrds 3790 udp QuickBooks RDS Almira Almira 2003-07
ndsconnect 3890 tcp Niche Data Server Connect Roland Schneider Roland Schneider 2003-10
ndsconnect 3890 udp Niche Data Server Connect Roland Schneider Roland Schneider 2003-10
udt-os 3900 tcp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 tcp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
udt-os 3900 udp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 udp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
nimsh 3901 tcp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimsh 3901 udp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 tcp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 udp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
charsetmgr 3903 tcp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
charsetmgr 3903 udp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
omnilink-port 3904 tcp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
omnilink-port 3904 udp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
mupdate 3905 tcp Mailbox Update (MUPDATE) protocol RFC 3656
mupdate 3905 udp Mailbox Update (MUPDATE) protocol RFC 3656
topovista-data 3906 tcp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
topovista-data 3906 udp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
imoguia-port 3907 tcp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
imoguia-port 3907 udp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
hppronetman 3908 tcp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
hppronetman 3908 udp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
surfcontrolcpa 3909 tcp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
surfcontrolcpa 3909 udp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
bv-is 3990 tcp BindView-IS
bv-is 3990 udp BindView-IS
omasgport 4090 tcp OMA BCAST Service Guide Mark Lipford Mark Lipford 2006-07
omasgport 4090 udp OMA BCAST Service Guide Mark Lipford Mark Lipford 2006-07
sieve 4190 tcp ManageSieve Protocol
4190 udp Reserved RFC 5804
wiegand 4390 tcp Physical Access Control Scott Guthery Scott Guthery 2008-08-25
wiegand 4390 udp Physical Access Control Scott Guthery Scott Guthery 2008-08-25
4489-4499 Unassigned Known UNAUTHORIZED USE: Ports 4490 and 4491
rid 4590 tcp RID over HTTP/TLS IESG IETF Chair RFC 6546
4590 udp Reserved
prelude 4690 tcp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
prelude 4690 udp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
vxlan-gpe 4790 udp Generic Protocol Extension for Virtual eXtensible Local Area Network (VXLAN) Lawrence Kreeger Lawrence Kreeger 2014-08-26
4790 tcp Reserved
4890-4893 Unassigned
hfcs 4900 tcp HFSQL Client/Server Database Engine PC SOFT Jerome AERTS 2006-03-02 2014-02-02
hfcs 4900 udp HFSQL Client/Server Database Engine PC SOFT Jerome AERTS 2006-03-02 2014-02-02
flr-agent 4901 tcp FileLocator Remote Search Agent

IANA assigned this well-formed service name as a replacement for "flr_agent".
David Vest David Vest 2008-11-19
flr_agent 4901 tcp FileLocator Remote Search Agent David Vest David Vest 2008-11-19 This entry is an alias to "flr-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
4901 udp Reserved
magiccontrol 4902 tcp magicCONROL RF and Data Interface Andreas Spalenski Andreas Spalenski 2008-11-24
4902 udp Reserved
4903-4911 Unassigned
busycal 4990 tcp BusySync Calendar Synch. Protocol David Riggle David Riggle 2008-01-07 Defined TXT keys: Proprietary
busycal 4990 udp BusySync Calendar Synch. Protocol David Riggle David Riggle 2008-01-07 Defined TXT keys: Proprietary
car 5090 sctp Candidate AR
aol 5190 tcp America-Online Marty Lyons Marty Lyons
aol 5190 udp America-Online Marty Lyons Marty Lyons
5690-5692 Unassigned
rfb 5900 tcp Remote Framebuffer Tristan Richardson Tristan Richardson 2006-03 RFC 6143
rfb 5900 udp Remote Framebuffer Tristan Richardson Tristan Richardson 2006-03 RFC 6143
5901-5902 Unassigned
ff-ice 5903 tcp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 udp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 sctp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE

Contact Information

Name Organization Contact URI Last Updated
Almira almira_niciu&intuit.com 2003-07
Andreas Spalenski andreas.spalenski&trsystems.de 2008-11-24
Charles Honton chas&honton.org
Cimarron Boozer cboozer&funk.com
David Riggle dave&busymac.com 2008-01-07
David Vest dave&mythicsoft.com 2008-11-19
Devon Dawson devon.dawson&hp.com 2003-11
Dirk Hillbrecht dirk&hillbrecht.de
Emidio Cunha emidio&janeladigital.com 2003-11
Gilbert Moineau gilbert.moineau&colubris.com 2002-05
Greg Hudson ghudson&mit.edu 2023-11-17
Greg Saccone gregory.t.saccone&boeing.com 2022-08-08
Greg Sidebottom gregside&home.com
Gregg Townsend gmt&cs.arizona.edu 2003-11
Hywel Morgan hywelm&surfcontrol.com 2003-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
International Civil Aviation Organisation (ICAO) gisinbox&icao.int 2024-11-19
James Powell james&mailhost.unidata.com
Jerome AERTS PC SOFT jae&pcsoft.fr 2014-02-02
Johnson Luo johnson_luo&mail.sercomm.com.tw
Joseph Hines jhines&webmethods.com
Joseph Krebs joek&caps.com
Lawrence Kreeger kreeger&cisco.com 2013-04-19
Lyndon Ong LyOng&ciena.com
Marc Baudoin babafou&babafou.eu.org
Mark Lipford mark.a.lipford&sprint.com 2006-07
Marty Lyons marty&aol.com
Matti Salmi matti.salmi&nokia.com 2002-08
Milton E. Sagen msagen&extensis.com
Paul B. Finley pfinley&us.ibm.com 2003-10
PC SOFT jae&pcsoft.fr 2014-02-02
Peter Boucher pboucher&senforce.com
Roland Schneider rsch&nicherms.com 2003-10
Ronen Shaul ronen&arnetsystems.com 2003-10
Scott Guthery sguthery&hidcorp.com 2008-08-25
Shams Naqi SSNAQVI&aol.com
Steve Dobson sdobson&allstor.com
Tatsuya Ueda tatsu&ist.fujitsu.com 2003-10
Tristan Richardson iana&realvnc.com 2006-03
William Egge begge&emagisoft.com
Yoann Vandoorselaere yoann&prelude-ids.org 2005-08