Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ttc-etap-ds 2978 udp TTCs Enterprise Test Access Protocol - DS Daniel Becker Daniel Becker
h263-video 2979 tcp H.263 Video Streaming Jauvane C. de Oliveira Jauvane C. de Oliveira
h263-video 2979 udp H.263 Video Streaming Jauvane C. de Oliveira Jauvane C. de Oliveira
rebol 2997 tcp REBOL Holger Kruse Holger Kruse
rebol 2997 udp REBOL Holger Kruse Holger Kruse
3097 tcp Reserved
3097 udp Reserved
itu-bicc-stc 3097 sctp ITU-T Q.1902.1/Q.2150.3 Greg Sidebottom Greg Sidebottom
embrace-dp-s 3197 tcp Embrace Device Protocol Server
embrace-dp-s 3197 udp Embrace Device Protocol Server
cytel-lm 3297 tcp Cytel License Manager Yogesh P. Gajjar Yogesh P. Gajjar
cytel-lm 3297 udp Cytel License Manager Yogesh P. Gajjar Yogesh P. Gajjar
cloanto-lm 3397 tcp Cloanto License Manager Takeo Sato Takeo Sato 2010-04-30
cloanto-lm 3397 udp Cloanto License Manager Takeo Sato Takeo Sato 2010-04-30
ipether232port 3497 tcp ipEther232Port Marcus Leufgen Marcus Leufgen 2002-05
ipether232port 3497 udp ipEther232Port Marcus Leufgen Marcus Leufgen 2002-05
a14 3597 tcp A14 (AN-to-SC/MM)
a14 3597 udp A14 (AN-to-SC/MM)
nw-license 3697 tcp NavisWorks License System Tim Wiegand Tim Wiegand 2003-02
nw-license 3697 udp NavisWorks License System Tim Wiegand Tim Wiegand 2003-02
idps 3797 tcp idps Jean-Francois Rabasse Jean-Francois Rabasse 2003-07
idps 3797 udp idps Jean-Francois Rabasse Jean-Francois Rabasse 2003-07
sdo-ssh 3897 tcp Simple Distributed Objects over SSH Alexander Philippou Alexander Philippou 2003-10
sdo-ssh 3897 udp Simple Distributed Objects over SSH Alexander Philippou Alexander Philippou 2003-10
lanrevagent 3970 tcp LANrev Agent Martin Bestmann Martin Bestmann Defined TXT keys:
txtvers
server=<main LANrev server for agent>
vers=<version of LANrev Agent>
build=<build number of LANrev Agent>
id=<agent identifier>
lanrevagent 3970 udp LANrev Agent Martin Bestmann Martin Bestmann Defined TXT keys:
txtvers
server=<main LANrev server for agent>
vers=<version of LANrev Agent>
build=<build number of LANrev Agent>
id=<agent identifier>
lanrevserver 3971 tcp LANrev Server Martin Bestmann Martin Bestmann 2005-08
lanrevserver 3971 udp LANrev Server Martin Bestmann Martin Bestmann 2005-08
iconp 3972 tcp ict-control Protocol Roel Harbers Roel Harbers 2005-08
iconp 3972 udp ict-control Protocol Roel Harbers Roel Harbers 2005-08
progistics 3973 tcp ConnectShip Progistics ConnectShip, Inc. Robert Kinyon 2005-08 2019-12-12
progistics 3973 udp ConnectShip Progistics ConnectShip, Inc. Robert Kinyon 2005-08 2019-12-12
xk22 3974 tcp Remote Applicant Tracking Service Marc Castelluccio Marc Castelluccio 2005-08 2022-09-09
xk22 3974 udp Remote Applicant Tracking Service Marc Castelluccio Marc Castelluccio 2005-08 2022-09-09
airshot 3975 tcp Air Shot Shingo Kimura Shingo Kimura 2005-08
airshot 3975 udp Air Shot Shingo Kimura Shingo Kimura 2005-08
opswagent 3976 tcp Server Automation Agent Hewlett Packard Enterprise Cristi Fati 2016-04-14
opswagent 3976 udp Server Automation Agent Hewlett Packard Enterprise Cristi Fati 2016-04-14
opswmanager 3977 tcp Opsware Manager Dave Jagoda Dave Jagoda 2006-06
opswmanager 3977 udp Opsware Manager Dave Jagoda Dave Jagoda 2006-06
secure-cfg-svr 3978 tcp Secured Configuration Server Dr. Anupam Bharali Dr. Anupam Bharali 2006-06
secure-cfg-svr 3978 udp Secured Configuration Server Dr. Anupam Bharali Dr. Anupam Bharali 2006-06
smwan 3979 tcp Smith Micro Wide Area Network Service David Sperling David Sperling 2006-06
smwan 3979 udp Smith Micro Wide Area Network Service David Sperling David Sperling 2006-06
agentsease-db 3997 tcp aes_db Colin Hughes Colin Hughes 2006-02
agentsease-db 3997 udp aes_db Colin Hughes Colin Hughes 2006-02
patrolview 4097 tcp Patrol View Portnoy Boxman Portnoy Boxman
patrolview 4097 udp Patrol View Portnoy Boxman Portnoy Boxman
hctl 4197 tcp Harman HControl Protocol Harman International Industries Inc. Darin Smith 2017-02-16
hctl 4197 udp Harman HControl Protocol Harman International Industries Inc. Darin Smith 2017-02-16
4397-4399 Unassigned
a21-an-1xbs 4597 tcp A21 (AN-1xBS) David Ott David Ott 2006-02
a21-an-1xbs 4597 udp A21 (AN-1xBS) David Ott David Ott 2006-02
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
dots-signal 4646 udp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
ccss-qsm 4970 tcp CCSS QSystemMonitor David Young David Young 2006-01
ccss-qsm 4970 udp CCSS QSystemMonitor David Young David Young 2006-01
burp 4971 tcp BackUp and Restore Program Marat Khalili Marat Khalili 2017-08-23
4971 udp Reserved
4972-4979 Unassigned
tunstall-lwp 5197 tcp Tunstall Lone worker device interface Tunstall Healthcare (UK) Ltd. Robert Moore 2014-12-10
5197 udp Reserved
5283-5297 Unassigned
stresstester 5397 tcp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08
stresstester 5397 udp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08
ininmessaging 5597 tcp inin secure messaging Mike Gagle Mike Gagle 2006-05
ininmessaging 5597 udp inin secure messaging Mike Gagle Mike Gagle 2006-05
5697-5699 Unassigned
5795-5797 Unassigned
5970-5983 Unassigned
ircs-u 6697 tcp Internet Relay Chat via TLS/SSL 2014-02-11 RFC 7194
6697 udp Reserved 2014-02-11
conductor 6970 tcp Conductor test coordination protocol George Neville-Neil George Neville-Neil 2014-09-18
6970 udp Reserved
conductor-mpx 6970 sctp conductor for multiplex George Neville-Neil George Neville-Neil 2014-07-29
6971-6979 Unassigned
MobilitySrv 6997 tcp Mobility XE Protocol Joseph T Savarese Joseph T Savarese 2007-06
MobilitySrv 6997 udp Mobility XE Protocol Joseph T Savarese Joseph T Savarese 2007-06
hexarc 7397 tcp Hexarc Command Language George Moromisato George Moromisato 2004-11
hexarc 7397 udp Hexarc Command Language George Moromisato George Moromisato 2004-11
klio 7697 tcp KLIO communications Helmut Giritzer Helmut Giritzer 2005-08
klio 7697 udp KLIO communications Helmut Giritzer Helmut Giritzer 2005-08
pnet-conn 7797 tcp Propel Connector port
pnet-conn 7797 udp Propel Connector port
7968-7978 Unassigned
micromuse-ncps 7979 tcp Micromuse-ncps Hing Wing To Hing Wing To
micromuse-ncps 7979 udp Micromuse-ncps Hing Wing To Hing Wing To
7983-7997 Unassigned
pushns 7997 tcp PUSH Notification Service Tristan Seifert Tristan Seifert 2011-01-31
7997 udp Reserved
sac 8097 tcp SAC Port Id Girish Bhat Girish Bhat 2006-04
sac 8097 udp SAC Port Id Girish Bhat Girish Bhat 2006-04
8955-8979 Unassigned
oracle-ms-ens 8997 tcp Oracle Messaging Server Event Notification Service Oracle Corp. Hubert Vijay Arokiasamy 2014-10-28
8997 udp Reserved
mpidcagt 9397 tcp MpIdcAgt Yutaka Ono Yutaka Ono
mpidcagt 9397 udp MpIdcAgt Yutaka Ono Yutaka Ono
pd-admin 9597 tcp PD Administration Duk Loi Duk Loi 2005-11
pd-admin 9597 udp PD Administration Duk Loi Duk Loi 2005-11
board-roar 9700 tcp Board M.I.T. Service Francesco Rosi Francesco Rosi 2006-01
board-roar 9700 udp Board M.I.T. Service Francesco Rosi Francesco Rosi 2006-01

Contact Information

Name Organization Contact URI Last Updated
Alexander Philippou alex&noemax.com 2003-10
Colin Hughes chughes&agentsease.net 2006-02
ConnectShip, Inc. ConnectShipIT&connectship.com 2019-12-12
Cristi Fati cristi.fati&hpe.com 2016-04-13
Daniel Becker beckerd&ttc.com
Darin Smith darin.smith&harman.com 2017-02-16
Dave Jagoda dj&opsware.com 2006-06
David Ott dott&qualcomm.com 2010-10-15
David Sperling dsperling&smithmicro.com 2006-06
David Young david.young&ccsseurope.co.uk 2006-01
Dr. Anupam Bharali paniana&gmail.com 2006-06
Duk Loi dloi&peerdirect.com 2005-11
Francesco Rosi frosi&orenburg.com 2006-01
George Moromisato gpm&neurohack.com 2004-11
George Neville-Neil gnn&neville-neil.com 2014-07-29
Girish Bhat gbhat&cranite.com 2006-04
Graham Parsons graham.parsons&reflective.com 2005-08
Greg Sidebottom gregside&home.com
Harman International Industries Inc. darin.smith&harman.com 2017-02-16
Helmut Giritzer helmut.giritzer&o.roteskreuz.at 2005-08
Hewlett Packard Enterprise 2016-04-14
Hing Wing To wing.to&mircromuse.com
Holger Kruse holger&rebol.net
Hubert Vijay Arokiasamy Oracle Corp. hubert.vijay.arokiasamy&oracle.com 2014-10-28
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jauvane C. de Oliveira jauvane&acm.org
Jean-Francois Rabasse jfr&idps.org 2003-07
Joseph T Savarese joesa&nmwco.com 2007-06
Marat Khalili qm2k&yandex.ru 2017-08-23
Marc Castelluccio marc&xk22.com 2022-08-16
Marcus Leufgen leufgen&ipcas.de 2002-05
Martin Bestmann martin&poleposition-sw.com 2005-08
Mike Gagle mikeg&inin.com 2006-05
Oracle Corp. hubert.vijay.arokiasamy&oracle.com 2014-10-28
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Robert Kinyon rkinyon&connectship.com 2019-12-12
Robert Moore Tunstall Healthcare (UK) Ltd. robert.moore&tunstall.com 2014-12-10
Roel Harbers r.harbers&ict-control.com 2005-08
Shingo Kimura Shingo.Kimura&jp.sony.com 2005-08
Takeo Sato ts-iana&cloanto.net 2010-04-30
Tim Wiegand tim.wiegand&navisworks.com 2003-02
Tristan Seifert admin&247server.net 2011-01-31
Tunstall Healthcare (UK) Ltd. robert.moore&tunstall.com 2014-12-10
Yogesh P. Gajjar yogesh&cytel.com
Yutaka Ono ono&saint.nm.fujitsu.co.jp