Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| linktest | 3746 | tcp | LXPRO.COM LinkTest | ||||||||
| linktest | 3746 | udp | LXPRO.COM LinkTest | ||||||||
| linktest-s | 3747 | tcp | LXPRO.COM LinkTest SSL | Greg Bailey | Greg Bailey | 2003-04 | |||||
| linktest-s | 3747 | udp | LXPRO.COM LinkTest SSL | Greg Bailey | Greg Bailey | 2003-04 | |||||
| webdata | 3748 | tcp | webData | Michael Whiteley | Michael Whiteley | 2003-04 | |||||
| webdata | 3748 | udp | webData | Michael Whiteley | Michael Whiteley | 2003-04 | |||||
| cimtrak | 3749 | tcp | CimTrak | Robert E. Johnson III | Robert E. Johnson III | 2003-04 | |||||
| cimtrak | 3749 | udp | CimTrak | Robert E. Johnson III | Robert E. Johnson III | 2003-04 | |||||
| cbos-ip-port | 3750 | tcp | CBOS/IP ncapsalation port | Thomas Dannemiller | Thomas Dannemiller | 2003-04 | |||||
| cbos-ip-port | 3750 | udp | CBOS/IP ncapsalation port | Thomas Dannemiller | Thomas Dannemiller | 2003-04 | |||||
| gprs-cube | 3751 | tcp | CommLinx GPRS Cube | Peter Johnson | Peter Johnson | 2003-04 | |||||
| gprs-cube | 3751 | udp | CommLinx GPRS Cube | Peter Johnson | Peter Johnson | 2003-04 | |||||
| vipremoteagent | 3752 | tcp | Vigil-IP RemoteAgent | Bryan Alvord | Bryan Alvord | 2003-04 | |||||
| vipremoteagent | 3752 | udp | Vigil-IP RemoteAgent | Bryan Alvord | Bryan Alvord | 2003-04 | |||||
| nattyserver | 3753 | tcp | NattyServer Port | Akira Saito | Akira Saito | 2003-04 | |||||
| nattyserver | 3753 | udp | NattyServer Port | Akira Saito | Akira Saito | 2003-04 | |||||
| timestenbroker | 3754 | tcp | TimesTen Broker Port | David Aspinwall | David Aspinwall | 2003-04 | |||||
| timestenbroker | 3754 | udp | TimesTen Broker Port | David Aspinwall | David Aspinwall | 2003-04 | |||||
| sas-remote-hlp | 3755 | tcp | SAS Remote Help Server | Gary T. Ciampa | Gary T. Ciampa | 2003-04 | |||||
| sas-remote-hlp | 3755 | udp | SAS Remote Help Server | Gary T. Ciampa | Gary T. Ciampa | 2003-04 | |||||
| canon-capt | 3756 | tcp | Canon CAPT Port | Takashi Okazawa | Takashi Okazawa | 2003-04 | |||||
| canon-capt | 3756 | udp | Canon CAPT Port | Takashi Okazawa | Takashi Okazawa | 2003-04 | |||||
| grf-port | 3757 | tcp | GRF Server Port | Robert Banfill | Robert Banfill | 2003-04 | |||||
| grf-port | 3757 | udp | GRF Server Port | Robert Banfill | Robert Banfill | 2003-04 | |||||
| apw-registry | 3758 | tcp | apw RMI registry | Dan Davis | Dan Davis | 2003-04 | |||||
| apw-registry | 3758 | udp | apw RMI registry | Dan Davis | Dan Davis | 2003-04 | |||||
| exapt-lmgr | 3759 | tcp | Exapt License Manager | Christoph Kukulies | Christoph Kukulies | 2003-04 | |||||
| exapt-lmgr | 3759 | udp | Exapt License Manager | Christoph Kukulies | Christoph Kukulies | 2003-04 | |||||
| adtempusclient | 3760 | tcp | adTempus Client | Bill Wingate | Bill Wingate | 2003-05 | |||||
| adtempusclient | 3760 | udp | adTEmpus Client | Bill Wingate | Bill Wingate | 2003-05 | |||||
| gsakmp | 3761 | tcp | gsakmp port | RFC 4535 | |||||||
| gsakmp | 3761 | udp | gsakmp port | RFC 4535 | |||||||
| gbs-smp | 3762 | tcp | GBS SnapMail Protocol | Eric Harris-Braun | Eric Harris-Braun | 2003-06 | |||||
| gbs-smp | 3762 | udp | GBS SnapMail Protocol | Eric Harris-Braun | Eric Harris-Braun | 2003-06 | |||||
| xo-wave | 3763 | tcp | XO Wave Control Port | Bjorn Dittmer-Roche | Bjorn Dittmer-Roche | 2003-06 | |||||
| xo-wave | 3763 | udp | XO Wave Control Port | Bjorn Dittmer-Roche | Bjorn Dittmer-Roche | 2003-06 | |||||
| mni-prot-rout | 3764 | tcp | MNI Protected Routing | Tim Behne | Tim Behne | 2003-06 | |||||
| mni-prot-rout | 3764 | udp | MNI Protected Routing | Tim Behne | Tim Behne | 2003-06 | |||||
| rtraceroute | 3765 | tcp | Remote Traceroute | A. Blake Cooper | A. Blake Cooper | 2003-06 | |||||
| rtraceroute | 3765 | udp | Remote Traceroute | A. Blake Cooper | A. Blake Cooper | 2003-06 | |||||
| sitewatch-s | 3766 | tcp | SSL e-watch sitewatch server | e-Watch Corporation | John M Baird | 2014-05-13 | this port was previously updated on 2009-06-19 | ||||
| 3766 | udp | Reserved | this port was previously updated on 2009-06-19 | ||||||||
| listmgr-port | 3767 | tcp | ListMGR Port | Takashi Kubota | Takashi Kubota | 2003-06 | |||||
| listmgr-port | 3767 | udp | ListMGR Port | Takashi Kubota | Takashi Kubota | 2003-06 | |||||
| rblcheckd | 3768 | tcp | rblcheckd server daemon | Sabri Berisha | Sabri Berisha | 2003-06 | |||||
| rblcheckd | 3768 | udp | rblcheckd server daemon | Sabri Berisha | Sabri Berisha | 2003-06 | |||||
| haipe-otnk | 3769 | tcp | HAIPE Network Keying | Mike Irani | Mike Irani | 2003-06 | |||||
| haipe-otnk | 3769 | udp | HAIPE Network Keying | Mike Irani | Mike Irani | 2003-06 | |||||
| cindycollab | 3770 | tcp | Cinderella Collaboration | Ulrich Kortenkamp | Ulrich Kortenkamp | 2003-06 | |||||
| cindycollab | 3770 | udp | Cinderella Collaboration | Ulrich Kortenkamp | Ulrich Kortenkamp | 2003-06 | |||||
| paging-port | 3771 | tcp | RTP Paging Port | Patrick Ferriter | Patrick Ferriter | 2003-06 | |||||
| paging-port | 3771 | udp | RTP Paging Port | Patrick Ferriter | Patrick Ferriter | 2003-06 | |||||
| ctp | 3772 | tcp | Chantry Tunnel Protocol | Inderpreet Singh | Inderpreet Singh | 2003-06 | |||||
| ctp | 3772 | udp | Chantry Tunnel Protocol | Inderpreet Singh | Inderpreet Singh | 2003-06 | |||||
| ctdhercules | 3773 | tcp | ctdhercules | Carl Banzhof | Carl Banzhof | 2003-06 | |||||
| ctdhercules | 3773 | udp | ctdhercules | Carl Banzhof | Carl Banzhof | 2003-06 | |||||
| zicom | 3774 | tcp | ZICOM | Sabu Das | Sabu Das | 2003-06 | |||||
| zicom | 3774 | udp | ZICOM | Sabu Das | Sabu Das | 2003-06 | |||||
| ispmmgr | 3775 | tcp | ISPM Manager Port | Eric Anderson | Eric Anderson | 2003-06 | |||||
| ispmmgr | 3775 | udp | ISPM Manager Port | Eric Anderson | Eric Anderson | 2003-06 | |||||
| dvcprov-port | 3776 | tcp | Device Provisioning Port | Rob Lehew | Rob Lehew | 2003-06 | |||||
| dvcprov-port | 3776 | udp | Device Provisioning Port | Rob Lehew | Rob Lehew | 2003-06 | |||||
| jibe-eb | 3777 | tcp | Jibe EdgeBurst | Chap Tippin | Chap Tippin | 2003-06 | |||||
| jibe-eb | 3777 | udp | Jibe EdgeBurst | Chap Tippin | Chap Tippin | 2003-06 | |||||
| c-h-it-port | 3778 | tcp | Cutler-Hammer IT Port | Thomas Ruchti | Thomas Ruchti | 2003-06 | |||||
| c-h-it-port | 3778 | udp | Cutler-Hammer IT Port | Thomas Ruchti | Thomas Ruchti | 2003-06 | |||||
| cognima | 3779 | tcp | Cognima Replication | Ralph Greenwell | Ralph Greenwell | 2003-06 | |||||
| cognima | 3779 | udp | Cognima Replication | Ralph Greenwell | Ralph Greenwell | 2003-06 | |||||
| nnp | 3780 | tcp | Nuzzler Network Protocol | Andreas Schwarz | Andreas Schwarz | 2003-06 | |||||
| nnp | 3780 | udp | Nuzzler Network Protocol | Andreas Schwarz | Andreas Schwarz | 2003-06 | |||||
| abcvoice-port | 3781 | tcp | ABCvoice server port | Carlos Gonzalez-Roman Ferrer | Carlos Gonzalez-Roman Ferrer | 2003-06 | |||||
| abcvoice-port | 3781 | udp | ABCvoice server port | Carlos Gonzalez-Roman Ferrer | Carlos Gonzalez-Roman Ferrer | 2003-06 | |||||
| iso-tp0s | 3782 | tcp | Secure ISO TP0 port | Herbert Falk | Herbert Falk | 2003-06 | |||||
| iso-tp0s | 3782 | udp | Secure ISO TP0 port | Herbert Falk | Herbert Falk | 2003-06 | |||||
| bim-pem | 3783 | tcp | Impact Mgr./PEM Gateway | Walter G. Giroir | Walter G. Giroir | 2003-07 | |||||
| bim-pem | 3783 | udp | Impact Mgr./PEM Gateway | Walter G. Giroir | Walter G. Giroir | 2003-07 | |||||
| bfd-control | 3784 | tcp | BFD Control Protocol | RFC 5881 | |||||||
| bfd-control | 3784 | udp | BFD Control Protocol | RFC 5881 | |||||||
| bfd-echo | 3785 | tcp | BFD Echo Protocol | RFC 5881 | |||||||
| bfd-echo | 3785 | udp | BFD Echo Protocol | RFC 5881 | |||||||
| upstriggervsw | 3786 | tcp | VSW Upstrigger port | Mark-Tim Junghanns | Mark-Tim Junghanns | 2003-07 | |||||
| upstriggervsw | 3786 | udp | VSW Upstrigger port | Mark-Tim Junghanns | Mark-Tim Junghanns | 2003-07 | |||||
| fintrx | 3787 | tcp | Fintrx | Peter G. L. Potgieser | Peter G. L. Potgieser | 2003-07 | |||||
| fintrx | 3787 | udp | Fintrx | Peter G. L. Potgieser | Peter G. L. Potgieser | 2003-07 | |||||
| isrp-port | 3788 | tcp | SPACEWAY Routing port | Vaibhav Kumar | Vaibhav Kumar | 2003-07 | |||||
| isrp-port | 3788 | udp | SPACEWAY Routing port | Vaibhav Kumar | Vaibhav Kumar | 2003-07 | |||||
| remotedeploy | 3789 | tcp | RemoteDeploy Administration Port [July 2003] | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| remotedeploy | 3789 | udp | RemoteDeploy Administration Port [July 2003] | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| quickbooksrds | 3790 | tcp | QuickBooks RDS | Almira | Almira | 2003-07 | |||||
| quickbooksrds | 3790 | udp | QuickBooks RDS | Almira | Almira | 2003-07 | |||||
| tvnetworkvideo | 3791 | tcp | TV NetworkVideo Data port | Kevin Brunner | Kevin Brunner | 2003-07 | |||||
| tvnetworkvideo | 3791 | udp | TV NetworkVideo Data port | Kevin Brunner | Kevin Brunner | 2003-07 | |||||
| sitewatch | 3792 | tcp | e-Watch Corporation SiteWatch | John M. Baird | John M. Baird | 2003-07 | |||||
| sitewatch | 3792 | udp | e-Watch Corporation SiteWatch | John M. Baird | John M. Baird | 2003-07 | |||||
| dcsoftware | 3793 | tcp | DataCore Software | Andre Cato | Andre Cato | 2003-07 | |||||
| dcsoftware | 3793 | udp | DataCore Software | Andre Cato | Andre Cato | 2003-07 | |||||
| jaus | 3794 | tcp | JAUS Robots | Steven B. Cliff | Steven B. Cliff | 2003-07 | |||||
| jaus | 3794 | udp | JAUS Robots | Steven B. Cliff | Steven B. Cliff | 2003-07 | |||||
| myblast | 3795 | tcp | myBLAST Mekentosj port | Alexander Griekspoor | Alexander Griekspoor | 2003-07 | |||||
| myblast | 3795 | udp | myBLAST Mekentosj port | Alexander Griekspoor | Alexander Griekspoor | 2003-07 | |||||
| spw-dialer | 3796 | tcp | Spaceway Dialer | Patrick Fisher | Patrick Fisher | 2003-07 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| A. Blake Cooper | blake&cluebie.net | 2003-06 | |
| Akira Saito | admin&kobu.com | 2003-04 | |
| Alexander Griekspoor | a.griekspoor&nki.nl | 2003-07 | |
| Almira | almira_niciu&intuit.com | 2003-07 | |
| Andre Cato | andre.cato&datacore.com | 2003-07 | |
| Andreas Schwarz | andreas.schwarz&securepoint.de | 2003-06 | |
| Bill Wingate | bill.wingate&arcanadev.com | 2003-05 | |
| Bjorn Dittmer-Roche | bjorn&xowave.com | 2003-06 | |
| Bryan Alvord | bryan&vaticor.com | 2003-04 | |
| Carl Banzhof | cbanzhof&citadel.com | 2003-06 | |
| Carlos Gonzalez-Roman Ferrer | iana&abcdatos.com | 2003-06 | |
| Chap Tippin | chad.tippin&jibeinc.com | 2003-06 | |
| Christoph Kukulies | info&exapt.de | 2003-04 | |
| Dan Davis | Dan.A.Davis&hp.com | 2003-04 | |
| David Aspinwall | aspinwall×ten.com | 2003-04 | |
| Detlef Rothe | detlef.rothe&ts.fujitsu.com | 2009-05-15 | |
| e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 | |
| Eric Anderson | eanderson&netvision.com | 2003-06 | |
| Eric Harris-Braun | eric&glassbead.com | 2003-06 | |
| Gary T. Ciampa | Gary.Ciampa&sas.com | 2003-04 | |
| Greg Bailey | gbailey&lxpro.com | 2003-04 | |
| Herbert Falk | herb&sisconet.com | 2003-06 | |
| Inderpreet Singh | isingh&chantrynetworks.com | 2003-06 | |
| John M. Baird | jbaird&e-watch.com | 2003-07 | |
| John M Baird | e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 |
| Kevin Brunner | brunner&tivo.com | 2003-07 | |
| Mark-Tim Junghanns | mjunghanns&vangerow.de | 2003-07 | |
| Michael Whiteley | michael&whiteley.com | 2003-04 | |
| Mike Irani | irani&spawar.navy.mil | 2003-06 | |
| Patrick Ferriter | Patrick.Ferriter&zultys.com | 2003-06 | |
| Patrick Fisher | pfisher&hns.com | 2004-12 | |
| Peter G. L. Potgieser | p.g.l.potgieser&interpay.nl | 2003-07 | |
| Peter Johnson | peter&commlinx.com.au | 2004-11 | |
| Ralph Greenwell | iana&cognima.com | 2012-03-15 | |
| Rob Lehew | rlehewµsoft.com | 2003-06 | |
| Robert Banfill | robert&banfill.net | 2003-04 | |
| Robert E. Johnson III | johnson.robert&cimcor.com | 2003-04 | |
| Sabri Berisha | sabri&cluecentral.net | 2003-06 | |
| Sabu Das | sabud&zicomsecure.com | 2003-06 | |
| Steven B. Cliff | scliff&remotec-andros.com | 2003-07 | |
| Takashi Kubota | kubota.takashi&pfu.fugitsu.com | 2003-06 | |
| Takashi Okazawa | okazawa.takashi&canon.co.jp | 2003-04 | |
| Thomas Dannemiller | tom.dannemiller&rolls-royce.com | 2003-04 | |
| Thomas Ruchti | thomasmruchti&eaton.com | 2003-06 | |
| Tim Behne | timothybµwavenetworks.com | 2003-06 | |
| Ulrich Kortenkamp | kortenkamp&cinderella.de | 2003-06 | |
| Vaibhav Kumar | vakumar&hns.com | 2003-07 | |
| Walter G. Giroir | walt_giroir&bmc.com | 2003-07 |