Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
immedianet-bcn 3657 udp ImmediaNet Beacon Bill Homan Bill Homan 2003-01
ps-ams 3658 tcp PlayStation AMS (Secure) Edgar Alan Tu Edgar Alan Tu 2003-01
ps-ams 3658 udp PlayStation AMS (Secure) Edgar Alan Tu Edgar Alan Tu 2003-01
apple-sasl 3659 tcp Apple SASL David M. O'Rourke David M. O'Rourke 2003-01
apple-sasl 3659 udp Apple SASL David M. O'Rourke David M. O'Rourke 2003-01
can-nds-ssl 3660 tcp IBM Tivoli Directory Service using SSL
can-nds-ssl 3660 udp IBM Tivoli Directory Service using SSL
can-ferret-ssl 3661 tcp IBM Tivoli Directory Service using SSL Nic Catrambone Nic Catrambone 2003-01
can-ferret-ssl 3661 udp IBM Tivoli Directory Service using SSL Nic Catrambone Nic Catrambone 2003-01
pserver 3662 tcp pserver Patrick Furlong Patrick Furlong 2003-01
pserver 3662 udp pserver Patrick Furlong Patrick Furlong 2003-01
dtp 3663 tcp DIRECWAY Tunnel Protocol John Border John Border 2003-01
dtp 3663 udp DIRECWAY Tunnel Protocol John Border John Border 2003-01
ups-engine 3664 tcp UPS Engine Port
ups-engine 3664 udp UPS Engine Port
ent-engine 3665 tcp Enterprise Engine Port Mike Delgrosso Mike Delgrosso 2003-01
ent-engine 3665 udp Enterprise Engine Port Mike Delgrosso Mike Delgrosso 2003-01
eserver-pap 3666 tcp IBM eServer PAP Dave Gimpl Dave Gimpl 2003-01
eserver-pap 3666 udp IBM EServer PAP Dave Gimpl Dave Gimpl 2003-01
infoexch 3667 tcp IBM Information Exchange Paul Ford-Hutchinson Paul Ford-Hutchinson 2003-01
infoexch 3667 udp IBM Information Exchange Paul Ford-Hutchinson Paul Ford-Hutchinson 2003-01
dell-rm-port 3668 tcp Dell Remote Management Bradley Bransom Bradley Bransom 2003-01
dell-rm-port 3668 udp Dell Remote Management Bradley Bransom Bradley Bransom 2003-01
casanswmgmt 3669 tcp CA SAN Switch Management Emre Tunar Emre Tunar 2003-01
casanswmgmt 3669 udp CA SAN Switch Management Emre Tunar Emre Tunar 2003-01
smile 3670 tcp SMILE TCP/UDP Interface Andre Petras Andre Petras 2003-01
smile 3670 udp SMILE TCP/UDP Interface Andre Petras Andre Petras 2003-01
efcp 3671 tcp e Field Control (EIBnet) Marc Goossens Marc Goossens 2003-01
efcp 3671 udp e Field Control (EIBnet) Marc Goossens Marc Goossens 2003-01
lispworks-orb 3672 tcp LispWorks ORB Lisp Support Lisp Support
lispworks-orb 3672 udp LispWorks ORB Lisp Support Lisp Support
mediavault-gui 3673 tcp Openview Media Vault GUI Stephen Gold Stephen Gold 2003-01
mediavault-gui 3673 udp Openview Media Vault GUI Stephen Gold Stephen Gold 2003-01
wininstall-ipc 3674 tcp WinINSTALL IPC Port Bill Somerville Bill Somerville 2008-08-13
wininstall-ipc 3674 udp WinINSTALL IPC Port Bill Somerville Bill Somerville 2008-08-13
calltrax 3675 tcp CallTrax Data Port Oliver Bailey Oliver Bailey 2003-01
calltrax 3675 udp CallTrax Data Port Oliver Bailey Oliver Bailey 2003-01
va-pacbase 3676 tcp VisualAge Pacbase server Dominique Lelievre Dominique Lelievre 2003-01
va-pacbase 3676 udp VisualAge Pacbase server Dominique Lelievre Dominique Lelievre 2003-01
roverlog 3677 tcp RoverLog IPC Tom Mayo Tom Mayo 2003-01
roverlog 3677 udp RoverLog IPC Tom Mayo Tom Mayo 2003-01
ipr-dglt 3678 tcp DataGuardianLT Bruce Carlson Bruce Carlson 2003-01
ipr-dglt 3678 udp DataGuardianLT Bruce Carlson Bruce Carlson 2003-01
newton-dock 3679 tcp Newton Dock Paul Guyot Paul Guyot 2025-01-23
newton-dock 3679 udp Newton Dock Paul Guyot Paul Guyot 2025-01-23
npds-tracker 3680 tcp NPDS Tracker Paul Guyot Paul Guyot 2003-01
npds-tracker 3680 udp NPDS Tracker Paul Guyot Paul Guyot 2003-01
bts-x73 3681 tcp BTS X73 Port Todd Cooper Todd Cooper 2003-01
bts-x73 3681 udp BTS X73 Port Todd Cooper Todd Cooper 2003-01
cas-mapi 3682 tcp EMC SmartPackets-MAPI Koen Schoofs Koen Schoofs 2003-01
cas-mapi 3682 udp EMC SmartPackets-MAPI Koen Schoofs Koen Schoofs 2003-01
bmc-ea 3683 tcp BMC EDV/EA Portnoy Boxman Portnoy Boxman 2003-01
bmc-ea 3683 udp BMC EDV/EA Portnoy Boxman Portnoy Boxman 2003-01
faxstfx-port 3684 tcp FAXstfX Alec Carlson Alec Carlson 2003-01
faxstfx-port 3684 udp FAXstfX Alec Carlson Alec Carlson 2003-01
dsx-agent 3685 tcp DS Expert Agent Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16
dsx-agent 3685 udp DS Expert Agent Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16
tnmpv2 3686 tcp Trivial Network Management Andrea Premoli Andrea Premoli 2003-01
tnmpv2 3686 udp Trivial Network Management Andrea Premoli Andrea Premoli 2003-01
simple-push 3687 tcp simple-push
simple-push 3687 udp simple-push
simple-push-s 3688 tcp simple-push Secure C. Enrique Ortiz C. Enrique Ortiz 2003-01
simple-push-s 3688 udp simple-push Secure C. Enrique Ortiz C. Enrique Ortiz 2003-01
daap 3689 tcp Digital Audio Access Protocol (iTunes) Amandeep Jawa Amandeep Jawa 2003-01 Defined TXT keys: txtvers, Version, iTSh Version, Machine ID, Database ID, Machine Name, Password
daap 3689 udp Digital Audio Access Protocol (iTunes) Amandeep Jawa Amandeep Jawa 2003-01 Defined TXT keys: txtvers, Version, iTSh Version, Machine ID, Database ID, Machine Name, Password
svn 3690 tcp Subversion Greg Hudson Greg Hudson 2003-01
svn 3690 udp Subversion Greg Hudson Greg Hudson 2003-01
magaya-network 3691 tcp Magaya Network Port Jesus David Rodriguez Jesus David Rodriguez 2003-02
magaya-network 3691 udp Magaya Network Port Jesus David Rodriguez Jesus David Rodriguez 2003-02
intelsync 3692 tcp Brimstone IntelSync Davey Taylor Davey Taylor 2003-02
intelsync 3692 udp Brimstone IntelSync Davey Taylor Davey Taylor 2003-02
easl 3693 tcp Emergency Automatic Structure Lockdown System Mele Associates Greg Hansen; Randy Yates 2014-11-26 This port was previously removed on 2007-04-05.
3693 udp Reserved 2014-11-26 This port was previously removed on 2007-04-05.
3694 Unassigned 2007-04-05
bmc-data-coll 3695 tcp BMC Data Collection Portnoy Boxman Portnoy Boxman 2003-02
bmc-data-coll 3695 udp BMC Data Collection Portnoy Boxman Portnoy Boxman 2003-02
telnetcpcd 3696 tcp Telnet Com Port Control Thomas J. Pinkl Thomas J. Pinkl 2003-02
telnetcpcd 3696 udp Telnet Com Port Control Thomas J. Pinkl Thomas J. Pinkl 2003-02
nw-license 3697 tcp NavisWorks License System Tim Wiegand Tim Wiegand 2003-02
nw-license 3697 udp NavisWorks License System Tim Wiegand Tim Wiegand 2003-02
sagectlpanel 3698 tcp SAGECTLPANEL Mark Gamble Mark Gamble 2003-02
sagectlpanel 3698 udp SAGECTLPANEL Mark Gamble Mark Gamble 2003-02
kpn-icw 3699 tcp Internet Call Waiting B. J. Kortekaas B. J. Kortekaas 2003-02
kpn-icw 3699 udp Internet Call Waiting B. J. Kortekaas B. J. Kortekaas 2003-02
rt-event 3706 tcp Real-Time Event Port
rt-event 3706 udp Real-Time Event Port
wv-csp-sms-cir 3716 tcp WV CSP SMS CIR Channel
wv-csp-sms-cir 3716 udp WV CSP SMS CIR Channel
array-manager 3726 tcp Xyratex Array Manager David A. Lethe David A. Lethe 2003-04
array-manager 3726 udp Xyratex Array Manager David A. Lethe David A. Lethe 2003-04
rs-rmi 3736 tcp RealSpace RMI Barry McDarby Barry McDarby 2003-04
rs-rmi 3736 udp RealSpace RMI Barry McDarby Barry McDarby 2003-04
linktest 3746 tcp LXPRO.COM LinkTest
linktest 3746 udp LXPRO.COM LinkTest
canon-capt 3756 tcp Canon CAPT Port Takashi Okazawa Takashi Okazawa 2003-04
canon-capt 3756 udp Canon CAPT Port Takashi Okazawa Takashi Okazawa 2003-04
adtempusclient 3760 tcp adTempus Client Bill Wingate Bill Wingate 2003-05
adtempusclient 3760 udp adTEmpus Client Bill Wingate Bill Wingate 2003-05
gsakmp 3761 tcp gsakmp port RFC 4535
gsakmp 3761 udp gsakmp port RFC 4535
gbs-smp 3762 tcp GBS SnapMail Protocol Eric Harris-Braun Eric Harris-Braun 2003-06

Contact Information

Name Organization Contact URI Last Updated
Alec Carlson acarlson&smithmicro.com 2003-01
Amandeep Jawa daap&apple.com 2003-01
Andre Petras a.petras&arcor.de 2003-01
Andrea Premoli Andrea_maria.Premoli&icn.siemens.it 2003-01
B. J. Kortekaas b.j.kortekaas&kpn.com 2003-02
Barry McDarby realspace&starwolf.biz 2003-04
Bill Homan bhoman&spanworks.com 2003-01
Bill Somerville Bill.Somerville&scalable.com 2008-08-13
Bill Wingate bill.wingate&arcanadev.com 2003-05
Bradley Bransom bradley_bransom&dell.com 2003-01
Bruce Carlson bruce.carlson&iprintl.com 2003-01
C. Enrique Ortiz eortiz&j2medeveloper.com 2003-01
Dave Gimpl gimpl&us.ibm.com 2003-01
Davey Taylor davey.taylor&brimstone.net 2003-02
David A. Lethe david_lethe&us.xyratex.com 2003-04
David M. O'Rourke daveo&apple.com 2003-01
Dominique Lelievre dominique.lelievre&fr.ibm.com 2003-01
Edgar Alan Tu Edgar_Tu&playstation.sony.com 2003-01
Emre Tunar emre.tunar&ca.com 2004-11
Eric Harris-Braun eric&glassbead.com 2003-06
Greg Hansen Mele Associates greg.hansen&meleassociates.com 2014-11-26
Greg Hudson ghudson&mit.edu 2023-11-17
Jason Lockett Jay.Lockett&quest.com 2008-12-16
Jesus David Rodriguez jesusdavid&magaya.com 2003-02
John Border border&hns.com 2003-01
Koen Schoofs schoofs_koen&emc.com 2003-01
Lisp Support lisp-support&xanalys.com
Marc Goossens mgoossens&eiba.com 2003-01
Mark Gamble mark.gamble&sage.com 2003-02
Melanie Kacerek melanie.kacerek&quest.com 2008-12-16
Mele Associates easl&meleassociates.com 2014-11-26
Mike Delgrosso mdelgros&tripplite.com 2003-01
Nic Catrambone ncatramb&us.ibm.com 2003-01
Oliver Bailey zzf66jjlm&time-lines.com 2003-01
Patrick Furlong pfurlong&darkknight.ca 2003-01
Paul Ford-Hutchinson paulfordh&uk.ibm.com 2003-01
Paul Guyot pguyot&kallisys.net 2003-01
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Randy Yates Digital Signal Labs yates&digitalsignallabs.com 2014-11-26
Stephen Gold 2003-01
Takashi Okazawa okazawa.takashi&canon.co.jp 2003-04
Thomas J. Pinkl tom&pinkl.com 2003-02
Tim Wiegand tim.wiegand&navisworks.com 2003-02
Todd Cooper todd&do11073.com 2003-01
Tom Mayo tmayo1&rochester.rr.com 2003-01