Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| spw-dialer | 3796 | tcp | Spaceway Dialer | Patrick Fisher | Patrick Fisher | 2003-07 | |||||
| spw-dialer | 3796 | udp | Spaceway Dialer | Patrick Fisher | Patrick Fisher | 2003-07 | |||||
| idps | 3797 | tcp | idps | Jean-Francois Rabasse | Jean-Francois Rabasse | 2003-07 | |||||
| idps | 3797 | udp | idps | Jean-Francois Rabasse | Jean-Francois Rabasse | 2003-07 | |||||
| minilock | 3798 | tcp | Minilock | Daniel Julio Reyes | Daniel Julio Reyes | 2003-08 | |||||
| minilock | 3798 | udp | Minilock | Daniel Julio Reyes | Daniel Julio Reyes | 2003-08 | |||||
| radius-dynauth | 3799 | tcp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| radius-dynauth | 3799 | udp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| spugna | 3807 | tcp | SpuGNA Communication Port | Samuele Sequi | Samuele Sequi | 2004-02 | |||||
| spugna | 3807 | udp | SpuGNA Communication Port | Samuele Sequi | Samuele Sequi | 2004-02 | |||||
| tapeware | 3817 | tcp | Yosemite Tech Tapeware | Luke Dion | Luke Dion | 2004-04 | |||||
| tapeware | 3817 | udp | Yosemite Tech Tapeware | Luke Dion | Luke Dion | 2004-04 | |||||
| netmpi | 3827 | tcp | Netadmin Systems MPI service | Göran Runfeldt | Göran Runfeldt | 2007-07-10 | |||||
| netmpi | 3827 | udp | Netadmin Systems MPI service | Göran Runfeldt | Göran Runfeldt | 2007-07-10 | |||||
| mkm-discovery | 3837 | tcp | MARKEM Auto-Discovery | Vadym Kargin | Vadym Kargin | 2005-08 | |||||
| mkm-discovery | 3837 | udp | MARKEM Auto-Discovery | Vadym Kargin | Vadym Kargin | 2005-08 | |||||
| msfw-control | 3847 | tcp | MS Firewall Control | Oren Trutner | Oren Trutner | 2003-08 | |||||
| msfw-control | 3847 | udp | MS Firewall Control | Oren Trutner | Oren Trutner | 2003-08 | |||||
| trap-port | 3857 | tcp | Trap Port | Norm Freedman | Norm Freedman | 2003-08 | |||||
| trap-port | 3857 | udp | Trap Port | Norm Freedman | Norm Freedman | 2003-08 | |||||
| dzoglserver | 3867 | tcp | Sun SDViz DZOGLSERVER Port | Kevin Rushforth | Kevin Rushforth | 2003-08 | |||||
| dzoglserver | 3867 | udp | Sun SDViz DZOGLSERVER Port | Kevin Rushforth | Kevin Rushforth | 2003-08 | |||||
| ovsam-d-agent | 3870 | tcp | hp OVSAM HostAgent Disco | Mike Pontillo | Mike Pontillo | 2003-08 | |||||
| ovsam-d-agent | 3870 | udp | hp OVSAM HostAgent Disco | Mike Pontillo | Mike Pontillo | 2003-08 | |||||
| avocent-adsap | 3871 | tcp | Avocent DS Authorization | Eduardo Fernandez | Eduardo Fernandez | 2003-08 | |||||
| avocent-adsap | 3871 | udp | Avocent DS Authorization | Eduardo Fernandez | Eduardo Fernandez | 2003-08 | |||||
| oem-agent | 3872 | tcp | OEM Agent | Narain Jagathesan | Narain Jagathesan | 2003-11 | |||||
| oem-agent | 3872 | udp | OEM Agent | Narain Jagathesan | Narain Jagathesan | 2003-11 | |||||
| fagordnc | 3873 | tcp | fagordnc | Luis Zugasti | Luis Zugasti | 2003-11 | |||||
| fagordnc | 3873 | udp | fagordnc | Luis Zugasti | Luis Zugasti | 2003-11 | |||||
| sixxsconfig | 3874 | tcp | SixXS Configuration | Jeroen Massar | Jeroen Massar | 2003-11 | |||||
| sixxsconfig | 3874 | udp | SixXS Configuration | Jeroen Massar | Jeroen Massar | 2003-11 | |||||
| pnbscada | 3875 | tcp | PNBSCADA | Philip N. Bergstresser | Philip N. Bergstresser | ||||||
| pnbscada | 3875 | udp | PNBSCADA | Philip N. Bergstresser | Philip N. Bergstresser | ||||||
| dl-agent | 3876 | tcp | DirectoryLockdown Agent IANA assigned this well-formed service name as a replacement for "dl_agent". |
Jason Lockett; Melanie Kacerek | Jason Lockett; Melanie Kacerek | 2008-12-16 | |||||
| dl_agent | 3876 | tcp | DirectoryLockdown Agent | Jason Lockett; Melanie Kacerek | Jason Lockett; Melanie Kacerek | 2008-12-16 | This entry is an alias to "dl-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| dl-agent | 3876 | udp | DirectoryLockdown Agent IANA assigned this well-formed service name as a replacement for "dl_agent". |
Jason Lockett; Melanie Kacerek | Jason Lockett; Melanie Kacerek | 2008-12-16 | |||||
| dl_agent | 3876 | udp | DirectoryLockdown Agent | Jason Lockett; Melanie Kacerek | Jason Lockett; Melanie Kacerek | 2008-12-16 | This entry is an alias to "dl-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| xmpcr-interface | 3877 | tcp | XMPCR Interface Port | Christopher Carlson | Christopher Carlson | 2003-10 | |||||
| xmpcr-interface | 3877 | udp | XMPCR Interface Port | Christopher Carlson | Christopher Carlson | 2003-10 | |||||
| fotogcad | 3878 | tcp | FotoG CAD interface | Jason Szabo | Jason Szabo | 2003-10 | |||||
| fotogcad | 3878 | udp | FotoG CAD interface | Jason Szabo | Jason Szabo | 2003-10 | |||||
| appss-lm | 3879 | tcp | appss license manager | Peter Krueger | Peter Krueger | 2003-10 | |||||
| appss-lm | 3879 | udp | appss license manager | Peter Krueger | Peter Krueger | 2003-10 | |||||
| ciphire-data | 3887 | tcp | Ciphire Data Transport | Lars Eilebrecht | Lars Eilebrecht | 2003-10 | |||||
| ciphire-data | 3887 | udp | Ciphire Data Transport | Lars Eilebrecht | Lars Eilebrecht | 2003-10 | |||||
| sdo-ssh | 3897 | tcp | Simple Distributed Objects over SSH | Alexander Philippou | Alexander Philippou | 2003-10 | |||||
| sdo-ssh | 3897 | udp | Simple Distributed Objects over SSH | Alexander Philippou | Alexander Philippou | 2003-10 | |||||
| imoguia-port | 3907 | tcp | Imoguia Port | Emidio Cunha | Emidio Cunha | 2003-11 | |||||
| imoguia-port | 3907 | udp | Imoguia Port | Emidio Cunha | Emidio Cunha | 2003-11 | |||||
| aftmux | 3917 | tcp | AFT multiplex port | Alfred Schmidt | Alfred Schmidt | 2003-11 | |||||
| aftmux | 3917 | udp | AFT multiplex port | Alfred Schmidt | Alfred Schmidt | 2003-11 | |||||
| natdataservice | 3927 | tcp | ScsTsr | Ghanshyam Patel | Ghanshyam Patel | 2003-11 | |||||
| natdataservice | 3927 | udp | ScsTsr | Ghanshyam Patel | Ghanshyam Patel | 2003-11 | |||||
| dvbservdsc | 3937 | tcp | DVB Service Discovery | Bert van Willigen; Peter MacAvock | Bert van Willigen; Peter MacAvock | 2003-11 | |||||
| dvbservdsc | 3937 | udp | DVB Service Discovery | Bert van Willigen; Peter MacAvock | Bert van Willigen; Peter MacAvock | 2003-11 | |||||
| ccp | 3947 | tcp | Connect and Control Protocol for Consumer, Commercial, and Industrial Electronic Devices | Aaron Myer | Aaron Myer | 2004-06 | |||||
| ccp | 3947 | udp | Connect and Control Protocol for Consumer, Commercial, and Industrial Electronic Devices | Aaron Myer | Aaron Myer | 2004-06 | |||||
| mqe-broker | 3957 | tcp | MQEnterprise Broker | ||||||||
| mqe-broker | 3957 | udp | MQEnterprise Broker | ||||||||
| ppsms | 3967 | tcp | PPS Message Service | Bart Schaefer | Bart Schaefer | 2005-08 | |||||
| ppsms | 3967 | udp | PPS Message Service | Bart Schaefer | Bart Schaefer | 2005-08 | |||||
| lanrevagent | 3970 | tcp | LANrev Agent | Martin Bestmann | Martin Bestmann | Defined TXT keys: txtvers server=<main LANrev server for agent> vers=<version of LANrev Agent> build=<build number of LANrev Agent> id=<agent identifier> |
|||||
| lanrevagent | 3970 | udp | LANrev Agent | Martin Bestmann | Martin Bestmann | Defined TXT keys: txtvers server=<main LANrev server for agent> vers=<version of LANrev Agent> build=<build number of LANrev Agent> id=<agent identifier> |
|||||
| lanrevserver | 3971 | tcp | LANrev Server | Martin Bestmann | Martin Bestmann | 2005-08 | |||||
| lanrevserver | 3971 | udp | LANrev Server | Martin Bestmann | Martin Bestmann | 2005-08 | |||||
| iconp | 3972 | tcp | ict-control Protocol | Roel Harbers | Roel Harbers | 2005-08 | |||||
| iconp | 3972 | udp | ict-control Protocol | Roel Harbers | Roel Harbers | 2005-08 | |||||
| progistics | 3973 | tcp | ConnectShip Progistics | ConnectShip, Inc. | Robert Kinyon | 2005-08 | 2019-12-12 | ||||
| progistics | 3973 | udp | ConnectShip Progistics | ConnectShip, Inc. | Robert Kinyon | 2005-08 | 2019-12-12 | ||||
| xk22 | 3974 | tcp | Remote Applicant Tracking Service | Marc Castelluccio | Marc Castelluccio | 2005-08 | 2022-09-09 | ||||
| xk22 | 3974 | udp | Remote Applicant Tracking Service | Marc Castelluccio | Marc Castelluccio | 2005-08 | 2022-09-09 | ||||
| airshot | 3975 | tcp | Air Shot | Shingo Kimura | Shingo Kimura | 2005-08 | |||||
| airshot | 3975 | udp | Air Shot | Shingo Kimura | Shingo Kimura | 2005-08 | |||||
| opswagent | 3976 | tcp | Server Automation Agent | Hewlett Packard Enterprise | Cristi Fati | 2016-04-14 | |||||
| opswagent | 3976 | udp | Server Automation Agent | Hewlett Packard Enterprise | Cristi Fati | 2016-04-14 | |||||
| opswmanager | 3977 | tcp | Opsware Manager | Dave Jagoda | Dave Jagoda | 2006-06 | |||||
| opswmanager | 3977 | udp | Opsware Manager | Dave Jagoda | Dave Jagoda | 2006-06 | |||||
| secure-cfg-svr | 3978 | tcp | Secured Configuration Server | Dr. Anupam Bharali | Dr. Anupam Bharali | 2006-06 | |||||
| secure-cfg-svr | 3978 | udp | Secured Configuration Server | Dr. Anupam Bharali | Dr. Anupam Bharali | 2006-06 | |||||
| smwan | 3979 | tcp | Smith Micro Wide Area Network Service | David Sperling | David Sperling | 2006-06 | |||||
| smwan | 3979 | udp | Smith Micro Wide Area Network Service | David Sperling | David Sperling | 2006-06 | |||||
| centerline | 3987 | tcp | Centerline | Mark Simpson | Mark Simpson | ||||||
| centerline | 3987 | udp | Centerline | Mark Simpson | Mark Simpson | ||||||
| agentsease-db | 3997 | tcp | aes_db | Colin Hughes | Colin Hughes | 2006-02 | |||||
| agentsease-db | 3997 | udp | aes_db | Colin Hughes | Colin Hughes | 2006-02 | |||||
| pxc-splr | 4007 | tcp | pxc-splr | Dave Nesbitt | Dave Nesbitt | ||||||
| pxc-splr | 4007 | udp | pxc-splr | Dave Nesbitt | Dave Nesbitt | ||||||
| talarian-mcast3 | 4017 | tcp | Talarian Mcast | ||||||||
| talarian-mcast3 | 4017 | udp | Talarian Mcast | ||||||||
| bxp | 4027 | tcp | bitxpress | Morgan Doyle | Morgan Doyle | ||||||
| bxp | 4027 | udp | bitxpress | Morgan Doyle | Morgan Doyle | ||||||
| ravehd | 4037 | tcp | RaveHD network control | Jason Howard | Jason Howard | 2006-01 | |||||
| ravehd | 4037 | udp | RaveHD network control | Jason Howard | Jason Howard | 2006-01 | |||||
| ctp-state | 4047 | tcp | Context Transfer Protocol | Hesham Soliman | Hesham Soliman | 2005-11 | |||||
| ctp-state | 4047 | udp | Context Transfer Protocol | Hesham Soliman | Hesham Soliman | 2005-11 | |||||
| wfm | 4057 | tcp | Servigistics WFM server | Yuri Machkasov | Yuri Machkasov | 2006-08 | |||||
| wfm | 4057 | udp | Servigistics WFM server | Yuri Machkasov | Yuri Machkasov | 2006-08 | |||||
| idp | 4067 | tcp | Information Distribution Protocol | Michaela Vanderveen | Michaela Vanderveen | 2007-02 | |||||
| idp | 4067 | udp | Information Distribution Protocol | Michaela Vanderveen | Michaela Vanderveen | 2007-02 | |||||
| tripe | 4070 | tcp | Trivial IP Encryption (TrIPE) | Mark Wooding | Mark Wooding | 2007-07-10 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Aaron Myer | aaron.myer&in2nets.com | 2004-06 | |
| Alexander Philippou | alex&noemax.com | 2003-10 | |
| Alfred Schmidt | a.schmidt&aft-werdohl.de | 2003-11 | |
| Bart Schaefer | bart&suburbansoftware.com | 2005-08 | |
| Bert van Willigen | bert.vanwilligen&philips.com | 2003-11 | |
| Christopher Carlson | cjc&dobbz.com | 2003-10 | |
| Colin Hughes | chughes&agentsease.net | 2006-02 | |
| ConnectShip, Inc. | ConnectShipIT&connectship.com | 2019-12-12 | |
| Cristi Fati | cristi.fati&hpe.com | 2016-04-13 | |
| Daniel Julio Reyes | danieljreyes&yahoo.com | 2003-08 | |
| Dave Jagoda | dj&opsware.com | 2006-06 | |
| Dave Nesbitt | nesbitt&cp10.es.xerox.com | ||
| David Sperling | dsperling&smithmicro.com | 2006-06 | |
| Dr. Anupam Bharali | paniana&gmail.com | 2006-06 | |
| Eduardo Fernandez | eduardo.fernandez&avocent.com | 2003-08 | |
| Emidio Cunha | emidio&janeladigital.com | 2003-11 | |
| Göran Runfeldt | goran&netadmin.se | 2007-07-10 | |
| Ghanshyam Patel | gpatel&natinc.com | 2003-11 | |
| Hesham Soliman | H.Soliman&flarion.com | 2005-11 | |
| Hewlett Packard Enterprise | 2016-04-14 | ||
| Jason Howard | jason&spectsoft.com | 2006-01 | |
| Jason Lockett | Jay.Lockett&quest.com | 2008-12-16 | |
| Jason Szabo | jason.szabo&vexcel.com | 2003-10 | |
| Jean-Francois Rabasse | jfr&idps.org | 2003-07 | |
| Jeroen Massar | jeroen&unfix.org | 2005-08 | |
| Kevin Rushforth | kevin.rushforth&sun.com | 2003-08 | |
| Lars Eilebrecht | le+iana&leogic.com | 2003-10 | |
| Luis Zugasti | lzugasti&fagorautomation.es | 2003-11 | |
| Luke Dion | ldion&tapeware.com | 2004-04 | |
| Marc Castelluccio | marc&xk22.com | 2022-08-16 | |
| Mark Simpson | simpson¢erline.com | ||
| Mark Wooding | mdw&distorted.org.uk | 2007-07-10 | |
| Martin Bestmann | martin&poleposition-sw.com | 2005-08 | |
| Melanie Kacerek | melanie.kacerek&quest.com | 2008-12-16 | |
| Michaela Vanderveen | mvandervn&yahoo.com | 2007-02 | |
| Mike Pontillo | pontillo&hp.com | 2003-08 | |
| Morgan Doyle | morgan&mpt.ie | ||
| Narain Jagathesan | narain.jagathesan&oracle.com | 2003-11 | |
| Norm Freedman | normfree&san.rr.com | 2003-08 | |
| Oren Trutner | orentrutµsoft.com | 2003-08 | |
| Patrick Fisher | pfisher&hns.com | 2004-12 | |
| Peter Krueger | krueger&appss.de | 2003-10 | |
| Peter MacAvock | macavock&dvb.org | ||
| Philip N. Bergstresser | phil&bergstresser.org | ||
| Robert Kinyon | rkinyon&connectship.com | 2019-12-12 | |
| Roel Harbers | r.harbers&ict-control.com | 2005-08 | |
| Samuele Sequi | samuelesequi&defcom.it | 2004-02 | |
| Shingo Kimura | Shingo.Kimura&jp.sony.com | 2005-08 | |
| Vadym Kargin | vkargin&markem.com | 2005-08 | |
| Yuri Machkasov | ymachkasov&servigistics.com | 2006-08 |