Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| secure-cfg-svr | 3978 | tcp | Secured Configuration Server | Dr. Anupam Bharali | Dr. Anupam Bharali | 2006-06 | |||||
| secure-cfg-svr | 3978 | udp | Secured Configuration Server | Dr. Anupam Bharali | Dr. Anupam Bharali | 2006-06 | |||||
| smwan | 3979 | tcp | Smith Micro Wide Area Network Service | David Sperling | David Sperling | 2006-06 | |||||
| smwan | 3979 | udp | Smith Micro Wide Area Network Service | David Sperling | David Sperling | 2006-06 | |||||
| 3980 | tcp | Reserved | 2006-06 | 2020-12-29 | Historic usage was acms. De-Assigned on 2020-12-29 | ||||||
| 3980 | udp | Reserved | |||||||||
| starfish | 3981 | tcp | Starfish System Admin | Dan Razzell | Dan Razzell | 2006-06 | |||||
| starfish | 3981 | udp | Starfish System Admin | Dan Razzell | Dan Razzell | 2006-06 | |||||
| eis | 3982 | tcp | ESRI Image Server | ||||||||
| eis | 3982 | udp | ESRI Image Server | ||||||||
| eisp | 3983 | tcp | ESRI Image Service | Keith Ryden | Keith Ryden | 2006-07 | |||||
| eisp | 3983 | udp | ESRI Image Service | Keith Ryden | Keith Ryden | 2006-07 | |||||
| mapper-nodemgr | 3984 | tcp | MAPPER network node manager | ||||||||
| mapper-nodemgr | 3984 | udp | MAPPER network node manager | ||||||||
| mapper-mapethd | 3985 | tcp | MAPPER TCP/IP server | ||||||||
| mapper-mapethd | 3985 | udp | MAPPER TCP/IP server | ||||||||
| mapper-ws-ethd | 3986 | tcp | MAPPER workstation server IANA assigned this well-formed service name as a replacement for "mapper-ws_ethd". |
John C. Horton | John C. Horton | ||||||
| mapper-ws_ethd | 3986 | tcp | MAPPER workstation server | John C. Horton | John C. Horton | This entry is an alias to "mapper-ws-ethd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| mapper-ws-ethd | 3986 | udp | MAPPER workstation server IANA assigned this well-formed service name as a replacement for "mapper-ws_ethd". |
John C. Horton | John C. Horton | ||||||
| mapper-ws_ethd | 3986 | udp | MAPPER workstation server | John C. Horton | John C. Horton | This entry is an alias to "mapper-ws-ethd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| centerline | 3987 | tcp | Centerline | Mark Simpson | Mark Simpson | ||||||
| centerline | 3987 | udp | Centerline | Mark Simpson | Mark Simpson | ||||||
| dcs-config | 3988 | tcp | DCS Configuration Port | Ian Cargill | Ian Cargill | 2005-08 | |||||
| dcs-config | 3988 | udp | DCS Configuration Port | Ian Cargill | Ian Cargill | 2005-08 | |||||
| bv-queryengine | 3989 | tcp | BindView-Query Engine | ||||||||
| bv-queryengine | 3989 | udp | BindView-Query Engine | ||||||||
| bv-is | 3990 | tcp | BindView-IS | ||||||||
| bv-is | 3990 | udp | BindView-IS | ||||||||
| bv-smcsrv | 3991 | tcp | BindView-SMCServer | ||||||||
| bv-smcsrv | 3991 | udp | BindView-SMCServer | ||||||||
| bv-ds | 3992 | tcp | BindView-DirectoryServer | ||||||||
| bv-ds | 3992 | udp | BindView-DirectoryServer | ||||||||
| bv-agent | 3993 | tcp | BindView-Agent | David A. Gayler | David A. Gayler | 2005-08 | |||||
| bv-agent | 3993 | udp | BindView-Agent | David A. Gayler | David A. Gayler | 2005-08 | |||||
| 3994 | Unassigned | 2008-04-24 | |||||||||
| iss-mgmt-ssl | 3995 | tcp | ISS Management Svcs SSL | Wes Wilson | Wes Wilson | 2003-10 | |||||
| iss-mgmt-ssl | 3995 | udp | ISS Management Svcs SSL | Wes Wilson | Wes Wilson | 2003-10 | |||||
| abcsoftware | 3996 | tcp | abcsoftware-01 | Andrew Zimmerman | Andrew Zimmerman | 2004-06 | |||||
| abcsoftware | 3996 | udp | abcsoftware-01 | Andrew Zimmerman | Andrew Zimmerman | 2004-06 | |||||
| agentsease-db | 3997 | tcp | aes_db | Colin Hughes | Colin Hughes | 2006-02 | |||||
| agentsease-db | 3997 | udp | aes_db | Colin Hughes | Colin Hughes | 2006-02 | |||||
| dnx | 3998 | tcp | Distributed Nagios Executor Service | John Calcote | John Calcote | 2007-11-06 | |||||
| dnx | 3998 | udp | Distributed Nagios Executor Service | John Calcote | John Calcote | 2007-11-06 | |||||
| nvcnet | 3999 | tcp | Norman distributes scanning service | Kristian A. Bognaes | Kristian A. Bognaes | 2007-11-06 | |||||
| nvcnet | 3999 | udp | Norman distributes scanning service | Kristian A. Bognaes | Kristian A. Bognaes | 2007-11-06 | |||||
| chimera-hwm | 4009 | tcp | Chimera HWM | Ken Anderson | Ken Anderson | ||||||
| chimera-hwm | 4009 | udp | Chimera HWM | Ken Anderson | Ken Anderson | ||||||
| talarian-mcast5 | 4019 | tcp | Talarian Mcast | Geoff Mendal | Geoff Mendal | ||||||
| talarian-mcast5 | 4019 | udp | Talarian Mcast | Geoff Mendal | Geoff Mendal | ||||||
| ip-qsig | 4029 | tcp | IP Q signaling protocol | Toru Tachibana | Toru Tachibana | ||||||
| ip-qsig | 4029 | udp | IP Q signaling protocol | Toru Tachibana | Toru Tachibana | ||||||
| fazzt-admin | 4039 | tcp | Fazzt Administration | Lewis Wolfgang | Lewis Wolfgang | 2006-05 | |||||
| fazzt-admin | 4039 | udp | Fazzt Administration | Lewis Wolfgang | Lewis Wolfgang | 2006-05 | |||||
| wafs | 4049 | tcp | Wide Area File Services | Yuval Hager | Yuval Hager | 2006-01 | |||||
| wafs | 4049 | udp | Wide Area File Services | Yuval Hager | Yuval Hager | 2006-01 | |||||
| dlms-cosem | 4059 | tcp | DLMS/COSEM | Gyozo Kmethy | Gyozo Kmethy | 2006-11 | |||||
| dlms-cosem | 4059 | udp | DLMS/COSEM | Gyozo Kmethy | Gyozo Kmethy | 2006-11 | |||||
| minger | 4069 | tcp | Minger Email Address Validation Service | Arvel Hathcock | Arvel Hathcock | 2007-03 | |||||
| minger | 4069 | udp | Minger Email Address Validation Service | Arvel Hathcock | Arvel Hathcock | 2007-03 | |||||
| santools | 4079 | tcp | SANtools Diagnostic Server | David A. Lethe | David A. Lethe | 2008-05-01 | |||||
| santools | 4079 | udp | SANtools Diagnostic Server | David A. Lethe | David A. Lethe | 2008-05-01 | |||||
| opencore | 4089 | tcp | OpenCORE Remote Control Service | Pim van Riezen | Pim van Riezen | 2006-07 | |||||
| opencore | 4089 | udp | OpenCORE Remote Control Service | Pim van Riezen | Pim van Riezen | 2006-07 | |||||
| omasgport | 4090 | tcp | OMA BCAST Service Guide | Mark Lipford | Mark Lipford | 2006-07 | |||||
| omasgport | 4090 | udp | OMA BCAST Service Guide | Mark Lipford | Mark Lipford | 2006-07 | |||||
| ewinstaller | 4091 | tcp | EminentWare Installer | ||||||||
| ewinstaller | 4091 | udp | EminentWare Installer | ||||||||
| ewdgs | 4092 | tcp | EminentWare DGS | David A. Gayler | David A. Gayler | 2006-07 | |||||
| ewdgs | 4092 | udp | EminentWare DGS | David A. Gayler | David A. Gayler | 2006-07 | |||||
| pvxpluscs | 4093 | tcp | Pvx Plus CS Host | Michael King | Michael King | 2006-07 | |||||
| pvxpluscs | 4093 | udp | Pvx Plus CS Host | Michael King | Michael King | 2006-07 | |||||
| sysrqd | 4094 | tcp | sysrq daemon | Julien Danjou | Julien Danjou | 2006-07 | |||||
| sysrqd | 4094 | udp | sysrq daemon | Julien Danjou | Julien Danjou | 2006-07 | |||||
| xtgui | 4095 | tcp | xtgui information service | Jim Robanske | Jim Robanske | 2006-05 | |||||
| xtgui | 4095 | udp | xtgui information service | Jim Robanske | Jim Robanske | 2006-05 | |||||
| bre | 4096 | tcp | BRE (Bridge Relay Element) | Stephen Egbert | Stephen Egbert | ||||||
| bre | 4096 | udp | BRE (Bridge Relay Element) | Stephen Egbert | Stephen Egbert | ||||||
| patrolview | 4097 | tcp | Patrol View | Portnoy Boxman | Portnoy Boxman | ||||||
| patrolview | 4097 | udp | Patrol View | Portnoy Boxman | Portnoy Boxman | ||||||
| drmsfsd | 4098 | tcp | drmsfsd | Masao Iwai | Masao Iwai | ||||||
| drmsfsd | 4098 | udp | drmsfsd | Masao Iwai | Masao Iwai | ||||||
| dpcp | 4099 | tcp | DPCP | John Croft | John Croft | ||||||
| dpcp | 4099 | udp | DPCP | John Croft | John Croft | ||||||
| izm | 4109 | tcp | Instantiated Zero-control Messaging | David Miller | David Miller | 2007-02 | |||||
| izm | 4109 | udp | Instantiated Zero-control Messaging | David Miller | David Miller | 2007-02 | |||||
| assuria-slm | 4119 | tcp | Assuria Log Manager | Nick Connor | Nick Connor | 2006-12 | |||||
| assuria-slm | 4119 | udp | Assuria Log Manager | Nick Connor | Nick Connor | 2006-12 | |||||
| nuauth | 4129 | tcp | NuFW authentication protocol | Eric Leblond | Eric Leblond | 2007-06 | |||||
| nuauth | 4129 | udp | NuFW authentication protocol | Eric Leblond | Eric Leblond | 2007-06 | |||||
| thrtx | 4139 | tcp | Imperfect Networks Server | Dinkar Chivaluri | Dinkar Chivaluri | 2006-02 | |||||
| thrtx | 4139 | udp | Imperfect Networks Server | Dinkar Chivaluri | Dinkar Chivaluri | 2006-02 | |||||
| agslb | 4149 | tcp | A10 GSLB Service | John Chiong | John Chiong | 2007-07-02 | |||||
| agslb | 4149 | udp | A10 GSLB Service | John Chiong | John Chiong | 2007-07-02 | |||||
| nss | 4159 | tcp | Network Security Service | Dave Wierbowski | Dave Wierbowski | 2006-08 | |||||
| nss | 4159 | udp | Network Security Service | Dave Wierbowski | Dave Wierbowski | 2006-08 | |||||
| iadt | 4169 | tcp | Automation Drive Interface Transport | Paul Suhler | Paul Suhler | 2008-02-15 | |||||
| iadt-disc | 4169 | udp | Internet ADT Discovery Protocol | Paul A. Suhler | Paul A. Suhler | 2009-02-06 | |||||
| MaxumSP | 4179 | tcp | Maxum Services | Greg Stine | Greg Stine | 2007-07-05 | |||||
| MaxumSP | 4179 | udp | Maxum Services | Greg Stine | Greg Stine | 2007-07-05 | |||||
| pcep | 4189 | tcp | Path Computation Element Communication Protocol | ||||||||
| 4189 | udp | Reserved | RFC 5440 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrew Zimmerman | andrew&zimmerman.net | 2004-06 | |
| Arvel Hathcock | arvel&altn.com | 2007-03 | |
| Colin Hughes | chughes&agentsease.net | 2006-02 | |
| Dan Razzell | dan&starfishsystems.ca | 2006-06 | |
| Dave Wierbowski | wierbows&us.ibm.com | 2006-08 | |
| David A. Gayler | David.Gayler&bindview.com | 2005-08 | |
| David A. Gayler | dgayler&eminentware.com | 2006-07 | |
| David A. Lethe | david&santools.com | 2013-12-09 | |
| David Miller | dave.dsm&gmail.com | 2007-02 | |
| David Sperling | dsperling&smithmicro.com | 2006-06 | |
| Dinkar Chivaluri | dchivaluri&imperfectnetworks.com | 2006-02 | |
| Dr. Anupam Bharali | paniana&gmail.com | 2006-06 | |
| Eric Leblond | eric&inl.fr | 2007-06 | |
| Geoff Mendal | mendal&talarian.com | ||
| Greg Stine | greg.stine&siemens.com | 2007-07-05 | |
| Gyozo Kmethy | gyozo.kmethy&gnarus.hu | 2006-11 | |
| Ian Cargill | ian.cargill&e-dendrite.com | 2005-08 | |
| Jim Robanske | jimr&cray.com | 2006-05 | |
| John C. Horton | jch&unirsvl.rsvl.unisys.com | ||
| John Calcote | jcalcote&users.sourceforge.net | 2007-11-06 | |
| John Chiong | jchiong&a10networks.com | 2007-07-02 | |
| John Croft | john.croft&calista.demon.co.uk | ||
| Julien Danjou | acid&debian.org | 2006-07 | |
| Keith Ryden | kryden&esri.com | 2006-07 | |
| Ken Anderson | kanderso&kleber.ics.uci.edu | ||
| Kristian A. Bognaes | Norman Safeground AS | kristian.bognaes&norman.com | 2014-01-15 |
| Lewis Wolfgang | wolfgang&kencast.com | 2006-05 | |
| Mark Lipford | mark.a.lipford&sprint.com | 2006-07 | |
| Mark Simpson | simpson¢erline.com | ||
| Masao Iwai | iwai&kel.fujitsu.co.jp | ||
| Michael King | mike.king&pvxplus.com | 2006-07 | |
| Nick Connor | nickc&assuria.com | 2010-06-30 | |
| Paul A. Suhler | paul.suhler&quantum.com | 2009-02-06 | |
| Paul Suhler | paul.suhler&quantum.com | 2008-02-15 | |
| Pim van Riezen | registries&panelsix.com | 2006-07 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Stephen Egbert | egbert&ra.timeplex.com | ||
| Toru Tachibana | tatibana&exs.ts.fujitsu.co.jp | ||
| Wes Wilson | wwilson&iss.net | 2003-10 | |
| Yuval Hager | yuval&avramzon.net | 2006-01 |