Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
powerguardian 1777 tcp powerguardian Charles Bennett Charles Bennett 2008-08-29
powerguardian 1777 udp powerguardian Charles Bennett Charles Bennett 2008-08-29
prodigy-intrnet 1778 tcp prodigy-internet Bob Dedrick Bob Dedrick
prodigy-intrnet 1778 udp prodigy-internet Bob Dedrick Bob Dedrick
pharmasoft 1779 tcp pharmasoft Ola Strandberg Ola Strandberg
pharmasoft 1779 udp pharmasoft Ola Strandberg Ola Strandberg
dpkeyserv 1780 tcp dpkeyserv Yasunari Gon Yamasita Yasunari Gon Yamasita
dpkeyserv 1780 udp dpkeyserv Yasunari Gon Yamasita Yasunari Gon Yamasita
answersoft-lm 1781 tcp answersoft-lm James A. Brewster James A. Brewster
answersoft-lm 1781 udp answersoft-lm James A. Brewster James A. Brewster
hp-hcip 1782 tcp hp-hcip Allen Baker Allen Baker
hp-hcip 1782 udp hp-hcip Allen Baker Allen Baker
1783 Decomissioned Port 04/14/00, ms naonao naonao
finle-lm 1784 tcp Finle License Manager Dongling Wang Dongling Wang
finle-lm 1784 udp Finle License Manager Dongling Wang Dongling Wang
windlm 1785 tcp Wind River Systems License Manager Will Dere Will Dere
windlm 1785 udp Wind River Systems License Manager Will Dere Will Dere
funk-logger 1786 tcp funk-logger
funk-logger 1786 udp funk-logger
funk-license 1787 tcp funk-license Cimarron Boozer; Eric Wilde Cimarron Boozer; Eric Wilde
funk-license 1787 udp funk-license Cimarron Boozer; Eric Wilde Cimarron Boozer; Eric Wilde
psmond 1788 tcp psmond Will Golson Will Golson
psmond 1788 udp psmond Will Golson Will Golson
hello 1789 tcp hello D. J. Bernstein D. J. Bernstein 2018-04-05
hello 1789 udp hello D. J. Bernstein D. J. Bernstein 2018-04-05
nmsp 1790 tcp Narrative Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
nmsp 1790 udp Narrative Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
ea1 1791 tcp EA1 Kirk MacLean Kirk MacLean
ea1 1791 udp EA1 Kirk MacLean Kirk MacLean
ibm-dt-2 1792 tcp ibm-dt-2 Sam Borman Sam Borman
ibm-dt-2 1792 udp ibm-dt-2 Sam Borman Sam Borman
rsc-robot 1793 tcp rsc-robot Andrew Jay Schneider Andrew Jay Schneider
rsc-robot 1793 udp rsc-robot Andrew Jay Schneider Andrew Jay Schneider
cera-bcm 1794 tcp cera-bcm Leo Moesgaard Leo Moesgaard
cera-bcm 1794 udp cera-bcm Leo Moesgaard Leo Moesgaard
dpi-proxy 1795 tcp dpi-proxy Charles Gordon Charles Gordon
dpi-proxy 1795 udp dpi-proxy Charles Gordon Charles Gordon
vocaltec-admin 1796 tcp Vocaltec Server Administration Scott Petrack Scott Petrack
vocaltec-admin 1796 udp Vocaltec Server Administration Scott Petrack Scott Petrack
uma 1797 tcp UMA Martin Kirk Martin Kirk
uma 1797 udp UMA Martin Kirk Martin Kirk
etp 1798 tcp Event Transfer Protocol Mike Wray Mike Wray
etp 1798 udp Event Transfer Protocol Mike Wray Mike Wray
netrisk 1799 tcp NETRISK Kevin Green Kevin Green
netrisk 1799 udp NETRISK Kevin Green Kevin Green
ansys-lm 1800 tcp ANSYS-License manager Suzanne Lorrin Suzanne Lorrin
ansys-lm 1800 udp ANSYS-License manager Suzanne Lorrin Suzanne Lorrin
msmq 1801 tcp Microsoft Message Que Amnon Horowitz Amnon Horowitz
msmq 1801 udp Microsoft Message Que Amnon Horowitz Amnon Horowitz
concomp1 1802 tcp ConComp1 Ed Vincent Ed Vincent
concomp1 1802 udp ConComp1 Ed Vincent Ed Vincent
hp-hcip-gwy 1803 tcp HP-HCIP-GWY Allen Baker Allen Baker
hp-hcip-gwy 1803 udp HP-HCIP-GWY Allen Baker Allen Baker
enl 1804 tcp ENL Brian Olson Brian Olson
enl 1804 udp ENL Brian Olson Brian Olson
enl-name 1805 tcp ENL-Name Brian Olson Brian Olson
enl-name 1805 udp ENL-Name Brian Olson Brian Olson
musiconline 1806 tcp Musiconline Craig Weeks Craig Weeks
musiconline 1806 udp Musiconline Craig Weeks Craig Weeks
fhsp 1807 tcp Fujitsu Hot Standby Protocol Eiki Iwata Eiki Iwata
fhsp 1807 udp Fujitsu Hot Standby Protocol Eiki Iwata Eiki Iwata
oracle-vp2 1808 tcp Oracle-VP2 Craig Fowler Craig Fowler
oracle-vp2 1808 udp Oracle-VP2 Craig Fowler Craig Fowler
oracle-vp1 1809 tcp Oracle-VP1 Craig Fowler Craig Fowler
oracle-vp1 1809 udp Oracle-VP1 Craig Fowler Craig Fowler
jerand-lm 1810 tcp Jerand License Manager Robert Monat Robert Monat
jerand-lm 1810 udp Jerand License Manager Robert Monat Robert Monat
scientia-sdb 1811 tcp Scientia-SDB SYSTEMS MANAGER SYSTEMS MANAGER
scientia-sdb 1811 udp Scientia-SDB SYSTEMS MANAGER SYSTEMS MANAGER
radius 1812 tcp RADIUS RFC 2865
radius 1812 udp RADIUS RFC 2865
radius-acct 1813 tcp RADIUS Accounting RFC 2866
radius-acct 1813 udp RADIUS Accounting RFC 2866
tdp-suite 1814 tcp TDP Suite Rob Lockhart Rob Lockhart
tdp-suite 1814 udp TDP Suite Rob Lockhart Rob Lockhart
mmpft 1815 tcp Manufacturing messaging protocol for factory transmission Ralf Muckenhirn Ralf Muckenhirn 2024-06-12
mmpft 1815 udp Manufacturing messaging protocol for factory transmission Ralf Muckenhirn Ralf Muckenhirn 2024-06-12
harp 1816 tcp HARP Bjorn Chambless Bjorn Chambless
harp 1816 udp HARP Bjorn Chambless Bjorn Chambless
rkb-oscs 1817 tcp RKB-OSCS Robert Kevin Breton Robert Kevin Breton
rkb-oscs 1817 udp RKB-OSCS Robert Kevin Breton Robert Kevin Breton
etftp 1818 tcp Enhanced Trivial File Transfer Protocol William Polites William Polites
etftp 1818 udp Enhanced Trivial File Transfer Protocol William Polites William Polites
plato-lm 1819 tcp Plato License Manager Mark Morris Mark Morris
plato-lm 1819 udp Plato License Manager Mark Morris Mark Morris
mcagent 1820 tcp mcagent Ryoichi Shinohara Ryoichi Shinohara
mcagent 1820 udp mcagent Ryoichi Shinohara Ryoichi Shinohara
donnyworld 1821 tcp donnyworld Don Oliver Don Oliver
donnyworld 1821 udp donnyworld Don Oliver Don Oliver
es-elmd 1822 tcp es-elmd David Duncan David Duncan
es-elmd 1822 udp es-elmd David Duncan David Duncan
unisys-lm 1823 tcp Unisys Natural Language License Manager Raymond A. Diedrichs Raymond A. Diedrichs
unisys-lm 1823 udp Unisys Natural Language License Manager Raymond A. Diedrichs Raymond A. Diedrichs
metrics-pas 1824 tcp metrics-pas Tom Haapanen Tom Haapanen
metrics-pas 1824 udp metrics-pas Tom Haapanen Tom Haapanen
direcpc-video 1825 tcp DirecPC Video Chris Kerrigan Chris Kerrigan
direcpc-video 1825 udp DirecPC Video Chris Kerrigan Chris Kerrigan
ardt 1826 tcp ARDT Mike Goddard Mike Goddard
ardt 1826 udp ARDT Mike Goddard Mike Goddard
asi 1827 tcp ASI Bob Tournoux Bob Tournoux
asi 1827 udp ASI Bob Tournoux Bob Tournoux

Contact Information

Name Contact URI Last Updated
Allen Baker abaker&boi.hp.com
Amnon Horowitz amnonh&microsoft.com
Andrew Jay Schneider ajs&relsoft.com
Bjorn Chambless bjorn&cs.pdx.edu
Bob Dedrick bob&staff.prodigy.com
Bob Tournoux bob.tournoux&usiny.mail.abb.com
Brian Olson briolson&pacbell.net
Charles Bennett bennettc&ohio.edu 2008-08-29
Charles Gordon cgordon&digprod.com
Chris Kerrigan ckerrigan&hns.com
Cimarron Boozer cboozer&funk.com
Craig Fowler cfowler&us.oracle.com
Craig Weeks cweeks&syspace.co.uk
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
David Duncan dduncan&es.com
Don Oliver don&donnyworld.com
Dongling Wang dongling&finle.com
Ed Vincent edv&concomp.com
Eiki Iwata eiki&nd.net.fujitsu.co.jp
Eric Wilde eric&funk.com
James A. Brewster jimbrew&answersoft.com
Kevin Green Kevin_Green&tds.com
Kirk MacLean kmaclean&ea.com
Leo Moesgaard leo_moesgaard&dk.ibm.com
Mark Morris mim&ermuk.com
Martin Kirk m.kirk&opengroup.org
Mike Goddard mike.goddard&ardent.com.au
Mike Wray mjw&hplb.hpl.hp.com
Ola Strandberg Ola.Strandberg&pharmasoft.se
Paul Santinelli Jr. psantinelli&narrative.com
Ralf Muckenhirn info&muckenhirn.net 2024-06-11
Raymond A. Diedrichs rayd&slu.tr.unisys.com
Rob Lockhart rob.lockhart&mot.com
Robert Kevin Breton BOBBRETON&hotmail.com
Robert Monat jerand&jerand.com
Ryoichi Shinohara shinohara&vnet.ibm.com
SYSTEMS MANAGER systems-manager&scientia.com
Sam Borman sam_borman&uk.ibm.com
Scott Petrack Scott_Petrack&vocaltec.com
Suzanne Lorrin sml&ansyspo.ansys.com
Tom Haapanen tomh&metrics.com
Will Dere will&wrs.com
Will Golson golson&fc.hp.com
William Polites wpolites&mitre.org
Yasunari Gon Yamasita yamasita&omronsoft.co.jp
naonao&kikaku.mmp.fujitsu.co.jp