Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| adobeserver-5 | 3705 | udp | Adobe Server 5 | Bernd Paradies | Bernd Paradies | 2008-01-14 | |||||
| anoto-rendezv | 3715 | tcp | Anoto Rendezvous Port | Ola Sandstrom | Ola Sandstrom | 2003-03 | |||||
| anoto-rendezv | 3715 | udp | Anoto Rendezvous Port | Ola Sandstrom | Ola Sandstrom | 2003-03 | |||||
| na-er-tip | 3725 | tcp | Netia NA-ER Port | Jean-Pierre Garcia | Jean-Pierre Garcia | 2003-04 | |||||
| na-er-tip | 3725 | udp | Netia NA-ER Port | Jean-Pierre Garcia | Jean-Pierre Garcia | 2003-04 | |||||
| pwdis | 3735 | tcp | Password Distribution | Robert Erl | Robert Erl | 2003-04 | |||||
| pwdis | 3735 | udp | Password Distribution | Robert Erl | Robert Erl | 2003-04 | |||||
| gw-call-port | 3745 | tcp | GWRTC Call Port | Felisa Ares | Felisa Ares | 2003-04 | |||||
| gw-call-port | 3745 | udp | GWRTC Call Port | Felisa Ares | Felisa Ares | 2003-04 | |||||
| cbos-ip-port | 3750 | tcp | CBOS/IP ncapsalation port | Thomas Dannemiller | Thomas Dannemiller | 2003-04 | |||||
| cbos-ip-port | 3750 | udp | CBOS/IP ncapsalation port | Thomas Dannemiller | Thomas Dannemiller | 2003-04 | |||||
| gprs-cube | 3751 | tcp | CommLinx GPRS Cube | Peter Johnson | Peter Johnson | 2003-04 | |||||
| gprs-cube | 3751 | udp | CommLinx GPRS Cube | Peter Johnson | Peter Johnson | 2003-04 | |||||
| vipremoteagent | 3752 | tcp | Vigil-IP RemoteAgent | Bryan Alvord | Bryan Alvord | 2003-04 | |||||
| vipremoteagent | 3752 | udp | Vigil-IP RemoteAgent | Bryan Alvord | Bryan Alvord | 2003-04 | |||||
| nattyserver | 3753 | tcp | NattyServer Port | Akira Saito | Akira Saito | 2003-04 | |||||
| nattyserver | 3753 | udp | NattyServer Port | Akira Saito | Akira Saito | 2003-04 | |||||
| timestenbroker | 3754 | tcp | TimesTen Broker Port | David Aspinwall | David Aspinwall | 2003-04 | |||||
| timestenbroker | 3754 | udp | TimesTen Broker Port | David Aspinwall | David Aspinwall | 2003-04 | |||||
| sas-remote-hlp | 3755 | tcp | SAS Remote Help Server | Gary T. Ciampa | Gary T. Ciampa | 2003-04 | |||||
| sas-remote-hlp | 3755 | udp | SAS Remote Help Server | Gary T. Ciampa | Gary T. Ciampa | 2003-04 | |||||
| canon-capt | 3756 | tcp | Canon CAPT Port | Takashi Okazawa | Takashi Okazawa | 2003-04 | |||||
| canon-capt | 3756 | udp | Canon CAPT Port | Takashi Okazawa | Takashi Okazawa | 2003-04 | |||||
| grf-port | 3757 | tcp | GRF Server Port | Robert Banfill | Robert Banfill | 2003-04 | |||||
| grf-port | 3757 | udp | GRF Server Port | Robert Banfill | Robert Banfill | 2003-04 | |||||
| apw-registry | 3758 | tcp | apw RMI registry | Dan Davis | Dan Davis | 2003-04 | |||||
| apw-registry | 3758 | udp | apw RMI registry | Dan Davis | Dan Davis | 2003-04 | |||||
| exapt-lmgr | 3759 | tcp | Exapt License Manager | Christoph Kukulies | Christoph Kukulies | 2003-04 | |||||
| exapt-lmgr | 3759 | udp | Exapt License Manager | Christoph Kukulies | Christoph Kukulies | 2003-04 | |||||
| gsakmp | 3761 | tcp | gsakmp port | RFC 4535 | |||||||
| gsakmp | 3761 | udp | gsakmp port | RFC 4535 | |||||||
| rtraceroute | 3765 | tcp | Remote Traceroute | A. Blake Cooper | A. Blake Cooper | 2003-06 | |||||
| rtraceroute | 3765 | udp | Remote Traceroute | A. Blake Cooper | A. Blake Cooper | 2003-06 | |||||
| ispmmgr | 3775 | tcp | ISPM Manager Port | Eric Anderson | Eric Anderson | 2003-06 | |||||
| ispmmgr | 3775 | udp | ISPM Manager Port | Eric Anderson | Eric Anderson | 2003-06 | |||||
| bfd-control | 3784 | tcp | BFD Control Protocol | RFC 5881 | |||||||
| bfd-control | 3784 | udp | BFD Control Protocol | RFC 5881 | |||||||
| bfd-echo | 3785 | tcp | BFD Echo Protocol | RFC 5881 | |||||||
| bfd-echo | 3785 | udp | BFD Echo Protocol | RFC 5881 | |||||||
| myblast | 3795 | tcp | myBLAST Mekentosj port | Alexander Griekspoor | Alexander Griekspoor | 2003-07 | |||||
| myblast | 3795 | udp | myBLAST Mekentosj port | Alexander Griekspoor | Alexander Griekspoor | 2003-07 | |||||
| radius-dynauth | 3799 | tcp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| radius-dynauth | 3799 | udp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| tcpdataserver | 3805 | tcp | ThorGuard Server Port | Joel E. Steiger | Joel E. Steiger | 2004-02 | |||||
| tcpdataserver | 3805 | udp | ThorGuard Server Port | Joel E. Steiger | Joel E. Steiger | 2004-02 | |||||
| lansurveyorxml | 3815 | tcp | LANsurveyor XML | Michael Swan | Michael Swan | 2004-04 | |||||
| lansurveyorxml | 3815 | udp | LANsurveyor XML | Michael Swan | Michael Swan | 2004-04 | |||||
| ffserver | 3825 | tcp | Antera FlowFusion Process Simulation | Armin Liebchen | Armin Liebchen | 2007-06 | |||||
| ffserver | 3825 | udp | Antera FlowFusion Process Simulation | Armin Liebchen | Armin Liebchen | 2007-06 | |||||
| spectardb | 3835 | tcp | Spectar Database Rights Service | Jan Rutger Voorhorst | Jan Rutger Voorhorst | 2006-10 | |||||
| spectardb | 3835 | udp | Spectar Database Rights Service | Jan Rutger Voorhorst | Jan Rutger Voorhorst | 2006-10 | |||||
| v-one-spp | 3845 | tcp | V-ONE Single Port Proxy | Daniel Becker | Daniel Becker | ||||||
| v-one-spp | 3845 | udp | V-ONE Single Port Proxy | Daniel Becker | Daniel Becker | ||||||
| qtms-bootstrap | 3850 | tcp | QTMS Bootstrap Protocol | Phil Willis | Phil Willis | 2003-08 | |||||
| qtms-bootstrap | 3850 | udp | QTMS Bootstrap Protocol | Phil Willis | Phil Willis | 2003-08 | |||||
| spectraport | 3851 | tcp | SpectraTalk Port | Madhav Karhade | Madhav Karhade | 2003-08 | |||||
| spectraport | 3851 | udp | SpectraTalk Port | Madhav Karhade | Madhav Karhade | 2003-08 | |||||
| sse-app-config | 3852 | tcp | SSE App Configuration | Tim Wilson | Tim Wilson | 2003-08 | |||||
| sse-app-config | 3852 | udp | SSE App Configuration | Tim Wilson | Tim Wilson | 2003-08 | |||||
| sscan | 3853 | tcp | SONY scanning protocol | Takashi Aihara | Takashi Aihara | 2003-08 | |||||
| sscan | 3853 | udp | SONY scanning protocol | Takashi Aihara | Takashi Aihara | 2003-08 | |||||
| stryker-com | 3854 | tcp | Stryker Comm Port | Andrew Schultz | Andrew Schultz | 2003-08 | |||||
| stryker-com | 3854 | udp | Stryker Comm Port | Andrew Schultz | Andrew Schultz | 2003-08 | |||||
| opentrac | 3855 | tcp | OpenTRAC | Scott Miller | Scott Miller | 2003-08 | |||||
| opentrac | 3855 | udp | OpenTRAC | Scott Miller | Scott Miller | 2003-08 | |||||
| informer | 3856 | tcp | INFORMER | Filippo Fadda | Filippo Fadda | 2003-08 | |||||
| informer | 3856 | udp | INFORMER | Filippo Fadda | Filippo Fadda | 2003-08 | |||||
| trap-port | 3857 | tcp | Trap Port | Norm Freedman | Norm Freedman | 2003-08 | |||||
| trap-port | 3857 | udp | Trap Port | Norm Freedman | Norm Freedman | 2003-08 | |||||
| trap-port-mom | 3858 | tcp | Trap Port MOM | Norm Freedman | Norm Freedman | 2003-08 | |||||
| trap-port-mom | 3858 | udp | Trap Port MOM | Norm Freedman | Norm Freedman | 2003-08 | |||||
| nav-port | 3859 | tcp | Navini Port | Chris Sanders | Chris Sanders | 2003-08 | |||||
| nav-port | 3859 | udp | Navini Port | Chris Sanders | Chris Sanders | 2003-08 | |||||
| asap-udp | 3863 | udp | asap udp port | RFC 5352 | |||||||
| asap-sctp | 3863 | sctp | asap sctp | RFC 5352 | |||||||
| asap-tcp-tls | 3864 | tcp | asap/tls tcp port | RFC 5352 | |||||||
| asap-sctp-tls | 3864 | sctp | asap-sctp/tls | RFC 5352 | |||||||
| xpl | 3865 | tcp | xpl automation protocol | Ian Lowe | Ian Lowe | 2003-08 | |||||
| xpl | 3865 | udp | xpl automation protocol | Ian Lowe | Ian Lowe | 2003-08 | |||||
| diameter | 3868 | sctp | DIAMETER | RFC 3588 | |||||||
| pnbscada | 3875 | tcp | PNBSCADA | Philip N. Bergstresser | Philip N. Bergstresser | ||||||
| pnbscada | 3875 | udp | PNBSCADA | Philip N. Bergstresser | Philip N. Bergstresser | ||||||
| topflow-ssl | 3885 | tcp | TopFlow SSL | Ken Nelson | Ken Nelson | ||||||
| topflow-ssl | 3885 | udp | TopFlow SSL | Ken Nelson | Ken Nelson | ||||||
| syam-smc | 3895 | tcp | SyAm SMC Service Port | Michael Daniele | Michael Daniele | 2003-10 | |||||
| syam-smc | 3895 | udp | SyAm SMC Service Port | Michael Daniele | Michael Daniele | 2003-10 | |||||
| mupdate | 3905 | tcp | Mailbox Update (MUPDATE) protocol | RFC 3656 | |||||||
| mupdate | 3905 | udp | Mailbox Update (MUPDATE) protocol | RFC 3656 | |||||||
| agcat | 3915 | tcp | Auto-Graphics Cataloging | Paul Cope | Paul Cope | 2003-11 | |||||
| agcat | 3915 | udp | Auto-Graphics Cataloging | Paul Cope | Paul Cope | 2003-11 | |||||
| zmp | 3925 | tcp | Zoran Media Port | Gerard Cerchio | Gerard Cerchio | 2003-11 | |||||
| zmp | 3925 | udp | Zoran Media Port | Gerard Cerchio | Gerard Cerchio | 2003-11 | |||||
| sdp-portmapper | 3935 | tcp | SDP Port Mapper Protocol | James Pinkerton | James Pinkerton | 2003-11 | |||||
| sdp-portmapper | 3935 | udp | SDP Port Mapper Protocol | James Pinkerton | James Pinkerton | 2003-11 | |||||
| emcads | 3945 | tcp | EMCADS Server Port | Lars Struwe Christensen | Lars Struwe Christensen | 2004-01 | |||||
| emcads | 3945 | udp | EMCADS Server Port | Lars Struwe Christensen | Lars Struwe Christensen | 2004-01 | |||||
| namemunge | 3950 | tcp | Name Munging | John C. Klensin | John C. Klensin | 2004-07 | |||||
| namemunge | 3950 | udp | Name Munging | John C. Klensin | John C. Klensin | 2004-07 | |||||
| pwgippfax | 3951 | tcp | PWG IPP Facsimile | Ira McDonald | Ira McDonald | 2004-08 | |||||
| pwgippfax | 3951 | udp | PWG IPP Facsimile | Ira McDonald | Ira McDonald | 2004-08 | |||||
| i3-sessionmgr | 3952 | tcp | I3 Session Manager | Mike Gagle | Mike Gagle | 2004-08 |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| A. Blake Cooper | blake&cluebie.net | 2003-06 |
| Akira Saito | admin&kobu.com | 2003-04 |
| Alexander Griekspoor | a.griekspoor&nki.nl | 2003-07 |
| Andrew Schultz | aschultz&strykercom.com | 2003-08 |
| Armin Liebchen | armin&anteradesign.com | 2007-06 |
| Bernd Paradies | bparadie&adobe.com | 2008-01-14 |
| Bryan Alvord | bryan&vaticor.com | 2003-04 |
| Chris Sanders | csanders&navini.com | 2003-08 |
| Christoph Kukulies | info&exapt.de | 2003-04 |
| Dan Davis | Dan.A.Davis&hp.com | 2003-04 |
| Daniel Becker | dbecker&v-one.com | |
| David Aspinwall | aspinwall×ten.com | 2003-04 |
| Eric Anderson | eanderson&netvision.com | 2003-06 |
| Felisa Ares | faa06&tid.es | 2003-04 |
| Filippo Fadda | fadda&osway.com | 2003-08 |
| Gary T. Ciampa | Gary.Ciampa&sas.com | 2003-04 |
| Gerard Cerchio | gjpc&circlesoft.com | 2003-11 |
| Ian Lowe | ian&xplproject.org.uk | 2003-08 |
| Ira McDonald | imcdonald&sharplabs.com | 2005-12 |
| James Pinkerton | jpinkµsoft.com | 2003-11 |
| Jan Rutger Voorhorst | janrutger&roadware.nl | 2006-10 |
| Jean-Pierre Garcia | jp.garcia&netia.net | 2003-04 |
| Joel E. Steiger | jsteiger&eic-us.com | 2004-02 |
| John C. Klensin | klensin&jck.com | 2004-07 |
| Ken Nelson | nelson&toplayer.com | |
| Lars Struwe Christensen | lsc&giritech.com | 2004-01 |
| Madhav Karhade | madhav.karhade&wibhu.com | 2003-08 |
| Michael Daniele | michael.daniele&syamsoftware.com | 2003-11 |
| Michael Swan | swan&neon.com | 2004-04 |
| Mike Gagle | mikeg&inin.com | 2006-05 |
| Norm Freedman | normfree&san.rr.com | 2003-08 |
| Ola Sandstrom | ola.sandstrom&anoto.com | 2003-03 |
| Paul Cope | prc&auto-graphics.com | 2003-11 |
| Peter Johnson | peter&commlinx.com.au | 2004-11 |
| Phil Willis | phil.willis&prism-uk.com | 2003-08 |
| Philip N. Bergstresser | phil&bergstresser.org | |
| Robert Banfill | robert&banfill.net | 2003-04 |
| Robert Erl | roerl&web.de | 2003-04 |
| Scott Miller | scott&opentrac.org | 2003-08 |
| Takashi Aihara | aiharat&sm.sony.co.jp | 2003-08 |
| Takashi Okazawa | okazawa.takashi&canon.co.jp | 2003-04 |
| Thomas Dannemiller | tom.dannemiller&rolls-royce.com | 2003-04 |
| Tim Wilson | tim.wilson&motorola.com | 2003-08 |