Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| tripe | 4070 | tcp | Trivial IP Encryption (TrIPE) | Mark Wooding | Mark Wooding | 2007-07-10 | |||||
| tripe | 4070 | udp | Trivial IP Encryption (TrIPE) | Mark Wooding | Mark Wooding | 2007-07-10 | |||||
| aibkup | 4071 | tcp | Automatically Incremental Backup | Volker Wiegand | Volker Wiegand | 2007-07-10 | |||||
| aibkup | 4071 | udp | Automatically Incremental Backup | Volker Wiegand | Volker Wiegand | 2007-07-10 | |||||
| zieto-sock | 4072 | tcp | Zieto Socket Communications | Malcolm McLean | Malcolm McLean | 2007-07-19 | |||||
| zieto-sock | 4072 | udp | Zieto Socket Communications | Malcolm McLean | Malcolm McLean | 2007-07-19 | |||||
| iRAPP | 4073 | tcp | Interactive Remote Application Pairing Protocol | Volodymyr_Bykov | Volodymyr_Bykov | 2007-08-20 | 2016-11-23 | ||||
| iRAPP | 4073 | udp | Interactive Remote Application Pairing Protocol | Volodymyr_Bykov | Volodymyr_Bykov | 2007-08-20 | 2016-11-23 | ||||
| cequint-cityid | 4074 | tcp | Cequint City ID UI trigger | Phill Goeckler | Phill Goeckler | 2007-08-20 | |||||
| cequint-cityid | 4074 | udp | Cequint City ID UI trigger | Phill Goeckler | Phill Goeckler | 2007-08-20 | |||||
| perimlan | 4075 | tcp | ISC Alarm Message Service | Bernie Malkowski | Bernie Malkowski | 2007-08-20 | |||||
| perimlan | 4075 | udp | ISC Alarm Message Service | Bernie Malkowski | Bernie Malkowski | 2007-08-20 | |||||
| seraph | 4076 | tcp | Seraph DCS | Jason Spence | Jason Spence | 2008-01-22 | |||||
| seraph | 4076 | udp | Seraph DCS | Jason Spence | Jason Spence | 2008-01-22 | |||||
| 4077 | tcp | Reserved | |||||||||
| ascomalarm | 4077 | udp | Ascom IP Alarming | Ascom Austria GmbH | Ascom Austria GmbH | 2008-05-01 | |||||
| cssp | 4078 | tcp | Coordinated Security Service Protocol | Michael McDaniels | Michael McDaniels | 2008-05-01 | |||||
| 4078 | udp | Reserved | |||||||||
| santools | 4079 | tcp | SANtools Diagnostic Server | David A. Lethe | David A. Lethe | 2008-05-01 | |||||
| santools | 4079 | udp | SANtools Diagnostic Server | David A. Lethe | David A. Lethe | 2008-05-01 | |||||
| applusservice | 4087 | tcp | APplus Service | Alfred Weindl | Marcus Schairer | 2008-06-05 | 2021-08-09 | ||||
| 4087 | udp | Reserved | |||||||||
| patrolview | 4097 | tcp | Patrol View | Portnoy Boxman | Portnoy Boxman | ||||||
| patrolview | 4097 | udp | Patrol View | Portnoy Boxman | Portnoy Boxman | ||||||
| j-ac | 4107 | tcp | JDL Accounting LAN Service | Takashi Sahara | Takashi Sahara | 2006-09 | |||||
| j-ac | 4107 | udp | JDL Accounting LAN Service | Takashi Sahara | Takashi Sahara | 2006-09 | |||||
| hillrserv | 4117 | tcp | Hillr Connection Manager | Freddy A. Ayuso-Henson | Freddy A. Ayuso-Henson | 2008-05-22 | |||||
| hillrserv | 4117 | udp | Hillr Connection Manager | Freddy A. Ayuso-Henson | Freddy A. Ayuso-Henson | 2008-05-22 | |||||
| unikeypro | 4127 | tcp | NetUniKeyServer | Raymond Chaw | Raymond Chaw | 2007-05 | |||||
| unikeypro | 4127 | udp | NetUniKeyServer | Raymond Chaw | Raymond Chaw | 2007-05 | |||||
| cl-db-remote | 4137 | tcp | Classic Line Database Server Remote | Arno Kirmeir | Arno Kirmeir | 2007-01 | |||||
| cl-db-remote | 4137 | udp | Classic Line Database Server Remote | Arno Kirmeir | Arno Kirmeir | 2007-01 | |||||
| vrxpservman | 4147 | tcp | Multum Service Manager | Scott Mager | Scott Mager | 2006-10 | |||||
| vrxpservman | 4147 | udp | Multum Service Manager | Scott Mager | Scott Mager | 2006-10 | |||||
| stat-scanner | 4157 | tcp | STAT Scanner Control | ||||||||
| stat-scanner | 4157 | udp | STAT Scanner Control | ||||||||
| ddgn | 4167 | tcp | DeskDirect Global Network | Laurie Charlwood | Laurie Charlwood | 2007-08-22 | |||||
| ddgn | 4167 | udp | DeskDirect Global Network | Laurie Charlwood | Laurie Charlwood | 2007-08-22 | |||||
| d-cinema-csp | 4170 | tcp | SMPTE Content Synchonization Protocol | Michael Karagosian | Michael Karagosian | 2008-09-04 | |||||
| 4170 | udp | Reserved | |||||||||
| ml-svnet | 4171 | tcp | Maxlogic Supervisor Communication | Taha Paksu | Taha Paksu | 2009-12-21 | |||||
| 4171 | udp | Reserved | |||||||||
| pcoip | 4172 | tcp | PC over IP | HP Inc. | Jeff Jeansonne | 2009-12-23 | 2026-03-10 | ||||
| pcoip | 4172 | udp | PC over IP | HP Inc. | Jeff Jeansonne | 2009-12-23 | 2026-03-10 | ||||
| 4173 | tcp | Reserved | |||||||||
| mma-discovery | 4173 | udp | MMA Device Discovery | MIDI Manufacturers Assoc Inc | Tom White | 2011-11-14 | |||||
| smcluster | 4174 | tcp | StorMagic Cluster Services | Chris Farey | Chris Farey | 2011-03-09 | |||||
| sm-disc | 4174 | udp | StorMagic Discovery | StorMagic Ltd | Chris Farey | 2011-12-16 | |||||
| bccp | 4175 | tcp | Brocade Cluster Communication Protocol | Norival Figueira | Norival Figueira | 2010-04-07 | |||||
| 4175 | udp | Reserved | |||||||||
| tl-ipcproxy | 4176 | tcp | Translattice Cluster IPC Proxy | Michael Lyle | Michael Lyle | 2009-11-03 | |||||
| 4176 | udp | Reserved | |||||||||
| wello | 4177 | tcp | Wello P2P pubsub service | Christian Westbrook | Christian Westbrook | 2007-11-15 | |||||
| wello | 4177 | udp | Wello P2P pubsub service | Christian Westbrook | Christian Westbrook | 2007-11-15 | |||||
| storman | 4178 | tcp | StorMan | Werner Guertler | Werner Guertler | 2009-05-11 | |||||
| storman | 4178 | udp | StorMan | Werner Guertler | Werner Guertler | 2009-05-11 | |||||
| MaxumSP | 4179 | tcp | Maxum Services | Greg Stine | Greg Stine | 2007-07-05 | |||||
| MaxumSP | 4179 | udp | Maxum Services | Greg Stine | Greg Stine | 2007-07-05 | |||||
| csc-proxy | 4187 | tcp | Cascade Proxy IANA assigned this well-formed service name as a replacement for "csc_proxy". |
Matt Craighead | Matt Craighead | 2008-09-11 | |||||
| csc_proxy | 4187 | tcp | Cascade Proxy | Matt Craighead | Matt Craighead | 2008-09-11 | This entry is an alias to "csc-proxy". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 4187 | udp | Reserved | |||||||||
| hctl | 4197 | tcp | Harman HControl Protocol | Harman International Industries Inc. | Darin Smith | 2017-02-16 | |||||
| hctl | 4197 | udp | Harman HControl Protocol | Harman International Industries Inc. | Darin Smith | 2017-02-16 | |||||
| trueconf | 4307 | tcp | TrueConf Videoconference Service | Dmitry Odintsov | Lev Yakupov | 2007-10-22 | 2017-05-12 | ||||
| trueconf | 4307 | udp | TrueConf Videoconference Service | Dmitry Odintsov | Lev Yakupov | 2007-10-22 | 2017-05-12 | ||||
| opentelemetry | 4317 | tcp | OpenTelemetry Protocol | OpenTelemetry | Morgan McLean | 2020-12-09 | |||||
| 4317 | udp | Reserved | |||||||||
| rwhois | 4321 | tcp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| rwhois | 4321 | udp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| jaxer-web | 4327 | tcp | Jaxer Web Protocol | Uri Sarid | Uri Sarid | 2008-01-07 | |||||
| jaxer-web | 4327 | udp | Jaxer Web Protocol | Uri Sarid | Uri Sarid | 2008-01-07 | |||||
| netconf-ch-ssh | 4334 | tcp | NETCONF Call Home (SSH) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| netconf-ch-tls | 4335 | tcp | NETCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| restconf-ch-tls | 4336 | tcp | RESTCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4337-4339 | Unassigned | ||||||||||
| lansurveyor | 4347 | tcp | LAN Surveyor | Michael Swan | Michael Swan | ||||||
| lansurveyor | 4347 | udp | LAN Surveyor | Michael Swan | Michael Swan | ||||||
| qsnet-cond | 4357 | tcp | QSNet Conductor | ||||||||
| qsnet-cond | 4357 | udp | QSNet Conductor | ||||||||
| 4367 | Unassigned | ||||||||||
| elpro-tunnel | 4370 | tcp | ELPRO V2 Protocol Tunnel IANA assigned this well-formed service name as a replacement for "elpro_tunnel". |
Harry Courtice | Harry Courtice | 2008-04-14 | |||||
| elpro_tunnel | 4370 | tcp | ELPRO V2 Protocol Tunnel | Harry Courtice | Harry Courtice | 2008-04-14 | This entry is an alias to "elpro-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| elpro-tunnel | 4370 | udp | ELPRO V2 Protocol Tunnel IANA assigned this well-formed service name as a replacement for "elpro_tunnel". |
Harry Courtice | Harry Courtice | 2008-04-14 | |||||
| elpro_tunnel | 4370 | udp | ELPRO V2 Protocol Tunnel | Harry Courtice | Harry Courtice | 2008-04-14 | This entry is an alias to "elpro-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| l2c-control | 4371 | tcp | LAN2CAN Control | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| l2c-disc | 4371 | udp | LAN2CAN Discovery | Phil Tolson | Phil Tolson | 2010-01-21 | |||||
| l2c-data | 4372 | tcp | LAN2CAN Data | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| l2c-data | 4372 | udp | LAN2CAN Data | Phil Tolson | Phil Tolson | 2010-01-21 | |||||
| remctl | 4373 | tcp | Remote Authenticated Command Service | Russ Allbery | Russ Allbery | 2007-08-30 | |||||
| remctl | 4373 | udp | Remote Authenticated Command Service | Russ Allbery | Russ Allbery | 2007-08-30 | |||||
| psi-ptt | 4374 | tcp | PSI Push-to-Talk Protocol | Frank Bredenbröcker | Frank Bredenbröcker | 2008-07-17 | |||||
| 4374 | udp | Reserved | |||||||||
| tolteces | 4375 | tcp | Toltec EasyShare | Joon Radley | Joon Radley | 2008-10-21 | |||||
| tolteces | 4375 | udp | Toltec EasyShare | Joon Radley | Joon Radley | 2008-10-21 | |||||
| bip | 4376 | tcp | BioAPI Interworking | Jean-Paul Lemaire | Jean-Paul Lemaire | 2007-07-05 | |||||
| bip | 4376 | udp | BioAPI Interworking | Jean-Paul Lemaire | Jean-Paul Lemaire | 2007-07-05 | |||||
| cp-spxsvr | 4377 | tcp | Cambridge Pixel SPx Server | ||||||||
| cp-spxsvr | 4377 | udp | Cambridge Pixel SPx Server | ||||||||
| cp-spxdpy | 4378 | tcp | Cambridge Pixel SPx Display | Richard Warren | Richard Warren | 2007-07-05 | |||||
| cp-spxdpy | 4378 | udp | Cambridge Pixel SPx Display | Richard Warren | Richard Warren | 2007-07-05 | |||||
| ctdb | 4379 | tcp | CTDB | Ronnie Sahlberg | Ronnie Sahlberg | 2007-07-05 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alfred Weindl | alfred.weindl&assecosol.com | 2021-08-09 | |
| Arno Kirmeir | Arno.kirmeir&sage.de | 2007-01 | |
| Ascom Austria GmbH | info&ascom.at | 2008-05-01 | |
| Bernie Malkowski | bmalkowski&integratedsecuritycorp.com | 2007-08-20 | |
| Chris Farey | StorMagic Ltd | chris_farey&stormagic.com | 2011-12-16 |
| Christian Westbrook | cw&wellohorld.com | 2007-11-15 | |
| Darin Smith | darin.smith&harman.com | 2017-02-16 | |
| David A. Lethe | david&santools.com | 2013-12-09 | |
| Dmitry Odintsov | dimodin&trueconf.com | 2017-05-12 | |
| Frank Bredenbröcker | fbredenbroecker&psi.de | 2008-07-17 | |
| Freddy A. Ayuso-Henson | fayusohenson&hillr.com | 2008-05-22 | |
| Greg Stine | greg.stine&siemens.com | 2007-07-05 | |
| Harman International Industries Inc. | darin.smith&harman.com | 2017-02-16 | |
| Harry Courtice | harry.courtice&elprotech.com | 2008-04-14 | |
| HP Inc. | jeff.jeansonne&hp.com | 2026-03-10 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jason Spence | jspence&lightconsulting.com | 2008-01-22 | |
| Jean-Paul Lemaire | jean-paul.lemaire&univ-paris-diderot.fr | 2007-07-05 | |
| Jeff Jeansonne | jeff.jeansonne&hp.com | 2026-03-10 | |
| Joon Radley | joon&toltec.co.za
support&toltec.co.za |
2008-10-21 | |
| Laurie Charlwood | laurie.charlwood&printsoft.com | 2007-08-22 | |
| Lev Yakupov | lyakupov&trueconf.com | 2017-05-12 | |
| Malcolm McLean | malcolmm&zieto.co.za | 2007-07-19 | |
| Marcus Schairer | marcus.schairer&assecosol.com | 2021-08-09 | |
| Mark Kosters | markk&internic.net | ||
| Mark Wooding | mdw&distorted.org.uk | 2007-07-10 | |
| Matt Craighead | matt.craighead&conifersystems.com | 2008-09-11 | |
| Michael Karagosian | michael.karagosian&mkpe.com | 2008-09-04 | |
| Michael Lyle | protocols&translattice.com | 2009-11-03 | |
| Michael McDaniels | Extreme Networks Inc | mmcdaniels&extremenetworks.com | 2008-05-01 |
| Michael Swan | swan&neon.com | 2004-04 | |
| MIDI Manufacturers Assoc Inc | info&midi.org | 2011-11-14 | |
| Morgan McLean | OpenTelemetry | morgan_mclean&hotmail.com | 2020-12-09 |
| Norival Figueira | nfigueir&brocade.com | 2010-04-07 | |
| OpenTelemetry | cncf-opentelemetry-governance&lists.cncf.io | 2020-12-09 | |
| Phil Tolson | philtolson&eaton.com | 2010-01-21 | |
| Phill Goeckler | pgoeckler&cequint.com | 2007-08-20 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Raymond Chaw | Raymond&esecutech.com | 2007-05 | |
| Richard Warren | richard&cambridgepixel.com | 2008-09-17 | |
| Ronnie Sahlberg | ronniesahlberg&gmail.com | 2007-07-05 | |
| Russ Allbery | rra&stanford.edu | 2007-08-30 | |
| Scott Mager | Scott.Mager&cerner.com | 2006-10 | |
| StorMagic Ltd | chris_farey&stormagic.com | 2011-12-16 | |
| Taha Paksu | tahapaksu&mavili.com.tr | 2009-12-21 | |
| Takashi Sahara | sahara&jdl.co.jp | 2006-09 | |
| Tom White | MIDI Manufacturers Assoc Inc | info&midi.org | 2011-11-14 |
| Uri Sarid | uri&aptana.com | 2008-01-22 | |
| Volker Wiegand | volker.wiegand&t-online.de | 2007-07-10 | |
| Volodymyr_Bykov | vbickov&gmail.com | 2016-11-23 | |
| Werner Guertler | werner.guertler&fujitsu.com | 2025-04-03 |