Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
4189 udp Reserved RFC 5440
sieve 4190 tcp ManageSieve Protocol
4190 udp Reserved RFC 5804
4191 tcp Reserved
dsmipv6 4191 udp Dual Stack MIPv6 NAT Traversal RFC 5555
azeti 4192 tcp Azeti Agent Service Uwe Holz Uwe Holz 2009-11-09
azeti-bd 4192 udp azeti blinddate Michael Werski Michael Werski 2010-02-18
pvxplusio 4193 tcp PxPlus remote file srvr Mike King Mike King 2009-11-09
4193 udp Reserved
spdm 4194 tcp Security Protocol and Data Model DMTF Administration Robert Keyes 2022-01-10 2025-05-30
4194 udp Reserved
aws-wsp 4195 tcp AWS protocol for cloud remoting solution Amazon.com Services LLC Lauren Townsend 2020-04-06
aws-wsp 4195 udp AWS protocol for cloud remoting solution Amazon.com Services LLC Lauren Townsend 2020-04-06
aws-wsp 4195 sctp AWS protocol for cloud remoting solution Amazon.com Services LLC Lauren Townsend 2020-04-06
aws-wsp 4195 dccp AWS protocol for cloud remoting solution Amazon.com Services LLC Lauren Townsend 2020-04-06
4196 Unassigned
hctl 4197 tcp Harman HControl Protocol Harman International Industries Inc. Darin Smith 2017-02-16
hctl 4197 udp Harman HControl Protocol Harman International Industries Inc. Darin Smith 2017-02-16
4198 Unassigned
eims-admin 4199 tcp EIMS ADMIN Glenn Anderson Glenn Anderson
eims-admin 4199 udp EIMS ADMIN Glenn Anderson Glenn Anderson
vrml-multi-use 4200-4299 VRML Multi User Systems Mitra Mitra
dserver 4309 tcp Exsequi Appliance Discovery Angelo Masci Angelo Masci 2007-01
dserver 4309 udp Exsequi Appliance Discovery Angelo Masci Angelo Masci 2007-01
skytale 4319 tcp Sentyron SkyTale encrypted communication Sentyron B.V. Mark Revier 2022-01-20 2025-10-30
skytale 4319 udp Sentyron SkyTale encrypted communication Sentyron B.V. Mark Revier 2022-01-20 2025-10-30
publiqare-sync 4329 tcp PubliQare Distributed Environment Synchronisation Engine Tom Maaswinkel Tom Maaswinkel 2011-02-07
4329 udp Reserved
4337-4339 Unassigned
lisp-data 4341 udp LISP Data Packets IESG IETF Chair 2007-11-12 2021-02-17 RFC 9300
lisp-control 4342 udp LISP Control Packets IETF IESG 2007-05 2021-02-25 RFC 9301
fsportmap 4349 tcp File System Port Map Ron Minnich Ron Minnich
fsportmap 4349 udp File System Port Map Ron Minnich Ron Minnich
omabcastltkm 4359 tcp OMA BCAST Long-Term Key Messages Frank Hartung Frank Hartung 2007-09-07
omabcastltkm 4359 udp OMA BCAST Long-Term Key Messages Frank Hartung Frank Hartung 2007-09-07
epmd 4369 tcp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
epmd 4369 udp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
ctdb 4379 tcp CTDB Ronnie Sahlberg Ronnie Sahlberg 2007-07-05
ctdb 4379 udp CTDB Ronnie Sahlberg Ronnie Sahlberg 2007-07-05
xandros-cms 4389 tcp Xandros Community Management Service Stephen M. Webb Stephen M. Webb 2007-05
xandros-cms 4389 udp Xandros Community Management Service Stephen M. Webb Stephen M. Webb 2007-05
wiegand 4390 tcp Physical Access Control Scott Guthery Scott Guthery 2008-08-25
wiegand 4390 udp Physical Access Control Scott Guthery Scott Guthery 2008-08-25
apwi-imserver 4391 tcp American Printware IMServer Protocol Lech Lakomy Lech Lakomy 2009-02-12
4391 udp Reserved
apwi-rxserver 4392 tcp American Printware RXServer Protocol Lech Lakomy Lech Lakomy 2009-02-12
4392 udp Reserved
apwi-rxspooler 4393 tcp American Printware RXSpooler Protocol Lech Lakomy Lech Lakomy 2009-02-12
4393 udp Reserved
4394 tcp Reserved
apwi-disc 4394 udp American Printware Discovery Lech Lakomy Lech Lakomy 2009-02-12
omnivisionesx 4395 tcp OmniVision communication for Virtual environments Vacquier Serge Vacquier Serge 2009-02-12
omnivisionesx 4395 udp OmniVision communication for Virtual environments Vacquier Serge Vacquier Serge 2009-02-12
fly 4396 tcp Fly Object Space Nigel Warren Nigel Warren 2009-02-12
4396 udp Reserved
4397-4399 Unassigned
netcabinet-com 4409 tcp Net-Cabinet comunication Ian Manning Ian Manning 2009-12-16
4409 udp Reserved
cbp 4419 tcp Colnod Binary Protocol Colsys s.r.o. Jiri Merth 2016-03-23
4419 udp Reserved
omviagent 4429 tcp OMV Investigation Agent-Server Serge Vacquier Serge Vacquier 2009-05-20
4429 udp Reserved
privatewire 4449 tcp PrivateWire Uri Resnitzky Uri Resnitzky
privatewire 4449 udp PrivateWire Uri Resnitzky Uri Resnitzky
4459 Unassigned
ntske 4460 tcp Network Time Security Key Establishment IESG IETF Chair 2020-04-07 RFC 8915
4461-4479 Unassigned
4489-4499 Unassigned Known UNAUTHORIZED USE: Ports 4490 and 4491
ipsec-nat-t 4500 tcp IPsec NAT-Traversal 2022-09-15 RFC 9329
ipsec-nat-t 4500 udp IPsec NAT-Traversal 2017-07-07 RFC 3948; RFC 7296
4539-4544 Unassigned
aegate 4549 tcp Aegate PMR Service Nick Warrington Nick Warrington 2006-03
aegate 4549 udp Aegate PMR Service Nick Warrington Nick Warrington 2006-03
dtn-bundle 4556 tcp DTN Bundle TCP CL Protocol IESG IETF Chair 2021-02-22 RFC 9174
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985
hylafax 4559 tcp HylaFAX Lee Howard Lee Howard 2002-03
hylafax 4559 udp HylaFAX Lee Howard Lee Howard 2002-03
iax 4569 tcp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
iax 4569 udp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
4574-4589 Unassigned
rid 4590 tcp RID over HTTP/TLS IESG IETF Chair RFC 6546
4590 udp Reserved
l3t-at-an 4591 tcp HRPD L3T (AT-AN) Avi Lior Avi Lior 2009-02-27
l3t-at-an 4591 udp HRPD L3T (AT-AN) Avi Lior Avi Lior 2009-02-27
4592 tcp Reserved
hrpd-ith-at-an 4592 udp HRPD-ITH (AT-AN) David Ott David Ott 2008-06-05
ipt-anri-anri 4593 tcp IPT (ANRI-ANRI)
ipt-anri-anri 4593 udp IPT (ANRI-ANRI)
ias-session 4594 tcp IAS-Session (ANRI-ANRI)
ias-session 4594 udp IAS-Session (ANRI-ANRI)
ias-paging 4595 tcp IAS-Paging (ANRI-ANRI)
ias-paging 4595 udp IAS-Paging (ANRI-ANRI)
ias-neighbor 4596 tcp IAS-Neighbor (ANRI-ANRI) David Ott David Ott 2007-07-31
ias-neighbor 4596 udp IAS-Neighbor (ANRI-ANRI) David Ott David Ott 2007-07-31
a21-an-1xbs 4597 tcp A21 (AN-1xBS) David Ott David Ott 2006-02
a21-an-1xbs 4597 udp A21 (AN-1xBS) David Ott David Ott 2006-02
a16-an-an 4598 tcp A16 (AN-AN) David Ott David Ott 2005-12
a16-an-an 4598 udp A16 (AN-AN) David Ott David Ott 2005-12
a17-an-an 4599 tcp A17 (AN-AN) David Ott David Ott 2006-02
a17-an-an 4599 udp A17 (AN-AN) David Ott David Ott 2006-02
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132

Contact Information

Name Organization Contact URI Last Updated
Amazon.com Services LLC aws-iana&amazon.com 2022-11-07
Angelo Masci angelomasci&yahoo.co.uk 2007-01
Avi Lior avi&bridgewatersystems.com 2009-02-27
Benjamin Kowarsch benjamin&sunrise-tel.com 2004-11
Colsys s.r.o. jiri.merth&colsys.cz 2016-03-23
Darin Smith darin.smith&harman.com 2017-02-16
David Ott dott&qualcomm.com 2010-10-15
DMTF Administration admin&dmtf.org 2025-05-30
Erlang/OTP support epmd&erix.ericsson.se 2004-12
Frank Hartung Frank.Hartung&ericsson.com 2007-09-07
Glenn Anderson glenn&qualcomm.co.nz
Harman International Industries Inc. darin.smith&harman.com 2017-02-16
IESG iesg&ietf.org
IETF iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ian Manning ian&baycastle.co.uk 2009-12-16
Jiri Merth jiri.merth&colsys.cz 2016-03-23
Lauren Townsend Amazon.com Services LLC townslau&amazon.com 2020-04-06
Lech Lakomy llakomy&apwi.com 2009-02-12
Lee Howard iana&hylafax.org 2002-03
Mark Revier Sentyron B.V. iana&sentyron.com 2025-10-30
Michael Werski michael.werski&azeti.net 2010-02-18
Mike King mike.king&pvxplus.com 2009-11-09
Mitra mitra&earth.path.net
Nick Warrington nick.warrington&paconsulting.com 2006-03
Nigel Warren info&flyobjectspace.com 2009-02-12
Robert Keyes robert&woldconsulting.com 2025-05-30
Ron Minnich rminnich&sarnoff.com
Ronnie Sahlberg ronniesahlberg&gmail.com 2007-07-05
Scott Guthery sguthery&hidcorp.com 2008-08-25
Sentyron B.V. iana&sentyron.com 2025-10-30
Serge Vacquier svacquier&axway.com 2019-03-29
Stephen M. Webb stephenw&xandros.com 2007-05
Tom Maaswinkel tom.maaswinkel&publiqare.nl 2011-02-07
Uri Resnitzky info&arx.com
Uwe Holz uwe.holz&azeti.net 2009-11-09
Vacquier Serge vacquier&systar.fr 2009-02-12