Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| landmarks | 3969 | udp | Landmark Messages | Petri Rauhala | Petri Rauhala | 2005-08 | |||||
| opswagent | 3976 | tcp | Server Automation Agent | Hewlett Packard Enterprise | Cristi Fati | 2016-04-14 | |||||
| opswagent | 3976 | udp | Server Automation Agent | Hewlett Packard Enterprise | Cristi Fati | 2016-04-14 | |||||
| mapper-ws-ethd | 3986 | tcp | MAPPER workstation server IANA assigned this well-formed service name as a replacement for "mapper-ws_ethd". |
John C. Horton | John C. Horton | ||||||
| mapper-ws_ethd | 3986 | tcp | MAPPER workstation server | John C. Horton | John C. Horton | This entry is an alias to "mapper-ws-ethd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| mapper-ws-ethd | 3986 | udp | MAPPER workstation server IANA assigned this well-formed service name as a replacement for "mapper-ws_ethd". |
John C. Horton | John C. Horton | ||||||
| mapper-ws_ethd | 3986 | udp | MAPPER workstation server | John C. Horton | John C. Horton | This entry is an alias to "mapper-ws-ethd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| abcsoftware | 3996 | tcp | abcsoftware-01 | Andrew Zimmerman | Andrew Zimmerman | 2004-06 | |||||
| abcsoftware | 3996 | udp | abcsoftware-01 | Andrew Zimmerman | Andrew Zimmerman | 2004-06 | |||||
| pxc-spvr | 4006 | tcp | pxc-spvr | ||||||||
| pxc-spvr | 4006 | udp | pxc-spvr | ||||||||
| talarian-mcast2 | 4016 | tcp | Talarian Mcast | ||||||||
| talarian-mcast2 | 4016 | udp | Talarian Mcast | ||||||||
| as-debug | 4026 | tcp | Graphical Debug Server | Steve Halverson | Steve Halverson | ||||||
| as-debug | 4026 | udp | Graphical Debug Server | Steve Halverson | Steve Halverson | ||||||
| wap-push-https | 4036 | tcp | WAP Push OTA-HTTP secure | Matthieu Lachance | Matthieu Lachance | ||||||
| wap-push-https | 4036 | udp | WAP Push OTA-HTTP secure | Matthieu Lachance | Matthieu Lachance | ||||||
| acp-proto | 4046 | tcp | Accounting Protocol | ||||||||
| acp-proto | 4046 | udp | Accounting Protocol | ||||||||
| lms | 4056 | tcp | Location Message Service | Sergey Burnevsky | Sergey Burnevsky | 2006-08 | |||||
| lms | 4056 | udp | Location Message Service | Sergey Burnevsky | Sergey Burnevsky | 2006-08 | |||||
| dsmeter-iatc | 4060 | tcp | DSMETER Inter-Agent Transfer Channel IANA assigned this well-formed service name as a replacement for "dsmeter_iatc". |
John McCann | John McCann | 2006-12 | |||||
| dsmeter_iatc | 4060 | tcp | DSMETER Inter-Agent Transfer Channel | John McCann | John McCann | 2006-12 | This entry is an alias to "dsmeter-iatc". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| dsmeter-iatc | 4060 | udp | DSMETER Inter-Agent Transfer Channel IANA assigned this well-formed service name as a replacement for "dsmeter_iatc". |
John McCann | John McCann | 2006-12 | |||||
| dsmeter_iatc | 4060 | udp | DSMETER Inter-Agent Transfer Channel | John McCann | John McCann | 2006-12 | This entry is an alias to "dsmeter-iatc". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| ice-location | 4061 | tcp | Ice Location Service (TCP) | ||||||||
| ice-location | 4061 | udp | Ice Location Service (TCP) | ||||||||
| ice-slocation | 4062 | tcp | Ice Location Service (SSL) | ||||||||
| ice-slocation | 4062 | udp | Ice Location Service (SSL) | ||||||||
| ice-router | 4063 | tcp | Ice Firewall Traversal Service (TCP) | ||||||||
| ice-router | 4063 | udp | Ice Firewall Traversal Service (TCP) | ||||||||
| ice-srouter | 4064 | tcp | Ice Firewall Traversal Service (SSL) | Bernard Normier | Bernard Normier | 2006-12 | |||||
| ice-srouter | 4064 | udp | Ice Firewall Traversal Service (SSL) | Bernard Normier | Bernard Normier | 2006-12 | |||||
| avanti-cdp | 4065 | tcp | Avanti Common Data IANA assigned this well-formed service name as a replacement for "avanti_cdp". |
Steve Meyer Sr. | Steve Meyer Sr. | 2007-02 | |||||
| avanti_cdp | 4065 | tcp | Avanti Common Data | Steve Meyer Sr. | Steve Meyer Sr. | 2007-02 | This entry is an alias to "avanti-cdp". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| avanti-cdp | 4065 | udp | Avanti Common Data IANA assigned this well-formed service name as a replacement for "avanti_cdp". |
Steve Meyer Sr. | Steve Meyer Sr. | 2007-02 | |||||
| avanti_cdp | 4065 | udp | Avanti Common Data | Steve Meyer Sr. | Steve Meyer Sr. | 2007-02 | This entry is an alias to "avanti-cdp". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| pmas | 4066 | tcp | Performance Measurement and Analysis | Zenon Fortuna | Zenon Fortuna | 2007-02 | |||||
| pmas | 4066 | udp | Performance Measurement and Analysis | Zenon Fortuna | Zenon Fortuna | 2007-02 | |||||
| idp | 4067 | tcp | Information Distribution Protocol | Michaela Vanderveen | Michaela Vanderveen | 2007-02 | |||||
| idp | 4067 | udp | Information Distribution Protocol | Michaela Vanderveen | Michaela Vanderveen | 2007-02 | |||||
| ipfltbcst | 4068 | tcp | IP Fleet Broadcast | Trung Huu Tran | Trung Huu Tran | 2007-03 | |||||
| ipfltbcst | 4068 | udp | IP Fleet Broadcast | Trung Huu Tran | Trung Huu Tran | 2007-03 | |||||
| minger | 4069 | tcp | Minger Email Address Validation Service | Arvel Hathcock | Arvel Hathcock | 2007-03 | |||||
| minger | 4069 | udp | Minger Email Address Validation Service | Arvel Hathcock | Arvel Hathcock | 2007-03 | |||||
| seraph | 4076 | tcp | Seraph DCS | Jason Spence | Jason Spence | 2008-01-22 | |||||
| seraph | 4076 | udp | Seraph DCS | Jason Spence | Jason Spence | 2008-01-22 | |||||
| 4086 | tcp | Reserved | |||||||||
| ftsync | 4086 | udp | Firewall/NAT state table synchronization | Heiner Erne | Heiner Erne | 2008-06-06 | |||||
| bre | 4096 | tcp | BRE (Bridge Relay Element) | Stephen Egbert | Stephen Egbert | ||||||
| bre | 4096 | udp | BRE (Bridge Relay Element) | Stephen Egbert | Stephen Egbert | ||||||
| synchronite | 4106 | tcp | Synchronite | James Figgins | James Figgins | 2006-07 | |||||
| synchronite | 4106 | udp | Synchronite | James Figgins | James Figgins | 2006-07 | |||||
| smartcard-tls | 4116 | tcp | smartcard-TLS | Ilan Mahalal | Ilan Mahalal | 2006-04 | |||||
| smartcard-tls | 4116 | udp | smartcard-TLS | Ilan Mahalal | Ilan Mahalal | 2006-04 | |||||
| ddrepl | 4126 | tcp | Data Domain Replication Service | Pratik Wadher | Pratik Wadher | 2007-05 | |||||
| ddrepl | 4126 | udp | Data Domain Replication Service | Pratik Wadher | Pratik Wadher | 2007-05 | |||||
| cl-db-request | 4136 | tcp | Classic Line Database Server Request | ||||||||
| cl-db-request | 4136 | udp | Classic Line Database Server Request | ||||||||
| tgcconnect | 4146 | tcp | TGCConnect Beacon | Brian Becker | Brian Becker | 2006-10 | |||||
| tgcconnect | 4146 | udp | TGCConnect Beacon | Brian Becker | Brian Becker | 2006-10 | |||||
| stat-results | 4156 | tcp | STAT Results | ||||||||
| stat-results | 4156 | udp | STAT Results | ||||||||
| jini-discovery | 4160 | tcp | Jini Discovery | Mark Hodapp | Mark Hodapp | ||||||
| jini-discovery | 4160 | udp | Jini Discovery | Mark Hodapp | Mark Hodapp | ||||||
| omscontact | 4161 | tcp | OMS Contact | ||||||||
| omscontact | 4161 | udp | OMS Contact | ||||||||
| omstopology | 4162 | tcp | OMS Topology | David Page | David Page | 2005-08 | |||||
| omstopology | 4162 | udp | OMS Topology | David Page | David Page | 2005-08 | |||||
| silverpeakpeer | 4163 | tcp | Silver Peak Peer Protocol | Damon Ennis | Damon Ennis | 2007-03 | |||||
| silverpeakpeer | 4163 | udp | Silver Peak Peer Protocol | Damon Ennis | Damon Ennis | 2007-03 | |||||
| silverpeakcomm | 4164 | tcp | Silver Peak Communication Protocol | Damon Ennis | Damon Ennis | 2007-03 | |||||
| silverpeakcomm | 4164 | udp | Silver Peak Communication Protocol | Damon Ennis | Damon Ennis | 2007-03 | |||||
| altcp | 4165 | tcp | ArcLink over Ethernet | Dmitry Brant | Dmitry Brant | 2007-03 | |||||
| altcp | 4165 | udp | ArcLink over Ethernet | Dmitry Brant | Dmitry Brant | 2007-03 | |||||
| joost | 4166 | tcp | Joost Peer to Peer Protocol | Colm MacCarthaigh | Colm MacCarthaigh | 2007-04 | |||||
| joost | 4166 | udp | Joost Peer to Peer Protocol | Colm MacCarthaigh | Colm MacCarthaigh | 2007-04 | |||||
| ddgn | 4167 | tcp | DeskDirect Global Network | Laurie Charlwood | Laurie Charlwood | 2007-08-22 | |||||
| ddgn | 4167 | udp | DeskDirect Global Network | Laurie Charlwood | Laurie Charlwood | 2007-08-22 | |||||
| pslicser | 4168 | tcp | PrintSoft License Server | David Weisgerber | David Weisgerber | 2007-09-27 | |||||
| pslicser | 4168 | udp | PrintSoft License Server | David Weisgerber | David Weisgerber | 2007-09-27 | |||||
| iadt | 4169 | tcp | Automation Drive Interface Transport | Paul Suhler | Paul Suhler | 2008-02-15 | |||||
| iadt-disc | 4169 | udp | Internet ADT Discovery Protocol | Paul A. Suhler | Paul A. Suhler | 2009-02-06 | |||||
| tl-ipcproxy | 4176 | tcp | Translattice Cluster IPC Proxy | Michael Lyle | Michael Lyle | 2009-11-03 | |||||
| 4176 | udp | Reserved | |||||||||
| boxbackupstore | 4186 | tcp | Box Backup Store Service | Chris Wilson | Chris Wilson | 2008-09-11 | |||||
| 4186 | udp | Reserved | |||||||||
| dsmipv6 | 4191 | udp | Dual Stack MIPv6 NAT Traversal | RFC 5555 | |||||||
| 4196 | Unassigned | ||||||||||
| pinghgl | 4306 | tcp | Hellgate London | David Berk | David Berk | 2007-08-30 | |||||
| pinghgl | 4306 | udp | Hellgate London | David Berk | David Berk | 2007-08-30 | |||||
| p6ssmc | 4311 | tcp | P6R Secure Server Management Console | Jim Susoy | Jim Susoy | 2010-01-21 | |||||
| choiceview-clt | 4316 | tcp | ChoiceView Client | Radish Systems | Richard A. Davis | 2013-03-28 | |||||
| 4316 | udp | Reserved | |||||||||
| rwhois | 4321 | tcp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| rwhois | 4321 | udp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| geognosis | 4326 | tcp | Cadcorp GeognoSIS | Martin Daly | Martin Daly | 2006-11 | 2022-08-12 | ||||
| geognosis | 4326 | udp | Cadcorp GeognoSIS | Martin Daly | Martin Daly | 2006-11 | 2022-08-12 | ||||
| restconf-ch-tls | 4336 | tcp | RESTCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4336 | udp | Reserved | |||||||||
| elanlm | 4346 | tcp | ELAN LM | Paul Ballew | Paul Ballew |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrew Zimmerman | andrew&zimmerman.net | 2004-06 | |
| Arvel Hathcock | arvel&altn.com | 2007-03 | |
| Bernard Normier | bernard&zeroc.com | 2006-12 | |
| Brian Becker | bbecker&tgc-usa.com | 2006-10 | |
| Chris Wilson | chris+iana&qwirx.com | 2008-09-11 | |
| Colm MacCarthaigh | colm.maccarthaigh&joost.com | 2007-04 | |
| Cristi Fati | cristi.fati&hpe.com | 2016-04-13 | |
| Damon Ennis | damon&silver-peak.com | 2007-03 | |
| David Berk | dberk&ping-0.com | 2007-08-30 | |
| David Page | david.page&sun.com | 2005-08 | |
| David Weisgerber | david.weisgerber&printsoft.de | 2007-09-27 | |
| Dmitry Brant | dmitry_brant&lincolnelectric.com | 2007-03 | |
| Heiner Erne | Hirschmann Automation and Control GmbH | heiner.erne&hirschmann.de | 2008-06-06 |
| Hewlett Packard Enterprise | 2016-04-14 | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ilan Mahalal | imahalal&axalto.com | 2006-04 | |
| James Figgins | james.figgins&durodata.co.uk | 2006-07 | |
| Jason Spence | jspence&lightconsulting.com | 2008-01-22 | |
| Jim Susoy | jim.susoy&p6r.com | 2010-01-21 | |
| John C. Horton | jch&unirsvl.rsvl.unisys.com | ||
| John McCann | jmccann&visualclick.com | 2006-12 | |
| Laurie Charlwood | laurie.charlwood&printsoft.com | 2007-08-22 | |
| Mark Hodapp | mark.hodapp&sun.com | ||
| Mark Kosters | markk&internic.net | ||
| Martin Daly | martin.daly&cadcorp.com | 2022-08-12 | |
| Matthieu Lachance | matthieu.lachance&openwave.com | ||
| Michael Lyle | protocols&translattice.com | 2009-11-03 | |
| Michaela Vanderveen | mvandervn&yahoo.com | 2007-02 | |
| Paul A. Suhler | paul.suhler&quantum.com | 2009-02-06 | |
| Paul Ballew | ballew&projtech.com | ||
| Paul Suhler | paul.suhler&quantum.com | 2008-02-15 | |
| Petri Rauhala | petri.rauhala&nokia.com | 2005-08 | |
| Pratik Wadher | pratik&datadomain.com | 2007-05 | |
| Radish Systems | rad&radishsystems.com | 2013-03-28 | |
| Richard A. Davis | Radish Systems | rad&radishsystems.com | 2013-03-28 |
| Sergey Burnevsky | sergey.burnevsky&nokia.com | 2006-08 | |
| Stephen Egbert | egbert&ra.timeplex.com | ||
| Steve Halverson | shalver&us.ibm.com | ||
| Steve Meyer Sr. | stevem&avanti-tech.com | 2007-02 | |
| Trung Huu Tran | trung.tran&navy.mil | 2007-03 | |
| Zenon Fortuna | zenon&mips.com | 2007-02 |