Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ctdb 4379 tcp CTDB Ronnie Sahlberg Ronnie Sahlberg 2007-07-05
ctdb 4379 udp CTDB Ronnie Sahlberg Ronnie Sahlberg 2007-07-05
4397-4399 Unassigned
nacagent 4407 tcp Network Access Control Agent ITGroup ITGroup 2008-06-30
4407 udp Reserved
workflowdir 4417 tcp Workflow Director Communication WfDir Brian Doyle 2015-12-11
4417 udp Reserved
drizzle 4427 tcp Drizzle database server Elliot Murphy Elliot Murphy 2008-07-09
4427 udp Reserved
n1-rmgmt 4447 tcp N1-RMGMT Lori Tassin Lori Tassin
n1-rmgmt 4447 udp N1-RMGMT Lori Tassin Lori Tassin
prRegister 4457 tcp PR Register Donny Gilor Donny Gilor
prRegister 4457 udp PR Register Donny Gilor Donny Gilor
4461-4479 Unassigned
prex-tcp 4487 tcp Protocol for Remote Execution over TCP Daniel Ruppert Daniel Ruppert 2010-09-16
4487 udp Reserved
ipsec-nat-t 4500 udp IPsec NAT-Traversal 2017-07-07 RFC 3948; RFC 7296
wssauthsvc 4537 tcp WSS Security Service Mark Tirschwell Mark Tirschwell 2006-01
wssauthsvc 4537 udp WSS Security Service Mark Tirschwell Mark Tirschwell 2006-01
lanner-lm 4547 tcp Lanner License Manager Les Enstone Les Enstone
lanner-lm 4547 udp Lanner License Manager Les Enstone Les Enstone
ieee-mih 4551 tcp MIH Services RFC 5677
ieee-mih 4551 udp MIH Services RFC 5677
dtn-bundle 4556 tcp DTN Bundle TCP CL Protocol IESG IETF Chair 2021-02-22 RFC 9174
dtn-bundle 4556 udp DTN Bundle UDP CL Protocol 2006-11 2014-02-21 RFC 7122
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985
4557 tcp Reserved
mtcevrunqss 4557 udp Marathon everRun Quorum Service Server David Schwartz David Schwartz 2009-06-18
tram 4567 tcp TRAM Joe Wesley Joe Wesley
tram 4567 udp TRAM Joe Wesley Joe Wesley
deploymentmap 4570 tcp Service to distribute and update within a site deployment information for Oracle Communications Suite Oracle Corp. Dan Newman 2013-09-20
4570 udp Reserved
4571-4572 Unassigned
cardifftec-back 4573 tcp A port for communication between a server and client for a custom backup system CardiffTec Benjamin Misell 2016-05-19
4573 udp Reserved
4574-4589 Unassigned
a21-an-1xbs 4597 tcp A21 (AN-1xBS) David Ott David Ott 2006-02
a21-an-1xbs 4597 udp A21 (AN-1xBS) David Ott David Ott 2006-02
a17-an-an 4599 tcp A17 (AN-AN) David Ott David Ott 2006-02
a17-an-an 4599 udp A17 (AN-AN) David Ott David Ott 2006-02
4607-4620 Unassigned
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
dots-signal 4646 udp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
4647-4657 Unassigned
mmacomm 4667 tcp MMA Comm Services
mmacomm 4667 udp MMA Comm Services
light 4670 tcp Light packets transfer protocol Adam Golovenko Adam Golovenko 2006-10
light 4670 udp Light packets transfer protocol Adam Golovenko Adam Golovenko 2006-10
acter 4671 tcp Bull RSF action server Christian Caudrelier Christian Caudrelier 2006-02
acter 4671 udp Bull RSF action server Christian Caudrelier Christian Caudrelier 2006-02
rfa 4672 tcp remote file access server
rfa 4672 udp remote file access server
cxws 4673 tcp CXWS Operations Phil Abercrombie Phil Abercrombie 2005-08
cxws 4673 udp CXWS Operations Phil Abercrombie Phil Abercrombie 2005-08
appiq-mgmt 4674 tcp AppIQ Agent Management Phil Abercrombie Phil Abercrombie 2005-08
appiq-mgmt 4674 udp AppIQ Agent Management Phil Abercrombie Phil Abercrombie 2005-08
dhct-status 4675 tcp BIAP Device Status
dhct-status 4675 udp BIAP Device Status
dhct-alerts 4676 tcp BIAP Generic Alert Louis Slothouber Louis Slothouber 2005-08
dhct-alerts 4676 udp BIAP Generic Alert Louis Slothouber Louis Slothouber 2005-08
bcs 4677 tcp Business Continuity Servi Siew Sim Siew Sim 2005-08
bcs 4677 udp Business Continuity Servi Siew Sim Siew Sim 2005-08
traversal 4678 tcp boundary traversal Kevin Lu Kevin Lu 2005-08
traversal 4678 udp boundary traversal Kevin Lu Kevin Lu 2005-08
mgesupervision 4679 tcp MGE UPS Supervision
mgesupervision 4679 udp MGE UPS Supervision
nst 4687 tcp Network Scanner Tool FTP Mala Bhat Mala Bhat 2005-08
nst 4687 udp Network Scanner Tool FTP Mala Bhat Mala Bhat 2005-08
netxms-agent 4700 tcp NetXMS Agent
netxms-agent 4700 udp NetXMS Agent
netxms-mgmt 4701 tcp NetXMS Management
netxms-mgmt 4701 udp NetXMS Management
netxms-sync 4702 tcp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
netxms-sync 4702 udp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
npqes-test 4703 tcp Network Performance Quality Evaluation System Test Service Zhengli Zhengli 2010-06-28
4703 udp Reserved
assuria-ins 4704 tcp Assuria Insider Nick Connor Nick Connor 2010-06-30
4704 udp Reserved
4705-4710 Unassigned
trinity-dist 4711 tcp Trinity Trust Network Node Communication P3KI GmbH Gregor Jehle 2017-01-12
trinity-dist 4711 udp Trinity Trust Network Node Communication P3KI GmbH Gregor Jehle 2017-01-12
trinity-dist 4711 sctp Trinity Trust Network Node Communication P3KI GmbH Gregor Jehle 2017-01-12
4712-4724 Unassigned
truckstar 4725 tcp TruckStar Service Brian Toothill Brian Toothill 2010-10-15
truckstar 4725 udp TruckStar Service Brian Toothill Brian Toothill 2010-10-15
4726 tcp Reserved
a26-fap-fgw 4726 udp A26 (FAP-FGW) David Ott David Ott 2010-10-15
fcis 4727 tcp F-Link Client Information Service
fcis-disc 4727 udp F-Link Client Information Service Discovery Makoto Zukawa Makoto Zukawa 2010-10-15
capmux 4728 tcp CA Port Multiplexer Nigel Groves Nigel Groves 2006-06
capmux 4728 udp CA Port Multiplexer Nigel Groves Nigel Groves 2006-06
4729 tcp Reserved
gsmtap 4729 udp GSM Interface Tap Harald Welte Harald Welte 2009-01-16
gearman 4730 tcp Gearman Job Queue System Eric Day Eric Day 2009-01-16
gearman 4730 udp Gearman Job Queue System Eric Day Eric Day 2009-01-16
remcap 4731 tcp Remote Capture Protocol Marc Donner Marc Donner 2009-01-16
4731 udp Reserved
4732 tcp Reserved
ohmtrigger 4732 udp OHM server trigger Franck Lefevre Franck Lefevre 2009-11-18
resorcs 4733 tcp RES Orchestration Catalog Services Bob Janssen Bob Janssen 2009-11-18
4733 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Adam Golovenko golovenko&gmail.com 2006-10
Benjamin Misell beninjam174&gmail.com 2016-05-19
Bob Janssen b.janssen&ressoftware.com 2009-11-18
Brian Doyle bd&wfdir.com 2015-12-11
Brian Toothill brian.toothill&touchstar.co.uk 2010-10-15
CardiffTec beninjam174&gmail.com 2016-05-19
Christian Caudrelier Christian.Caudrelier&bull.net 2006-02
Dan Newman Oracle Corp. dan.c.newman&oracle.com 2013-09-20
Daniel Ruppert daniel&kaffi.lu 2010-09-16
David Ott dott&qualcomm.com 2010-10-15
David Schwartz david.schwartz&marathontechnologies.com 2009-06-18
Donny Gilor dgilor&pop01.ny.us.ibm.net
Elliot Murphy elliot.murphy&gmail.com 2008-07-09
Eric Day eday&oddments.org 2009-01-16
Franck Lefevre franck.lefevre&digitalairways.com 2009-11-18
Gregor Jehle hadez&p3ki.com 2017-01-12
Harald Welte laforge&gnumonks.org 2009-01-16
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITGroup itgroup&stillsecure.com 2008-06-30
Joe Wesley joe.wesley&east.sun.com
Kevin Lu kevinlu&micromethod.com 2005-08
Les Enstone lenstone&lanner.co.uk
Lori Tassin Ramsey&network-1.com
Louis Slothouber lpslot&biap.com 2005-08
Makoto Zukawa zukawa&jp.fujitsu.com 2010-10-15
Mala Bhat bmala&ssdi.sharp.co.in 2005-08
Marc Donner mail&poweraudio.de 2009-01-16
Mark Tirschwell mark.tirschwell&wallstreetsystems.com 2006-01
Nick Connor nickc&assuria.com 2010-06-30
Nigel Groves nigel.groves&ca.com 2006-06
Oracle Corp. dan.c.newman&oracle.com 2013-09-20
P3KI GmbH iana&p3ki.com 2017-01-12
Phil Abercrombie phil.abercrombie&appiq.com 2005-08
Ronnie Sahlberg ronniesahlberg&gmail.com 2007-07-05
Siew Sim ssim&asempra.com 2005-08
Victor Kirhenshtein victor&opticom.lv 2006-07
WfDir bd&wfdir.com 2015-12-11
Zhengli std&iwncomm.com 2010-06-28