Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
dots-signal 4646 udp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
playsta2-lob 4659 tcp PlayStation2 Lobby Port Noam Rimon Noam Rimon 2004-12
playsta2-lob 4659 udp PlayStation2 Lobby Port Noam Rimon Noam Rimon 2004-12
eportcommdata 4669 tcp E-Port Data Service Robert Shaffer Robert Shaffer 2006-02
eportcommdata 4669 udp E-Port Data Service Robert Shaffer Robert Shaffer 2006-02
mgesupervision 4679 tcp MGE UPS Supervision
mgesupervision 4679 udp MGE UPS Supervision
altovacentral 4689 tcp Altova DatabaseCentral Altova Altova 2005-08
altovacentral 4689 udp Altova DatabaseCentral Altova Altova 2005-08
prelude 4690 tcp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
prelude 4690 udp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
mtn 4691 tcp monotone Netsync Protocol Thomas Keller Thomas Keller 2010-12-22
mtn 4691 udp monotone Netsync Protocol Thomas Keller Thomas Keller 2010-12-22
conspiracy 4692 tcp Conspiracy messaging Jens Edlund Jens Edlund 2005-08
conspiracy 4692 udp Conspiracy messaging Jens Edlund Jens Edlund 2005-08
4693-4699 Unassigned
4729 tcp Reserved
gsmtap 4729 udp GSM Interface Tap Harald Welte Harald Welte 2009-01-16
ipfix 4739 tcp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2005-08
ipfix 4739 udp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2005-08
ipfix 4739 sctp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2006-01
profilemac 4749 tcp Profile for Mac David Sinclair David Sinclair 2006-05
profilemac 4749 udp Profile for Mac David Sinclair David Sinclair 2006-05
vxlan 4789 udp Virtual eXtensible Local Area Network (VXLAN) Lawrence Kreeger Lawrence Kreeger 2013-04-19 2014-06-17 RFC 7348
4789 tcp Reserved
vxlan-gpe 4790 udp Generic Protocol Extension for Virtual eXtensible Local Area Network (VXLAN) Lawrence Kreeger Lawrence Kreeger 2014-08-26
4790 tcp Reserved
roce 4791 udp IP Routable RocE InfiniBand Trade Association (IBTA) Diego Crupnicoff (IBTA TWG Chair) 2014-10-17
4791 tcp Reserved
unified-bus 4792 tcp IP Routable Unified Bus Huawei Wei Pan 2022-07-08 2023-04-10
unified-bus 4792 udp IP Routable Unified Bus Huawei Wei Pan 2022-07-08 2023-04-10
4793 tcp Reserved
uet 4793 udp Ultra Ethernet Transport Ultra Ethernet Consortium Vivek Kashyap 2025-06-16
4794 tcp Reserved
veroce 4794 udp veRoCE Transport Protocol ByteDance Dai Huichen 2026-03-06
4795-4799 Unassigned
varadero-2 4839 tcp Varadero-2 Carlos Arteaga Carlos Arteaga
varadero-2 4839 udp Varadero-2 Carlos Arteaga Carlos Arteaga
appserv-https 4849 tcp App Server - Admin HTTPS Sreeram Duvvuru Sreeram Duvvuru 2002-04
appserv-https 4849 udp App Server - Admin HTTPS Sreeram Duvvuru Sreeram Duvvuru 2002-04
phrelaydbg 4869 tcp Photon Relay Debug Michael Hunter Michael Hunter
phrelaydbg 4869 udp Photon Relay Debug Michael Hunter Michael Hunter
wsdl-event 4879 tcp WSDL Event Receiver Charles F Steele Charles F Steele 2011-02-15
4879 udp Reserved
xcap-control 4889 tcp xcap code analysis portal cluster control and administration 88solutions Corporation Manfred Koethe 2018-06-06
4889 udp Reserved
4890-4893 Unassigned
lyskom 4894 tcp LysKOM Protocol A Per Cederqvist Per Cederqvist
lyskom 4894 udp LysKOM Protocol A Per Cederqvist Per Cederqvist
4895-4898 Unassigned
radmin-port 4899 tcp RAdmin Port Dmitri Znosko Dmitri Znosko 2003-03
radmin-port 4899 udp RAdmin Port Dmitri Znosko Dmitri Znosko 2003-03
hfcs 4900 tcp HFSQL Client/Server Database Engine PC SOFT Jerome AERTS 2006-03-02 2014-02-02
hfcs 4900 udp HFSQL Client/Server Database Engine PC SOFT Jerome AERTS 2006-03-02 2014-02-02
flr-agent 4901 tcp FileLocator Remote Search Agent

IANA assigned this well-formed service name as a replacement for "flr_agent".
David Vest David Vest 2008-11-19
flr_agent 4901 tcp FileLocator Remote Search Agent David Vest David Vest 2008-11-19 This entry is an alias to "flr-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
4901 udp Reserved
magiccontrol 4902 tcp magicCONROL RF and Data Interface Andreas Spalenski Andreas Spalenski 2008-11-24
4902 udp Reserved
4903-4911 Unassigned
lutap 4912 tcp Technicolor LUT Access Protocol Markus Loeffler Markus Loeffler 2009-02-17
4912 udp Reserved
lutcp 4913 tcp LUTher Control Protocol Markus Loeffler Markus Loeffler 2007-07-03
bones 4914 tcp Bones Remote Control Andreas Foedrowitz Andreas Foedrowitz 2008-06-18
bones 4914 udp Bones Remote Control Andreas Foedrowitz Andreas Foedrowitz 2008-06-18
frcs 4915 tcp Fibics Remote Control Service Ken Lagarec Ken Lagarec 2009-04-17
4915 udp Reserved
4916-4929 Unassigned
fmsg 4930 tcp Host-to-host messaging FMSG AI PTY LTD Mark Mennell 2026-10-15
4930 udp Reserved
4931-4935 Unassigned
an-signaling 4936 udp Signal protocol port for autonomic networking Cisco Systems Toerless Eckert 2014-06-06
4936 tcp Reserved
4937 tcp Reserved
atsc-mh-ssc 4937 udp ATSC-M/H Service Signaling Channel Jerry Whitaker Jerry Whitaker 2008-10-27
4938-4939 Unassigned
eq-office-4940 4940 tcp Equitrac Office
eq-office-4940 4940 udp Equitrac Office
eq-office-4941 4941 tcp Equitrac Office
eq-office-4941 4941 udp Equitrac Office
eq-office-4942 4942 tcp Equitrac Office Tom Haapanen Tom Haapanen 2007-07-11
eq-office-4942 4942 udp Equitrac Office Tom Haapanen Tom Haapanen 2007-07-11
4943-4948 Unassigned
munin 4949 tcp Munin Graphing Framework Jimmy Olsen Jimmy Olsen 2010-12-24
munin 4949 udp Munin Graphing Framework Jimmy Olsen Jimmy Olsen 2010-12-24
sybasesrvmon 4950 tcp Sybase Server Monitor Chris Irie Chris Irie 2008-03-26
sybasesrvmon 4950 udp Sybase Server Monitor Chris Irie Chris Irie 2008-03-26
pwgwims 4951 tcp PWG WIMS Ira McDonald Ira McDonald 2005-12
pwgwims 4951 udp PWG WIMS Ira McDonald Ira McDonald 2005-12
sagxtsds 4952 tcp SAG Directory Server Michael Chirila Michael Chirila 2006-01
sagxtsds 4952 udp SAG Directory Server Michael Chirila Michael Chirila 2006-01
dbsyncarbiter 4953 tcp Synchronization Arbiter Dave Neudoerffer Dave Neudoerffer 2009-11-18
4953 udp Reserved
4954-4968 Unassigned Known UNAUTHORIZED USE: port 4967
ccss-qmm 4969 tcp CCSS QMessageMonitor
ccss-qmm 4969 udp CCSS QMessageMonitor
ccss-qsm 4970 tcp CCSS QSystemMonitor David Young David Young 2006-01
ccss-qsm 4970 udp CCSS QSystemMonitor David Young David Young 2006-01
burp 4971 tcp BackUp and Restore Program Marat Khalili Marat Khalili 2017-08-23
4971 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
88solutions Corporation koethe&88solutions.com 2018-06-06
Altova has&altova.com 2005-08
Andreas Foedrowitz andreas.foedrowitz&thomson.net 2008-06-18
Andreas Spalenski andreas.spalenski&trsystems.de 2008-11-24
ByteDance daihuichen&bytedance.com 2026-03-06
Carlos Arteaga carteaga&abacoinc.com
Charles F Steele charles_steele&agilent.com 2011-02-15
Chris Irie irie&sybase.com 2008-03-26
Cisco Systems eckert&cisco.com 2014-06-06
Dai Huichen daihuichen&bytedance.com 2026-03-06
Dave Neudoerffer dave.neudoerffer&sybase.com 2009-11-18
David Sinclair dev&profilemac.com 2006-05
David Vest dave&mythicsoft.com 2008-11-19
David Young david.young&ccsseurope.co.uk 2006-01
Diego Crupnicoff (IBTA TWG Chair) diego&mellanox.com 2014-10-17
Dmitri Znosko support&radmin.com 2003-03
FMSG AI PTY LTD mark&fmsg.ai 2026-10-15
Harald Welte laforge&gnumonks.org 2009-01-16
Huawei tarzan.pan&huawei.com 2023-04-10
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
InfiniBand Trade Association (IBTA) administration&infinibandta.org 2014-10-17
Ira McDonald imcdonald&sharplabs.com 2005-12
Jens Edlund edlund&speech.kth.se 2005-08
Jerome AERTS PC SOFT jae&pcsoft.fr 2014-02-02
Jerry Whitaker jwhitaker&atsc.org 2008-10-27
Jimmy Olsen jo&redpill-linpro.com 2010-12-24
Ken Lagarec klagarec&fibics.com 2009-04-17
Lawrence Kreeger kreeger&cisco.com 2013-04-19
Manfred Koethe koethe&88solutions.com 2018-06-06
Marat Khalili qm2k&yandex.ru 2017-08-23
Mark Mennell mark&fmsg.ai 2026-10-15
Markus Loeffler markus.loeffler&thomson.net 2009-02-17
Michael Chirila Michael.Chirila&softwareag.com 2006-01
Michael Hunter mphunter&qnx.com
Nevil Brownlee n.brownlee&auckland.ac.nz 2006-10
Noam Rimon noam.rimon&playstation.sony.com 2004-12
PC SOFT jae&pcsoft.fr 2014-02-02
Per Cederqvist ceder&lysator.liu.se
Robert Shaffer bob.shaffer&micmod.com 2006-02
Sreeram Duvvuru sduv&sfbay.sun.com 2002-04
Thomas Keller me&thomaskeller.biz 2010-12-22
Toerless Eckert Cisco Systems eckert&cisco.com 2014-06-06
Tom Haapanen tomh&equitrac.com 2007-07-11
Ultra Ethernet Consortium vivek.kashyap&intel.com 2025-06-16
Vivek Kashyap vivek.kashyap&intel.com 2025-06-16
Wei Pan Huawei tarzan.pan&huawei.com 2023-04-10
Yoann Vandoorselaere yoann&prelude-ids.org 2005-08