Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| altcp | 4165 | tcp | ArcLink over Ethernet | Dmitry Brant | Dmitry Brant | 2007-03 | |||||
| altcp | 4165 | udp | ArcLink over Ethernet | Dmitry Brant | Dmitry Brant | 2007-03 | |||||
| bccp | 4175 | tcp | Brocade Cluster Communication Protocol | Norival Figueira | Norival Figueira | 2010-04-07 | |||||
| 4175 | udp | Reserved | |||||||||
| wcpp | 4185 | tcp | Woven Control Plane Protocol | Christopher LILJENSTOLPE | Christopher LILJENSTOLPE | 2008-04-14 | |||||
| wcpp | 4185 | udp | Woven Control Plane Protocol | Christopher LILJENSTOLPE | Christopher LILJENSTOLPE | 2008-04-14 | |||||
| 4189 | udp | Reserved | RFC 5440 | ||||||||
| 4190 | udp | Reserved | RFC 5804 | ||||||||
| dsmipv6 | 4191 | udp | Dual Stack MIPv6 NAT Traversal | RFC 5555 | |||||||
| aws-wsp | 4195 | tcp | AWS protocol for cloud remoting solution | Amazon.com Services LLC | Lauren Townsend | 2020-04-06 | |||||
| aws-wsp | 4195 | udp | AWS protocol for cloud remoting solution | Amazon.com Services LLC | Lauren Townsend | 2020-04-06 | |||||
| aws-wsp | 4195 | sctp | AWS protocol for cloud remoting solution | Amazon.com Services LLC | Lauren Townsend | 2020-04-06 | |||||
| aws-wsp | 4195 | dccp | AWS protocol for cloud remoting solution | Amazon.com Services LLC | Lauren Townsend | 2020-04-06 | |||||
| batman | 4305 | tcp | better approach to mobile ad-hoc networking | Simon Wunderlich | Simon Wunderlich | 2007-08-30 | |||||
| batman | 4305 | udp | better approach to mobile ad-hoc networking | Simon Wunderlich | Simon Wunderlich | 2007-08-30 | |||||
| 4315 | Unassigned | Unauthorized Use Known on port 4315 | |||||||||
| 4324 | Reserved | 2015-05-12 | This entry is being removed on 2015-05-12. | ||||||||
| geognosisadmin | 4325 | tcp | Cadcorp GeognoSIS Administrator | Computer Aided Development Corporation Ltd (Cadcorp) | Martin Daly | 2022-08-12 | |||||
| geognosisman | 4325 | udp | Cadcorp GeognoSIS Administrator | Computer Aided Development Corporation Ltd (Cadcorp) | Martin Daly | 2022-08-12 | |||||
| netconf-ch-tls | 4335 | tcp | NETCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4335 | udp | Reserved | |||||||||
| m4-network-as | 4345 | tcp | Macro 4 Network AS | Paul Wren | Paul Wren | ||||||
| m4-network-as | 4345 | udp | Macro 4 Network AS | Paul Wren | Paul Wren | ||||||
| net-device | 4350 | tcp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| net-device | 4350 | udp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| plcy-net-svcs | 4351 | tcp | PLCY Net Services | J.J. Ekstrom | J.J. Ekstrom | ||||||
| plcy-net-svcs | 4351 | udp | PLCY Net Services | J.J. Ekstrom | J.J. Ekstrom | ||||||
| pjlink | 4352 | tcp | Projector Link | Mitsuo Kodama | Mitsuo Kodama | 2005-06 | |||||
| pjlink | 4352 | udp | Projector Link | Mitsuo Kodama | Mitsuo Kodama | 2005-06 | |||||
| f5-iquery | 4353 | tcp | F5 iQuery | Tom Kee | Tom Kee | ||||||
| f5-iquery | 4353 | udp | F5 iQuery | Tom Kee | Tom Kee | ||||||
| qsnet-trans | 4354 | tcp | QSNet Transmitter | ||||||||
| qsnet-trans | 4354 | udp | QSNet Transmitter | ||||||||
| qsnet-workst | 4355 | tcp | QSNet Workstation | ||||||||
| qsnet-workst | 4355 | udp | QSNet Workstation | ||||||||
| qsnet-assist | 4356 | tcp | QSNet Assistant | ||||||||
| qsnet-assist | 4356 | udp | QSNet Assistant | ||||||||
| qsnet-cond | 4357 | tcp | QSNet Conductor | ||||||||
| qsnet-cond | 4357 | udp | QSNet Conductor | ||||||||
| qsnet-nucl | 4358 | tcp | QSNet Nucleus | Neer Kleinman | Neer Kleinman | ||||||
| qsnet-nucl | 4358 | udp | QSNet Nucleus | Neer Kleinman | Neer Kleinman | ||||||
| omabcastltkm | 4359 | tcp | OMA BCAST Long-Term Key Messages | Frank Hartung | Frank Hartung | 2007-09-07 | |||||
| omabcastltkm | 4359 | udp | OMA BCAST Long-Term Key Messages | Frank Hartung | Frank Hartung | 2007-09-07 | |||||
| 4363-4365 | Unassigned | ||||||||||
| tolteces | 4375 | tcp | Toltec EasyShare | Joon Radley | Joon Radley | 2008-10-21 | |||||
| tolteces | 4375 | udp | Toltec EasyShare | Joon Radley | Joon Radley | 2008-10-21 | |||||
| omnivisionesx | 4395 | tcp | OmniVision communication for Virtual environments | Vacquier Serge | Vacquier Serge | 2009-02-12 | |||||
| omnivisionesx | 4395 | udp | OmniVision communication for Virtual environments | Vacquier Serge | Vacquier Serge | 2009-02-12 | |||||
| ds-mail | 4405 | tcp | ASIGRA Televaulting Message Level Restore service | ||||||||
| ds-mail | 4405 | udp | ASIGRA Televaulting Message Level Restore service | ||||||||
| brcd-vr-req | 4415 | tcp | Brocade Virtual Router Request | Brocade Communications Systems | Nick Carter | 2015-11-17 | |||||
| 4415 | udp | Reserved | |||||||||
| netrockey6 | 4425 | tcp | NetROCKEY6 SMART Plus Service | Feitian Technologies | Feitian Technologies | 2010-09-15 | |||||
| netrockey6 | 4425 | udp | NetROCKEY6 SMART Plus Service | Feitian Technologies | Feitian Technologies | 2010-09-15 | |||||
| krb524 | 4444 | tcp | KRB524 | B. Clifford Neuman | B. Clifford Neuman | krb524 assigned the port, nv used it without an assignment | |||||
| krb524 | 4444 | udp | KRB524 | B. Clifford Neuman | B. Clifford Neuman | krb524 assigned the port, nv used it without an assignment | |||||
| nv-video | 4444 | tcp | NV Video default | Ron Frederick | Ron Frederick | krb524 assigned the port, nv used it without an assignment | |||||
| nv-video | 4444 | udp | NV Video default | Ron Frederick | Ron Frederick | krb524 assigned the port, nv used it without an assignment | |||||
| upnotifyp | 4445 | tcp | UPNOTIFYP | Mark Fox | Mark Fox | ||||||
| upnotifyp | 4445 | udp | UPNOTIFYP | Mark Fox | Mark Fox | ||||||
| camp | 4450 | tcp | Common ASCII Messaging Protocol | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| camp | 4450 | udp | Common ASCII Messaging Protocol | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctisystemmsg | 4451 | tcp | CTI System Msg | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctisystemmsg | 4451 | udp | CTI System Msg | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctiprogramload | 4452 | tcp | CTI Program Load | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctiprogramload | 4452 | udp | CTI Program Load | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| nssalertmgr | 4453 | tcp | NSS Alert Manager | ||||||||
| nssalertmgr | 4453 | udp | NSS Alert Manager | ||||||||
| nssagentmgr | 4454 | tcp | NSS Agent Manager | Jim Hill | Jim Hill | ||||||
| nssagentmgr | 4454 | udp | NSS Agent Manager | Jim Hill | Jim Hill | ||||||
| prchat-user | 4455 | tcp | PR Chat User | ||||||||
| prchat-user | 4455 | udp | PR Chat User | ||||||||
| prchat-server | 4456 | tcp | PR Chat Server | ||||||||
| prchat-server | 4456 | udp | PR Chat Server | ||||||||
| prRegister | 4457 | tcp | PR Register | Donny Gilor | Donny Gilor | ||||||
| prRegister | 4457 | udp | PR Register | Donny Gilor | Donny Gilor | ||||||
| mcp | 4458 | tcp | Matrix Configuration Protocol | Tim DeBaillie | Tim DeBaillie | 2006-12 | |||||
| mcp | 4458 | udp | Matrix Configuration Protocol | Tim DeBaillie | Tim DeBaillie | 2006-12 | |||||
| 4459 | Unassigned | ||||||||||
| ntske | 4460 | tcp | Network Time Security Key Establishment | IESG | IETF Chair | 2020-04-07 | RFC 8915 | ||||
| assyst-dr | 4485 | tcp | Assyst Data Repository Service | Albert Cester | Albert Cester | 2008-08-26 | |||||
| 4485 | udp | Reserved | |||||||||
| ipsec-nat-t | 4500 | tcp | IPsec NAT-Traversal | 2022-09-15 | RFC 9329 | ||||||
| ipsec-nat-t | 4500 | udp | IPsec NAT-Traversal | 2017-07-07 | RFC 3948; RFC 7296 | ||||||
| 4501 | Unassigned | IANA | IANA | De-registered 08 June 2001 | |||||||
| a25-fap-fgw | 4502 | sctp | A25 (FAP-FGW) | 3GPP2 | Zhiming Li | 2012-01-11 | |||||
| 4503 | tcp | Reserved | |||||||||
| m-bus-oms | 4503 | udp | M-Bus-OMS over UDP | OMS-Group e. V. (Open Metering System Group) | Ahmed Kasttet | 2025-05-19 | |||||
| 4504-4533 | Unassigned | ||||||||||
| 4534 | tcp | Reserved | |||||||||
| armagetronad | 4534 | udp | Armagetron Advanced Game Server | Manuel Moos | Yann Kaiser | 2012-11-02 | |||||
| ehs | 4535 | tcp | Event Heap Server | ||||||||
| ehs | 4535 | udp | Event Heap Server | ||||||||
| ehs-ssl | 4536 | tcp | Event Heap Server SSL | Brad Johanson | Brad Johanson | 2005-08 | |||||
| ehs-ssl | 4536 | udp | Event Heap Server SSL | Brad Johanson | Brad Johanson | 2005-08 | |||||
| wssauthsvc | 4537 | tcp | WSS Security Service | Mark Tirschwell | Mark Tirschwell | 2006-01 | |||||
| wssauthsvc | 4537 | udp | WSS Security Service | Mark Tirschwell | Mark Tirschwell | 2006-01 | |||||
| swx-gate | 4538 | tcp | Software Data Exchange Gateway | Julien VALIENTE | Julien VALIENTE | 2006-05 | |||||
| swx-gate | 4538 | udp | Software Data Exchange Gateway | Julien VALIENTE | Julien VALIENTE | 2006-05 | |||||
| 4539-4544 | Unassigned | ||||||||||
| worldscores | 4545 | tcp | WorldScores | Steve Davis | Steve Davis |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP2 | lizhiming&huawei.com | 2012-01-11 | |
| Ahmed Kasttet | OMS-Group e. V. (Open Metering System Group) | ahmed.kasttet&oms-group.org | 2025-05-19 |
| Albert Cester | albert.cester&assyst-intl.com | 2008-08-26 | |
| Amazon.com Services LLC | aws-iana&amazon.com | 2022-11-07 | |
| B. Clifford Neuman | bcn&isi.edu | 2022-02-18 | |
| Brad Johanson | bradj&tidebreak.com | 2005-08 | |
| Brocade Communications Systems | ncarter&brocade.com | 2015-11-17 | |
| Christopher LILJENSTOLPE | cdl&asgaard.org | 2008-04-14 | |
| Clint Eskew | Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 |
| Computer Aided Development Corporation Ltd (Cadcorp) | martin.daly&cadcorp.com | 2022-08-12 | |
| Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 | |
| Dmitry Brant | dmitry_brant&lincolnelectric.com | 2007-03 | |
| Donny Gilor | dgilor&pop01.ny.us.ibm.net | ||
| Feitian Technologies | product&ftsafe.com | 2010-09-15 | |
| Frank Hartung | Frank.Hartung&ericsson.com | 2007-09-07 | |
| Glenn Peterson | glennpµsoft.com | ||
| IANA | iana&iana.org | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| J.J. Ekstrom | |||
| Jim Hill | jhill&symantec.com | ||
| Joon Radley | joon&toltec.co.za
support&toltec.co.za |
2008-10-21 | |
| Julien VALIENTE | j.valiente&objectif-software.com | 2006-05 | |
| Lauren Townsend | Amazon.com Services LLC | townslau&amazon.com | 2020-04-06 |
| Manuel Moos | z-man&users.sf.net | 2012-11-02 | |
| Mark Fox | markf&uplanet.com | ||
| Mark Tirschwell | mark.tirschwell&wallstreetsystems.com | 2006-01 | |
| Martin Daly | martin.daly&cadcorp.com | 2022-08-12 | |
| Mitsuo Kodama | kodama&jbmia.or.jp | 2005-06 | |
| Neer Kleinman | neer&qsr.co.il | ||
| Nick Carter | ncarter&brocade.com | 2015-11-17 | |
| Norival Figueira | nfigueir&brocade.com | 2010-04-07 | |
| OMS-Group e. V. (Open Metering System Group) | office&oms-group.org | 2025-05-19 | |
| Paul Wren | Paul.Wren¯o4.com | ||
| Ron Frederick | frederick&parc.xerox.com | ||
| Simon Wunderlich | siwu&hrz.tu-chemnitz.de | 2007-08-30 | |
| Steve Davis | sdavis&optum-inc.com | ||
| Tim DeBaillie | debaillie&ciholas.com | 2006-12 | |
| Tom Kee | t.kee&f5.com | ||
| Vacquier Serge | vacquier&systar.fr | 2009-02-12 | |
| Yann Kaiser | kaiser.yann&gmail.com | 2012-11-02 | |
| Zhiming Li | 3GPP2 | lizhiming&huawei.com | 2012-01-11 |