Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
elanlm 4346 tcp ELAN LM Paul Ballew Paul Ballew
elanlm 4346 udp ELAN LM Paul Ballew Paul Ballew
qsnet-assist 4356 tcp QSNet Assistant
qsnet-assist 4356 udp QSNet Assistant
matrix-vnet 4360 tcp Matrix VNet Communication Protocol

IANA assigned this well-formed service name as a replacement for "matrix_vnet".
Rehan Mahmood Rehan Mahmood 2009-03-18
matrix_vnet 4360 tcp Matrix VNet Communication Protocol Rehan Mahmood Rehan Mahmood 2009-03-18 This entry is an alias to "matrix-vnet". This entry is now historic, not usable for use with many common service discovery mechanisms.
4360 udp Reserved
4361 tcp Reserved
nacnl 4361 udp NavCom Discovery and Control Port Yilei Jia Yilei Jia 2009-03-18
4362 tcp Reserved
afore-vdp-disc 4362 udp AFORE vNode Discovery protocol Michael Richardson Michael Richardson 2011-02-08
4363-4365 Unassigned
shadowstream 4366 udp ShadowStream System StorageCraft Technology Corporation David McConkie 2014-12-17
4366 tcp Reserved
4367 Unassigned
wxbrief 4368 tcp WeatherBrief Direct Kim Alan Waggoner Kim Alan Waggoner 2006-11
wxbrief 4368 udp WeatherBrief Direct Kim Alan Waggoner Kim Alan Waggoner 2006-11
epmd 4369 tcp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
epmd 4369 udp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
bip 4376 tcp BioAPI Interworking Jean-Paul Lemaire Jean-Paul Lemaire 2007-07-05
bip 4376 udp BioAPI Interworking Jean-Paul Lemaire Jean-Paul Lemaire 2007-07-05
fly 4396 tcp Fly Object Space Nigel Warren Nigel Warren 2009-02-12
4396 udp Reserved
ds-slp 4406 tcp ASIGRA Televaulting DS-Sleeper Service Andrei Litvinn Andrei Litvinn 2005-01
ds-slp 4406 udp ASIGRA Televaulting DS-Sleeper Service Andrei Litvinn Andrei Litvinn 2005-01
newmood-player 4416 tcp Newmood Media Player Creation Newmood Inc. Bruno Frechette 2015-11-18 2026-09-30
newmood-player 4416 udp Newmood Media Player discovery Creation Newmood Inc. Bruno Frechette 2015-11-18 2026-09-30
netrockey6 4425 tcp NetROCKEY6 SMART Plus Service Feitian Technologies Feitian Technologies 2010-09-15
netrockey6 4425 udp NetROCKEY6 SMART Plus Service Feitian Technologies Feitian Technologies 2010-09-15
beacon-port-2 4426 tcp SMARTS Beacon Port Eyal Yardeni Eyal Yardeni 2003-11
beacon-port-2 4426 udp SMARTS Beacon Port Eyal Yardeni Eyal Yardeni 2003-11
n1-fwp 4446 tcp N1-FWP
n1-fwp 4446 udp N1-FWP
prchat-server 4456 tcp PR Chat Server
prchat-server 4456 udp PR Chat Server
ntske 4460 tcp Network Time Security Key Establishment IESG IETF Chair 2020-04-07 RFC 8915
4460 udp Reserved
4461-4479 Unassigned
icms 4486 tcp Integrated Client Message Service Resource Allocation Team Resource Allocation Team 2010-09-27
icms 4486 udp Integrated Client Message Service Resource Allocation Team Resource Allocation Team 2010-09-27
ipsec-nat-t 4500 udp IPsec NAT-Traversal 2017-07-07 RFC 3948; RFC 7296
ehs-ssl 4536 tcp Event Heap Server SSL Brad Johanson Brad Johanson 2005-08
ehs-ssl 4536 udp Event Heap Server SSL Brad Johanson Brad Johanson 2005-08
sf-lm 4546 tcp SF License Manager (Sentinel) Thomas Koell Thomas Koell
sf-lm 4546 udp SF License Manager (Sentinel) Thomas Koell Thomas Koell
ieee-mih 4551 tcp MIH Services RFC 5677
ieee-mih 4551 udp MIH Services RFC 5677
dtn-bundle 4556 tcp DTN Bundle TCP CL Protocol IESG IETF Chair 2021-02-22 RFC 9174
dtn-bundle 4556 udp DTN Bundle UDP CL Protocol 2006-11 2014-02-21 RFC 7122
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985
4560-4562 Unassigned
amahi-anywhere 4563 tcp Amahi Anywhere Amahi Carlos Puchol 2014-02-27
4563 udp Reserved
4564-4565 Unassigned
kwtc 4566 tcp Kids Watch Time Control Service Larry Zarou Larry Zarou 2006-10
kwtc 4566 udp Kids Watch Time Control Service Larry Zarou Larry Zarou 2006-10
tram 4567 tcp TRAM Joe Wesley Joe Wesley
tram 4567 udp TRAM Joe Wesley Joe Wesley
bmc-reporting 4568 tcp BMC Reporting Portnoy Boxman Portnoy Boxman
bmc-reporting 4568 udp BMC Reporting Portnoy Boxman Portnoy Boxman
iax 4569 tcp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
iax 4569 udp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
rid 4590 tcp RID over HTTP/TLS IESG IETF Chair RFC 6546
ias-neighbor 4596 tcp IAS-Neighbor (ANRI-ANRI) David Ott David Ott 2007-07-31
ias-neighbor 4596 udp IAS-Neighbor (ANRI-ANRI) David Ott David Ott 2007-07-31
a16-an-an 4598 tcp A16 (AN-AN) David Ott David Ott 2005-12
a16-an-an 4598 udp A16 (AN-AN) David Ott David Ott 2005-12
piranha1 4600 tcp Piranha1
piranha1 4600 udp Piranha1
piranha2 4601 tcp Piranha2 Primark Corporation Primark Corporation
piranha2 4601 udp Piranha2 Primark Corporation Primark Corporation
mtsserver 4602 tcp EAX MTS Server Pedro A Rodriguez Pedro A Rodriguez 2008-08-06
4602 udp Reserved
menandmice-upg 4603 tcp Men & Mice Upgrade Agent Eggert Thorlacius Eggert Thorlacius 2010-01-27
4603 udp Reserved
irp 4604 tcp Identity Registration Protocol Sixscape Communications, Pte. Ltd. Lawrence E. Hughes 2014-03-17 2014-08-26
4604 udp Reserved
sixchat 4605 tcp Direct End to End Secure Chat Protocol Sixscape Communications, Pte. Ltd. Lawrence E. Hughes 2014-09-11
4605 udp Reserved
sixid 4606 tcp Secure ID to IP registration and lookup Sixscape Communications, Pte. Ltd. Lawrence E. Hughes 2020-04-28
4606 udp Reserved
4607-4620 Unassigned
4621 tcp Reserved
ventoso 4621 udp Bidirectional single port remote radio VOIP and Control stream Ventoso Integrated Peripherals John Lindsey 2016-03-04
4622-4645 Unassigned
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
dots-signal 4646 udp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
4647-4657 Unassigned
playsta2-app 4658 tcp PlayStation2 App Port
playsta2-app 4658 udp PlayStation2 App Port
playsta2-lob 4659 tcp PlayStation2 Lobby Port Noam Rimon Noam Rimon 2004-12
playsta2-lob 4659 udp PlayStation2 Lobby Port Noam Rimon Noam Rimon 2004-12
smaclmgr 4660 tcp smaclmgr Hiromi Taki Hiromi Taki
smaclmgr 4660 udp smaclmgr Hiromi Taki Hiromi Taki
kar2ouche 4661 tcp Kar2ouche Peer location service Andy Krouwel Andy Krouwel
kar2ouche 4661 udp Kar2ouche Peer location service Andy Krouwel Andy Krouwel
oms 4662 tcp OrbitNet Message Service Roy Davies Roy Davies 2005-08
oms 4662 udp OrbitNet Message Service Roy Davies Roy Davies 2005-08
noteit 4663 tcp Note It! Message Service Pedro Alpedrinha Pedro Alpedrinha 2006-02
noteit 4663 udp Note It! Message Service Pedro Alpedrinha Pedro Alpedrinha 2006-02
ems 4664 tcp Rimage Messaging Server David V. Raskin David V. Raskin 2006-02

Contact Information

Name Organization Contact URI Last Updated
Amahi iana&amahi.org 2014-02-27
Andrei Litvinn support&asigra.com 2005-01
Andy Krouwel andy&kar2ouche.com
Benjamin Kowarsch benjamin&sunrise-tel.com 2004-11
Brad Johanson bradj&tidebreak.com 2005-08
Bruno Frechette Creation Newmood Inc. bruno&newmood.com 2026-09-30
Carlos Puchol Amahi iana&amahi.org 2014-02-27
Creation Newmood Inc. it&newmood.com 2026-09-30
David McConkie StorageCraft Technology Corporation dave.mcconkie&storagecraft.com 2014-12-17
David Ott dott&qualcomm.com 2010-10-15
David V. Raskin draskin&rimage.com 2006-02
Eggert Thorlacius eggi&menandmice.com 2010-01-27
Erlang/OTP support epmd&erix.ericsson.se 2004-12
Eyal Yardeni eyal.yardeni&smarts.com 2003-11
Feitian Technologies product&ftsafe.com 2010-09-15
Hiromi Taki stg-togo&saint.nm.fujitsu.co.jp
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jean-Paul Lemaire jean-paul.lemaire&univ-paris-diderot.fr 2007-07-05
Joe Wesley joe.wesley&east.sun.com
John Lindsey john.lindsey&nilesradio.com 2016-03-04
Kim Alan Waggoner kimw&weatherbank.com 2006-11
Larry Zarou zarla01&cbsits.com 2006-10
Lawrence E. Hughes Sixscape Communications, Ltd. lhughes&sixscape.com 2014-03-17
Michael Richardson mcr&sandelman.ca 2011-02-08
Nigel Warren info&flyobjectspace.com 2009-02-12
Noam Rimon noam.rimon&playstation.sony.com 2004-12
Paul Ballew ballew&projtech.com
Pedro A Rodriguez pedro.rdz&eaxtechnologies.com.mx 2008-08-06
Pedro Alpedrinha pedro.alpedrinha&redevirtual.com 2006-02
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Primark Corporation joe.boone&primark.com
Rehan Mahmood rehan&matrixmultimedia.co.uk 2009-03-18
Resource Allocation Team resources&littlehall.com 2010-09-27
Roy Davies rdavies&daq.net 2005-08
Sixscape Communications, Pte. Ltd. lhughes&sixscape.com 2014-08-26
StorageCraft Technology Corporation dave.mcconkie&storagecraft.com 2014-12-17
Thomas Koell info&sf.com
Ventoso Integrated Peripherals john.lindsey&nilesradio.com 2016-03-04
Yilei Jia yjia&navcomtech.com 2009-03-18